地图编号

来源：ET引擎帮助文档　分类：基础编号资料

地图编号及对应小地图编号对照表。

共 645 条地图资料。

地图代码: 0 小地图号: 0101; 地图代码: 0; 小地图号: 0101 | 地图代码: 1 小地图号: 0102; 地图代码: 1; 小地图号: 0102 | 地图代码: 2 小地图号: 0105; 地图代码: 2; 小地图号: 0105
地图代码: 3 小地图号: 0106; 地图代码: 3; 小地图号: 0106 | 地图代码: 4 小地图号: 0121; 地图代码: 4; 小地图号: 0121 | 地图代码: 5 小地图号: 0161; 地图代码: 5; 小地图号: 0161
地图代码: 6 小地图号: 0191; 地图代码: 6; 小地图号: 0191 | 地图代码: 11 小地图号: 0103; 地图代码: 11; 小地图号: 0103 | 地图代码: 12 小地图号: 0104; 地图代码: 12; 小地图号: 0104
地图代码: 61 小地图号: 0192; 地图代码: 61; 小地图号: 0192 | 地图代码: 62 小地图号: 0196; 地图代码: 62; 小地图号: 0196 | 地图代码: 63 小地图号: 0199; 地图代码: 63; 小地图号: 0199
地图代码: 64 小地图号: 0202; 地图代码: 64; 小地图号: 0202 | 地图代码: 65 小地图号: 0203; 地图代码: 65; 小地图号: 0203 | 地图代码: 66 小地图号: 0204; 地图代码: 66; 小地图号: 0204
地图代码: 0100 小地图号: 地图代码: 0100; 小地图号: | 地图代码: 0101 小地图号: 地图代码: 0101; 小地图号: | 地图代码: 0102 小地图号: 地图代码: 0102; 小地图号:
地图代码: 0103 小地图号: 地图代码: 0103; 小地图号: | 地图代码: 0104 小地图号: 地图代码: 0104; 小地图号: | 地图代码: 0105 小地图号: 地图代码: 0105; 小地图号:
地图代码: 0106 小地图号: 地图代码: 0106; 小地图号: | 地图代码: 0107 小地图号: 地图代码: 0107; 小地图号: | 地图代码: 0108 小地图号: 地图代码: 0108; 小地图号:
地图代码: 0109 小地图号: 地图代码: 0109; 小地图号: | 地图代码: 0110 小地图号: 地图代码: 0110; 小地图号: | 地图代码: 0111 小地图号: 地图代码: 0111; 小地图号:
地图代码: 0112 小地图号: 地图代码: 0112; 小地图号: | 地图代码: 0113 小地图号: 地图代码: 0113; 小地图号: | 地图代码: 0114 小地图号: 地图代码: 0114; 小地图号:
地图代码: 0115 小地图号: 地图代码: 0115; 小地图号: | 地图代码: 0116 小地图号: 地图代码: 0116; 小地图号: | 地图代码: 0117 小地图号: 地图代码: 0117; 小地图号:
地图代码: 0118 小地图号: 地图代码: 0118; 小地图号: | 地图代码: 0119 小地图号: 地图代码: 0119; 小地图号: | 地图代码: 0120 小地图号: 地图代码: 0120; 小地图号:
地图代码: 0121 小地图号: 地图代码: 0121; 小地图号: | 地图代码: 0122 小地图号: 地图代码: 0122; 小地图号: | 地图代码: 0123 小地图号: 地图代码: 0123; 小地图号:
地图代码: 0124 小地图号: 地图代码: 0124; 小地图号: | 地图代码: 0125 小地图号: 地图代码: 0125; 小地图号: | 地图代码: 0126 小地图号: 地图代码: 0126; 小地图号:
地图代码: 0127 小地图号: 地图代码: 0127; 小地图号: | 地图代码: 0128 小地图号: 地图代码: 0128; 小地图号: | 地图代码: 0129 小地图号: 地图代码: 0129; 小地图号:
地图代码: 0130 小地图号: 地图代码: 0130; 小地图号: | 地图代码: 0131 小地图号: 地图代码: 0131; 小地图号: | 地图代码: 0132 小地图号: 地图代码: 0132; 小地图号:
地图代码: 0133 小地图号: 地图代码: 0133; 小地图号: | 地图代码: 0134 小地图号: 地图代码: 0134; 小地图号: | 地图代码: 0135 小地图号: 地图代码: 0135; 小地图号:
地图代码: 0136 小地图号: 地图代码: 0136; 小地图号: | 地图代码: 0137 小地图号: 地图代码: 0137; 小地图号: | 地图代码: 0138 小地图号: 地图代码: 0138; 小地图号:
地图代码: 0139 小地图号: 地图代码: 0139; 小地图号: | 地图代码: 0140 小地图号: 地图代码: 0140; 小地图号: | 地图代码: 0141 小地图号: 地图代码: 0141; 小地图号:
地图代码: 0142 小地图号: 地图代码: 0142; 小地图号: | 地图代码: 0143 小地图号: 地图代码: 0143; 小地图号: | 地图代码: 0144 小地图号: 地图代码: 0144; 小地图号:
地图代码: 0145 小地图号: 地图代码: 0145; 小地图号: | 地图代码: 0146 小地图号: 地图代码: 0146; 小地图号: | 地图代码: 0147 小地图号: 地图代码: 0147; 小地图号:
地图代码: 0148 小地图号: 地图代码: 0148; 小地图号: | 地图代码: 0149 小地图号: 地图代码: 0149; 小地图号: | 地图代码: 0150 小地图号: 地图代码: 0150; 小地图号:
地图代码: 0151 小地图号: 地图代码: 0151; 小地图号: | 地图代码: 0152 小地图号: 地图代码: 0152; 小地图号: | 地图代码: 0153 小地图号: 地图代码: 0153; 小地图号:
地图代码: 0154 小地图号: 地图代码: 0154; 小地图号: | 地图代码: 0155 小地图号: 地图代码: 0155; 小地图号: | 地图代码: 0156 小地图号: 地图代码: 0156; 小地图号:
地图代码: 0157 小地图号: 地图代码: 0157; 小地图号: | 地图代码: 0158 小地图号: 地图代码: 0158; 小地图号: | 地图代码: 0159 小地图号: 地图代码: 0159; 小地图号:
地图代码: 0160 小地图号: 地图代码: 0160; 小地图号: | 地图代码: 0161 小地图号: 地图代码: 0161; 小地图号: | 地图代码: 0162 小地图号: 地图代码: 0162; 小地图号:
地图代码: 0170 小地图号: 地图代码: 0170; 小地图号: | 地图代码: 0171 小地图号: 地图代码: 0171; 小地图号: | 地图代码: 611 小地图号: 193; 地图代码: 611; 小地图号: 193
地图代码: 612 小地图号: 194; 地图代码: 612; 小地图号: 194 | 地图代码: 613 小地图号: 195; 地图代码: 613; 小地图号: 195 | 地图代码: 621 小地图号: 197; 地图代码: 621; 小地图号: 197
地图代码: 622 小地图号: 198; 地图代码: 622; 小地图号: 198 | 地图代码: 631 小地图号: 200; 地图代码: 631; 小地图号: 200 | 地图代码: 632 小地图号: 201; 地图代码: 632; 小地图号: 201
地图代码: 1001 小地图号: 地图代码: 1001; 小地图号: | 地图代码: 1002 小地图号: 地图代码: 1002; 小地图号: | 地图代码: 1003 小地图号: 地图代码: 1003; 小地图号:
地图代码: 1004 小地图号: 地图代码: 1004; 小地图号: | 地图代码: 1005 小地图号: 地图代码: 1005; 小地图号: | 地图代码: 1006 小地图号: 地图代码: 1006; 小地图号:
地图代码: 1007 小地图号: 地图代码: 1007; 小地图号: | 地图代码: 1111 小地图号: 地图代码: 1111; 小地图号: | 地图代码: 01132 小地图号: 地图代码: 01132; 小地图号:
地图代码: 01141 小地图号: 地图代码: 01141; 小地图号: | 地图代码: 01142 小地图号: 地图代码: 01142; 小地图号: | 地图代码: 01152 小地图号: 地图代码: 01152; 小地图号:
地图代码: 10123 小地图号: 地图代码: 10123; 小地图号: | 地图代码: alx 小地图号: 3032; 地图代码: alx; 小地图号: 3032 | 地图代码: B010 小地图号: 地图代码: B010; 小地图号:
地图代码: B011 小地图号: 地图代码: B011; 小地图号: | 地图代码: B012 小地图号: 地图代码: B012; 小地图号: | 地图代码: B013 小地图号: 地图代码: B013; 小地图号:
地图代码: B101 小地图号: B101----B340地图一样; 地图代码: B101; 小地图号: B101----B340地图一样 | 地图代码: B341 小地图号: 地图代码: B341; 小地图号: | 地图代码: B342 小地图号: 地图代码: B342; 小地图号:
地图代码: B343 小地图号: 地图代码: B343; 小地图号: | 地图代码: B344 小地图号: 地图代码: B344; 小地图号: | 地图代码: B345 小地图号: 地图代码: B345; 小地图号:
地图代码: B346 小地图号: 地图代码: B346; 小地图号: | 地图代码: B347 小地图号: 地图代码: B347; 小地图号: | 地图代码: B351 小地图号: 地图代码: B351; 小地图号:
地图代码: B352 小地图号: 地图代码: B352; 小地图号: | 地图代码: B353 小地图号: 地图代码: B353; 小地图号: | 地图代码: B354 小地图号: 地图代码: B354; 小地图号:
地图代码: B355 小地图号: 地图代码: B355; 小地图号: | 地图代码: B356 小地图号: 地图代码: B356; 小地图号: | 地图代码: B357 小地图号: 地图代码: B357; 小地图号:
地图代码: bsr01 小地图号: 535; 地图代码: bsr01; 小地图号: 535 | 地图代码: bsr02 小地图号: 536; 地图代码: bsr02; 小地图号: 536 | 地图代码: bsr03 小地图号: 537; 地图代码: bsr03; 小地图号: 537
地图代码: bsrlm01 小地图号: 538; 地图代码: bsrlm01; 小地图号: 538 | 地图代码: bsrlm02 小地图号: 539; 地图代码: bsrlm02; 小地图号: 539 | 地图代码: bsrlm03 小地图号: 540; 地图代码: bsrlm03; 小地图号: 540
地图代码: bsrlm04 小地图号: 541; 地图代码: bsrlm04; 小地图号: 541 | 地图代码: bsrlm05 小地图号: 542; 地图代码: bsrlm05; 小地图号: 542 | 地图代码: bsrlm 小地图号: 543; 地图代码: bsrlm; 小地图号: 543
地图代码: ch001 小地图号: 308; 地图代码: ch001; 小地图号: 308 | 地图代码: cqbgc 小地图号: 地图代码: cqbgc; 小地图号: | 地图代码: D001 小地图号: 001; 地图代码: D001; 小地图号: 001
地图代码: D002 小地图号: 002; 地图代码: D002; 小地图号: 002 | 地图代码: d2 小地图号: 3103; 地图代码: d2; 小地图号: 3103 | 地图代码: D003 小地图号: 003; 地图代码: D003; 小地图号: 003
地图代码: D011 小地图号: 004; 地图代码: D011; 小地图号: 004 | 地图代码: D012 小地图号: 005; 地图代码: D012; 小地图号: 005 | 地图代码: D12 小地图号: 104; 地图代码: D12; 小地图号: 104
地图代码: D021 小地图号: 044; 地图代码: D021; 小地图号: 044 | 地图代码: D022 小地图号: 006; 地图代码: D022; 小地图号: 006 | 地图代码: D023 小地图号: 007; 地图代码: D023; 小地图号: 007
地图代码: D024 小地图号: 045; 地图代码: D024; 小地图号: 045 | 地图代码: D032 小地图号: 006; 地图代码: D032; 小地图号: 006 | 地图代码: D033 小地图号: 007; 地图代码: D033; 小地图号: 007
地图代码: D042 小地图号: 006; 地图代码: D042; 小地图号: 006 | 地图代码: D043 小地图号: 007; 地图代码: D043; 小地图号: 007 | 地图代码: D052 小地图号: 006; 地图代码: D052; 小地图号: 006
地图代码: D053 小地图号: 007; 地图代码: D053; 小地图号: 007 | 地图代码: D401 小地图号: 008; 地图代码: D401; 小地图号: 008 | 地图代码: D402 小地图号: 009; 地图代码: D402; 小地图号: 009
地图代码: D403 小地图号: 010; 地图代码: D403; 小地图号: 010 | 地图代码: D404 小地图号: 011; 地图代码: D404; 小地图号: 011 | 地图代码: D405 小地图号: 012; 地图代码: D405; 小地图号: 012
地图代码: D406 小地图号: 013; 地图代码: D406; 小地图号: 013 | 地图代码: D411 小地图号: 014; 地图代码: D411; 小地图号: 014 | 地图代码: D412 小地图号: 015; 地图代码: D412; 小地图号: 015
地图代码: D413 小地图号: 016; 地图代码: D413; 小地图号: 016 | 地图代码: D414 小地图号: 017; 地图代码: D414; 小地图号: 017 | 地图代码: D415 小地图号: 018; 地图代码: D415; 小地图号: 018
地图代码: D416 小地图号: 019; 地图代码: D416; 小地图号: 019 | 地图代码: D421 小地图号: 020; 地图代码: D421; 小地图号: 020 | 地图代码: D422 小地图号: 021; 地图代码: D422; 小地图号: 021
地图代码: D423 小地图号: 地图代码: D423; 小地图号: | 地图代码: d501 小地图号: 022; 地图代码: d501; 小地图号: 022 | 地图代码: d502 小地图号: 023; 地图代码: d502; 小地图号: 023
地图代码: d503 小地图号: 024; 地图代码: d503; 小地图号: 024 | 地图代码: d504 小地图号: 025; 地图代码: d504; 小地图号: 025 | 地图代码: d505 小地图号: 047; 地图代码: d505; 小地图号: 047
地图代码: d511 小地图号: 地图代码: d511; 小地图号: | 地图代码: d512 小地图号: 地图代码: d512; 小地图号: | 地图代码: d513 小地图号: 地图代码: d513; 小地图号:
地图代码: d514 小地图号: 地图代码: d514; 小地图号: | 地图代码: d515 小地图号: 地图代码: d515; 小地图号: | 地图代码: d601 小地图号: 026; 地图代码: d601; 小地图号: 026
地图代码: d602 小地图号: 027; 地图代码: d602; 小地图号: 027 | 地图代码: d603 小地图号: 028; 地图代码: d603; 小地图号: 028 | 地图代码: d604 小地图号: 029; 地图代码: d604; 小地图号: 029
地图代码: d605 小地图号: 030; 地图代码: d605; 小地图号: 030 | 地图代码: d606 小地图号: 031; 地图代码: d606; 小地图号: 031 | 地图代码: d607-d610一样 小地图号: 地图代码: d607-d610一样; 小地图号:
地图代码: d611 小地图号: 地图代码: d611; 小地图号: | 地图代码: d612 小地图号: 081; 地图代码: d612; 小地图号: 081 | 地图代码: d613 小地图号: 082; 地图代码: d613; 小地图号: 082
地图代码: d614 小地图号: 083; 地图代码: d614; 小地图号: 083 | 地图代码: d614 小地图号: 083; 地图代码: d614; 小地图号: 083 | 地图代码: d615 小地图号: 084; 地图代码: d615; 小地图号: 084
地图代码: d616 小地图号: 085; 地图代码: d616; 小地图号: 085 | 地图代码: d617 小地图号: 086; 地图代码: d617; 小地图号: 086 | 地图代码: d618 小地图号: 087; 地图代码: d618; 小地图号: 087
地图代码: D619 小地图号: 地图代码: D619; 小地图号: | 地图代码: D701 小地图号: 053; 地图代码: D701; 小地图号: 053 | 地图代码: d710 小地图号: 地图代码: d710; 小地图号:
地图代码: D711 小地图号: 033; 地图代码: D711; 小地图号: 033 | 地图代码: D712 小地图号: 034; 地图代码: D712; 小地图号: 034 | 地图代码: d713 小地图号: 035; 地图代码: d713; 小地图号: 035
地图代码: D714 小地图号: 036; 地图代码: D714; 小地图号: 036 | 地图代码: D715 小地图号: 055; 地图代码: D715; 小地图号: 055 | 地图代码: d716 小地图号: 056; 地图代码: d716; 小地图号: 056
地图代码: D717 小地图号: 057; 地图代码: D717; 小地图号: 057 | 地图代码: D1002 小地图号: 094; 地图代码: D1002; 小地图号: 094 | 地图代码: D1003 小地图号: 091; 地图代码: D1003; 小地图号: 091
地图代码: D1004 小地图号: 097; 地图代码: D1004; 小地图号: 097 | 地图代码: D2000 小地图号: 008; 地图代码: D2000; 小地图号: 008 | 地图代码: D2001 小地图号: 122; 地图代码: D2001; 小地图号: 122
地图代码: D2002 小地图号: 123; 地图代码: D2002; 小地图号: 123 | 地图代码: D2003 小地图号: 124; 地图代码: D2003; 小地图号: 124 | 地图代码: D2004 小地图号: 125; 地图代码: D2004; 小地图号: 125
地图代码: D2005 小地图号: 126; 地图代码: D2005; 小地图号: 126 | 地图代码: D2006 小地图号: 127; 地图代码: D2006; 小地图号: 127 | 地图代码: D2007 小地图号: 128; 地图代码: D2007; 小地图号: 128
地图代码: D2008 小地图号: 129; 地图代码: D2008; 小地图号: 129 | 地图代码: D2009 小地图号: 133; 地图代码: D2009; 小地图号: 133 | 地图代码: D2010 小地图号: 131; 地图代码: D2010; 小地图号: 131
地图代码: D2011 小地图号: 132; 地图代码: D2011; 小地图号: 132 | 地图代码: D2012 小地图号: 133; 地图代码: D2012; 小地图号: 133 | 地图代码: D2013 小地图号: 134; 地图代码: D2013; 小地图号: 134
地图代码: D2031 小地图号: 141; 地图代码: D2031; 小地图号: 141 | 地图代码: D2032 小地图号: 142; 地图代码: D2032; 小地图号: 142 | 地图代码: D2033 小地图号: 143; 地图代码: D2033; 小地图号: 143
地图代码: D2034 小地图号: 144; 地图代码: D2034; 小地图号: 144 | 地图代码: D2041 小地图号: 151; 地图代码: D2041; 小地图号: 151 | 地图代码: D2042 小地图号: 152; 地图代码: D2042; 小地图号: 152
地图代码: D2043 小地图号: 153; 地图代码: D2043; 小地图号: 153 | 地图代码: D2044 小地图号: 154; 地图代码: D2044; 小地图号: 154 | 地图代码: D2051 小地图号: 162; 地图代码: D2051; 小地图号: 162
地图代码: D2052 小地图号: 163; 地图代码: D2052; 小地图号: 163 | 地图代码: D2053 小地图号: 164; 地图代码: D2053; 小地图号: 164 | 地图代码: D2054 小地图号: 165; 地图代码: D2054; 小地图号: 165
地图代码: D2055 小地图号: 166; 地图代码: D2055; 小地图号: 166 | 地图代码: D2056 小地图号: 167; 地图代码: D2056; 小地图号: 167 | 地图代码: D2061 小地图号: 171; 地图代码: D2061; 小地图号: 171
地图代码: D2062 小地图号: 172; 地图代码: D2062; 小地图号: 172 | 地图代码: D2063 小地图号: 173; 地图代码: D2063; 小地图号: 173 | 地图代码: D2064 小地图号: 174; 地图代码: D2064; 小地图号: 174
地图代码: D2065 小地图号: 175; 地图代码: D2065; 小地图号: 175 | 地图代码: D2066 小地图号: 176; 地图代码: D2066; 小地图号: 176 | 地图代码: D2067 小地图号: 177; 地图代码: D2067; 小地图号: 177
地图代码: D2070 小地图号: 181; 地图代码: D2070; 小地图号: 181 | 地图代码: D2071 小地图号: 182; 地图代码: D2071; 小地图号: 182 | 地图代码: D2072 小地图号: 183; 地图代码: D2072; 小地图号: 183
地图代码: D2073 小地图号: 184; 地图代码: D2073; 小地图号: 184 | 地图代码: D2074 小地图号: 185; 地图代码: D2074; 小地图号: 185 | 地图代码: D2075 小地图号: 186; 地图代码: D2075; 小地图号: 186
地图代码: D2076 小地图号: 187; 地图代码: D2076; 小地图号: 187 | 地图代码: D2077 小地图号: 188; 地图代码: D2077; 小地图号: 188 | 地图代码: D2078 小地图号: 189; 地图代码: D2078; 小地图号: 189
地图代码: D2079 小地图号: 190; 地图代码: D2079; 小地图号: 190 | 地图代码: D2081 小地图号: 304; 地图代码: D2081; 小地图号: 304 | 地图代码: D2082 小地图号: 306; 地图代码: D2082; 小地图号: 306
地图代码: D2083-kfd2083 小地图号: 301; 地图代码: D2083-kfd2083; 小地图号: 301 | 地图代码: D5061-D5069 小地图号: 地图代码: D5061-D5069; 小地图号: | 地图代码: D5071 小地图号: 048; 地图代码: D5071; 小地图号: 048
地图代码: D5072 小地图号: 049; 地图代码: D5072; 小地图号: 049 | 地图代码: D5073 小地图号: 050; 地图代码: D5073; 小地图号: 050 | 地图代码: D5074 小地图号: 051; 地图代码: D5074; 小地图号: 051
地图代码: D10011 小地图号: 091; 地图代码: D10011; 小地图号: 091 | 地图代码: D10012 小地图号: 092; 地图代码: D10012; 小地图号: 092 | 地图代码: D10013 小地图号: 093; 地图代码: D10013; 小地图号: 093
地图代码: D10031 小地图号: 095; 地图代码: D10031; 小地图号: 095 | 地图代码: D10032 小地图号: 096; 地图代码: D10032; 小地图号: 096 | 地图代码: D10051 小地图号: 098; 地图代码: D10051; 小地图号: 098
地图代码: D10052 小地图号: 099; 地图代码: D10052; 小地图号: 099 | 地图代码: D10053 小地图号: 108; 地图代码: D10053; 小地图号: 108 | 地图代码: D10054 小地图号: 109; 地图代码: D10054; 小地图号: 109
地图代码: D10061 小地图号: 地图代码: D10061; 小地图号: | 地图代码: D10062 小地图号: 地图代码: D10062; 小地图号: | 地图代码: D10071 小地图号: 地图代码: D10071; 小地图号:
地图代码: D71601 小地图号: 地图代码: D71601; 小地图号: | 地图代码: D71602 小地图号: 地图代码: D71602; 小地图号: | 地图代码: D71603-D71625 小地图号: 地图代码: D71603-D71625; 小地图号:
地图代码: D71650-D71651 小地图号: 地图代码: D71650-D71651; 小地图号: | 地图代码: D71652-D71653 小地图号: 地图代码: D71652-D71653; 小地图号: | 地图代码: db001 小地图号: 地图代码: db001; 小地图号:
地图代码: ddnb 小地图号: 地图代码: ddnb; 小地图号: | 地图代码: DM001 小地图号: 地图代码: DM001; 小地图号: | 地图代码: DM002 小地图号: 地图代码: DM002; 小地图号:
地图代码: DM011 小地图号: 地图代码: DM011; 小地图号: | 地图代码: dns001 小地图号: 320; 地图代码: dns001; 小地图号: 320 | 地图代码: dualcity 小地图号: 3025; 地图代码: dualcity; 小地图号: 3025
地图代码: dygw 小地图号: 3150; 地图代码: dygw; 小地图号: 3150 | 地图代码: E001 小地图号: 059; 地图代码: E001; 小地图号: 059 | 地图代码: E002 小地图号: 060; 地图代码: E002; 小地图号: 060
地图代码: E401 小地图号: 062; 地图代码: E401; 小地图号: 062 | 地图代码: E402 小地图号: 063; 地图代码: E402; 小地图号: 063 | 地图代码: E403 小地图号: 064; 地图代码: E403; 小地图号: 064
地图代码: E404 小地图号: 065; 地图代码: E404; 小地图号: 065 | 地图代码: E601 小地图号: 067; 地图代码: E601; 小地图号: 067 | 地图代码: E602 小地图号: 068; 地图代码: E602; 小地图号: 068
地图代码: E603 小地图号: 069; 地图代码: E603; 小地图号: 069 | 地图代码: E604 小地图号: 070; 地图代码: E604; 小地图号: 070 | 地图代码: E605 小地图号: 071; 地图代码: E605; 小地图号: 071
地图代码: E701 小地图号: 073; 地图代码: E701; 小地图号: 073 | 地图代码: E702 小地图号: 074; 地图代码: E702; 小地图号: 074 | 地图代码: E703 小地图号: 075; 地图代码: E703; 小地图号: 075
地图代码: EM000 小地图号: 地图代码: EM000; 小地图号: | 地图代码: EV000 小地图号: 306; 地图代码: EV000; 小地图号: 306 | 地图代码: EV001 小地图号: 304; 地图代码: EV001; 小地图号: 304
地图代码: EV002 小地图号: 地图代码: EV002; 小地图号: | 地图代码: EV003 小地图号: 地图代码: EV003; 小地图号: | 地图代码: f001 小地图号: 037; 地图代码: f001; 小地图号: 037
地图代码: f002 小地图号: 038; 地图代码: f002; 小地图号: 038 | 地图代码: f003 小地图号: 039; 地图代码: f003; 小地图号: 039 | 地图代码: f004 小地图号: 040; 地图代码: f004; 小地图号: 040
地图代码: f005 小地图号: 041; 地图代码: f005; 小地图号: 041 | 地图代码: f006 小地图号: 111; 地图代码: f006; 小地图号: 111 | 地图代码: f007 小地图号: 112; 地图代码: f007; 小地图号: 112
地图代码: f008 小地图号: 113; 地图代码: f008; 小地图号: 113 | 地图代码: f009 小地图号: 114; 地图代码: f009; 小地图号: 114 | 地图代码: f010 小地图号: 115; 地图代码: f010; 小地图号: 115
地图代码: F011 小地图号: 046; 地图代码: F011; 小地图号: 046 | 地图代码: F012 小地图号: 地图代码: F012; 小地图号: | 地图代码: F013 小地图号: 地图代码: F013; 小地图号:
地图代码: F014 小地图号: 地图代码: F014; 小地图号: | 地图代码: FOX01 小地图号: 329; 地图代码: FOX01; 小地图号: 329 | 地图代码: FOX02 小地图号: 330; 地图代码: FOX02; 小地图号: 330
地图代码: FOX03 小地图号: 331; 地图代码: FOX03; 小地图号: 331 | 地图代码: fzd 小地图号: 地图代码: fzd; 小地图号: | 地图代码: G001 小地图号: 118; 地图代码: G001; 小地图号: 118
地图代码: G002 小地图号: 119; 地图代码: G002; 小地图号: 119 | 地图代码: G003--G014 小地图号: 116; 地图代码: G003--G014; 小地图号: 116 | 地图代码: G015 小地图号: 117; 地图代码: G015; 小地图号: 117
地图代码: GA0 小地图号: 地图代码: GA0; 小地图号: | 地图代码: GA1 小地图号: 地图代码: GA1; 小地图号: | 地图代码: GA2 小地图号: 地图代码: GA2; 小地图号:
地图代码: GA3 小地图号: 地图代码: GA3; 小地图号: | 地图代码: grly 小地图号: 地图代码: grly; 小地图号: | 地图代码: gudong01 小地图号: 地图代码: gudong01; 小地图号:
地图代码: gudong02 小地图号: 地图代码: gudong02; 小地图号: | 地图代码: gudong03 小地图号: 地图代码: gudong03; 小地图号: | 地图代码: H001 小地图号: 068; 地图代码: H001; 小地图号: 068
地图代码: H002 小地图号: 033; 地图代码: H002; 小地图号: 033 | 地图代码: H003 小地图号: 045; 地图代码: H003; 小地图号: 045 | 地图代码: H004 小地图号: 031; 地图代码: H004; 小地图号: 031
地图代码: H005 小地图号: 164; 地图代码: H005; 小地图号: 164 | 地图代码: H006 小地图号: 057; 地图代码: H006; 小地图号: 057 | 地图代码: H007 小地图号: 047; 地图代码: H007; 小地图号: 047
地图代码: H008 小地图号: 134; 地图代码: H008; 小地图号: 134 | 地图代码: H009 小地图号: 095; 地图代码: H009; 小地图号: 095 | 地图代码: H010 小地图号: 184; 地图代码: H010; 小地图号: 184
地图代码: H102 小地图号: 034; 地图代码: H102; 小地图号: 034 | 地图代码: H104 小地图号: 030; 地图代码: H104; 小地图号: 030 | 地图代码: H105 小地图号: 172; 地图代码: H105; 小地图号: 172
地图代码: H106 小地图号: 042; 地图代码: H106; 小地图号: 042 | 地图代码: H201 小地图号: 010; 地图代码: H201; 小地图号: 010 | 地图代码: H202 小地图号: 049; 地图代码: H202; 小地图号: 049
地图代码: H203 小地图号: 051; 地图代码: H203; 小地图号: 051 | 地图代码: H204 小地图号: 038; 地图代码: H204; 小地图号: 038 | 地图代码: hero001 小地图号: 地图代码: hero001; 小地图号:
地图代码: hero1 小地图号: 302; 地图代码: hero1; 小地图号: 302 | 地图代码: hgz 小地图号: 地图代码: hgz; 小地图号: | 地图代码: hjsbk 小地图号: 328; 地图代码: hjsbk; 小地图号: 328
地图代码: hjxly 小地图号: 3104; 地图代码: hjxly; 小地图号: 3104 | 地图代码: hl001 小地图号: 地图代码: hl001; 小地图号: | 地图代码: hl001 小地图号: 304; 地图代码: hl001; 小地图号: 304
地图代码: hl002 小地图号: 305; 地图代码: hl002; 小地图号: 305 | 地图代码: hmw 小地图号: 地图代码: hmw; 小地图号: | 地图代码: hz01 小地图号: 地图代码: hz01; 小地图号:
地图代码: hz02 小地图号: 地图代码: hz02; 小地图号: | 地图代码: jingxiu 小地图号: 地图代码: jingxiu; 小地图号: | 地图代码: jjc01 小地图号: 地图代码: jjc01; 小地图号:
地图代码: jjc02 小地图号: 地图代码: jjc02; 小地图号: | 地图代码: jjc03 小地图号: 地图代码: jjc03; 小地图号: | 地图代码: jjc04 小地图号: 地图代码: jjc04; 小地图号:
地图代码: jjc05 小地图号: 地图代码: jjc05; 小地图号: | 地图代码: JMZC 小地图号: 319; 地图代码: JMZC; 小地图号: 319 | 地图代码: JZ001 小地图号: 310; 地图代码: JZ001; 小地图号: 310
地图代码: JZ002 小地图号: 311; 地图代码: JZ002; 小地图号: 311 | 地图代码: JZ003 小地图号: 312; 地图代码: JZ003; 小地图号: 312 | 地图代码: JZ006 小地图号: 313; 地图代码: JZ006; 小地图号: 313
地图代码: JZ007 小地图号: 3121; 地图代码: JZ007; 小地图号: 3121 | 地图代码: k001 小地图号: 地图代码: k001; 小地图号: | 地图代码: kbhy 小地图号: 3105; 地图代码: kbhy; 小地图号: 3105
地图代码: kuanggong 小地图号: 3066; 地图代码: kuanggong; 小地图号: 3066 | 地图代码: L001 小地图号: 040; 地图代码: L001; 小地图号: 040 | 地图代码: L002 小地图号: 129; 地图代码: L002; 小地图号: 129
地图代码: L003 小地图号: 128; 地图代码: L003; 小地图号: 128 | 地图代码: L004 小地图号: 126; 地图代码: L004; 小地图号: 126 | 地图代码: L005 小地图号: 134; 地图代码: L005; 小地图号: 134
地图代码: L006 小地图号: 038; 地图代码: L006; 小地图号: 038 | 地图代码: lts101 小地图号: 325; 地图代码: lts101; 小地图号: 325 | 地图代码: M001 小地图号: 077; 地图代码: M001; 小地图号: 077
地图代码: M100 小地图号: 124; 地图代码: M100; 小地图号: 124 | 地图代码: M101 小地图号: 地图代码: M101; 小地图号: | 地图代码: mhfy 小地图号: 3153; 地图代码: mhfy; 小地图号: 3153
地图代码: mirdota02 小地图号: 3105; 地图代码: mirdota02; 小地图号: 3105 | 地图代码: n0 小地图号: 3149; 地图代码: n0; 小地图号: 3149 | 地图代码: n3 小地图号: 3035; 地图代码: n3; 小地图号: 3035
地图代码: n4 小地图号: 3167; 地图代码: n4; 小地图号: 3167 | 地图代码: n5 小地图号: 3169; 地图代码: n5; 小地图号: 3169 | 地图代码: n6 小地图号: 3170; 地图代码: n6; 小地图号: 3170
地图代码: n63 小地图号: 3060; 地图代码: n63; 小地图号: 3060 | 地图代码: n101 小地图号: 205; 地图代码: n101; 小地图号: 205 | 地图代码: n102 小地图号: 206; 地图代码: n102; 小地图号: 206
地图代码: n103 小地图号: 207; 地图代码: n103; 小地图号: 207 | 地图代码: n104 小地图号: 208; 地图代码: n104; 小地图号: 208 | 地图代码: n105 小地图号: 209; 地图代码: n105; 小地图号: 209
地图代码: n106 小地图号: 210; 地图代码: n106; 小地图号: 210 | 地图代码: n107 小地图号: 211; 地图代码: n107; 小地图号: 211 | 地图代码: n108 小地图号: 212; 地图代码: n108; 小地图号: 212
地图代码: n109 小地图号: 213; 地图代码: n109; 小地图号: 213 | 地图代码: n110 小地图号: 214; 地图代码: n110; 小地图号: 214 | 地图代码: n111 小地图号: 215; 地图代码: n111; 小地图号: 215
地图代码: NALX 小地图号: 3053; 地图代码: NALX; 小地图号: 3053 | 地图代码: nanm 小地图号: 3026; 地图代码: nanm; 小地图号: 3026 | 地图代码: nch001 小地图号: 3062; 地图代码: nch001; 小地图号: 3062
地图代码: ND024 小地图号: 3054 nd0241地图一样; 地图代码: ND024; 小地图号: 3054 nd0241地图一样 | 地图代码: ND701 小地图号: 3051; 地图代码: ND701; 小地图号: 3051 | 地图代码: ND717 小地图号: 3052; 地图代码: ND717; 小地图号: 3052
地图代码: ND2013 小地图号: 3070; 地图代码: ND2013; 小地图号: 3070 | 地图代码: ND2070 小地图号: 3068; 地图代码: ND2070; 小地图号: 3068 | 地图代码: ND2075 小地图号: 3069; 地图代码: ND2075; 小地图号: 3069
地图代码: ND2079 小地图号: 3071; 地图代码: ND2079; 小地图号: 3071 | 地图代码: ND5071 小地图号: 3072 nd50711地图一样; 地图代码: ND5071; 小地图号: 3072 nd50711地图一样 | 地图代码: ND5072 小地图号: 3073; 地图代码: ND5072; 小地图号: 3073
地图代码: ND5073 小地图号: 3074; 地图代码: ND5073; 小地图号: 3074 | 地图代码: ND5074 小地图号: 3075; 地图代码: ND5074; 小地图号: 3075 | 地图代码: Nf002 小地图号: 3057; 地图代码: Nf002; 小地图号: 3057
地图代码: NFOX01 小地图号: 3055; 地图代码: NFOX01; 小地图号: 3055 | 地图代码: NFOX02 小地图号: 3058; 地图代码: NFOX02; 小地图号: 3058 | 地图代码: NFOX03 小地图号: 3056; 地图代码: NFOX03; 小地图号: 3056
地图代码: nGA0 小地图号: 地图代码: nGA0; 小地图号: | 地图代码: ngrly 小地图号: 3061; 地图代码: ngrly; 小地图号: 3061 | 地图代码: Nhero1 小地图号: 3059 nhero2地图一样; 地图代码: Nhero1; 小地图号: 3059 nhero2地图一样
地图代码: nhjsbk 小地图号: 3076; 地图代码: nhjsbk; 小地图号: 3076 | 地图代码: Nkuanggong 小地图号: 3066; 地图代码: Nkuanggong; 小地图号: 3066 | 地图代码: Nlts102 小地图号: 3063; 地图代码: Nlts102; 小地图号: 3063
地图代码: Nr001 小地图号: 3064; 地图代码: Nr001; 小地图号: 3064 | 地图代码: NZ001 小地图号: 314 nz005,nz009 地图一样; 地图代码: NZ001; 小地图号: 314 nz005,nz009 地图一样 | 地图代码: NZ002 小地图号: 315 nz006,nz010地图一样; 地图代码: NZ002; 小地图号: 315 nz006,nz010地图一样
地图代码: NZ003 小地图号: 316 nz007,nz011地图一样; 地图代码: NZ003; 小地图号: 316 nz007,nz011地图一样 | 地图代码: NZ004 小地图号: 317 nz012地图一样; 地图代码: NZ004; 小地图号: 317 nz012地图一样 | 地图代码: NZ013 小地图号: 318 nz014,nz017~nd020地图一样; 地图代码: NZ013; 小地图号: 318 nz014,nz017~nd020地图一样
地图代码: NZ015 小地图号: 311 nz016~nz0161地图一样; 地图代码: NZ015; 小地图号: 311 nz016~nz0161地图一样 | 地图代码: NZ017 小地图号: 318; 地图代码: NZ017; 小地图号: 318 | 地图代码: NZ021 小地图号: 3122 nz0211地图一样; 地图代码: NZ021; 小地图号: 3122 nz0211地图一样
地图代码: Q001 小地图号: Q001-------Q003地图一样; 地图代码: Q001; 小地图号: Q001-------Q003地图一样 | 地图代码: Q004 小地图号: q0041地图一样; 地图代码: Q004; 小地图号: q0041地图一样 | 地图代码: Q011 小地图号: 地图代码: Q011; 小地图号:
地图代码: Q012 小地图号: q012~q014地图一样; 地图代码: Q012; 小地图号: q012~q014地图一样 | 地图代码: Q015 小地图号: 地图代码: Q015; 小地图号: | 地图代码: Q016 小地图号: 地图代码: Q016; 小地图号:
地图代码: r001 小地图号: 3064; 地图代码: r001; 小地图号: 3064 | 地图代码: S001 小地图号: 地图代码: S001; 小地图号: | 地图代码: sldg 小地图号: 3106; 地图代码: sldg; 小地图号: 3106
地图代码: T0007 小地图号: 037 T119,T219,T319地图一样; 地图代码: T0007; 小地图号: 037 T119,T219,T319地图一样 | 地图代码: T103 小地图号: T203,T303地图一样; 地图代码: T103; 小地图号: T203,T303地图一样 | 地图代码: T105 小地图号: T205,T305地图一样; 地图代码: T105; 小地图号: T205,T305地图一样
地图代码: T109 小地图号: 064 T209,T309地图一样; 地图代码: T109; 小地图号: 064 T209,T309地图一样 | 地图代码: T115 小地图号: 054 T215,T315地图一样; 地图代码: T115; 小地图号: 054 T215,T315地图一样 | 地图代码: T118 小地图号: T218,T318地图一样; 地图代码: T118; 小地图号: T218,T318地图一样
地图代码: T125 小地图号: 地图代码: T125; 小地图号: | 地图代码: T131 小地图号: T231,T331,T138,T238,T338地图一样; 地图代码: T131; 小地图号: T231,T331,T138,T238,T338地图一样 | 地图代码: T132 小地图号: T232,T332地图一样; 地图代码: T132; 小地图号: T232,T332地图一样
地图代码: T134 小地图号: T1341~T1343,T234,T334地图一样; 地图代码: T134; 小地图号: T1341~T1343,T234,T334地图一样 | 地图代码: T139 小地图号: T239,T339地图一样; 地图代码: T139; 小地图号: T239,T339地图一样 | 地图代码: T140 小地图号: T1401~T14020,T240,T340地图一样; 地图代码: T140; 小地图号: T1401~T14020,T240,T340地图一样
地图代码: T209 小地图号: 地图代码: T209; 小地图号: | 地图代码: T335 小地图号: 地图代码: T335; 小地图号: | 地图代码: T1061 小地图号: T1061~T1063至T3061~T3063地图一样; 地图代码: T1061; 小地图号: T1061~T1063至T3061~T3063地图一样
地图代码: T1281 小地图号: T1281~T1283至T3281~T3283地图一样; 地图代码: T1281; 小地图号: T1281~T1283至T3281~T3283地图一样 | 地图代码: wyzz01 小地图号: 545; 地图代码: wyzz01; 小地图号: 545 | 地图代码: wyzz 小地图号: 544; 地图代码: wyzz; 小地图号: 544
地图代码: yabiao 小地图号: 3033; 地图代码: yabiao; 小地图号: 3033 | 地图代码: ygfx1 小地图号: 3153 ygfx3地图一样; 地图代码: ygfx1; 小地图号: 3153 ygfx3地图一样 | 地图代码: ygfx2 小地图号: 3154; 地图代码: ygfx2; 小地图号: 3154
地图代码: ygsd1 小地图号: 3145; 地图代码: ygsd1; 小地图号: 3145 | 地图代码: ygsd2 小地图号: 3146; 地图代码: ygsd2; 小地图号: 3146 | 地图代码: ygsd3 小地图号: 3147; 地图代码: ygsd3; 小地图号: 3147
地图代码: ygsd4 小地图号: 3148; 地图代码: ygsd4; 小地图号: 3148 | 地图代码: YXSD 小地图号: 319; 地图代码: YXSD; 小地图号: 319 | 地图代码: zhousan 小地图号: 190; 地图代码: zhousan; 小地图号: 190
地图代码: zhouwu 小地图号: 042; 地图代码: zhouwu; 小地图号: 042 | 地图代码: zhouyi 小地图号: 045; 地图代码: zhouyi; 小地图号: 045 | 地图代码: zhuhuozhen 小地图号: 地图代码: zhuhuozhen; 小地图号:
地图代码: zlg002 小地图号: 地图代码: zlg002; 小地图号: | 地图代码: zlg003 小地图号: 地图代码: zlg003; 小地图号: | 地图代码: zlg101 小地图号: 地图代码: zlg101; 小地图号:
地图代码: dx002_01 小地图号: 地图代码: dx002_01; 小地图号: | 地图代码: em001 小地图号: 地图代码: em001; 小地图号: | 地图代码: fd 小地图号: 地图代码: fd; 小地图号:
地图代码: hell107 小地图号: 地图代码: hell107; 小地图号: | 地图代码: hell108 小地图号: 地图代码: hell108; 小地图号: | 地图代码: hell109 小地图号: 地图代码: hell109; 小地图号:
地图代码: hell201 小地图号: 3134; 地图代码: hell201; 小地图号: 3134 | 地图代码: hell202 小地图号: 3135; 地图代码: hell202; 小地图号: 3135 | 地图代码: hell203 小地图号: 3136; 地图代码: hell203; 小地图号: 3136
地图代码: hell204 小地图号: 3137; 地图代码: hell204; 小地图号: 3137 | 地图代码: hell205 小地图号: 3138; 地图代码: hell205; 小地图号: 3138 | 地图代码: hell206 小地图号: 3139; 地图代码: hell206; 小地图号: 3139
地图代码: hf001 小地图号: 3157; 地图代码: hf001; 小地图号: 3157 | 地图代码: hf002 小地图号: 3158; 地图代码: hf002; 小地图号: 3158 | 地图代码: hf003 小地图号: 3159; 地图代码: hf003; 小地图号: 3159
地图代码: hf004 小地图号: 3160; 地图代码: hf004; 小地图号: 3160 | 地图代码: hf005 小地图号: 3161 hf0051~hf0057地图一样; 地图代码: hf005; 小地图号: 3161 hf0051~hf0057地图一样 | 地图代码: hsdk1 小地图号: 3141; 地图代码: hsdk1; 小地图号: 3141
地图代码: hsdk2 小地图号: 3151; 地图代码: hsdk2; 小地图号: 3151 | 地图代码: hsdk3 小地图号: 3152; 地图代码: hsdk3; 小地图号: 3152 | 地图代码: hsdx1 小地图号: 3132; 地图代码: hsdx1; 小地图号: 3132
地图代码: hsdx2 小地图号: 3133; 地图代码: hsdx2; 小地图号: 3133 | 地图代码: hsdx3 小地图号: 3131; 地图代码: hsdx3; 小地图号: 3131 | 地图代码: jjc06 小地图号: 3116; 地图代码: jjc06; 小地图号: 3116
地图代码: jjc14 小地图号: 3114; 地图代码: jjc14; 小地图号: 3114 | 地图代码: JL1 小地图号: 地图代码: JL1; 小地图号: | 地图代码: JL2 小地图号: 地图代码: JL2; 小地图号:
地图代码: jz004 小地图号: 312 jz005,jz0051地图一样; 地图代码: jz004; 小地图号: 312 jz005,jz0051地图一样 | 地图代码: k002 小地图号: 地图代码: k002; 小地图号: | 地图代码: k004 小地图号: 地图代码: k004; 小地图号:
地图代码: leitai1 小地图号: 3117; 地图代码: leitai1; 小地图号: 3117 | 地图代码: leitai2 小地图号: 地图代码: leitai2; 小地图号: | 地图代码: lhsd 小地图号: 3174; 地图代码: lhsd; 小地图号: 3174
地图代码: lts102 小地图号: 325; 地图代码: lts102; 小地图号: 325 | 地图代码: n1 小地图号: 3166; 地图代码: n1; 小地图号: 3166 | 地图代码: n2 小地图号: 3165; 地图代码: n2; 小地图号: 3165
地图代码: n7 小地图号: 地图代码: n7; 小地图号: | 地图代码: n11 小地图号: 3168; 地图代码: n11; 小地图号: 3168 | 地图代码: n112 小地图号: 216; 地图代码: n112; 小地图号: 216
地图代码: n113 小地图号: 217; 地图代码: n113; 小地图号: 217 | 地图代码: n114 小地图号: 218; 地图代码: n114; 小地图号: 218 | 地图代码: nd2071 小地图号: 3077; 地图代码: nd2071; 小地图号: 3077
地图代码: nd2072 小地图号: 3078; 地图代码: nd2072; 小地图号: 3078 | 地图代码: nd2073 小地图号: 3079; 地图代码: nd2073; 小地图号: 3079 | 地图代码: nd2074 小地图号: 3080; 地图代码: nd2074; 小地图号: 3080
地图代码: nd2076 小地图号: 3081; 地图代码: nd2076; 小地图号: 3081 | 地图代码: nd2077 小地图号: 3082; 地图代码: nd2077; 小地图号: 3082 | 地图代码: nd2078 小地图号: 3083; 地图代码: nd2078; 小地图号: 3083
地图代码: nhl002 小地图号: 305; 地图代码: nhl002; 小地图号: 305 | 地图代码: qmlt 小地图号: 地图代码: qmlt; 小地图号: | 地图代码: redcave02 小地图号: 3142; 地图代码: redcave02; 小地图号: 3142
地图代码: redcave03 小地图号: 3143; 地图代码: redcave03; 小地图号: 3143 | 地图代码: sldx 小地图号: 3102; 地图代码: sldx; 小地图号: 3102 | 地图代码: sm001 小地图号: 3171; 地图代码: sm001; 小地图号: 3171
地图代码: sm002 小地图号: 3172; 地图代码: sm002; 小地图号: 3172 | 地图代码: ssd 小地图号: 地图代码: ssd; 小地图号: | 地图代码: village 小地图号: 326; 地图代码: village; 小地图号: 326
地图代码: w0 小地图号: w1,w2地图一样; 地图代码: w0; 小地图号: w1,w2地图一样 | 地图代码: worldcup0001 小地图号: 116 worldcup0002地图一样; 地图代码: worldcup0001; 小地图号: 116 worldcup0002地图一样 | 地图代码: wqd 小地图号: 地图代码: wqd; 小地图号:
地图代码: xc1 小地图号: 3029; 地图代码: xc1; 小地图号: 3029 | 地图代码: xcboss 小地图号: 3031; 地图代码: xcboss; 小地图号: 3031 | 地图代码: xcljtd 小地图号: 3030; 地图代码: xcljtd; 小地图号: 3030
地图代码: yd 小地图号: 地图代码: yd; 小地图号: | 地图代码: yuebing 小地图号: 地图代码: yuebing; 小地图号: | 地图代码: n0100 小地图号: 地图代码: n0100; 小地图号:
地图代码: n0101 小地图号: 地图代码: n0101; 小地图号: | 地图代码: n0102 小地图号: 地图代码: n0102; 小地图号: | 地图代码: n0103 小地图号: 地图代码: n0103; 小地图号:
地图代码: n0104 小地图号: 地图代码: n0104; 小地图号: | 地图代码: n0105 小地图号: 地图代码: n0105; 小地图号: | 地图代码: n0106 小地图号: 地图代码: n0106; 小地图号:
地图代码: n0107 小地图号: 地图代码: n0107; 小地图号: | 地图代码: n0108 小地图号: 地图代码: n0108; 小地图号: | 地图代码: n0109 小地图号: 地图代码: n0109; 小地图号:
地图代码: n0110 小地图号: n0111,n0112地图一样; 地图代码: n0110; 小地图号: n0111,n0112地图一样 | 地图代码: n0113 小地图号: 地图代码: n0113; 小地图号: | 地图代码: n0114 小地图号: n01141地图一样; 地图代码: n0114; 小地图号: n01141地图一样
地图代码: n0115 小地图号: 地图代码: n0115; 小地图号: | 地图代码: n0116 小地图号: 地图代码: n0116; 小地图号: | 地图代码: n0117 小地图号: 地图代码: n0117; 小地图号:
地图代码: n0118 小地图号: 地图代码: n0118; 小地图号: | 地图代码: n0119 小地图号: 地图代码: n0119; 小地图号: | 地图代码: n0120 小地图号: 地图代码: n0120; 小地图号:
地图代码: n0121 小地图号: 地图代码: n0121; 小地图号: | 地图代码: n0122 小地图号: 地图代码: n0122; 小地图号: | 地图代码: n0123 小地图号: 地图代码: n0123; 小地图号:
地图代码: n0124 小地图号: 地图代码: n0124; 小地图号: | 地图代码: n0125 小地图号: 地图代码: n0125; 小地图号: | 地图代码: n0126 小地图号: 地图代码: n0126; 小地图号:
地图代码: n0127 小地图号: 地图代码: n0127; 小地图号: | 地图代码: n0128 小地图号: 地图代码: n0128; 小地图号: | 地图代码: n0129 小地图号: 地图代码: n0129; 小地图号:
地图代码: n0130 小地图号: 地图代码: n0130; 小地图号: | 地图代码: n0131 小地图号: 地图代码: n0131; 小地图号: | 地图代码: n0132 小地图号: 地图代码: n0132; 小地图号:
地图代码: n0133 小地图号: 地图代码: n0133; 小地图号: | 地图代码: n0134 小地图号: 地图代码: n0134; 小地图号: | 地图代码: n0135 小地图号: 地图代码: n0135; 小地图号:
地图代码: n0136 小地图号: 地图代码: n0136; 小地图号: | 地图代码: n0137 小地图号: 地图代码: n0137; 小地图号: | 地图代码: n0138 小地图号: 地图代码: n0138; 小地图号:
地图代码: n0139 小地图号: 地图代码: n0139; 小地图号: | 地图代码: n0140 小地图号: 地图代码: n0140; 小地图号: | 地图代码: n0141 小地图号: 地图代码: n0141; 小地图号:
地图代码: n0142 小地图号: 地图代码: n0142; 小地图号: | 地图代码: n0143 小地图号: 地图代码: n0143; 小地图号: | 地图代码: n0144 小地图号: 地图代码: n0144; 小地图号:
地图代码: n0145 小地图号: 地图代码: n0145; 小地图号: | 地图代码: n0146 小地图号: 地图代码: n0146; 小地图号: | 地图代码: n0147 小地图号: 地图代码: n0147; 小地图号:
地图代码: n0148 小地图号: 地图代码: n0148; 小地图号: | 地图代码: n0149 小地图号: 地图代码: n0149; 小地图号: | 地图代码: n0150 小地图号: new0150，n0150_new地图一样; 地图代码: n0150; 小地图号: new0150，n0150_new地图一样
地图代码: n0151 小地图号: new0151地图一样; 地图代码: n0151; 小地图号: new0151地图一样 | 地图代码: n0152 小地图号: new01571地图一样; 地图代码: n0152; 小地图号: new01571地图一样 | 地图代码: n0153 小地图号: new0153地图一样; 地图代码: n0153; 小地图号: new0153地图一样
地图代码: n0154 小地图号: new01581地图一样; 地图代码: n0154; 小地图号: new01581地图一样 | 地图代码: n0155 小地图号: new0152地图一样; 地图代码: n0155; 小地图号: new0152地图一样 | 地图代码: n0156 小地图号: new0156地图一样; 地图代码: n0156; 小地图号: new0156地图一样
地图代码: n0158 小地图号: 地图代码: n0158; 小地图号: | 地图代码: n0159 小地图号: 地图代码: n0159; 小地图号: | 地图代码: n0160 小地图号: 地图代码: n0160; 小地图号:
地图代码: n0161 小地图号: 地图代码: n0161; 小地图号: | 地图代码: n1001 小地图号: 地图代码: n1001; 小地图号: | 地图代码: n1002 小地图号: 地图代码: n1002; 小地图号:
地图代码: n1003 小地图号: 地图代码: n1003; 小地图号: | 地图代码: n1004 小地图号: 地图代码: n1004; 小地图号: | 地图代码: n1005 小地图号: 地图代码: n1005; 小地图号:
地图代码: n1006 小地图号: 地图代码: n1006; 小地图号: | 地图代码: n1007 小地图号: 地图代码: n1007; 小地图号: | 地图代码: n01132 小地图号: 地图代码: n01132; 小地图号:
地图代码: nb341 小地图号: 地图代码: nb341; 小地图号: | 地图代码: nb342 小地图号: 地图代码: nb342; 小地图号: | 地图代码: nb343 小地图号: 地图代码: nb343; 小地图号:
地图代码: nb344 小地图号: 地图代码: nb344; 小地图号: | 地图代码: nb345 小地图号: 地图代码: nb345; 小地图号: | 地图代码: nb346 小地图号: 地图代码: nb346; 小地图号:
地图代码: nb347 小地图号: 地图代码: nb347; 小地图号: | 地图代码: nb351 小地图号: 地图代码: nb351; 小地图号: | 地图代码: nb352 小地图号: 地图代码: nb352; 小地图号:
地图代码: nb353 小地图号: 地图代码: nb353; 小地图号: | 地图代码: nb354 小地图号: 地图代码: nb354; 小地图号: | 地图代码: nb355 小地图号: 地图代码: nb355; 小地图号:
地图代码: nb356 小地图号: 地图代码: nb356; 小地图号: | 地图代码: ncqbgc 小地图号: 地图代码: ncqbgc; 小地图号: | 地图代码: new0154 小地图号: 地图代码: new0154; 小地图号:
地图代码: new0155 小地图号: 地图代码: new0155; 小地图号: | 地图代码: ngudong01 小地图号: 地图代码: ngudong01; 小地图号: | 地图代码: ngudong02 小地图号: 地图代码: ngudong02; 小地图号:
地图代码: ngudong03 小地图号: 地图代码: ngudong03; 小地图号: | 地图代码: sd 小地图号: 地图代码: sd; 小地图号: | 地图代码: shud 小地图号: 地图代码: shud; 小地图号:
地图代码: sj00 小地图号: 1001; 地图代码: sj00; 小地图号: 1001 | 地图代码: sj01 小地图号: 1002; 地图代码: sj01; 小地图号: 1002 | 地图代码: sj03 小地图号: 1003; 地图代码: sj03; 小地图号: 1003
地图代码: sj04 小地图号: 1004; 地图代码: sj04; 小地图号: 1004 | 地图代码: sj011 小地图号: 地图代码: sj011; 小地图号: | 地图代码: sj012 小地图号: 地图代码: sj012; 小地图号:
地图代码: sj013 小地图号: 地图代码: sj013; 小地图号: | 地图代码: sj021 小地图号: 1008; 地图代码: sj021; 小地图号: 1008 | 地图代码: sj022 小地图号: 1009; 地图代码: sj022; 小地图号: 1009
地图代码: sj031 小地图号: 地图代码: sj031; 小地图号: | 地图代码: sj032 小地图号: 地图代码: sj032; 小地图号: | 地图代码: sj0211 小地图号: 地图代码: sj0211; 小地图号:
地图代码: sj0212 小地图号: 地图代码: sj0212; 小地图号: | 地图代码: sj0222 小地图号: 地图代码: sj0222; 小地图号: | 地图代码: sj0223 小地图号: 地图代码: sj0223; 小地图号:


NPC代码

来源：ET引擎帮助文档　分类：基础编号资料

NPC 外观代码对照表。

共 159 条 NPC 代码资料。

NPC 代码：0 | NPC 代码：1 | NPC 代码：2 | NPC 代码：3
NPC 代码：4 | NPC 代码：5 | NPC 代码：6 | NPC 代码：7
NPC 代码：8 | NPC 代码：9 | NPC 代码：10 | NPC 代码：11
NPC 代码：12 | NPC 代码：13 | NPC 代码：14 | NPC 代码：15
NPC 代码：16 | NPC 代码：17 | NPC 代码：18 | NPC 代码：19
NPC 代码：20 | NPC 代码：21 | NPC 代码：22 | NPC 代码：23
NPC 代码：24 | NPC 代码：25 | NPC 代码：26 | NPC 代码：27
NPC 代码：28 | NPC 代码：29 | NPC 代码：30 | NPC 代码：31
NPC 代码：32 | NPC 代码：33 | NPC 代码：34 | NPC 代码：35
NPC 代码：36 | NPC 代码：37 | NPC 代码：38 | NPC 代码：39
NPC 代码：40 | NPC 代码：41 | NPC 代码：42 | NPC 代码：43
NPC 代码：48 | NPC 代码：49 | NPC 代码：50 | NPC 代码：51
NPC 代码：52 | NPC 代码：59 | NPC 代码：60 | NPC 代码：61
NPC 代码：62 | NPC 代码：63 | NPC 代码：64 | NPC 代码：65
NPC 代码：66 | NPC 代码：67 | NPC 代码：68 | NPC 代码：70
NPC 代码：71 | NPC 代码：72 | NPC 代码：73 | NPC 代码：74
NPC 代码：75 | NPC 代码：76 | NPC 代码：77 | NPC 代码：78
NPC 代码：79 | NPC 代码：80 | NPC 代码：81 | NPC 代码：82
NPC 代码：83 | NPC 代码：84 | NPC 代码：90 | NPC 代码：91
NPC 代码：92 | NPC 代码：94 | NPC 代码：95 | NPC 代码：96
NPC 代码：97 | NPC 代码：98 | NPC 代码：99 | NPC 代码：100
NPC 代码：101 | NPC 代码：102 | NPC 代码：200 | NPC 代码：201
NPC 代码：202 | NPC 代码：203 | NPC 代码：204 | NPC 代码：205
NPC 代码：206 | NPC 代码：207 | NPC 代码：208 | NPC 代码：209
NPC 代码：210 | NPC 代码：211 | NPC 代码：212 | NPC 代码：213
NPC 代码：214 | NPC 代码：215 | NPC 代码：216 | NPC 代码：217
NPC 代码：218 | NPC 代码：219 | NPC 代码：220 | NPC 代码：221
NPC 代码：222 | NPC 代码：223 | NPC 代码：224 | NPC 代码：225
NPC 代码：226 | NPC 代码：227 | NPC 代码：228 | NPC 代码：229
NPC 代码：230 | NPC 代码：231 | NPC 代码：232 | NPC 代码：233
NPC 代码：234 | NPC 代码：235 | NPC 代码：236 | NPC 代码：237
NPC 代码：238 | NPC 代码：239 | NPC 代码：240 | NPC 代码：241
NPC 代码：242 | NPC 代码：243 | NPC 代码：244 | NPC 代码：245
NPC 代码：246 | NPC 代码：247 | NPC 代码：248 | NPC 代码：249
NPC 代码：250 | NPC 代码：251 | NPC 代码：252 | NPC 代码：253
NPC 代码：254 | NPC 代码：255 | NPC 代码：256 | NPC 代码：257
NPC 代码：258 | NPC 代码：259 | NPC 代码：260 | NPC 代码：261
NPC 代码：262 | NPC 代码：263 | NPC 代码：264 | NPC 代码：265
NPC 代码：266 | NPC 代码：267 | NPC 代码：268 | NPC 代码：269
NPC 代码：270 | NPC 代码：271 | NPC 代码：272 |


怪物编号

来源：ET引擎帮助文档　分类：基础编号资料

怪物外观编号（APPR）对照表。

共 369 条怪物编号资料。

APPR:1 | APPR:2 | APPR:3
APPR:10 | APPR:11 | APPR:20
APPR:21 | APPR:22 | APPR:23
APPR:24 | APPR:25 | APPR:26
APPR:27 | APPR:28 | APPR:29
APPR:30 | APPR:31 | APPR:32
APPR:33 | APPR:34 | APPR:36
APPR:37 | APPR:38 | APPR:39
APPR:40 | APPR:41 | APPR:42
APPR:43 | APPR:44 | APPR:45
APPR:46 | APPR:47 | APPR:48
APPR:49 | APPR:50 | APPR:51
APPR:52 | APPR:53 | APPR:61
APPR:62 | APPR:63 | APPR:70
APPR:71 | APPR:72 | APPR:73
APPR:74 | APPR:80 | APPR:81
APPR:82 | APPR:83 | APPR:90
APPR:91 | APPR:92 | APPR:93
APPR:100 | APPR:101 | APPR:102
APPR:103 | APPR:104 | APPR:110
APPR:111 | APPR:112 | APPR:113
APPR:114 | APPR:115 | APPR:116
APPR:117 | APPR:118 | APPR:119
APPR:120 | APPR:121 | APPR:122
APPR:130 | APPR:131 | APPR:132
APPR:133 | APPR:140 | APPR:141
APPR:142 | APPR:143 | APPR:144
APPR:145 | APPR:146 | APPR:147
APPR:148 | APPR:150 | APPR:151
APPR:152 | APPR:153 | APPR:160
APPR:161 | APPR:162 | APPR:163
APPR:164 | APPR:165 | APPR:166
APPR:170 | APPR:171 | APPR:172
APPR:173 | APPR:180 | APPR:181
APPR:182 | APPR:183 | APPR:184
APPR:185 | APPR:186 | APPR:187
APPR:190 | APPR:191 | APPR:192
APPR:193 | APPR:194 | APPR:195
APPR:196 | APPR:200 | APPR:201
APPR:202 | APPR:203 | APPR:204
APPR:205 | APPR:206 | APPR:207
APPR:208 | APPR:209 | APPR:210
APPR:211 | APPR:212 | APPR:213
APPR:214 | APPR:215 | APPR:216
APPR:218 | APPR:220 | APPR:221
APPR:222 | APPR:223 | APPR:230
APPR:231 | APPR:232 | APPR:233
APPR:234 | APPR:235 | APPR:236
APPR:237 | APPR:238 | APPR:239
APPR:240 | APPR:241 | APPR:242
APPR:243 | APPR:250 | APPR:251
APPR:252 | APPR:253 | APPR:254
APPR:255 | APPR:256 | APPR:258
APPR:259 | APPR:260 | APPR:261
APPR:262 | APPR:263 | APPR:264
APPR:265 | APPR:266 | APPR:267
APPR:270 | APPR:271 | APPR:272
APPR:273 | APPR:274 | APPR:275
APPR:280 | APPR:281 | APPR:290
APPR:291 | APPR:292 | APPR:320
APPR:321 | APPR:322 | APPR:323
APPR:324 | APPR:325 | APPR:326
APPR:327 | APPR:328 | APPR:329
APPR:330 | APPR:331 | APPR:332
APPR:333 | APPR:334 | APPR:336
APPR:337 | APPR:340 | APPR:341
APPR:342 | APPR:350 | APPR:351
APPR:353 | APPR:354 | APPR:355
APPR:356 | APPR:357 | APPR:358
APPR:359 | APPR:360 | APPR:361
APPR:362 | APPR:363 | APPR:364
APPR:365 | APPR:366 | APPR:370
APPR:371 | APPR:372 | APPR:373
APPR:374 | APPR:375 | APPR:376
APPR:377 | APPR:378 | APPR:379
APPR:380 | APPR:381 | APPR:382
APPR:383 | APPR:390 | APPR:391
APPR:392 | APPR:393 | APPR:394
APPR:395 | APPR:396 | APPR:397
APPR:400 | APPR:401 | APPR:402
APPR:410 | APPR:411 | APPR:412
APPR:413 | APPR:414 | APPR:415
APPR:416 | APPR:417 | APPR:418
APPR:419 | APPR:420 | APPR:421
APPR:422 | APPR:423 | APPR:430
APPR:450 | APPR:451 | APPR:452
APPR:453 | APPR:454 | APPR:455
APPR:456 | APPR:457 | APPR:458
APPR:459 | APPR:460 | APPR:461
APPR:462 | APPR:463 | APPR:464
APPR:465 | APPR:466 | APPR:467
APPR:468 | APPR:469 | APPR:470
APPR:471 | APPR:472 | APPR:473
APPR:474 | APPR:475 | APPR:476
APPR:477 | APPR:480 | APPR:481
APPR:482 | APPR:483 | APPR:484
APPR:485 | APPR:486 | APPR:487
APPR:488 | APPR:490 | APPR:491
APPR:492 | APPR:493 | APPR:494
APPR:495 | APPR:496 | APPR:497
APPR:501 | APPR:502 | APPR:503
APPR:504 | APPR:505 | APPR:506
APPR:507 | APPR:508 | APPR:509
APPR:510 | APPR:511 | APPR:512
APPR:520 | APPR:521 | APPR:522
APPR:523 | APPR:524 | APPR:525
APPR:526 | APPR:527 | APPR:528
APPR:529 | APPR:613 | APPR:614
APPR:615 | APPR:616 | APPR:617
APPR:618 | APPR:619 | APPR:620
APPR:621 | APPR:622 | APPR:623
APPR:624 | APPR:630 | APPR:631
APPR:632 | APPR:633 | APPR:634
APPR:635 | APPR:636 | APPR:637
APPR:638 | APPR:639 | APPR:640
APPR:641 | APPR:642 | APPR:643
APPR:644 | APPR:645 | APPR:646
APPR:647 | APPR:648 | APPR:649
APPR:650 | APPR:651 | APPR:652
APPR:653 | APPR:654 | APPR:655
APPR:656 | APPR:657 | APPR:658
APPR:659 | APPR:660 | APPR:661
APPR:800 | APPR:801 | APPR:802


颜色列表

来源：ET引擎帮助文档　分类：基础编号资料

引擎颜色编号 0–255 对照表。

0 | 1 | 2 | 3 | 4
5 | 6 | 7 | 8 | 9
10 | 11 | 12 | 13 | 14
15 | 16 | 17 | 18 | 19
20 | 21 | 22 | 23 | 24
25 | 26 | 27 | 28 | 29
30 | 31 | 32 | 33 | 34
35 | 36 | 37 | 38 | 39
40 | 41 | 42 | 43 | 44
45 | 46 | 47 | 48 | 49
50 | 51 | 52 | 53 | 54
55 | 56 | 57 | 58 | 59
60 | 61 | 62 | 63 | 64
65 | 66 | 67 | 68 | 69
70 | 71 | 72 | 73 | 74
75 | 76 | 77 | 78 | 79
80 | 81 | 82 | 83 | 84
85 | 86 | 87 | 88 | 89
90 | 91 | 92 | 93 | 94
95 | 96 | 97 | 98 | 99
100 | 101 | 102 | 103 | 104
105 | 106 | 107 | 108 | 109
110 | 111 | 112 | 113 | 114
115 | 116 | 117 | 118 | 119
120 | 121 | 122 | 123 | 124
125 | 126 | 127 | 128 | 129
130 | 131 | 132 | 133 | 134
135 | 136 | 137 | 138 | 139
140 | 141 | 142 | 143 | 144
145 | 146 | 147 | 148 | 149
150 | 151 | 152 | 153 | 154
155 | 156 | 157 | 158 | 159
160 | 161 | 162 | 163 | 164
165 | 166 | 167 | 168 | 169
170 | 171 | 172 | 173 | 174
175 | 176 | 177 | 178 | 179
180 | 181 | 182 | 183 | 184
185 | 186 | 187 | 188 | 189
190 | 191 | 192 | 193 | 194
195 | 196 | 197 | 198 | 199
200 | 201 | 202 | 203 | 204
205 | 206 | 207 | 208 | 209
210 | 211 | 212 | 213 | 214
215 | 216 | 217 | 218 | 219
220 | 221 | 222 | 223 | 224
225 | 226 | 227 | 228 | 229
230 | 231 | 232 | 233 | 234
235 | 236 | 237 | 238 | 239
240 | 241 | 242 | 243 | 244
245 | 246 | 247 | 248 | 249
250 | 251 | 252 | 253 | 254
255 |  |  |  |


地图参数表

来源：ETmir2引擎帮助文档　分类：基础编号资料

地图配置文件参数标志及说明，共 63 条。

地图参数标志 | 说明
CHECKQUEST | 进入本地图执行任务脚本 格式：CHECKQUEST(Q001) 说明： Q001 代表脚本名。
NEEDSET_ON | 进入本地图需要人物指定标志为打开状态 格式：NEEDSET_ON(001) 说明：001 代表人物标志
NEEDSET_OFF | 进入本地图需要人物指定标志为关闭状态 格式：NEEDSET_OFF(001) 说明：001 代表人物标志
MUSIC | 进入入本地图播放音乐 格式：MUSIC(Wav\bg.mp3) 或者 MUSIC(Wav\sellect-loop2.wav)代表客户端Wav目录下的sellect-loop2.wav文件
EXPRATE | 进入本地图后杀怪经验倍数 格式：EXPRATE(100) 说明：100代表经验倍数，除以100后为实际倍数。
PKWINLEVEL | 进入本地图后可以PK升级 格式：PKWINLEVEL(1) 说明：1代表升多少级；
PKWINEXP | 进入本地图后可以PK得经验 格式：PKWINEXP(1000) 说明：1000代表得多少经验；
PKLOSTLEVEL | 进入本地图后可以PK死亡掉等级 格式：PKLOSTLEVEL(1) 说明：1代表掉多少等级；
PKLOSTEXP | 进入本地图后可以PK死亡掉经验 格式：PKLOSTEXPP(1000) 说明：1000代表掉多少经验；
DECHP | 进入本地图后自动减HP 格式：DECHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCHP | 进入本地图后自动加HP 格式：INCHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次加多少点；
DECGAMEGOLD | 进入本地图后自动减游戏币 格式：DECGAMEGOLD(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCGAMEGOLD | 进入本地图后自动加游戏币 格式：INCGAMEGOLD(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；
INCGAMEPOINT | 进入本地图后自动加游戏点 格式：INCGAMEPOINT(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；(用于游戏泡点功能)
RUNMON | 允许穿怪
RUNHUMAN | 允许穿人
NORUNMON | 禁止穿怪
NORUNHUMAN | 禁止穿人
NEEDHOLE | 进入需要洞
NORECALL | 禁止记忆召唤
NOGUILDRECALL | 禁止行会召唤
NODEARRECALL | 禁止夫妻召唤
NOMasterRECALL | 禁止师徒传送
NORANDOMMOVE | 禁止使用瞬息移动
NODRUG | 禁止吃药
MINE | 可以挖矿
NODEAL | 禁止交易
NOPOSITIONMOVE | 禁止定座标移动
NORECONNECT | 进游戏时退出本地图 格式:NORECONNECT(3) 说明：3 代表地图号盟重
QUIZ | 禁止喊话
ALLOWUSEMYSHOP | 允许摆摊，该参数只对个人商店的摆摊有效，对仿Hero摆摊的无效(必需先设置摆摊限制在指定地图才会生效)
NOALLOWUSEITEMS | 禁止使用物品 说明：NOALLOWUSEITEMS(回城卷|强效金创药)
NOTALLOWUSEMAGIC | 禁止使用技能 说明：NOTALLOWUSEMAGIC(火墙|彻地钉)
NOHEROPROTECT | 为禁止英雄守护
THUNDER | 例:THUNDER(10) 此地图有闪电效果,击中减hp为10
LAVA | 例:LAVA(10) 此地图地上冒岩浆,击中减HP为10
FLAME | FLAME(45:82:50|43:84:50)参数说明:x坐标：y坐标：伤害 可以为多坐标以|分隔
HORSE | 允许骑马
MISSION | 不允许使用任何物品和技能，并且宝宝在该地图会自动消失，不能攻击
NOMANNOMON | 智能刷怪 无效
NOCALLHERO | 禁止召唤英雄，已召唤英雄将自动消失
NIGHT | 该参数与M2内挂设置配合使用，当M2设置免蜡烛时凡是地图带NIGHT开启天气效果，M2取消免蜡烛时不带该参数的地图天启天气效果
NEEDLEVELTIME | 没到指定等级时不让进入，发送string.ini里的NeedLevelToXYErrorMsg提示可以自行修改
DECEXPRATETIME(值) | 每秒减双倍经验时间,如值小于1时，则默认为1
NGEXPRATE(数值) | 内功经验倍数(100代表经验倍数，除以100后为实际倍数)
PULSEXPRATE(数值) | 经络经验倍数(100代表经验倍数，除以100后为实际倍数)
DARK | 黑暗效果 如果同时存在 DAY以DAY参数效果为准
DAY | 白天效果 如果同时存在DARK以DAY参数效果为准
SAYLEVEL(等级) | 可限制当前地图人物说话等级.
DELDROPITEM | 人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).
REVIVAL(X:N) | 当前地图人物可复活的次数,X表示复活次数,N表示人物在当前地图已经复活次数的自动清零间隔(最小30秒).具体表示:每经过指定秒人物在当前地图复活过的次数自动减1.
NODROPUSEITEMS | 当前地图人物死亡不掉落身上的物品
NOSAFEPOSITIONMOVE | 禁止在当前地图安全区中使用传送戒指
NOALLOWUSEITEMS | 不允许使用物品NOALLOWUSEITEMS(回城卷,随机传送卷)
ONKILLMON | 杀死怪物时触发,对应地图参数中需要加入ONKILLMON才可生效!
HITMON(触发字段) | 攻击怪物 触发。 例:HITMON(@攻击) 攻击怪物会触发QF脚本的[@攻击]字段
FIGHT | 杀人不加PK值 死亡不掉装备
FIGHT2 | 杀人不加PK值 死亡掉装备
FIGHT3(是否掉装备) | 行会战地图 进入该地图名字颜色会变色，杀人不加PK。格式:FIGHT3(0) 死亡不掉装备 格式:FIGHT3(1) 死亡掉装备
FIGHT4 | 挑战地图 杀人不加PK 死亡不掉装备
WEATHER1 | 天气效果1 读取Effect_SE.wzl
WEATHER2 | 天气效果2 读取Effect_SE.wzl
WEATHER3 | 天气效果3 读取Effect_SE.wzl
SAFE | 地图安全区域


QFunction-0.txt(功能脚本)

来源：ET引擎说明文档　分类：基础资料
汇总 ET 引擎说明文档中明确用于 QFunction-0.txt 的固定触发字段、扩展回调和动态触发模式。点击“触发字段”可打开对应详情页；常量栏只列出该触发最主要的专属常量，完整用法以详情页为准。

触发字段 135动态模式 27来源页面 83

快速跳转： 人物与系统　战斗与技能　宝宝与英雄　物品与装备　行会地图与动态触发
触发字段 | 关联常量 | 关联参数 | 说明
人物与系统
[@ET反挂加载] | <$ETMACHINEID> | — | 反外挂客户端加载成功后触发，可用于初始化插件侧功能。
[@ET版本自定义标记文本] | <$STR(S$ET版本自定义标记文本)> | ●; 读取 data\bbzdywb.txt，文本长度≤32 | 客户端版本标记下发完成后触发。
[@ET地图变更] | — | — | 人物切换到其他地图时触发。
[@ET离开地图] | — | — | 人物离开当前地图时触发；该字段在更新日志中明确新增。
[@ET进入安全区] | — | — | 人物进入安全区域时触发。
[@ET离开安全区] | — | — | 人物离开安全区域时触发。
[@ET传送控制] | — | ●; ETAllowTag：1允许，0禁止 | 传送执行前触发，可决定是否允许传送。
[@ET小退控制] | — | ●; ETAllowTag：1允许，0禁止 | 人物小退前触发，可拦截小退。
[@ET大退控制] | — | ●; ETAllowTag：1允许，0禁止 | 人物大退前触发，可拦截大退。
[@PlayReconnection] | — | — | 人物小退/重连时触发。
[@PlayOffLine] | — | — | 人物大退离线时触发。
[@PlayLevelUp] | — | — | 人物升级时触发。
[@PlayDie] | <$CURRRTARGETNAME> | — | 人物死亡时的兼容触发字段。
[@ETPLAYDIE] | <$ETKILLERRACE>、<$ETKILLERNAME>、<$ETKILLERNAMECLIENT> | — | ET扩展死亡触发，补充击杀者类型与名称信息。
[@ET死亡前触发] | — | — | 人物真正死亡前触发。
[@Revival] | — | — | 人物复活时触发。
[@GetExp] | <$GetExp> | — | 人物获得经验时触发。
[@ETStartAutoPlayGame] | — | ●; 调用同名命令最终放行 | 玩家点击开始自动挂机时触发。
[@ETStopAutoPlayGame] | — | — | 玩家停止自动挂机或脚本主动停止时触发。
[@UsePlugin] | — | — | 检测到外挂/插件行为时触发。
[@Help] | — | — | 点击客户端帮助按钮时触发。
[@FindPathBegin] | — | — | 点击小地图开始自动寻路时触发。
[@FindPathStop] | — | — | 自动寻路被停止时触发。
[@FindPathEnd] | — | — | 自动寻路到达终点时触发。
[@ETOnTimerX] | — | ●; X=定时器索引 0–30 | 个人定时器到期后触发。
[@MoneyChange] | <$STR(S1)>（变更的货币名称） | — | 自定义货币数量发生变更时触发。
[@ETChangeAccountInfoOK] | — | — | 账号资料修改成功回调。
[@ETChangeAccountInfoError] | — | — | 账号错误或密保资料不完整回调。
[@ETChangeAccountInfoBusy] | — | — | 并发修改繁忙回调。
[@ETChangeAccountInfoError1] | — | — | 防扫号网关未正确安装或版本不匹配回调。
[@ETChangeAccountInfoError2] | — | — | 账号资料修改未知错误回调。
战斗与技能
[@Attack] | <$CURRRTARGETNAME>、<$CURRRUSEMAGICID> | — | 人物物理攻击目标时触发。
[@Struck] | <$CURRRTARGETNAME>、<$CURRRUSEMAGICID> | — | 人物受到物理攻击时触发。
[@MagicAttack] | <$CURRRTARGETNAME>、<$CURRRUSEMAGICID> | — | 人物使用魔法攻击目标时触发。
[@MagicStruck] | <$CURRRTARGETNAME>、<$CURRRUSEMAGICID> | — | 人物受到魔法攻击时触发。
[@HookAttack] | <$ETCURRRTARGETNAME> | ●; 参数2–4指定N变量：目标类型、技能ID、伤害值 | 启用物理攻击HOOK后回调，可修改最终伤害。
[@HookStruck] | <$ETCURRRTARGETNAME> | ●; 参数2–4指定N变量：目标类型、技能ID、伤害值 | 启用被物理攻击HOOK后回调，可修改最终伤害。
[@HookMagic] | <$ETCURRRTARGETNAME> | ●; 参数2–4指定N变量：目标类型、技能ID、伤害值 | 启用魔法攻击HOOK后回调，可修改最终伤害。
[@HookMagicStruck] | <$ETCURRRTARGETNAME> | ●; 参数2–4指定N变量：目标类型、技能ID、伤害值 | 启用被魔法攻击HOOK后回调，可修改最终伤害。
[@AttackDamage] | <$DamageValue> | ●; ChangeDamageValue | 人物攻击目标掉血前触发。
[@HeroAttackDamage] | <$H.DamageValue> | ●; ChangeDamageValue | 英雄攻击目标掉血前触发。
[@StruckDamage] | <$DamageValue> | ●; ChangeDamageValue | 人物被攻击掉血前触发。
[@HeroStruckDamage] | <$H.DamageValue> | ●; ChangeDamageValue | 英雄被攻击掉血前触发。
[@ETBeforeCritTrigger] | — | ●; ETReturn 可拦截 | 暴击结算前触发。
[@ETCritTrigger] | <$ETPARAM1>、<$ETPARAM2>、<$STR(N$暴击)> | ●; Return 伤害值 | 人物暴击触发，可改写暴击伤害。
[@ETBeginMagic] | <$ETMagicID>、<$ETMagicName>、<$ETMagicTarget>、<$ETMagicTargetRace> | ●; 控制命令决定是否继续施法 | 人物开始释放技能前触发。
[@ET交易前触发控制] | — | ●; 控制命令决定是否允许交易 | 交易动作执行前触发。
[@ET技能前触发控制] | <$CURRRUSEMAGICID> | ●; 控制命令决定是否允许施法 | 技能动作执行前触发。
[@ETDEALTRY] | <$STR(S$ETDEALTRYNAME)> | — | 交易尝试前的扩展触发。
[@ET烈火触发] | — | — | 烈火剑法触发。
[@ET开天触发] | — | — | 开天斩触发。
[@ET逐日触发] | — | — | 逐日剑法触发。
[@MagSelfFuncX] | — | ●; X=技能ID | 自身使用指定技能时触发。
[@MagTagFuncX] | — | ●; X=技能ID | 对人物目标使用指定技能时，施法者触发。
[@MagTagFuncExX] | — | ●; X=技能ID | 人物目标被指定技能命中时触发。
[@MagMonFuncX] | — | ●; X=技能ID | 怪物目标被指定技能命中时触发。
宝宝与英雄
[@宝宝物理攻击] | <$BATTACKMONSTER_*> | — | 宝宝进行物理攻击时触发。
[@宝宝魔法攻击] | <$BATTACKMONSTER_*> | — | 宝宝进行魔法攻击时触发。
[@OnSlaveAdd] | — | — | 人物新增/获得宝宝时触发。
[@OnSlaveLevel] | <$CURRRTARGETNAME> | — | 宝宝升级时触发。
[@OnSlaveDie] | <$CURRRTARGETNAME> | — | 宝宝死亡时触发。
[@KillSlave] | — | — | 杀死人物宝宝时触发。
[@HeroGetExp] | <$HeroGetExp> | — | 英雄获得经验时触发。
[@HeroLevelUp] | — | — | 英雄升级时触发。
物品与装备
[@物品爆出反馈] | <$STR(S$当前爆出物品名称)>、<$STR(S$当前爆出地图名称)>、<$STR(S$当前爆出怪物名称)> | — | 怪物物品爆出后的反馈触发。
[@M2DropItem] | <$DROPITEMNAME>、<$DROPMONNAME>、<$DROPMAPNAME>、<$DROPMAPNAMES> | — | 物品爆出鉴定专用触发。
[@自定义爆率触发字段] | <$DROPITEMNAME> | ●; 爆率行：物品名|@自定义字段 | 由怪物爆率文件配置的自定义QF触发字段。
[@ETDropUseItems] | <$DROPUSEITEMS.*> | — | 人物身上装备被爆出后触发。
[@ETDropBagItems] | <$DROPBAGITEMS.*> | — | 人物背包物品被爆出后触发。
[@HumDropItem] | — | — | 脚本命令使人物物品掉落时触发。
[@DropItem0] | <$CURRTEMNAME>、<$G_CURRTEMNAME>、<$CURRTEMSTDMODE> 等 | — | 人物扔出物品时触发。
[@PickUpItem0] | <$CURRTEMNAME>、<$G_CURRTEMNAME>、<$CURRTEMMAKEINDEX> 等 | — | 人物捡取物品时的基础触发。
[@PickUpItemEx] | <$CURRTEMNAME>、<$G_CURRTEMNAME>、<$CURRTEMMAKEINDEX> 等 | — | 人物捡取物品时的扩展触发。
[@PickUpItemX] | — | ●; X=对应触发编号 | 捡取物品关联LINKPICKUPITEM时使用。
[@DropItemX] | — | ●; X=对应触发编号 | 扔出物品关联LINKPICKUPITEM时使用。
[@TakeOnX] | — | ●; X=装备位置 0–18 | 穿戴指定装备位置的物品时触发。
[@TakeOffX] | — | ●; X=装备位置 0–18 | 取下指定装备位置的物品时触发。
[@TakeOnALL] | <$ETTakeOnNAME>、<$ETTakeOnIndex> | — | 任意引擎装备穿戴后触发。
[@TakeOffALL] | <$ETTakeOffNAME>、<$ETTakeOffIndex> | — | 任意引擎装备取下后触发。
[@ETTAKEON] | <$DLGITEM.NAME>、<$DLGITEM.STDMODE> | — | 时装首饰穿戴后触发。
[@ETTAKEOFF] | <$DLGITEM.NAME>、<$DLGITEM.STDMODE> | — | 时装首饰取下后触发。
[@ET穿戴前触发] | <$ETITEMNAME> | ●; 控制命令可阻止穿戴 | 装备穿戴动作执行前触发。
[@ET脱下前触发] | <$ETITEMNAME> | ●; 控制命令可阻止脱下 | 装备脱下动作执行前触发。
[@ItemDamageX] | — | ●; X=装备位置 0–18 | 装备持久耗尽消失时触发。
[@ET装备升级成功] | — | — | ET装备升级成功时触发。
[@ET装备升级失败] | — | — | ET装备升级失败时触发。
[@ET装备升级破碎] | — | — | ET装备升级破碎时触发。
[@UpgradeOKX] | — | ●; X=装备位置 | 兼容装备升级成功触发。
[@UpgradeFailX] | — | ●; X=装备位置 | 兼容装备升级失败触发。
[@UpgradeClearX] | — | ●; X=装备位置 | 装备升级属性被清除时触发。
[@AddLuck] | — | — | 使用祝福油时触发。
[@ETConfirmUseItem] | <$STR(N1)> | ●; 控制是否继续使用聚灵珠 | 聚灵珠使用前触发。
[@StdModeFuncX] | — | ●; X=AniCount，通常 1–999 | 双击指定物品时按AniCount触发。
[@GroupItemOnX] | — | ●; X=套装编号 | 人物套装生效时触发。
[@GroupItemOffX] | — | ●; X=套装编号 | 人物套装失效时触发。
[@HeroGroupItemOnX] | — | ●; X=套装编号 | 英雄套装生效时触发。
[@HeroGroupItemOffX] | — | ●; X=套装编号 | 英雄套装失效时触发。
[@ETGIVE] | <$CURRTEMNAME> | — | GIVE制造装备物品后触发，可关联刚生成的物品。
[@ETNotShopBuy] | — | ●; ETALLOWDROP：1禁止，0允许 | HERO摆摊/个人商铺购买前拦截。
[@ET购买商品物品] | <$STR(S$ET购买商品名称)> | — | 商城购买商品成功时触发。
[@BuyShopItem] | <$STR(S0)>（物品名）、<$STR(M0)>（价格） | — | 商铺购买物品成功时触发。
[@ETBeginShopItemUp] | <$ETUserShopName>、<$ETCURITEMNAME>、<$ETCurItemPrices> 等 | ●; ETStopShopItem 可中止 | 个人商店物品上架前触发。
[@ETBeginShopItemDown] | <$ETUserShopName>、<$ETCURITEMNAME>、<$ETCurItemPrices> 等 | ●; ETStopShopItem 可中止 | 个人商店物品下架前触发。
[@ETBeginHeroM2ItemUp] | <$ETCURITEMNAME>、<$ETCurItemPrices> 等 | ●; ETStopShopItem 可中止 | 仿HERO摆摊物品上架前触发。
[@StartMyShop] | — | ●; ForbidMyShop 可中断 | 仿HERO摆摊开始前触发。
[@StopMyShop] | — | — | 仿HERO摆摊停止时触发。
[@ShopStall] | — | ●; 地图参数 ALLOWUSEMYSHOP | 个人商店摆摊开始/停止时触发。
[@QueryMyShopFail] | — | — | 点击“我的商店”但尚未创建店铺时触发。
[@CreateMyShopOK] | — | — | 个人商店创建成功回调。
[@CreateMyShopFail] | — | — | 个人商店创建失败回调。
行会地图与动态触发
[@ET行会加入] | <$STR(S$当前行会名称)> | — | 人物加入行会时触发。
[@ET行会退出] | <$STR(S$当前行会名称)> | — | 人物退出行会时触发。
[@BattleCastle] | <$STR(S0)>、<$STR(S1)>、<$STR(S2)>、<$STR(N0)> | — | 行会占领/争夺城堡时触发。
[@BeginCastle] | <$STR(S0)> | — | 攻城战开始时触发。
[@EndCastleHint] | <$STR(S0)>、<$STR(N0)> | — | 攻城战即将结束时触发。
[@EndCastle] | <$STR(S0)>、<$STR(S1)>、<$STR(S2)>、<$STR(N0)> | — | 攻城战结束时触发。
[@GetCastleX] | — | ●; X=城堡编号 | 指定城堡被占领时触发。
[@GetCastle0] | — | — | 默认城堡占领触发。
[@GroupCreate] | — | — | 创建队伍时触发。
[@StartGroup] | — | — | 队伍开始/组队成功时触发。
[@LeaveGroup] | <$STR(S0)> / <$STR(S$0)> | — | 人物离开队伍时触发。
[@GroupDelMember] | <$STR(S0)> / <$STR(S$0)> | — | 队伍删除成员时触发。
[@GroupAddMember] | <$STR(S0)> / <$STR(S$0)> | — | 队伍新增成员时触发。
[@GroupKillMon] | — | — | 队伍杀死怪物时触发。
[@OnKillMob] | — | ●; 地图参数 ONKILLMON | 杀死怪物时触发。
[@KillPlay] | — | — | 杀死人物时触发。
[@地图事件自定义字段] | <$SCATTERITEMNAME>、<$SCATTERITEMX>、<$SCATTERITEMY> | ●; MapEvent.txt 中配置触发字段 | 地图事件发生时跳转到配置的QF字段。
[@GOTOLABEL自定义字段] | <$X>、<$Y> | ●; 模式、范围、目标脚本字段 | GOTOLABEL按人物/小组/行会/地图范围触发指定字段。
[@HCALL自定义字段] | — | ●; 人物名称 + 触发字段 | 指定在线人物执行给定QF字段。
[@DelayCall自定义字段] | — | ●; 延迟毫秒 + 触发字段 | 延时调用指定QF字段。
[@ItemBagButtonClickX] | — | ●; X=包裹按钮编号 1–5 | 点击包裹自定义按钮时触发。
[@ETButtonClickExX] | — | ●; X=自定义按钮触发序号 | 点击ET扩展自定义按钮时触发。
[@ButtonClickX] | — | ●; X=按钮触发序号 1–120 | 点击ADDBUTTON创建的按钮时触发。
[@NPC标签参数触发] | <$ETSCRIPTPARAM1>…<$ETSCRIPTPARAM10> | ●; @标签(参数1,…,参数10) | NPC标签跳转时携带最多10个参数。
[@ETQueryUserState] | <$C.USERNAME>、<$C.HP>、<$C.PKPOINT>、<$C.GOLDCOUNT>、<$C.GAMEGOLD> | ●; ETSTOPQUERYUSERSTATE 可禁止查看 | 查看其他人物装备/状态时触发。


更新日志

项目：ET引擎说明书　分类：ET引擎脚本文档

[20260830]（尝鲜版）更新：全套程序、ETmir2补丁编辑器

更新记录(本次更新尝鲜版内容如下)

  1. [!][修改]:心灵召唤技能 使用后 根据人物以及鼠标方位 下属排列为直线 ;

  2. [!][修改]:心灵召唤如果鼠标指针有目标的情况下宝宝默认设置攻击对象;

  3. [!][修改]:M2SERVER查询在线人物 有底色，显示的更明显;

  4. [!][修改]:物品特效 里面的 物品列表 和特效物品列表长度调整;

  5. [!][修改]:挂机异常问题，使用全屏吸怪，怪物在身上导致不攻击问题;

  6. [!][修改]:内挂药品默认值;

  7. [!][修改]:F12目标快捷键为Alt+N;

  8. [!][修改]:技能栏技能SkillDesc.dat默认增加等级描述跟着技能DB显示;

  9. [!][修改]:伤害实时掉血和飘血问题 M2server 选项->参数->游戏速度->伤害计算加速;

  10. [!][修改]:游戏窗口化拉伸像素失真;

  11. [!][修改]:F12人物飘血显示，和仅显示自身飘血;

  12. [!][修改]:野蛮禁锢逻辑改为即可禁锢;

  13. [!][修改]:优化野蛮冲撞逻辑,同屏不叠加人物;

  14. [!][修改]:聊天框增加CTRL+左键可取聊天全行文字;

  15. [!][修改]在当前地图使用传送以及随机物品,目标魔法锁定重置;

  16. [!][修改]:目标超过12格子后,目标魔法锁定重置;

  17. [!][修改]:人物下六格置放物品的记忆功能;

  18. [!][修改]:优化了游戏内信息提示占用带宽以及性能问题;

  19. [!][修改]:处于摆摊状态，默认为怪物不可攻击。

  20. [+][增加]:新增脚本命令修改账号密码信息功能

  21. [!][修正]:M2 选项——游戏命令 ——调试命令 修改异常问题

  22. [!][修正]:带传送戒指功能下不可达位置，聊天框提示;

  23. [!][修正]:吃药解包问题;

  24. [!][修正]:UI按钮有概率失效问题;

  25. [!][修正]:内挂F12的红绿毒互换选项优化逻辑,(功能设置->技能魔法->技能参数->使用内挂红绿毒互换规则);

  26. [!][修正]:不勾选显示信息前缀 喊话消息也带(!);

  27. [!][修正]:组队情况下队友宝宝血条颜色为粉色;

  28. [!][修正]:脱战60秒后 神兽趴下状态;

  29. [!][修正]:装备穿戴后微端图标坐标复原问题

  30. [!][修正]:优化双烈火逻辑;

  31. [!][修正]:M2客户端设置未勾选内挂禁止交易控件F12还显示的问题;

  32. [!][修正]:人物在交易状态下禁止任何操作;

  33. [!][修正]:战士职业MP不足时，使用野蛮冲撞发呆问题;

  34. [!][修正]:原人物在师徒模式下可攻击NPC改为人物在夫妻模式状态;

  35. [!][修正]:智能魔法距离开启后，技能第一次未释放动作继续跑动的问题;

  36. [!][修正]:智能魔法距离开启后，遇到实体障碍物无法跑动的问题;

  37. [!][修正]:地图过门瞬间人物使用魔法画面卡顿问题;

  38. [!][修正]:限时拾取地面颜色，在组队前和组队后的状态颜色显示问题;

  39. [!][修正]:地图视野范围内，极低概率出现假怪(幽灵怪)问题;

  40. [!][修正]:小助手未默认勾选显示飘血问题;

  41. [!][修正]:双击游戏窗口化放大分辨率时，全屏居中公告坐标问题；

  42. [!][修正]:ETChangeStatus 脚本设置失明BUFF异常报错提示

  43. [!][修正]:DBServer.exe导入其他人物数据时，俩件装备IDX相同问题，优化人物账号 名称不能复制问题

  44. [!][修正]:PlayImg绘制模式不带偏移坐标问题

  45. [!][修正]:个人商店货币取款异常问题

  46. [!][修正]:查看列表二————物品特效 物品名称和特效物品列表装备名称过长显示问题。

  47. [!][修正]:默认内挂—-极品提示功能 聊天框有置顶消息时点击聊天框自动拾取异常问题。

  48. [!][修正]:ETExtractStringEx 嵌套变量 分割无效问题，优化参数4可为空，为空时 不保存。

  49. [!][修正]:ETQUERYUSERSTATE查看指定玩家装备 玩家不在线时聊天框提示

  50. [!][修正]:野蛮冲撞判断人物模式

  51. [!][修正]:功能设置-其他控制2- 被麻痹禁止传送 人物死亡状态下，就不做处理。

  52. [!][修正]:智能魔法距离下去除治愈术魔法锁定

  53. [!][修正]:RunGate提示非法数据包问题

  54. [!][修正]:合区配置重写问题

  55. [!][修正]: 爆率格式 #CHILD 1/1 RANDOM
    (
    1/1 裁决之杖|@首爆触发
    )
    精准爆率命令不触发的问题

  56. [!][修正]:修复输入账号密码多次提示锁定问题

  57. [+][增加]:M2增加自己的宝宝血条变成粉色;

  58. [+][增加]:批量生成登录器;

  59. [+][增加]:掉线提示功能，增加客户端掉线提示，返回账号输入界面;

  60. [+][增加]:技能自定义快捷键设置;

  61. [+][增加]:组队后显示是队友为淡蓝色血条;

  62. [+][增加]:~快捷 拾取 物品归属增加拾取剩余秒数;

  63. [+][增加]:LogDatadServer;云查询;

  64. [+][增加]:ETChangeHumAbility 参数5 时效(秒)
    ETChangeHumAbility 参数1 参数2 参数3 参数4 参数5
    参数位置 参数说明
    参数1 属性索引
    参数2 属性类型(1-40)最大支持21亿,HP、MP最大值支持42亿
    参数3 操作符(+ 、- 、=)
    参数4 数值
    参数5 时效(秒)

  65. [+][增加]:增加飘血样式：ET反外挂插件-客户端功能扩展一-插件内挂（二）飘血路径;

  66. [+][增加]:关联地图参数显示-安全区-安全-战斗-图标提示;

  67. [+][增加]:UI按钮私聊控件已读-未读状态变化显示;

  68. [+][增加]:目标头顶素材x.y微调坐标设置,ET封挂插件-客户端功能扩展一-怪物头顶上箭头;

  69. [+][增加]:微端状态提示框上线默认x.y坐标固定偏移,ET封挂插件->客户端功能扩展一->常用设置->微端状态坐标;

  70. [+][增加]:UI攻击模式可左键点击循环模式切换和右键列表选择模式;

  71. [+][增加]:UI模式控件可点击切换以及右键选择模式列表;

  72. [+][增加]:游戏标题优化剔除列表名字以及攻击模式文字类型选项,登陆器配置内新模式选项

  73. [+][增加]:快捷栏显示叠加物品以及使用次数显示,客户端控制->内挂控制(二)->快捷物品显示次数

  74. [+][增加]:命令支持：获取技能信息命令
    GetMagicInfo 技能名称 值类型 变量
    值类型：0：技能等级1：强化等级2：技能点数
    示范：
    [@KTZ]
    GetMagicInfo 开天斩 0 N1
    GetMagicInfo 开天斩 1 N2
    GetMagicInfo 开天斩 2 N3
    SENDMSG 6 技能等级：<$str(N1)>，强化等级：<$str(N2)>，技能点：<$str(N3)>

  75. [+][增加]:仿HERO摆摊功能，取消摆摊触发[@StopMyShop]

  76. [+][增加]:ADDBUTTON 新增参数11 窗口锚点
    ADDBUTTON 参数11的居中锚点扩展：
    0 左上 1 右上 2 左下 3 右下 4 左中 5 上中 6 右中 7 下中 8 正中 9 人物头顶

  77. [+][增加]:新增飞剑术脚本和技能(技能ID 118) 详情参考说明文档

  78. [+][增加]:新增人物下属被诱惑之光技能诱惑提示

  79. [+][增加]:新增自定义货币功能 ET封挂插件-客户端功能扩展二-自定义货币;

  80. [+][增加]:新增DataManage数据管理工具个人商店搜索功能

  81. [+][增加]:新增ET封挂插件-在线管理与限制 点击IP地址可以进行排序功能

  82. [+][增加]:新增网络状态显示功能—-客户端控制—内挂控制一—-网络状态显示

  83. [+][增加]:新增角色交易功能 选项—-功能设置—-开启角色交易

  84. [+][增加]:新增商铺赠送功能 选项—-功能设置—-个人商铺 开启商铺赠送功能

  85. [+][增加]:新增组队状态下 组队成员聊天框拾取物品信息提示功能 选项—参数设置—信息控制—-组队拾取提示

  86. [+][增加]:新增默认内挂持久保护功能

  87. [+][增加]:新增技能升级时聊天框提示功能

  88. [+][增加]:新增客户端左上角释放魔法不足提示，以及释放魔法目标距离过远提示

  89. [+][增加]:ET封挂插件-在线管理与限制—黑名单 显示加入时间

  90. [+][增加]:ETONHORSE 脚本控制人物、上马、下马

  91. [+][增加]:ETCHECKATTACTEFF 检测判断当前攻击模式

  92. [+][增加]:ETOPENINPUTBOX 跳转指定的自定义输入框标签

  93. [+][增加]:ETREADWRITEFILE 配置文件读写(包含TXT,INI,CSV)支持绝对路径

  94. [+][增加]:ETMONESC 脚本刷出逃亡怪物

  95. [+][增加]:ETWEIGHTCHANGED 脚本刷新背包负重

  96. [+][增加]:新增内挂数字飘血过滤功能

  97. [+][增加]:ETSETPICKSTATE 设置禁止拾取命令

  98. [+][增加]:ETPlayMusic播放音乐

  99. [+][增加]:<Effect:I:T:C:A:D:S:C:X:Y> NPC界面调用人物、怪物、技能外观

  100. [!][增加]: AI反作弊系统

  101. [+][增加]: 云控 游戏日志记录系统，更详细记录游戏日志

  102. [+][增加]: Compval 变量 </=/>/!/?/&

  103. [+][增加]: 扩展#IF命令参数

2026-07-05 更新说明(本次更新尝鲜版内容如下)

  1. 新增毒符赋予元素属性和攻魔道属性在装备悬浮框中的展示。

  2. 优化了客户端视野刷新及同步的一处问题。

  3. 新增火墙伤害立即生效设置，火墙铺设后即刻造成伤害。

  4. 新增浑水摸鱼地图强制开启衣服简装模式。

  5. 优化了挂机功能的逻辑及稳定性。

  6. 客户端控制新增仿盛大免Shift键选项，并优化了PK锁定的逻辑判断。

  7. CHANGEITEMADDVALUE 命令修改物品附加属性值时，装备位置新增支持时装（17-18）和生肖（30-41）。

  8. MAPMOVE 命令新增范围参数，留空或填0则为定点传送（地图名 X坐标 Y坐标 范围）。

  9. 新增摆摊输入字体强制编号选项，可在功能设置-个人商店中配置。

  10. 功能设置-其他控制中新增修改时装名字前缀的功能。

  11. 参数设置-升级经验中新增优化经验值获取展示格式的选项。

  12. 新增内挂百分比保护功能，可按血量/蓝量百分比自动使用药品。

  13. 优化计时物品逻辑，新增Need=102/103/104三种计时方式（穿戴即计时、给予即计时在线计算、给予即计时离线也计算），并保留原有Need=101（穿戴后身上计时）的机制。

  14. 新增UI界面自定义货币的显示与修改功能，可在客户端控制-内挂控制2中配置。

  15. 优化了自定义界面跳转时的默认界面偏移问题。

  16. 优化了脚本命令ETChangeSlaveAbility调整宝宝属性的逻辑。

  17. 新增全体攻击模式下在安全区可攻击自己宝宝的开关按钮，位于功能设置-宝宝升级中。

  18. 优化了炼药制作界面的显示问题。

  19. 新增人物死亡掉落提示及怪物掉落提示功能，支持自定义颜色和格式（%ShowItem显示当前掉落物品名，%ShowDBItem显示数据库原名），并更新了String.ini中DropItemHint项的配置方式。

  20. 优化了野蛮冲撞技能施放时的卡顿问题。

  21. 优化了行会战中人物名颜色及小地图颜色的刷新逻辑，联盟显示蓝色点，敌对及敌对联盟显示橙色点，行会宣战取消时及时刷新。

  22. 新增魔法盾防御倍率设置，可在功能设置-技能魔法-魔法盾中调整。

  23. 优化了死亡状态下禁止玩家开关编组的逻辑。

  24. 新增变量 <$BATTACKMONSTER_DAMAGE>，用于获取宝宝当前攻击怪物的掉血量。

  25. 修复了时装首饰极品属性不生效的问题，以及点击查看他人装备时能拿下自己装备的问题。

  26. 新增全屏冰镰术功能 ETGroupIceSickle，支持开关、威力倍数、数量和持续时间参数。

  27. CHANGECUSTOMITEMTEXT 和 CHANGECUSTOMITEMTEXTCOLOR 命令新增支持装备位置 19-30（首饰盒）和 1001-1012（时装首饰），并增加了自定义文字长度限制。

  28. 修复了地图雷达将怪物"掷斧骷髅"误识别为特殊NPC的问题。

  29. 修复了怪物简装对雷炎神龙无效的问题，以及击杀后死亡不消失的问题。

  30. 默认内挂新增及时雨内挂战斗功能，并新增角色提示功能。

  31. 新增内挂自显恢复飘血功能，开启后恢复HP/MP的飘血仅自己可见，可在客户端控制-内挂控制中开启。

  32. 修复了黑铁矿纯度超过60时不增加武器持久的问题。

  33. 新增修复神水 Anicount=1 时 DuraMax 按1000计算，使用后扣除对应点数功能。

  34. KILLMONEXPRATE 和 POWERRATE 命令的有效时间填写 -1 时改为永久生效。

  35. DBServer 新增只允许中文名作为人物名的选项。

  36. 新增使用毒符类技能时增加相应使用提示的功能。

  37. 新增施法时目标距离太远导致技能施展失败的提示。

  38. 优化了道士治愈术指针未指向目标时，自动给自身加血的逻辑。

  39. 优化了内挂智能魔法距离的锁定问题。

  40. 新增聊天记录保存功能。

  41. 修复了商店购买物品时价格异常上涨的一处问题。

  42. 修复了 ETQUERYUSERSTATE 命令的一处异常问题。

  43. 新增宝宝召唤触发 [@OnSlaveAdd]，需在M2-脚本触发和功能扩展3中开启。

  44. 优化了仿HERO摆摊查看他人摊位时的标题显示问题。

  45. 修复了M2在线管理与限制中查找人物不生效的问题。

  46. 优化了锁定6格目标的相关逻辑。

  47. 新增限时称号 Source=1 时，小退也计算时间的逻辑。

  48. 兼容了 INPUTTEXT 和 INPUTNUM 命令。

  49. 兼容了 ETGETNPCNAME 命令。

  50. 兼容了 ETGetCustomItemText 和 ETGetCustomItemTextColor 命令。

  51. 兼容了 ETDELBUTTONEX 命令。

  52. 兼容了 ETStartFrameRect 激活技能施法框的命令。

  53. 修复了石化怪物在刷新后状态显示异常的问题。

  54. 新增人物攻击和被攻击掉血前触发，支持在当前触发中修改伤害血量。

  55. 修复了客户端功能扩展-特效编辑坐标异常的一处问题。

  56. 新增 UserItem 和 itemshow 调用装备信息展示功能，详情参考帮助文档。

  57. 注册界面新增限制大写字母创建账号的规则。

  58. 新增在线人物界面可自由拉伸的功能。

  59. 修复了彻地钉技能伤害异常的一处问题。

  60. 新增命令 getMapMonsterNumXY，用于获取指定地图中指定怪物的数量和坐标。

  61. 优化了武器升级成功时聊天框的提示字样。

  62. 修复了精准爆率下大刀卫士杀死怪物后爆出异常的一处问题。

  63. 商铺购买新增交易数量和批量购买数量功能。

  64. 优化了红字飘血的间距显示问题。

  65. 新增靴子 Anicount 字段支持增加人物负重。

  66. 优化了人形怪物外观及时刷新的逻辑。

  67. 修复了幻之双头血魔的一处异常问题。

  68. 优化了怪物实际扣血延迟的问题。

  69. 新增按死亡时间刷怪功能，支持在地图刷怪配置中增加是否死亡刷新及触发QF的参数。
    格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1) 是否死亡刷新 触发qf

  70. 修复了物品装备-极品属性中22类属性几率缺失的一处问题。

  71. 新增 ADDBUTTON 参数9支持颜色换行和倒计时显示，倒计时格式支持三种展示方式（默认、动态、秒数）。
    使用倒计时格式:
    <COUNTDOWN:倒计时时间(秒):次数(0无限次):M>
    参数M为显示格式：
    以90秒和50秒为例
    0或空时 默认显示方式 00:01:30 00:00:50
    1 根据是否有小时/分动态显示 01:30 50
    2 以秒显示 90 50

  72. 新增淡化火墙功能，可在客户端设置-内挂控制中开启。

  73. 新增NPC容器功能。

  74. 兼容了 CACHELOADCSV 命令。

  75. 修复了法师瞬息移动技能的一处异常问题。

  76. 新增 L 变量支持数组格式，如 L$测试 [11,22,33,44,55,66,77,aa]。

  77. 修复了装备改名后丢在地上不显示名称的问题，并优化了内观显示。

  78. 修复了嗜血术和流星火雨技能有几率打出空伤害的问题。

  79. 新增隔位野蛮功能，可在M2-技能设置中开启野蛮启用特效。

  80. 新增摆摊人物名变色功能及异价提醒功能。

  81. 优化了所有强化技能的特效表现。

  82. 兼容了NPC倒计时标签功能。

  83. 修复了改名功能的一处异常问题。

  84. 修复了升级武器取回时间异常的一处问题。

  85. 修复了 ETChangeHumAbility 增加体力和魔力时的一处异常问题。

  86. ETSetWeaponCurseTime 新增参数2，支持覆盖或叠加模式，默认为覆盖。

  87. 优化了 ETSETMAGICHOTKEY 和 ETGETMAGICHOTKEY 技能快捷键的设置与获取功能。

2026-05-12 更新说明(本次更新仅更新了尝鲜版)

  1. 修复了 ChangeSP 动态设置特殊属性（隐身）时，未立即生效隐身状态的一处问题。
  2. 修复了 UT/JZ 类型变量在 M2 上手动修改后无法保存生效的一处问题。
  3. 修复了红字飘血在击杀怪物时因角色定位坐标偏移导致飘血重复出现两次的问题。
  4. 新增宝宝属性叠加功能，可在 M2-选项-功能设置-宝宝升级 中进行配置。
  5. 新增诱惑之光技能限制选项：仅能诱惑等级小于或等于人物等级的怪物，可在 M2-选项-功能设置-技能魔法-法师技能 中勾选开启。
  6. 修复了使用随机传送石或回城石后，人物延迟不能立即跑动问题。
  7. 修复了 PLAYEFFECT 命令播放人物效果特效时无法正常显示的一处问题。
  8. 修复了读写配置项命令在特定情况下出现异常的一处问题。
  9. 新增摆摊功能：同一店铺中相同装备允许以不同价格异价提醒。
  10. 新增内挂智能魔法距离选项，优化法师远程技能释放体验。
  11. 新增便签功能，便于玩家记录临时信息或开发者调试标记。
  12. 修复了 HUMANHP 命令操作角色血量时的一处异常问题。
  13. 修复了 NPC 对话框在特定情况下显示异常的一处问题。
  14. 修复了 TEXT 参数在脚本解析过程中出现异常的一处问题。
  15. 修复了 L 变量在检测时出现的一处异常问题。
  16. 修复了 DBServer 编辑人物数据并导入后，保存修改无效的一处问题。
  17. 修复了游戏控制台标题及动态 IP 写入配置到 DBServer 时的一处问题。

2026-04-27 更新说明(本次更新仅更新了尝鲜版)

  1. 修复了超大血量怪物在特定情况下异常回血的一处问题。
  2. 修复了 TakeW 命令扣除身上武器或衣服后，客户端未能及时刷新显示的问题。
  3. 修复了 ETDETOXIFCATIONEX 命令解除红绿毒时的一处异常，并新增参数支持控制是否解除宝宝的中毒状态。
  4. 修复了 AddFunItemDura 命令增加物品持久后，客户端未能及时刷新显示的问题。
  5. 新增 47 类准星物品扩展，支持自定义准星类道具功能。
  6. 修复了使用回城石或随机传送石时，会错误触发 [@ET地图变更] 和 [@ET离开地图] 的一处问题。
  7. 修复了扩展大背包功能在某些情况下显示或操作异常的一处问题。
  8. 新增使用祝福油时的触发标签 [@AddLuck]，便于脚本记录或扩展祝福逻辑。
  9. 修复了 CSV 配置表中自定义常量读取异常的一处问题。
  10. 修复了拓展 NPC 脚本点击触发时，传递参数中物品名带有括号导致的异常问题。
  11. 修复了设置NPC面板文字坐标文字大小不生效的一处问题

2026-04-20 更新说明(本次更新仅更新了尝鲜版)

  1. 修复了 ETDelUserItem 命令删除玩家物品时偶发失效的一处问题。
  2. 修复了 ETGetMapHumCount 命令在特定地图或条件下无法正确获取人数的问题。
  3. 修复了数据库某些字段配置下，物品双击无法穿戴到对应装备位的一处问题。
  4. 修复了Ctrl+背包物品发到聊天框后，点击查看其装备属性时显示异常的一处问题。
  5. 修复了 ETGetItemFieldValueA 命令获取物品属性值在某些情况下不准确的问题。
  6. 修复了 ETCheckItemWitemValue 检测极品元素回收时部分场景下不生效的问题。
  7. 修复了佩戴护身戒指后，在某些情况下角色血量显示或计算异常的一处问题。
  8. 新增人物幸运值常量 <$UserLucky>，便于脚本中直接调用。
  9. 新增停止挂机快捷键 Ctrl+Alt+X，方便玩家快速结束挂机状态。
  10. 修复 ADDGuild 命令，参数SELF必须大写的问题。
  11. 新增 LINKBAGITEM、DelLinkItem、CLEARLINKITEM 命令，用于背包物品的临时链接与解除操作。
  12. 新增 @ET离开地图 触发，玩家离开地图时可执行自定义脚本逻辑。
  13. 新增 ETSEPURB扩展获取全身装备极品属性的数值总和。
  14. 新增 ETCheckFullBead、ETTAKEDURAITEM、ETTakeMineEX、ETGiveFullBead 命令，完善满珠相关操作逻辑。
  15. 新增内挂物品极品颜色自定义选项，玩家可自行选择极品装备在聊天框内的颜色显示。

2026-04-15 更新说明

  1. 修复了 CSV 文件在占用状态下读取不到表格数据的一处问题。
  2. 新增了 GetBagInfo、GetBagItemFieldValue 命令，用于获取背包及背包物品的字段信息。
  3. 新增了常量 <$UTCNOW8>，便于获取 UTC+8 时区的当前时间。
  4. 修复了 ETUNIXTOSTR、ETUNIXTOSTREX 命令在 Unix 时间戳转换时的一处错误。
  5. 修复了 ETSendCommand 命令在特定环境下的兼容性问题。
  6. 修复了 ETWhile 循环语句在执行过程中的一处逻辑问题。
  7. 修复了角色改名后相关数据同步的一处问题。
  8. 新增了内挂极品装备聊天框自动拾取功能，掉落极品时聊天框内可快捷拾取。

2026-04-13 更新说明

  1. 修复了吸血效果在某些情况下计算异常的一处问题。
  2. 优化了客户端NPC对话内容展示的排版和显示逻辑。
  3. 优化了ETFILTERGLOBALMSG过滤全服提示信息的处理机制。
  4. 修复了LOADCONLIST加载列表配置时可能读取失败的问题。
  5. 修复了ETSetIconEx设置顶戴花翎特效在某些场景下不生效的问题。
  6. 修复了ETChangeSlaveAbility调整宝宝属性时部分参数无效的问题。
  7. 修复了怪物数据库血量字段为负数时，怪物会立即死亡的问题，现已增加合法性校验。
  8. 修复了ETHashTableLoadEx加载哈希表数据时在某些情况下读取异常的问题。
  9. 修复了角色使用回城类道具后，周围视野未立即刷新的问题，现已恢复正常刷新逻辑。
  10. 修复了客户端程序被部分杀毒软件误报病毒的问题，已进行代码混淆及数字签名优化。
  11. 修复了人物对砍时双方同时死亡的一处问题。
  12. 兼容了怪物扩展无限血量功能。
  13. 优化了Rungate 安全过滤中增加了机器码限制登录角色数量功能，默认每个机器码最多同时登录 2 个角色。
  14. 在 LoginSrv 的基本设置-实名认证中增加了实名认证功能，可配置玩家身份信息校验。
  15. 在 LoginSrv 的基本设置中增加了禁止在游戏客户端内注册账号的选项，便于统一管理账号注册入口。
  16. 修复了在挂机状态下偶尔会主动攻击其他玩家的一处问题。

2026-04-08 更新说明

  1. 补充 JZ 私人变量（跨天重置，适合计数、标记、活动记录）。
  2. 增加将秒数转换为时间格式的命令，用于在公告、NPC、活动面板直接显示剩余时间。
  3. 增加创建/销毁定时器，用于周期执行脚本。
  4. 增加 ETGetHumVar 跨玩家读取变量。
  5. 增加检测当前 NPC 名称、攻击模式、指定范围目标、物品数据库字段等细节检测。
  6. 增加获取人物 Buff 剩余时长、强化加星数量、装备宝石数量、背包指定物品数量、指定行会成员数量等命令。
  7. 增加文件是否存在、删除文件、读取文件到哈希键值等运维写法。
  8. 把可视化爆率、哈希首爆、货币系统、NPC 参数标签、技能中断、商城摆摊拦截等内容整理成一套功能文档结构。

2025-11-19 更新说明

  1. 优化了时装首饰盒、时装生肖盒的物品穿戴和取下相关。
  2. 支持了自定义 UI 他人出战页背景图。
  3. 增加了角色出售查看装备栏出战页可查看可编辑。
  4. 完善了其它几处细节处理。

2025-11-10 更新说明

  1. 十步一杀自动锁定人物、强制越过障碍物。
  2. 攻击允许快速野蛮，鼠标指向定向野蛮。
  3. 快捷键 ALT+D 开关内挂走位刺杀。
  4. 补充技能控制与中断释放逻辑，用于禁用目标/地图/称号。
  5. 增加超级逐日剑法、超级开天斩、全屏火符。
  6. 封一键三技能、快捷设置等控制写法，脚本设置技能冷却、模拟激活三技能。
  7. 宝宝范围百分比切割、宝宝切割命令、改变目标状态。
  8. 宝宝升级触发、死亡触发、脚本调宝宝属性。
  9. 宝宝 Ctrl+Q 锁定怪物，以及宝宝继承人物爆率的扩展。

2025-10-31 更新说明

  1. 修复了怪物大血条和月灵冲突的一处问题。
  2. 修复了超大经验值存储到聚灵珠不准确的问题。
  3. 修复了 NoAutoOnline 地图参数禁止内挂挂机，用命令执行可以挂机的问题。
  4. 修复了调整怪物属性倍率会导致采集类怪物无法采集的问题。
  5. 修复了英雄偶尔无法佩戴和取下装备的问题。
  6. 扩展了减技能 CD 支持英雄流星火雨。
  7. 扩展了 ADDBUTTON、AddDlg、ADDNUMBERBUTTON 支持可视仓库和可视无限仓库。
  8. 扩展了 ChangeModeEx 命令参数支持防怪物冰封。
  9. 扩展了禁止爆出身上装备支持仅保护身上装备的参数。
  10. 扩展了配置器上装备提示信息自定义文字编辑栏长度。
  11. 扩展了 UpdateItem、CHANGEITEMADDVALUE 支持 51 之后的装备位置。
  12. 修改了强化技能九重之后威力倍数增加支持 0。
  13. 增加了技能图标固定到屏幕指定位置，以及显示在技能提示栏的操作命令。
  14. 增加了重新加载 QF 功能脚本的 GM 命令。
  15. 完善了角色交易相关代码，加固相关操作检测并解决利用该系统刷货币的问题。

2025-09-29 更新说明

  1. 完善了 checkitems 支持新增装备位置。
  2. 优化了自定义 OK 框防刷相关检测。
  3. 优化了怪物标识支持时间参数。

2025-09-25 更新说明

  1. 修复了极品矿石类、肉类价格出售错误的问题。
  2. 修复了武器升级破碎保护后武器名称前面还会显示 * 的问题。
  3. 修复了叠加类物品不显示“xxx被发现”的问题。
  4. 修复了配置器上合击界面角色发型偏移设置 Y 无效的问题。
  5. 修复了祈祷生效会清理掉镖车的问题。
  6. 修复了内挂自动凝聚技能的双烈火在移动到攻击第二刀无效的问题。
  7. 优化了宝箱开物品的细节。
  8. 优化了剑甲简装同时隐藏特效。
  9. 优化了浑水摸鱼神秘人地图护身血条显示的一处细节。
  10. 完善了数据库物品对内功恢复速度和内功值相关支持。
  11. 扩展了 AddDlg 支持带参数。
  12. 扩展了雕像绘制模式支持普通绘制。
  13. 加固了引擎对自定义 OK 框物品检测。
  14. 增加了怪物标识功能操作命令。
  15. 增加了修改地图坐标范围内怪物颜色。

2025-08-22 更新说明

  1. 优化了 OpenHumDlg 打开时装首饰盒。
  2. 优化了聊天栏英雄获取经验显示。

2025-08-12 更新说明

  1. 优化了时装神佑套装备注显示的一处细节。
  2. 优化了灭天火技能参数支持设置吸蓝百分比。

2025-07-21 更新说明

  1. 修复了使用聚灵珠获取经验时聊天框英雄获取经验显示错误的问题。
  2. 修复了 MonSpAbilList.txt 怪物特殊属性防御的一处细节判断。
  3. 修复了金刚石日志偶尔会出现记录不全的问题。
  4. 修改了 MoveMonToPos 命令仅对怪物有效。

2025-07-05 更新说明

  1. 修复了自定义装备框坐标改变后的重复显示问题。
  2. 修复了元素属性和套装属性的防御蛛网无法抵御部分怪物释放的蛛网。
  3. 修复了掉落人物身上物品命令 HumanDropUseItem 不能触发身上物品掉落触发 [@HumDropItem]。
  4. 修复了宠物无实体模式失效的问题。
  5. 修复了新爆率格式存在 RANDOM 时（如 #CHILD 1/1 RANDOM），角色杀怪爆率倍数对子爆率无效的问题。
  6. 扩展了 OpenHeroDlg 和 ADDBUTTON 支持时装首饰盒和神佑位置。
  7. 修改多级脚本 M. 排除了 NPC。
  8. 修改了怪物属性扩展 MonSpAbilList 中几个参数由开关模式改为几率模式。
  9. 增加了自定义装备框支持套装属性。
  10. 增加了自定义装备框支持英雄，命令前面加 H.。
  11. 增加了摆摊物品购买前触发和终止购买命令。
  12. 增加了新爆率格式杀怪爆率倍数无效的参数 BURSTRATE（例：#CHILD 1/1 BURSTRATE）。
  13. 增加了内挂挂机只打列表中怪物选项。
  14. 增加了自定义技能 - 攻击目标当选择为“半月攻击”时，增加默认伤害格数和技能等级提升一级格数设置。
  15. 增加了修复沙巴克城门和城墙的脚本命令。
  16. 解决了一处严重漏洞，本次更新网关需同步更新。
  17. 优化了其他几处细节。

2025-05-21 更新说明

  1. 修复了“战斗状态退出”功能的“不允许使用药品”选项勾选后不保存的问题。
  2. 修复了“战斗力计算设置”中新职业设置的参数值不保存的问题。
  3. 扩展了十步一杀技能的最大距离从 12 格调整到 22 格。
  4. 扩展了 MOBFIREBURN 支持 42E+ 的伤害。
  5. 增加了升级武器页面支持最大持久控制。
  6. 修改了切换地图保护排除当前地图随机或被技能拉动，仅切换地图有效。

2025-04-06 更新说明

  1. 优化了微端相关的几处细节处理。

2025-04-02 更新说明

  1. 修复了微端程序会出现不更新的一处问题。
  2. 优化了引擎的几处细节。

2025-03-25 更新说明

  1. 优化了角色在地图雷达显示。
  2. 优化了显示会员类型条件的一些细节。
  3. 优化了角色下线后施的毒消失支持所有目标类型。

2025-03-22 更新说明

  1. 修复了显示改名后的装备名字变量在取下物品后变量不会清空的问题。

2025-03-15 更新说明

  1. 增加了操作行会安定度、繁荣度、建筑度、人气度命令聊天框提示的关闭选项。
  2. 优化了 releasemagic 和 releasemagicex 释放强化技能的算法。

2025-03-10 更新说明

  1. 修复了调整元素倍率后 ScatterMonItems 命令的一处计算错误。

2025-03-07 更新说明

  1. 修复了自定义属性在悬浮框顶部显示时会多出一个关闭按钮的问题。
  2. 优化了角色交易系统查看购买角色装备时支持自定义装备框。

2025-03-01 更新说明

  1. 修复了战斗状态强制退出时角色不会掉线的问题。
  2. 修复了调整元素倍率后怪物元素失效的问题。
  3. 修改了宝宝杀人主人红名选项为攻击目标主人灰名。
  4. 增加了施毒术向宝宝施毒灰名选项。
  5. 优化了启动游戏窗口后最小化登录器的反应时间。

2025-02-28 更新说明

  1. 优化了内挂 BOSS 提示相关。
  2. 优化了内挂挂机时被攻击操作对触龙神伤害的一处误判为角色攻击的问题。
  3. 优化了拍卖行出价前触发支持获取拍卖人名称。
  4. 优化了人物变身怪物后小地图雷达显示为怪物。
  5. 扩展了 GetAllDBItemFieldValue 及多个装备相关命令支持称号和新增装备位置。
  6. 优化了系统兼容性及其他细节。

2025-02-14 更新说明

  1. 增加多开数量控制、客户端显示网络延迟。
  2. GM 制造物品带来源。
  3. 无限装备支持。
  4. 商城上架物品限制。
  5. 禁止走位捡物，锁定光环/箭头指示。
  6. 装备属性对比（补充了不显示对比箭头的处理方法）。
  7. 行会人员管理拓展。
  8. SetNewItemValue 支持到 255%，ChangeHumAbility 部分参数支持到 21 亿。
  9. 自定义装备属性扩展，新施毒系统配套脚本。
  10. 再次强调防止封包非法调用标签方法，给出推荐写法。

2025-01-17 更新说明

  1. 修复了个别类型物品持久相关的一处问题。
  2. 修改了红绿毒切换地图消失和下线消失为独立选项。
  3. 增加了复古模式悬浮框选项。
  4. 增加了武器诅咒前触发和中止诅咒命令。
  5. 增加了内挂隐藏 MapEffect,PlayEffect 特效选项。
  6. 优化了其它几处细节。

2024-10-21 更新说明

  1. 增加自定义货币系统（oldCurrency / NewCurrency），支持关联折算（主货币不足时自动扣元宝、金刚石、灵符、荣誉、经验等）。
  2. 增加 checkMoney、ChangeMoney 和 @MoneyChange 触发（货币变化时执行脚本）。
  3. 可在主界面、装备页、状态页、称号页、技能页、包裹、聊天框、商铺、大地图等多处显示自定义货币数量。
  4. 支持更换悬浮装备名字字体、装备悬浮标题图形化用法。
  5. Ctrl+鼠标怪物显示自定义透明文字框。
  6. 增加中间公告、左右侧喇叭、窗口抖动、自定义透明消息框、过滤全服提示信息。
  7. 拓展聊天栏查看装备、打开指定控件界面、动态插件按钮、多窗口脚本。
  8. 增加 BUFF 列表、自定义红蓝素材绘制、播放音乐、打开浏览器、复制到剪贴板、修改窗口标题。
  9. 补充文本文件操作、文本操作内存等实用脚本。

2024-05-29 更新说明

  1. 增加拓展刷怪触发、怪物爆出物品触发。
  2. 脚本刷逃亡怪物、范围嘲讽、全屏吸怪、杀怪鞭尸示例。
  3. 增加 ETQueryTargetEx，检测指定范围内的人物或怪物，回写数量和坐标。
  4. 增加获取指定地图同行会人数、地图人数。
  5. 新版怪物爆率：支持 #CHILD 里直接带条件（P/D/M/N/I/G/U 变量，支持 > < = 及多条件组合），用于等级爆率、货币爆率、活动爆率等。
  6. 文档建议把 CALL 爆率集中管理，以提高解析效率。
  7. 补充可视化爆率 I/II/III/IV 规则，支持字符串条件匹配、排除活动怪、开关怪物透视爆率。
  8. 增加“物品可爆出数量控制脚本”写法。
  9. 哈希表首爆方案：ETHashTableCreate、ETHashTableContainsKey、ETHashTableLoad、AddTextListEx，用于全服首爆、活动首杀、唯一掉落记录。

2024-01-17 更新说明

  1. 增加脚本整理背包、开启自动穿戴。
  2. 增加脚本删除角色物品、删除满足条件的聚灵珠、给满经验聚灵珠。
  3. 支持刷新背包负重、地面刷物品、设置禁止拾取。
  4. 增加 LINKPICKUPITEM 相关写法，让扔物品、穿戴、取下、Give 和拾取联动。
  5. 增加脚本设置临时属性、攻击倍数、伤害减免、失明、禁止移动等。
  6. 增加 Hook 物理/魔法攻击伤害（主动和被动都有）。
  7. 增加设置主动暴击次数、锁定人物最高等级。
  8. 支持设置人物外观、装备外观、时装外观，上下马控制。
  9. 增加脚本设置人物、怪物顶戴花翎特效。
  10. 增加查看指定玩家装备。
  11. 增加遍历背包获取物品信息。
  12. 增加检测包裹指定物品是否满持久、检测聚灵珠持久并删除。
  13. 增加获取宝石数量、强化加星数量、物品属性值。
  14. 增加根据物品名称或 IDX 取数据库字段。
  15. 增加检测 OK 框内物品信息、获取物品来源信息。
  16. 增加脚本命令掉落人物身上装备（用于惩罚、挑战副本规则）。

2023-09-08 更新说明

  1. 增加 ETReleaseMagic，脚本直接释放技能（指定 ID、等级、强化等级、是否显示效果、目标等）。
  2. 增加 ETReleaseMagicEx，无动作释放技能，可指定目标类型或自定义坐标。
  3. 能获取当前释放的技能信息、目标是谁、目标类型。
  4. 增加技能释放状态标记，用于前端同步。
  5. 增加 ETSETSKILLCDTIME，按毫秒或百分比调整技能冷却。
  6. 增加 ETActivateSkills，模拟激活烈火、逐日、开天，可无视冷却。
  7. 支持设置和获取技能快捷键，激活技能施法框并显示冷却。
  8. 可开关技能右侧公告提示。
  9. 通过 @ETBeginMagic + ETStopMagic 在施法前拦截技能。
  10. 补充设置技能伤害倍数、Buff、范围伤害 Buff 等写法。
  11. 增加解除中毒效果命令。
  12. 给出“天神召唤”自创技能示例，以及封一键三技能、快捷设置。

2023-05-26 更新说明

  1. 增加打开仓库触发。
  2. 增加交易前触发（用于资格判断、货币检查）。
  3. 增加商铺购买触发、个人摆摊购买触发、HERO 摆摊购买触发。
  4. 新摆摊：上架前触发 QF @ETBeginShopItemUp，下架前触发 QF @ETBeginShopItemDown，可用 ETStopShopItem 中止。
  5. 增加商城购买触发、拦截触发（用于限购、禁售、活动商店）。
  6. 增加装备穿戴前、脱下前触发。
  7. 增加人物死亡前、死亡触发。
  8. 增加人物和背包爆出物品触发。
  9. 增加物品爆出后反馈触发 @物品爆出反馈，配合变量做首爆、公告、额外奖励。
  10. 增加聚灵珠使用前触发、装备升级触发、鉴定专用触发。
  11. 增加地图变更触发 @ET地图变更。
  12. 增加进出安全区触发（安全区限制、PK提醒）。
  13. 增加攻城提示触发、行会触发、传送控制触发、小退控制触发。
  14. 增加技能控制触发 @ETBeginMagic，配合 ETStopMagic 中断技能释放。
  15. 增加烈火、开天、逐日等关键技能触发。
  16. 增加暴击前触发、人物暴击触发（用于暴击特效、暴击抵抗等扩展）。

2023-01-12 更新说明

  1. NPC 面板支持设置文字坐标、绝对坐标。
  2. 增加自定义 NPC 头顶按钮。
  3. NPC 面板支持输入框、编辑框。
  4. 增加跨 NPC 跳转标签 ETGotoLable，支持 QM、QF、机器人之间跳转。
  5. NPC 面板直接显示倒计时文字或素材倒计时。
  6. 支持标签带参数写法 @测试(1,2,3...)，增加 ETCHECKSCRIPTPARAM 校验参数合法性，防客户端改包。
  7. 文档提醒：敏感标签改成 @ET- 前缀，防止非法跳转。
  8. 文本处理命令：检测字符串长度、查找匹配、提取中间文本、取左右字符、替换、分割、随机截取、填充长度等。
  9. 分割后支持按概率随机取出内容，用于奖池、随机称号、动态公告。

2022-10-18 更新说明

  1. 整理变量大全：人物、怪物、技能、地图、装备、背包、商铺、掉落、货币、在线人数等。
  2. 私人变量 U/T 为可保存，J/Z 跨天重置（用于每日击杀、签到、限购）。
  3. 增加 RandomEx（分子/分母随机判断）。
  4. 增加 CheckTime，直接比较时间段剩余时长。
  5. 增加 CheckHpPer、CheckMpPer，支持人物和怪物的血蓝百分比。
  6. 增加 ETGetStateValue，可读取麻痹、冰冻、毒、蛛网、护体神盾、无极真气剩余时间。
  7. 补充获取格式化日期时间的方法。


用户协议(必读)

ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档

ET游戏引擎用户许可使用协议

项目：ET引擎说明书　分类：ET引擎脚本文档

ET游戏引擎用户许可使用协议

协议版本号：ET-USER-2026-V2.0

更新日期：【2026年04月03日】

公示平台：ET游戏引擎说明书

重要提示

请您在下载、安装、复制、访问或以其他方式使用ET游戏引擎（以下简称“本软件”“本引擎”）前，务必审慎阅读、充分理解本协议全部条款内容，特别是免除或者限制责任的条款、知识产权条款、用户权利与义务条款、个人信息保护相关条款、第三方著作权责任划分条款、《传奇》适配授权相关条款、协议更新与终止条款、争议解决条款，其中限制、免责条款将以加粗形式提示您重点注意。

未成年人应在法定监护人陪同下阅读本协议；若您为法人或非法人组织，请您确保您的签署、使用行为已获得合法有效授权。除非您已充分阅读、完全理解并接受本协议所有条款，否则您无权下载、安装、复制或使用本软件及相关服务。您的下载、安装、使用、登录、复制、分发、勾选同意本协议等任何行为，均视为您已阅读并同意本协议全部条款的约束，同时视为您已接受《ET反挂插件软件用户许可使用协议》的全部约定。本协议即在您与本引擎著作权人之间产生法律效力，成为对双方均具有约束力的法律文件。如果您不同意本协议中的任何条款，请立即停止下载、安装行为，并彻底删除已下载、安装的全部本软件相关文件。

一、协议主体与适用范围

协议双方：本协议许可方（以下简称“我们”“许可方”）为ET游戏引擎的原始开发方及全部知识产权权利人；被许可方（以下简称“您”“用户”）为下载、安装、使用、复制、分发本软件的自然人、法人或非法人组织，包括但不限于游戏开发者、游戏运营商、游戏运营相关技术服务方。

协议关系：本协议为ET游戏引擎相关产品及服务的主协议，《ET反挂插件软件用户许可使用协议》为本协议不可分割的补充协议，与本协议具有同等法律效力。本协议未约定的内容，适用《ET反挂插件软件用户许可使用协议》的相关约定；本协议与《ET反挂插件软件用户许可使用协议》约定不一致的，以补充协议为准。

适用范围：本协议适用于ET游戏引擎全部版本、安装包、源代码、组件库、工具集、配套文档、官方公示的使用说明书，以及我们基于本引擎开发的全部拓展应用（包括但不限于ET反挂插件软件、网关系统、服务器监控工具、版本制作工具等配套功能模块、衍生产品及服务）。本协议内容同时包括我们可能不断发布的关于本软件及服务的补充协议、业务规则、公告声明等内容，上述内容一经正式发布，即为本协议不可分割的组成部分，您同样应当遵守。

产品说明：本引擎目前处于测试期（免费期），我们在此测试期内向所有用户免费开放本引擎的使用权限，仅供用户进行非商业性的学习、研究、技术交流用途使用。测试期结束后，我们将另行发布官方公告明确许可模式与相关规则，不影响本协议核心条款的效力。

二、定义与术语

ET游戏引擎：指我们基于Delphi开发工具研发的游戏引擎软件，包含源代码、目标代码、组件库、工具集、安装程序、运行依赖库、技术文档等全部相关内容，以及后续的更新、升级、优化版本。

拓展应用：指基于ET游戏引擎开发的各类衍生产品及服务，包括但不限于ET反挂插件软件、网关系统、服务器监控工具、版本制作工具等配套功能模块与相关服务。

用户内容：指您基于本引擎开发、制作、上传、发布、存储的各类内容，包括但不限于游戏程序、美术素材、音效资源、地图数据、游戏剧情、代码程序、文案内容等。

官方渠道：指ET游戏引擎官方网站、我们授权的第三方下载平台、官方合作分发/销售渠道，具体以我们官方公示为准。

测试期（免费期）：指本引擎从正式开放免费下载之日起，至我们官方发布公告宣布测试期结束之日止的期间。

使用说明书：指我们在ET游戏引擎官方网站公示的，针对ET游戏引擎的安装部署、操作流程、功能使用、运维规范、异常处理方式、游戏适配操作指引等内容的官方说明文档，包括该文档的全部后续更新版本。

终端用户：指您基于ET游戏引擎开发、运营的游戏的最终玩家、使用者。

《传奇》：指网络游戏《LegendofMirII》，中文名《热血传奇》。

《传奇》适配授权：指我们已合法获得《传奇》网络游戏PC端相关权利人的正式授权，该授权包含本引擎及配套拓展应用适配《传奇》网络游戏PC端非官方版本游戏的技术适配行为，但不包括任何使用本引擎及拓展应用开发、运营任何游戏（包括《传奇》）的主体已获得对应游戏的著作权授权。任何主体使用本引擎及拓展应用开发、运营任何游戏，均需自行单独取得该游戏相关权利人的著作权授权。

三、知识产权声明

我们是ET游戏引擎及全部拓展应用的唯一知识产权权利人，本软件及相关服务的全部著作权、商标权、专利权、商业秘密等知识产权，以及与本软件相关的所有信息内容（包括但不限于文字表述及其组合、图标、图饰、图像、图表、色彩、界面设计、版面框架、有关数据、附加程序、印刷材料、电子文档、源代码、技术方案、密钥生成系统、使用说明书等），均受《中华人民共和国著作权法》《中华人民共和国商标法》《计算机软件保护条例》等相关法律法规和国际条约的完整保护。

我们已合法获得《传奇》网络游戏PC端相关权利人的正式技术适配授权，该授权包含本引擎及配套拓展应用适配《传奇》网络游戏PC端非官方版本游戏的技术适配行为，仅保障我们开展该适配行为的合法性，但不包括任何使用本引擎及拓展应用开发、运营任何游戏的主体已获得对应游戏的著作权授权。我们仅对本引擎及配套拓展应用适配《传奇》非官方版本游戏的技术授权合法性承担责任，不对任何主体使用本引擎开发、运营任何游戏的著作权合法性承担任何责任。

本协议仅授予您本软件的有限许可使用权，并未将本软件的任何知识产权转让给您。您基于本引擎自主开发、创作的用户内容的相关知识产权，由您自行享有或按相关法律规定处理；您使用本引擎开发用户内容的行为，不影响我们对本引擎本身享有的全部知识产权。

我们对本引擎开发的拓展应用（包括但不限于ET反挂插件软件）享有完整、独立的知识产权，您仅可在使用本引擎的过程中，按本协议约定配套使用相关拓展应用，不得单独对拓展应用进行复制、修改、分发、破解等任何超出本协议许可范围的行为。

未经我们或相关权利人书面同意，您不得为任何商业或非商业目的，自行或许可任何第三方实施、利用、转让上述知识产权，不得对使用说明书进行复制、篡改、分发、演绎等侵权行为。

您使用本引擎，不代表您自动获得了任何第三方游戏IP、著作权、商标权的相关授权。任何主体使用本引擎进行相关游戏的开发、运营行为，其行为是否构成侵权，由该使用主体自行承担全部责任，与我们及本引擎无任何关联。特别强调：任何主体使用本引擎开发、运营任何游戏，均需自行单独取得该游戏相关权利人的完整、合法、有效的著作权授权，未取得授权的，构成对该游戏著作权的侵权，全部侵权责任由该主体自行承担，与我们无任何关联，我们不承担任何连带责任。

四、许可使用范围

在本协议约定的范围及测试期（免费期）内，我们授予您一项个人的、非独占的、不可转让、不可转授权、免费的许可使用权，您可在符合法律法规及本协议约定的前提下，实施以下行为：

（1）下载、安装本引擎至您合法所有/控制的终端设备中，运行、使用本引擎的全部功能；

（2）为使用本引擎及服务的目的，复制本软件的一个副本仅用作备份，备份副本必须包含原软件中含有的所有著作权信息与本协议内容；

（3）基于本引擎进行非商业性的学习、研究、技术交流，开发、测试个人非商用的游戏内容及相关程序；

（4）非商业性地复制、分发本引擎完整安装包，前提是您完整保留本软件的著作权信息、本协议全部内容，不得对本软件进行任何形式的修改、破解、捆绑，且不得通过分发行为收取任何形式的费用、牟取任何商业利益。

针对《传奇》网络游戏PC端非官方版本的适配使用，我们已取得完整合法的技术适配授权，但该授权仅保障您使用本引擎适配该游戏的技术合法性，不代表您已获得任何游戏的著作权授权，您若将本引擎用于任何游戏的非商业性开发、测试，均需自行取得该游戏相关权利人的著作权授权，否则构成侵权，相关责任由您自行承担。

本条及本协议其他条款未明示授权的其他一切权利，均由我们完整保留。您行使上述未明示授权的权利时，须另外取得我们的书面许可；我们未行使前述任何权利，并不构成对该权利的放弃。

如您需要将本引擎用于商业用途（包括但不限于基于本引擎开发游戏并进行商业化运营、售卖、授权，使用本引擎进行商业项目开发、商业培训、广告推广等），您须提前与我们联系，另行签署书面商业许可协议，获得我们的正式书面授权后方可实施。未经书面授权，任何商业性使用行为均视为违约，我们有权追究您的全部法律责任。

我们原则上禁止您未经我们书面许可，私自对本引擎进行修改、适配、接入、应用于官方公示适配范围以外的其他游戏，无论本引擎在技术层面是否可实现对该等游戏的适配，该等禁止行为均适用于本协议全部有效期内。

五、用户行为规范

1.合法合规与规范使用义务

（1）您承诺，使用本引擎的全部行为均符合《中华人民共和国网络安全法》《中华人民共和国数据安全法》《中华人民共和国个人信息保护法》《中华人民共和国著作权法》《计算机软件保护条例》等相关法律法规、政策要求、行业规范，以及您所在国家/地区的相关法律规定，不得将本引擎用于任何违法、违规、侵权的用途。

（2）您承诺，使用本引擎的全部行为，均严格遵守本协议约定及ET游戏引擎官方网站公示的最新版使用说明书，不得超出说明书载明的操作规范、使用范围、权限要求使用本引擎。

（3）您明确知晓并同意，若您基于本引擎开发、运营相关游戏、程序或其他内容，应当自行取得相关全部合法资质、许可及第三方授权（包括但不限于游戏版号、网络文化经营许可证、ICP经营许可、著作权授权、商标授权等）。其中，针对《传奇》网络游戏PC端非官方版本，我们仅获得了本引擎及配套拓展应用适配该游戏的技术授权，该技术适配授权不包含任何游戏著作权的使用授权；针对所有游戏，您未取得相关资质、授权而产生的全部法律责任、纠纷、赔偿、行政处罚等，均由您自行独立承担，与我们及本引擎无任何关联。

（4）您不得利用本引擎制作、复制、发布、传播、运营含有以下内容的程序、游戏及相关内容：

a.反对宪法所确定的基本原则的；

b.危害国家安全，泄露国家秘密，颠覆国家政权，破坏国家统一的；

c.损害国家荣誉和利益的；

d.煽动民族仇恨、民族歧视，破坏民族团结的；

e.破坏国家宗教政策，宣扬邪教和封建迷信的；

f.散布谣言，扰乱社会秩序，破坏社会稳定的；

g.散布淫秽、色情、赌博、暴力、凶杀、恐怖或者教唆犯罪的；

h.侮辱或者诽谤他人，侵害他人名誉权、隐私权、知识产权等合法权益的；

i.煽动非法集会、结社、游行、示威、聚众扰乱社会秩序的；

j.以非法民间组织名义活动的；

k.含有虚假、误导性内容，欺骗、误导他人的；

l.含有法律、行政法规禁止的其他内容的。

（5）您将本引擎应用于《传奇》网络游戏PC端非官方版本游戏时，应确保相关使用行为符合我们获得的《传奇》技术适配授权范围，不得超范围使用，同时必须确保您已取得该游戏相关权利人的著作权授权，否则由此引发的侵权责任由您自行承担。

（6）即便您违反本协议约定，私自对本引擎进行修改以适配官方公示适配范围以外的其他游戏，或私自将本引擎应用于该等游戏，您仍需自行确保该等行为已获得对应游戏权利人的完整、合法、有效授权，不侵犯任何第三方的知识产权及其他合法权益，该等行为引发的全部责任均由您自行承担。

（7）您明确知晓，我们不参与您基于本引擎开展的任何开发、运营、分发等活动，不对您开发的任何内容进行审核、修改、编辑、推广，也不对您的相关行为承担任何责任。因您使用本引擎的行为引发的任何纠纷、处罚、侵权索赔、刑事责任等，均由您自行独立承担；如因此给我们造成损失的，您应全额赔偿（包括但不限于直接经济损失、商誉损失、维权费用、律师费、诉讼费等）。

2.终端用户告知与授权义务

（1）您在运营的游戏中使用本引擎及配套反挂插件等拓展应用时，应当以显著方式向终端用户充分、清晰、完整地告知相关软件的运行规则、功能目的、收集的个人信息范围、使用方式、存储期限等内容，并取得终端用户的合法、明确、具体、有效的授权同意，确保您及我们对终端用户相关信息的处理行为，均符合《中华人民共和国个人信息保护法》等相关法律法规的要求。

（2）您应向终端用户提供本协议、《ET游戏引擎隐私政策》《ET反挂插件软件用户许可使用协议》及使用说明书的官方查阅链接，确保终端用户可完整查阅相关规则。若终端用户不同意相关软件的运行规则及信息处理规则，您不得强制终端用户接受，且应保障终端用户的退出权利。

（3）因您未履行前述告知义务、未取得终端用户合法有效授权，或违规收集、使用、处理终端用户个人信息引发的全部纠纷、索赔、行政处罚、刑事责任，均由您自行独立承担全部责任；如因此给我们造成损失的，您应全额赔偿。

3.数据合规义务

（1）您保证，您通过本引擎及配套拓展应用采集、存储、上传、处理的全部数据，均为您依法收集、获取的数据，且已通过合法有效的方式取得相关数据主体的明示授权，确保我们为提供本引擎服务对前述数据进行的采集、上传、存储、分析等处理行为，均符合相关法律法规的要求，不存在任何违法、侵权情形。

（2）因您的数据的产生、收集、处理、使用等任何相关事项存在违反法律法规等情况而造成的全部结果及责任，均由您自行承担；我们有权随时全部或部分终止向您提供本引擎服务，并要求您赔偿由此给我们造成的全部损失。

4.禁止的侵权与违约行为

除非法律明确允许或我们书面许可，您不得实施以下行为：

（1）对本软件产品进行逆向工程、反向编译、反汇编、拆解、破解，或通过其他方式尝试发现本软件的源代码、核心算法、技术方案；

（2）对本软件进行修改、删减、增补、篡改，改动编译程序文件内部的任何资源，或基于本软件创作衍生作品，或将本软件嵌入其他软件、程序中；

（3）删除、改变、遮盖本软件上的所有著作权、商标、专利等权利管理电子信息，或故意避开、破坏我们为保护本软件知识产权而采取的技术措施；

（4）出租、出借、出售、转让、转授权本软件的使用权，或将本软件用于抵押、质押、担保等其他用途；

（5）将本软件用于开发、运营无版号游戏、套版号游戏、赌博服、打金服等违法违规游戏及程序，或为他人的违法违规行为提供技术支持、工具帮助；

（6）利用本引擎及相关服务，侵犯任何第三方的著作权、商标权、专利权、商业秘密、隐私权等合法权益；

（7）对本软件运行过程中释放到终端内存中的数据、客户端与服务器端的交互数据、软件运行所必需的系统数据，进行复制、修改、增加、删除、挂接运行，或使用插件、外挂、非经我们授权的第三方工具/服务接入本软件和相关系统；

（8）通过修改或伪造本软件运行中的指令、数据，增减、变动本软件的功能或运行效果，或将用于上述用途的软件、方法进行运营、向公众传播，无论该行为是否为商业目的；

（9）对本软件及相关服务进行抓取、镜像、爬虫，或通过非官方渠道提供本软件的下载、分发服务；

（10）对我们的ET反挂插件软件进行破解、规避、篡改，或开发、使用针对本反挂插件的外挂、作弊工具，或协助他人实施上述行为；

（11）未取得对应游戏相关权利人著作权授权，擅自使用本引擎开发、运营任何游戏，或超出我们获得的《传奇》适配授权范围使用本引擎；

（12）未经我们书面许可，私自对本引擎进行修改、适配、接入、应用于官方公示适配范围以外的其他任何游戏；

（13）超出官方使用说明书载明的操作规范、使用场景、权限范围使用本软件；

（14）其他违反本协议约定、侵犯我们知识产权、违反法律法规的行为。

5.说明书更新知悉义务

您明确知晓并同意，使用说明书的更新将在ET游戏引擎官方网站进行公示，我们无需就该等更新另行单独告知您。公示后的最新版使用说明书即对您产生法律约束力，您应随时关注官网公示内容，确保使用本引擎的行为始终符合最新版使用说明书的规范要求。

六、个人信息保护

我们严格遵守《中华人民共和国个人信息保护法》等相关法律法规，重视您及终端用户的个人信息保护，在此向您明确说明我们的个人信息处理规则，您可以通过本引擎官网的《ET游戏引擎隐私政策》查看完整的个人信息保护说明，本条款为核心规则提示，与《ET游戏引擎隐私政策》具有同等法律效力。

信息收集范围：我们仅会出于本协议约定的、为您提供本软件及服务的必要目的，收集您的相关信息，包括：

（1）您主动提供的信息：包括您的联系信息（如邮箱、电话）、身份信息（如您为企业用户时提供的企业相关信息）、您向我们提交的反馈、咨询、技术支持申请中包含的相关信息；

（2）我们自动收集的信息：当您运行、使用本引擎时，我们会收集您的设备相关信息（包括设备类型、操作系统版本、设备识别符、浏览器类型、IP地址）、软件使用日志信息（包括功能使用记录、访问时间、操作行为、崩溃日志、错误信息）、网络相关信息；

（3）为实现反外挂功能必要收集的信息：当您使用ET反挂插件软件时，我们会基于反外挂安全防护的必要目的，收集相关设备信息、程序运行信息、异常行为检测信息，不会收集与反外挂功能无关的终端用户个人敏感信息。

信息使用目的：我们收集您的个人信息，仅用于以下合法、正当、必要的目的：

（1）为您提供本引擎的核心功能、技术支持、问题排查、版本更新与优化；

（2）保障本引擎及相关服务的安全、稳定运行，防范恶意攻击、外挂、作弊、非法破解等行为；

（3）响应您的咨询、反馈，与您进行沟通联络；

（4）改善、优化本引擎的功能与用户体验，开发新的产品与服务；

（5）遵守法律法规要求，履行法定义务，处理相关投诉、纠纷。

信息存储与保护：我们在中华人民共和国境内运营中收集和产生的个人信息，将存储在中华人民共和国境内，不会向境外传输，除非获得您的明确授权同意，且符合法律法规关于跨境数据传输的相关要求。我们会采取行业通用的、合理的物理、管理和技术保障措施，保护您的个人信息不被未经授权的访问、披露、使用、修改、损坏或丢失。我们仅会在达成本协议所述目的所需的最短期限内保留您的个人信息，超出保留期限后，我们将对您的个人信息进行删除或匿名化处理，法律法规另有规定的除外。

信息共享与披露：我们承诺，不会向任何第三方出售、出租您的个人信息。仅在以下情形中，我们会向第三方共享您的相关信息：

（1）获得您的明确、具体的书面同意与授权后；

（2）为向您提供本软件及服务所必需，向我们的合作服务商、技术支持方共享，且我们会要求第三方严格遵守保密义务，仅能将信息用于约定的用途；

（3）根据法律法规、法律程序、政府部门或司法机关的强制性要求进行披露；

（4）为保护我们、您或其他用户的合法权益、财产安全，在合理必要范围内进行披露；

（5）因合并、收购、资产转让等交易导致的信息转移，我们会提前向您告知，并要求受让方继续受本协议约束。

您的个人信息权利：您对您的个人信息依法享有查阅、复制、更正、补充、删除、限制处理、撤回授权、要求解释说明的权利；终端用户对其个人信息同样享有前述法定权利，您应协助终端用户行使相关权利。您可以通过本协议文末的联系方式向我们提交相关申请，我们将在法律法规要求的时限内响应您的请求。

七、保密义务

双方均应对本协议履行过程中接触到的对方的保密信息履行永久保密义务，保密义务不因本协议的终止、解除、无效而失效。

未经对方书面同意，任何一方不得向任何第三方泄露、披露、转让、复制对方的保密信息，包括但不限于本软件的代码、技术方案、技术文档、未公开的功能信息、密钥生成规则，以及对方的商业秘密、运营数据、用户数据、注册信息、未公开的密钥信息、协议内容、往来文件等。

因法律法规要求、司法机关或行政机关的强制性命令需要披露保密信息的，披露方应在披露前3个工作日书面通知对方，并配合对方采取必要的保密保护措施，且仅在法定要求的范围内进行披露。

若您违反本条款约定的保密义务，应向我们支付违约金50万元，并赔偿我们因此遭受的全部损失；若我们违反本条款约定的保密义务，应向您赔偿您因此遭受的全部损失。

八、违约责任

您违反本协议约定的许可使用范围、实施禁止行为的，我们有权立即终止您的软件使用权限，您应向我们支付违约金50万元，违约金不足以弥补我们损失的（包括但不限于著作权侵权损失、商誉损失、维权费用、律师费、诉讼费等），您应继续赔偿不足部分；情节严重的，我们将依法向公安机关报案，追究您的刑事责任。

您违反本协议约定，未取得对应游戏相关权利人著作权授权，擅自使用本引擎开发、运营任何游戏，或超范围使用《传奇》适配授权的，由此引发的第三方侵权索赔、行政处罚、司法追责等全部责任由您自行承担；若因此给我们造成损失（包括但不限于商誉损失、维权费用、赔偿金等），您应全额赔偿，我们有权立即终止服务，不退还任何已支付费用（如有）。

您违反本协议约定的用户行为规范，未履行对终端用户的告知义务、数据合规义务，导致我们遭受损失或被第三方主张权利的，您应全额赔偿我们的全部损失，我们有权终止向您提供服务，不退还任何已支付费用（如有）。

您违反本协议约定，对本软件进行逆向工程、破解、反编译、修改、复制、分发、转售等侵权行为的，我们有权立即终止您的软件使用权限，您应向我们支付违约金50万元，违约金不足以弥补我们损失的，您应继续赔偿不足部分。

我们违反本协议约定，未按承诺提供软件核心服务、泄露您保密信息、违规处理个人信息等行为的，应向您赔偿您的所有损失；若造成您重大损失的，您有权解除本协议。

本条款约定的违约金不足以弥补一方实际损失的，受损方有权要求违约方赔偿全部实际损失，包括但不限于直接经济损失、间接经济损失、维权费用、律师费、诉讼费、保全费、差旅费等。

九、免责与责任限制

软件使用风险提示：本引擎处于测试期（免费期），我们仅按“现状”向您提供本软件及相关服务，不保证本软件完全无错误、无漏洞、无中断运行，不保证本软件与所有软硬件系统完全兼容，不保证本软件的功能完全满足您的使用需求。对于因软件兼容性问题、BUG、功能缺陷给您造成的影响，我们将尽力提供技术支持进行优化修复，但在法律允许的最大范围内，不承担由此产生的任何直接或间接责任。

第三方渠道免责：我们仅保证通过官方渠道提供的本软件不含病毒、木马等恶意代码。对于从非官方渠道获取的本软件或与本软件名称相同的安装程序，我们无法保证其安全性、完整性、有效性，不承担由此引起的直接或间接损害责任，相关风险由您自行承担。

用户行为免责：您充分了解并同意，您必须为自己使用本引擎的一切行为承担全部责任，包括您基于本引擎开发、制作、发布、运营的任何内容，以及由此产生的任何法律后果。我们不对您的用户内容、运营行为承担任何担保或连带责任，如因您的行为导致我们被第三方索赔、被行政机关处罚，您应全额赔偿我们因此遭受的全部损失。

知识产权侵权免责：您使用本引擎开发、运营相关内容时，应当自行确保相关内容不侵犯任何第三方的知识产权及其他合法权益，自行取得相关第三方授权。因您使用的素材、剧情、名称、地图、音乐等内容引发的知识产权侵权纠纷、索赔、行政处罚，均由您自行承担全部责任，与我们及本引擎无任何关联。

《传奇》相关免责：我们获得的《传奇》授权包括引擎及配套拓展应用的技术适配授权，但您使用本引擎开发、运营《传奇》相关游戏，未自行取得对应著作权授权引发的全部侵权责任、纠纷、处罚，均由您自行承担，与我们无任何关联，我们不承担任何连带责任。

商业运营免责：我们仅向您提供本引擎的技术工具，不参与您的任何商业运营活动，不对您的商业收益、运营亏损承担任何责任，也不对您开发、运营的游戏的用户数量、收益情况承担任何承诺或担保。您因商业运营行为引发的任何市场风险、合规风险、法律纠纷，均由您自行独立承担。

第三方原因免责：因第三方原因（包括但不限于第三方网络攻击、病毒入侵、第三方软件干扰、游戏权利人投诉等）导致本软件服务中断、功能异常的，我们不承担直接责任，但应尽力协助您排查问题、减少损失；若因第三方原因给您造成损失的，您应向第三方主张权利，我们不承担连带赔偿责任。

不可抗力免责：对于因地震、火灾、战争、政策调整、网络故障、电信系统故障、黑客攻击、计算机病毒爆发等不可抗力因素导致本软件无法正常使用、您的数据丢失、服务中断的，我们不承担任何责任，将尽力协助您减少损失，并及时恢复相关服务。

责任限制：在法律允许的最大范围内，无论在何种情形下，我们对您承担的全部赔偿责任总额，不超过您因使用本软件向我们支付的全部费用（测试期免费阶段为0元）。我们不对您的任何间接损失、附带损失、特殊损失、惩罚性赔偿承担责任，包括但不限于商业利润损失、业务中断、数据丢失、贸易中断等。

十、协议的生效、修改与终止

协议生效：本协议自您勾选同意、下载、安装、使用本软件的任一行为完成之日起生效，对您与我们均产生法律约束力。

协议修改：我们有权根据法律法规变化、产品调整、经营策略更新等情况，随时修改本协议。修改后的协议将在ET游戏引擎官方网站进行公示，公示期不少于7个工作日；对于重大条款变更、服务模式调整、核心权利义务修改，我们将提前30日进行公告。公示期满后即生效。如果您不同意修改后的协议内容，请立即停止使用本软件并删除全部相关文件；您在协议修改公示期满后继续使用本软件的行为，视为您已完全接受修改后的协议内容。我们无需就协议更新事宜单独通知您，您应自行随时关注官方网站的公示内容，因您未关注公示导致的任何损失，由您自行承担。

协议终止：

（1）您可以通过彻底删除本软件全部相关文件、停止使用本软件的方式，终止本协议；

（2）出现以下情形之一的，我们有权无需另行通知您，单方终止本协议，暂停或终止您对本软件的使用权限，且不退还任何费用（如有），同时保留追究您违约责任的权利：

a.您存在违反本协议约定的许可使用范围、实施禁止行为的，经我们通知后未在限定期限内整改的；

b.您未按官方使用说明书规范使用本软件，经提醒后仍未整改，给软件运行、我们的服务造成不利影响的；

c.您利用本引擎实施违法违规行为，被行政机关处罚、被司法机关追责，或被第三方权利人举报核实的；

d.您擅自将本引擎修改、适配、接入、应用于官方公示适配范围以外的其他游戏，或超范围使用《传奇》适配授权，引发侵权纠纷或违规风险的；

e.您未取得对应游戏相关权利人著作权授权，擅自使用本引擎开发、运营游戏，引发侵权投诉或行政处罚的；

f.您严重违反本协议其他约定、使用说明书规范或法律法规相关规定的。

（3）本协议终止后，本协议中的知识产权条款、保密条款、免责与责任限制条款、违约责任条款、争议解决条款、个人信息保护相关条款仍然有效，双方仍应遵守相关约定。

终止后的义务：本协议终止后，您应立即停止使用本软件，彻底删除本软件的全部副本、相关文件及源代码；我们有权停止向您提供任何相关的技术支持与服务。

十一、签署约定

本协议为网络电子协议，您在ET游戏引擎官方网站下载、安装本软件时，或在软件安装过程中、账号注册/登录时，将看到本协议完整内容及“我已阅读并同意《ET游戏引擎用户许可使用协议》”的勾选框。

您在线完整阅读本协议全部内容后，勾选前述勾选框的行为，即视为您通过网络电子方式签署本协议，确认已充分阅读、完全理解并自愿接受本协议全部条款（包括更新后的条款）的约束，本协议自您勾选同意之日起正式生效，对您与我们均具有法律约束力。

您勾选同意后，即视为您认可本协议的电子签署效力，该电子签署与书面签署具有同等法律效力，可作为双方权利义务履行、争议解决的依据。

若您未勾选同意本协议，将无法下载、安装、使用本软件及相关服务，双方不产生任何协议关系，您不得擅自下载、安装、使用本软件，否则构成违约，需承担相应的法律责任。

十二、争议解决

本协议的订立、效力、履行、解释及争议解决，均适用中华人民共和国法律（不包括冲突法规则）。

因本协议引起的或与本协议有关的任何争议，双方应首先友好协商解决；协商不成的，任何一方均有权向我们住所地有管辖权的人民法院提起诉讼。

在争议解决过程中，除争议事项外，双方应继续履行本协议的其他条款。

十三、其他条款

可分割性：如果本协议中的任何条款无论因何种原因完全或部分无效、不具有执行力，或违反任何适用的法律，则该条款被视为在相应范围内无效，但本协议的其余条款仍应有效并且有约束力。

通知与送达：我们将通过本引擎官方网站公告、您提供的邮箱、站内消息等方式，向您送达相关通知、公告、法律文书等内容。您在本协议项下提供的联系地址、邮箱、电话为有效联系方式，任何书面通知按该地址寄送，寄出后3日视为送达；通过电子方式送达的，发送成功即视为送达。若您预留的联系信息发生变更，应及时通过官方渠道更新，因您未及时更新联系信息导致的通知无法送达、响应延迟等损失，由您自行承担。

完整协议：本协议及我们发布的补充协议、隐私政策、业务规则、公告声明、使用说明书，构成您与我们之间关于本软件使用的完整协议，取代此前双方就此达成的任何口头或书面协议、沟通内容。

权利放弃：我们未行使本协议项下的任何权利、未追究您的任何违约行为，不视为对该权利的放弃，也不影响我们后续行使该权利或追究您的其他违约行为。

协议转让：您不得将本协议项下的权利或义务转让给任何第三方，除非获得我们的书面同意；我们可将本协议项下的权利或义务转让给我们的关联公司或承接我们相关业务的第三方，转让后我们将通过官方渠道公示，公示后即视为您已同意该转让行为。

联系方式：如您对本协议有任何疑问、意见或建议，可通过以下方式与我们联系：【官方邮箱地址：3774901398@qq.com】、【官方客服QQ：3774901398】、ET游戏引擎官方网站“联系我们”板块。

本协议一式两份，双方各执一份，具有同等法律效力（电子协议与书面协议具有同等效力）。

许可方（乙方）：ET游戏引擎开发团队

日期：【协议生效之日】

被许可方（甲方）：

账号名称：【以用户实际注册或登录的ET游戏引擎账号为准】

协议确认方式：【您下载、安装、启动、登录或继续使用本软件，即表示您已阅读、理解并同意接受本协议全部条款的约束】

协议生效日期：【您首次实施前述任一行为之日】


可视化爆率

项目：ET引擎说明书　分类：ET引擎脚本文档

可视化爆率I

可视化爆率II

条件规则的编写说明一
左边只允许填写变量 中间写逻辑符号 右边支持变量或者常量数值
逻辑符号(请用字母符号,注意样式别搞错):

=(等于)
!=(不等于)

> (大于)
=(大于等于)
<(小于)
<=(小于等于)
或(或，或者，用于多重条件判断)

注意:每一个步骤都要空格,要不然解析可能会不正常,请规范写代码

多条规则匹配判断用,分割 参考上图的条件规则的写法(请不要用拼音逗号,注意符号是否与文档一致)

如1:
变量 逻辑符号 常量数值
<$STR(U45)> >= 50
解析:U45变量 大于等于 50 视为条件满足

如2:
变量 逻辑符号 常量数值 分隔符 变量 逻辑符号 常量数值
<$LEVEL> > 100 , <$STR(N99)> = 888
解析:人物等级 大于 100 且 N99变量 等于 888 视为条件满足

如3:
变量 逻辑符号 变量
<$LEVEL> > <$STR(U45)>
解析:人物等级 大于 U45变量数值 视为条件满足

如4:
变量 逻辑符号 变量 或者 变量 逻辑符号 数值
<$LEVEL> > <$STR(U45)> 或 <$LEVEL> > 64
解析:人物等级 大于 U45变量数值 或者 人物等级大于64 视为条件满足

条件规则的编写说明二
M2插件(20200215)更新字符串匹配 如要匹配字符串 需要在判断文本或变量前面添加#符号 两者相对应添加# 逻辑判断符号只支持 = 或 !=

例子1:
#<$KILLMONNAME> != #雕像 , <$LEVEL> > 1998 或 <$LEVEL> > 1999

??????
;击杀怪物名称 不等于 雕像 且 人物等级 大于 1998 或 人物等级 大于 1999

例子2:
#<$KILLMONNAME> = #雕像 , <$LEVEL> > 1998 或 <$LEVEL> > 1999

??????
;击杀怪物名称 等于 雕像 且 人物等级 大于 1998 或 人物等级 大于 1999

可视化爆率III用于过滤活动怪,填写需要过滤的怪物全称,那这个怪物所爆的装备都不会走条件判断

可视化爆率IV


自定义元素

项目：ET引擎说明书　分类：ET引擎脚本文档

开启或关闭自定义元素

自定义属性名称


开启自动战斗

项目：ET引擎说明书　分类：ET引擎脚本文档

自动挂机，自动战斗开启

相关使用教程点击：链接

相关使用教程点击：链接

作用:按钮触发自动挂机命令

??????
开启自动挂机
#ACT
ETSENDCOMMAND 2024 1
或者
ETSENDCOMMAND 10001 1

关闭自动挂机
#ACT
ETSENDCOMMAND 2024 0
或者
ETSENDCOMMAND 10001 0

ET内挂自动挂机使用说明：

??????
#ACT
ShowWindow 2021

作用:显示自动挂机窗口

??????
#ACT
ShowWindow 2021

开启步骤

首先在ET客户端功能扩展一 - 插件内挂设置 - 开启自动挂机

一、第一步激活内挂-自动挂机的，如果不使用此命令激活，圈圈框出来的区域是不会激活的，也就可以通过此命令来区分使用者

一般放在QM-login里激活,也可以任意地方调用

??????
[@login]
#if
#act
ETOpenAutoPlayGame

二、第二步，玩家点击开始自动挂机会触发QF里的[@ETStartAutoPlayGame]，这里我们需要用一个新命令进行最终是否允许开始战斗,ETStartAutoPlayGame,与第一步的命令文字是不一致的！

??????
[@ETStartAutoPlayGame]
;点击开始自动挂机按钮就会触发QF里这个字段！
#IF
;可以写点判断来控制
#act
;如果允许的话就直接调用下面这个命令就行，然后自己可以加点其他提示，比如屏幕中间命令来提示是否允许开启
ETStartAutoPlayGame

三、第三，当开始挂机后，玩家点击停止按钮会触发触发QF里的[@ETStopAutoPlayGame]，或者调用脚本命令ETStopAutoPlayGame主动停止挂机，最终也会触发此QF字段，除非掉线了！

??????
[@ETStopAutoPlayGame]
#act
ETStopAutoPlayGame
sendmsg 6 停止成功！

其他

功能:检测人物是否ET自动挂机状态
格式:ETCheckAutoPlayGame

??????
#IF
ETCheckAutoPlayGame
#ACT
SendMsg 6 正在自动挂机

还有一些触发可配合使用，如

??????
[@ET地图变更]
#IF
ETCheckAutoPlayGame
#ACT
SendMsg 6 这里代表自动挂机状态下，地图发生更改，可能是人物死亡或地图超时被传送回来，这里可以做个阀门，把人物传送回去一开始自动战斗的地图，这样就可以实现无限循环的挂机

;此功能的搭配同时要 - 勾选地图发生切换时不停止战斗,进行静默等待重新进入原地图

关联最新脚本

开始自动挂机(先满足并激活挂机脚本命令)

??????
#ACT
ETSENDCOMMAND 2024 1

关闭自动挂机
#ACT
ETSENDCOMMAND 2024 0


物品自动拾取

项目：ET引擎说明书　分类：ET引擎脚本文档

激活自动捡物

命令:

STARTPICKUP

当精灵内挂已加载的时候，调用此命令可以直接开启精灵内挂的捡物。

停止自动捡物

命令:

STOPPICKUP

当精灵内挂已加载的时候，调用此命令可以直接停止精灵内挂的捡物。

设置条件使用

命令:
StartElf

参数1=条件开关(1:允许使用 0:不允许使用)

例子1:
在QM里寻找这个字段写,如果还有领取激活的，就在领取激活触发的字段也写一个，原理都是一样的

??????
[@Login]
#IF
;判断条件自己写，比如充值多少，有没有捐献，这些根据你自己的服去弄
#ACT
;允许使用写1 否则0 这个是控制他能不能开启自动捡物，另外不管你允许不允许捡物精灵还是会加载
StartElf 1
；这个开启捡物命令是让精灵窗口那个开启捡物按钮激活，这样就不需要小退
STARTPICKUP

开启假人自动拾取


装备自动回收

项目：ET引擎说明书　分类：ET引擎脚本文档

在插件面板内开启自动回收。

BackpackRecovery

参数1:1为开启玩家自动回收装备 0为关闭自动回收装备

开启例子:

BackpackRecovery 1

关闭例子:

BackpackRecovery 0

需要在装备自动回收窗口里设置好条件，再使用此命令。

手动触发回收命令
SendRecycle

??????
#IF
#ACT
;可以用于手动触发回收 前提是开启好装备回收再触发此命令
SendRecycle
??????
SetNumber

使用此命令首先要勾选图片里的框框,用于控制指定回收序号是否激活状态

参数1:回收序号（0~99）

参数2:激活状态(1激活 0取消激活)

例子:

??????
#IF
#ACT
BackpackRecovery 1
;首先要用这个命令开启此用户允许使用自动回收装备，否则激活回收序号也是没用的，他的作用意义是不一样的
??????
SetNumber 0 1
SetNumber 99 1
;这两条命令是激活回收序号0和99，图片里我加了0和99的回收序号，你们根据自己的编写改，激活后0和99的回收序号，插件就会自动回收0和99的序号的装备

；如果只想回收99的序号，不想回收0的序号那就这样写

??????
SetNumber 0 0
SetNumber 99 1

；如果都关闭回收序号，那就这样写

??????
SetNumber 0 0
SetNumber 99 0

设置装备回收，收益率

ETSetRecycleRate

参数1
收益类型(1:元宝、2:金币、3:泡点、4:灵符、5:金刚石、6:荣誉、7:经验、0:全部适用)
参数2
操作符(+ 、- 、=)
参数3
收益百分比

??????
[@执行命令]
#IF
CHECKLEVELEX > 0
#ACT
ETSetRecycleRate ALL = 50
SENDMSG 5
回收所有收益倍率提升50%
break

常量 说明
<$ETRECYCLERATE1> 返回收益元宝倍率
<$ETRECYCLERATE2> 返回收益金币倍率
<$ETRECYCLERATE3> 返回收益泡点倍率
<$ETRECYCLERATE4> 返回收益灵符倍率
<$ETRECYCLERATE5> 返回收益金刚石倍率
<$ETRECYCLERATE6> 返回收益荣誉倍率
<$ETRECYCLERATE7> 返回收益经验倍率

装备回收透明实时数据提示个性化修改

修改个性文字，将以下配置内容 另存为 客户端游戏目录\data\ET.ini
内容自己修改，以下是例子

[配置]
回收标题左=左[
回收标题右=]右
回收标题元宝=我是元宝+
回收标题金币=我是金币+
回收标题泡点=我是泡点+
回收标题灵符=我是灵符+
回收标题荣誉=我是荣誉+
回收标题金刚石=我是金刚石+
回收标题经验值=我是经验值+

#待插入图片

回收脚本触发例子

以回收序号0和99

??????
[@BackpackRecovery_99]
#IF
#ACT
SENDMSG 6 回收序号_99,回收数量:<$STR(S$回收数量)>,回收元宝:<$STR(S$回收元宝)>,回收金币:<$STR(S$回收金币)>,回收泡点:<$STR(S$回收泡点)>,回收灵符:<$STR(S$回收灵符)>,回收金刚石:<$STR(S$回收金刚石)>,回收荣誉:<$STR(S$回收荣誉)>,回收经验:<$STR(S$回收经验)>

[@BackpackRecovery_0]
#IF
#ACT
SENDMSG 6 回收序号_0,回收数量:<$STR(S$回收数量)>,回收元宝:<$STR(S$回收元宝)>,回收金币:<$STR(S$回收金币)>,回收泡点:<$STR(S$回收泡点)>,回收灵符:<$STR(S$回收灵符)>,回收金刚石:<$STR(S$回收金刚石)>,回收荣誉:<$STR(S$回收荣誉)>,回收经验:<$STR(S$回收经验)>


一键大背包设置

项目：ET引擎说明书　分类：ET引擎脚本文档

相关演示教程请点击??链接 相关演示教程请点击??链接


时装首饰装备扩展

项目：ET引擎说明书　分类：ET引擎脚本文档

相关演示视频教程点击:链接

相关演示视频教程点击:链接

触发穿戴QF

??????
[@ETTAKEON]
#if
#act
sendmsg 7 穿戴物品名称<$DLGITEM.NAME>，<$DLGITEM.STDMODE>
[@ETTAKEOFF]
#if
#act
sendmsg 7 取下物品名称<$DLGITEM.NAME>，<$DLGITEM.STDMODE>

时装首饰装备扩展的命令

已扩展引擎支持时装首饰的命令如下

1、checkitemw 物品 检测身上所带的物品

2、支持引擎文档【自定义装备进度条】所有命令

3、$VALUE1~$VALUE20 人物元素的属性值的常量共20个。1到20

4、ETCHANGEITEMNAME，时装装备改名脚本命令

参数一：时装首饰装备位置

参数二：新名字，留空即还原名字！

时装首饰装备位置参考
1001 项链
1002 手镯1
1003 手镯2
1004 戒指1
1005 戒指2
1006 头盔
1007 盾牌
1008 腰带
1009 鞋子
1010 军鼓
1011 宝石
1012 马牌

已开发支持时装首饰专用命令如下

1、回收身上时装首饰装备

??????
ETTAKEW

参数一：装备名称或装备位置
参数二：最大回收数量，大于等于1生效

时装首饰装备位置参考
1001 项链
1002 手镯1
1003 手镯2
1004 戒指1
1005 戒指2
1006 头盔
1007 盾牌
1008 腰带
1009 鞋子
1010 军鼓
1011 宝石
1012 马牌

注意：回收的装备是不会触发QF穿戴、取下等字段的。

比如：

[@TakeOff0] 0——18 或 @ETTAKEON 等

用此命令是不会有这些触发的


新增物品分类47

项目：ET引擎说明书　分类：ET引擎脚本文档

新增物品分类47，物品可叠加使用，类似宝石镶嵌~和31类的··结合产物，背包直接执行

StdMode=47 新增扩展物品 可叠加
Shape=50， 物品使用一次后消失 , 准星对准物品点击了 和宝石镶嵌那样视为使用
Shape=51， 物品可以一直使用，直到手动删除

右键使用后 鼠标变成准星模式

触发：以上扩展2种类型的物品人物触发 QF中的 [@StdmodeShowX] X=物品的Anicount 英雄触发 QF中的 [@HeroStdmodeShowX] X=物品的Anicount

增加NPC变量（变量名带G_可显示改名后的物品名，详见下方示范脚本）:
当前使用物品名：<$UseItemName>, <$H.UseItemName>
当前使用物品唯一ID：<$UseItemMakeIndex> <$H.UseItemMakeIndex>

+当前准星使用对象物品名： <$BagItemName> <$H.BagItemName>
+当前准星使用对象物品唯一ID：<$BagItemMakeIndex> <$H.BagItemMakeIndex>

??????
;==========================================================
·脚本示范

[@StdModeShow1]
#if
#act
SendMsg 6 人物当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>
SendMsg 6 使用物品目标名字:<$BagItemName>,唯一ID:<$BagItemMakeIndex>
SendMsg 6 邪恶の力量到此一游
LinkBagItem <$BagItemMakeIndex>
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
UpdateItem  -1
ClearLinkItem
break

[@HeroStdModeShow2]
#if
#act
SendMsg 6 英雄当前使用的物品名:<$H.UseItemName>，唯一ID:<$H.UseItemMakeIndex>
SendMsg 6 英雄物品目标名字:<$H.BagItemName>,唯一ID:<$H.BagItemMakeIndex>
H.LinkBagItem <$H.BagItemMakeIndex>
;修改物品星星数量
H.CHANGEITEMUPGRADECOUNT -1 + 1
H.UpdateItem -1
H.ClearLinkItem
break

[@StdModeShow1]
#if
#act
;$G_UseItemName 和$G_BagItemName支持改名后的名称显示，不带G_则为数据库名字
SendMsg 6 人物当前使用的物品名:<$UseItemName> （<$G_UseItemName> ），唯一ID:<$UseItemMakeIndex>
SendMsg 6 使用物品目标名字:<$BagItemName> （<$G_BagItemName> ）,唯一ID:<$BagItemMakeIndex>
break


设置NPC面板文字坐标

项目：ET引擎说明书　分类：ET引擎脚本文档

设置NPC文字坐标

??????
<text:文字内容:X:Y:(字号)大小:1是加粗/@触发>
<Text:测试下这段文字的显示|提示信息:10:20:(字号)大小:1是加粗/@测试>
<Text:<$STR(S87)>|提示信息:10:20{FCOLOR=250}:(字号)大小:1是加粗/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{FCOLOR=254}:(字号)大小:1是加粗/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{AUTOCOLOR=250,251,252,253,254}:(字号)大小:1是加粗/@测试>

不带@排版写法

??????
<Text:测试下这段文字的显示:50:80:(字号)大小:1是加粗/AUTOCOLOR=253>\
<Text:测试下这段文字的显示|提示信息666:10:90:(字号)大小:1是加粗/AUTOCOLOR=250,251,252,253,254>\


清除引擎变量脚本命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 变量相关

ETCLEARVAR

参数1 起始变量(支持P、D、M、N、S、G、A、I、U、T变量)
参数2 数量
参数三 (可忽略)清理普通变量，该参数为变量赋默认值

例子

??????
ETCLEARVAR N10 10
;这样N10~N19的变量就会被清理

用于开区时清理引擎全局变量


拓展U T J Z 变量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 变量相关

U,T,J,Z变量 U0-U9999 支持一万个 (私人变量，数字型) 可保存 T0-T9999 支持一万个 (私人变量，字符型) 可保存 J0-J9999 支持一万个 (私人变量，数字型) 可保存，超过00:00点后变量会重置. Z0-Z9999 支持一万个 (私人变量，字符型) 可保存，超过00:00点后变量会重置.

??????
 [@test1]
#ACT
MOV T0 <$USERNAME>
SENDMSG 0 <$STR(T0)> 255 253

[@test2]
#ACT
MOV U0 100
INC <$STR(U0)> 1
SENDMSG 6 【当前杀怪数=<$STR(U0)>】 255 253

 [@test3]
#ACT
MOV Z0 <$USERNAME>
SENDMSG 0 <$STR(Z0)> 255 253

[@test4]
#ACT
MOV J0 100
INC <$STR(J0)> 1
SENDMSG 6 【当前杀怪数=<$STR(J0)>】 255 253

注：使用JZ变量需要在插件客户端功能扩展二开启


变量大全

项目：ET引擎说明书　分类：ET引擎脚本文档 / 变量相关
变量条目：71 项
参数描述 | 参数变量
获取登录器编号ID | <$ETMACHINEID>
当前攻击造成的伤害上一刀伤害,存在不准确 | <$PKPOWER>
当前攻击的目标坐标X | <$ATTACKMONSTER_X>
当前攻击的目标坐标Y | <$ATTACKMONSTER_Y>
当前攻击的目标血量值 | <$ATTACKMONSTER_HP>
当前攻击的目标最大血量值 | <$ATTACKMONSTER_MAX_HP>
当前服务器系统时间 | <$TIME>
当前宝宝名称(需要在宝宝攻击触发字段内使用) | <$BABYNAME>
当前宝宝攻击目标的名称(需要在宝宝攻击触发字段内使用) | <$BATTACKMONSTER_NAME>
当前宝宝坐标X(需要在宝宝攻击触发字段内使用) | <$BATTACKMONSTER_X>
当前宝宝坐标Y(需要在宝宝攻击触发字段内使用) | <$BATTACKMONSTER_Y>
当前宝宝攻击的目标血量值(需要在宝宝攻击触发字段内使用) | <$BATTACKMONSTER_HP>
当前宝宝攻击的目标最大血量值(需要在宝宝攻击触发字段内使用) | <$BATTACKMONSTER_MAX_HP>
当前人物是否有复活属性(用于优化脚本,支持动态属性调整) | <$Revival>
当前人物复活CD(单位为秒，0代表可立即复活，其他数值代表N秒) | <$RevivalTimeEx>
获取当前杀死的怪物名称,不带数字后缀 | <$ETKILLMONNAMECLIENT>
获取当前杀死的怪物名称,支持宝宝击杀后获取,在@KillMon里使用 | <$ETKILLMONNAME>
获取宝宝当前攻击怪物的掉血量 | <$BATTACKMONSTER_DAMAGE>
身上物品总强化数 包括时装、首饰盒) | <$UPGRADECOUNT>
身上物品强化值 0~16 身上物品 17~18时装 19~30生肖盒 | <$UPGRADECOUNT0>~<$UPGRADECOUNT30>
首饰盒物品名称变量 | <$ETGODBLESSITEM1>~<$ETGODBLESSITEM12>
所有真人在线数 | <$ETONUSERCOUNT>
真人在线数不包含离线 | <$ETONUSERCOUNTOFFLINE>
时装首饰拓展变量人物元素的属性值的常量共20个 | <$VALUE1>~<$VALUE20>
获取技能ID | <$ETMagicID>
获取技能名称 | <$ETMagicName>
获取技能释放目标 | <$ETMagicTarget>
获取技能释放目标类型0=人物 1=英雄 其他怪物、NPC等 | <$ETMagicTargetRace>
暴击剩余有效的次数 | <$ETBASHEXCOUNT>
获取暴击伤害数值 | <$ETPARAM1>
获取触发暴击的技能ID | <$ETPARAM2>
获取刷怪名称 | <$ETREGMONNAME>
获取刷怪地图号 | <$ETREGMONMAP>
获取刷怪地图名 | <$ETREGMONMAPDESC>
获取刷怪坐标X | <$ETREGMONX>
获取刷怪坐标Y | <$ETREGMONY>
获取杀死怪物正在爆出的物品名称 | <$DROPITEMNAME>
获取NPC传递变量标签 | <$ETSCRIPTPARAM1>—<$ETSCRIPTPARAM10>
获取装备回收元宝倍率 | <$ETRECYCLERATE1>
获取装备回收金币倍率 | <$ETRECYCLERATE2>
获取装备回收泡点倍率 | <$ETRECYCLERATE3>
获取装备回收灵符倍率 | <$ETRECYCLERATE4>
获取装备回收金刚石倍率 | <$ETRECYCLERATE5>
获取装备回收荣誉倍率 | <$ETRECYCLERATE6>
获取装备回收经验倍率 | <$ETRECYCLERATE7>
获取商铺卖家名称 | <$ETSHOPSELLER>
获取商品名称 | <$ETSHOPITEM>
获取商品序号 | <$ETSHOPITEMIDX>
获取商品价格 | <$ETSHOPITEMPRICE>
获取商品货币类型 | <$ETSHOPITEMMONEYTYPE>
获取商品物品数量 | <$ETSHOPITEMCOUNT>
获取当前物品名称 指人物死亡爆出来 | <$DROPUSEITEMS.NAME>
获取当前物品改名名称 指人物死亡爆出来 | <$DROPUSEITEMS.G_NAME>
获取当前物品DB字段StdMode值 指人物死亡爆出来 | <$DROPUSEITEMS.STDMODE>
获取当前物品DB字段Shape值 指人物死亡爆出来 | <$DROPUSEITEMS.SHAPE>
获取当前物品DB字段AniCount值 指人物死亡爆出来 | <$DROPUSEITEMS.ANICOUNT>
获取当前物品DB字段Looks值 指人物死亡爆出来 | <$DROPUSEITEMS.LOOKS>
获取当前物品当前持久值 指人物死亡爆出来 | <$DROPUSEITEMS.DURA>
获取当前物品最大值 指人物死亡爆出来 | <$DROPUSEITEMS.DURAMAX>
获取当前物品DB字段Idx值 指人物死亡爆出来 | <$DROPUSEITEMS.INDEX>
获取当前物品DB字段Color值 指人物死亡爆出来 | <$DROPUSEITEMS.COLOR>
获取当前物品MakeIndex序列号 指人物死亡爆出来 | <$DROPUSEITEMS.MAKEINDEX>
获取当前双击穿戴物品的名称 | <$ETTakeOnNAME>
获取当前双击穿戴物品的位置 | <$ETTakeOnIndex>
显示当前使用宝石或升级材料名称 | <$ETCLICKNAME>
显示当前所指装备位置 | <$ETCLICKWHERE>
显示自定义货币数量 | <$MONEY(自定义货币)>
显示自定义货币及关联货币总数量 | <$MONEYALL(自定义货币)>
当前击中目标的名称 | <$ATTACKMONSTER_NAME>
人物幸运值 | <$UserLucky>
取时间戳 | <$UTCNOW8>


L变量使用方法

项目：ET引擎说明书　分类：ET引擎脚本文档 / 变量相关
??????
;-----------------------------------------【赋值元素变量】
;-----------------------------------------给元素变量赋值（非子元素），值两边必须加 []，不然报错。
MOV L$测试 [11,22,33,44,55,66,77,aa]
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,22,33,44,55,66,77,aa]
;-----------------------------------------【取各字元素（大于等于0从第一个往后取；小于0从最后一个往前取】
sendmsg 7 输出结果：<$str(L$测试[0])>,<$str(L$测试[1])>,<$str(L$测试[2])>,,,,,<$str(L$测试[-2])>,<$str(L$测试[-1])>,
;输出结果：11,22,33,,,,,77,aa,
;-----------------------------------------【修改子元素】
MOV L$测试[0] 00
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[00,22,33,44,55,66,77,aa]
;-----------------------------------------【增加子元素】
INC L$测试 bb
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[00,22,33,44,55,66,77,aa,bb]
;-----------------------------------------【删除子元素】
Dec L$测试 22
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[00,33,44,55,66,77,aa,bb]
;-----------------------------------------【修改子元素】
Mov L$测试2 [aa,bb,cc]
Mov L$测试[0] <$str(L$测试2)>
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[[aa,bb,cc],33,44,55,66,77,aa,bb]
;-----------------------------------------【获取子元素的位置】
ETGetListVarIndex L$测试 aa N1
sendmsg 7 [L$测试]中"aa"位于第<$STR(N1)>个子元素
;-----------------------------------------【获取子元素数量】
ETGetListVarCount L$测试 N1
sendmsg 7 [L$测试]中有<$STR(N1)>个子元素
;-----------------------------------------【检查子元素是否存在】
#if
ETCheckVarInList L$测试 bb
#act
sendmsg 7 [L$测试]中存在"bb"
#elseact
sendmsg 7 [L$测试]中不存在"bb"

;-----------------------------------------【元素支持变量下标（示例）】
Mov N1 1
MOV L$测试[<$Str(N1)>] 23
sendmsg 7 输出结果：<$str(L$测试[<$Str(N1)>])>

;示例2
[@main]
<1.赋值/@mov测试> <2.inc测试/@inc测试> <3.dec测试/@dec测试>\
[@mov测试]
#act
MOV L$测试 [1,2,3,4,5,a]
sendmsg 7 首次赋值(L$测试)的值为：<$STR(L$测试)>
sendmsg 6 ----------------------------------
MOV L$测试[0] b
sendmsg 7 修改后(L$测试)的值为：<$STR(L$测试)>
sendmsg 7 当前(L$测试[0])的值为：<$STR(L$测试[0])>
sendmsg 6 ----------------------------------
MOV N$id 0
MOV L$测试[<$STR(N$ID)>] c
sendmsg 7 当前(L$测试[<$STR(N$ID)>])的值为：<$STR(L$测试[<$STR(N$ID)>])>
sendmsg 6 ----------------------------------


变量数据传递MOVEX

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

MOVEX这个命令和MOV使用一样，不过在多级脚本使用中不一样

多级脚本触发，存在2个人物：

一个是执行脚本的人物，另外一个是触发这个脚本的人物，也就是说一个脚本是人物A执行的，但是这个脚本是由人物B触发后才开始运行的
看下面的例子:

??????
[@main]
#ACT
MOV S1 神话
S1.MOVEX S2 <$USERNAME>
SENDMSG 6 S2使用的是神话这个人物的，<$USERNAME>这个使用的是，谁点击这个脚本，就调用的谁的
SENDMSG 6 这个脚本存在2个人，执行脚本的人物S1和点击触发脚本的人物


将人物行会名加入列表

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

将人物行会名加入列表

命令格式

??????
==========================
[@addguildList]
#if
#act
ADDGUILDLIST guildlist.txt
==========================


扩展MOVR使用方法

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

扩展MOVR使用方法。

命令格式

??????
MOVR 变量 数值1 数值2
??????
;==========================================
MOVR G10 100 ;随机生成100以内的随机数.
MOVR G10 10 100 ;随机生成10-100之间随机数
MOVR G10 100 5000 ;随机生成100-5000之间随机数
MOVR G10 1000 9999 ;随机生成1000-9999之间随机数
;==========================================


清除列表内容

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

脚本功能:
清除列表内容

命令格式

??????
CLEARNAMELIST namelist.txt
??????
;==========================================
;清除列表
[@Clearnamelist]
#IF
#ACT
CLEARNAMELIST namelist.txt
#SAY
列表已被清除
;==========================================


删除列表行会名

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

删除列表行会名

命令格式

??????
==========================
[@delguildList]
#if
#act
DELGUILDLIST guildlist.txt
==========================


删除人物IP在列表中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

删除人物IP在列表中

命令格式

??????
================================
[@DelIPList]
#IF
#Act
DELIPLIST IPList.txt
================================


删除人物名在列表中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

删除人物名在列表中

命令格式

??????
================================
[@DelNameList]
#IF
#Act
DELNAMELIST NameList.txt
================================


删除人物帐号在列表中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

删除人物帐号在列表中

命令格式

??????
================================
[@DelAccountList]
#IF
#Act
DELACCOUNTLIST AccountList.txt
================================


增加人物IP在列表中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

增加人物IP在列表中

命令格式

??????
================================
[@AddIPList]
#IF
#Act
ADDIPLIST IPList.txt
================================


增加人物名在列表中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

增加人物名在列表中

命令格式

??????
================================
[@AddNameList]
#IF
#Act
ADDNAMELIST NameList.txt
================================


增加人物帐号在列表中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

增加人物帐号在列表中

命令格式

??????
================================
[@AddAccountList]
#IF
#Act
ADDACCOUNTLIST AccountList.txt
================================


自定义变量按变量值大小排序

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关
??????
SortVarToList

功能

自定义变量按变量值大小排序，并把排序后变量值对应的人物名存放到指定列表文件中(制作排行榜用)

命令格式

??????
SortVarToList 自定义变量名 自定义变量文件路径 排序后列表的保存路径 降序还是升序(0-1) 保存格式(0-1)为0时只保存人物名,为1时:人物名 变量值.

脚本示例

??????
[@test2]
#if
#act
SortVarToList LJSQZS ..\QuestDiary\数据文件\Test.txt ..\QuestDiary\数据文件\排序的文件.txt 0 1
break


自定义变量功能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能

自定义变量功能，不再受固定几个变量限制

使用方法：
三个步骤：
1、首先要声明变量
2、读取变量
3、保存变量
该变量支持增加、减少、脚本查看、检查大小等功能，该功能的开发突破了变量使用受限制，利用该变量可制作出超强功能脚本。
脚本样例：

??????
=========================================
<声明变量/@newvarInteger> \
<查看变量/@viewvarInteger>\
<读取变量/@loadvarInteger> \
<保存变量/@savevarInteger> \
<增加变量/@calcvarinc> <检查变量是否大于5/@checklarage5>\
<减少变量/@calcvardec> <检查变量是否小于5/@checksmall5>\
<检查变量是否等于5/@checkequal5>
[@calcvarinc]
#IF
#ACT
CALCVAR HUMAN QQQQ + 5
goto @varcontrol
[@calcvardec]
#IF
#ACT
CALCVAR HUMAN QQQQ - 5
goto @varcontrol
[@checkequal5]
#IF
CHECKVAR HUMAN QQQQ = 5
#ACT
sendmsg 7 等于5
goto @varcontrol
#ELSEACT
sendmsg 7 不等于5
goto @varcontrol
[@checklarage5]
#IF
CHECKVAR HUMAN QQQQ > 5
#ACT
sendmsg 7 大于5
goto @varcontrol
#ELSEACT
sendmsg 7 小于5
goto @varcontrol
[@checksmall5]
#IF
CHECKVAR HUMAN QQQQ < 5
#ACT
sendmsg 7 小于5
goto @varcontrol
#ELSEACT
sendmsg 7 大于5
goto @varcontrol
??????
[@decInteger]
#ACT
DEC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@addInteger]
#ACT
INC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@loadvarInteger]
#IF
#ACT
LOADVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol
??????
[@savevarInteger]
#IF
#ACT
SAVEVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol
[@viewvarInteger]
#ACT
sendmsg 7 <$HUMAN(QQQQ)>
GOTO @varcontrol
[@newvarInteger]
#IF
#ACT
VAR Integer HUMAN QQQQ
sendmsg 7 OK
GOTO @varcontrol
[@viewvarString]
<$HUMAN(QQQS)>


排序人物自定义变量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能：排序人物自定义变量.

格式: SortHumVarToListEx 变量名 变量路径 排序模式(0,1) 保存路径 保存模式(0,1)
说明: 排序模式 0=升序,1=降序
升序排序人物变量QQQQ:

??????
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 0
升序排序人物变量QQQQ,不保存人物变量:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 1


排序在线人物自定义变量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

功能：排序在线人物自定义变量.

格式: SortHumVarToLisL) 变量名 保存路径 排序模式(0,1) 名字路径

说明：排序模式 0=升序,1=降序

名字路径在排序后只保存人物名字不保存人物变量.

注意：此脚本命令只排序在线人物的变量

升序排序人物变量QQQQ:

??????
[@main]
#IF
#ACT
SortHumVarToList QQQQ ..\QuestDiary\测试.txt 0
升序排序人物变量QQQQ,单独保存人物名字:
[@main]
#IF
#ACT
SortHumVarToList QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试1.txt


机器码使用说明

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

<$MACHINEID> 机器码，和登录的角色无关，只要是该机器登录的角色，这个机器码就一样。
<$USERMACHINEID> 该机器当前登录的角色的机器码。不同的角色名称或不同的机器登录生成的机器码不一样。

配合以下命令可以限制角色登录游戏

CheckTextList 文件位置 字符串
AddTextList 文件位置 字符串
DelTextList 文件位置 字符串


扩展字符变量S和数字变量N

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 变量相关

扩展字符变量S和数字变量N

功能：扩展字符变量S和数字变量N
格式：无
说明：扩展字符变量S和数字变量N，除了支持0~499以外，可以在S$变量或N$变量后面增加任意字符，人物基础变量不需要加$。
例：
[@test]
#ACT
MOV S$我的人物名称 <$USERNAME>
SENDMSG 0 <$STR(S$我的人物名称)> 255 253
[@test1]
#ACT
MOV N$我的杀怪总数 100
INC <$STR(N$我的当前杀怪数)> 1
SENDMSG 6 【杀怪总数=<$STR(N$我的杀怪总数)>】【当前杀怪数=<$STR(N$我的当前杀怪数)>】 255 253

注意:
以下的人物基础变量。不需要在S变量或N变量的后加$，当然你也可以加，加上后就属于扩展变量，例如 S1和S$1 这样的2个变量完全是2个不同的变量。
P0-P99 (私人变量，数字型) 关闭对话框重置为0。
D0-D99 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M99 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N99 (私人变量，数字型) 下线不保存.小退归0.
S0-S99 (私人变量，字符型) 下线不保存.小退归0.
I0-I99 (全局变量，数字型) 下线不保存.小退归0.
G0-G499 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A499 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
U0-U49 (私人变量，数字型) 可保存。（存放在人物数据库Mir.db里面）
T0-T49 (私人变量，字符型) 可保存。（存放在人物数据库Mir.db里面）


获取人物Buff状态剩余时长

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

获取人物状态剩余时长

??????
ETGetStateValue

参数1：状态类型 (0=绿毒、1=红毒、2=不能攻击、4=不能移动、5=麻痹、8=隐身、9=神圣战甲术、10=幽灵盾、11=魔法盾、12=冰冻、
13=紫毒、14=蛛网、15=护体神盾、16=无极真气)
参数2：剩余时长 (支持所有变量)
例子：获取人物被麻痹的剩余时长

??????
[@获取麻痹状态]
#IF
#ACT
ETGetStateValue 5 N10
#IF
LARGE N10 0
#ACT
SENDMSG 7 你被麻痹中，剩余时长：<$STR(N10)>
#ELSEACT
SENDMSG 7 你没有被麻痹，剩余时长：<$STR(N10)>


极品元素回收检测

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令
??????
ETCheckItemWitemValue

参数一：物品名称 圣战戒指 或 *代表全部 检测多个装备名称可使用|进行分割，如：圣战戒指|圣战戒指A|圣战戒指B
参数二：极品类型 0普通属性/1元素属性/2颜色/3星星数
参数三：极品位置 普通属性(0-6)/元素属性(0-19)/数值如果填写-1，即代表计算 - 普通属性(0-6)的总和值 或 元素属性(0-19)总和值
参数四：符号 >、<、=
参数五：值 极品点数
参数六：数量 最大回收数量（0回收全部，如果数量不为0，且参数七为-1，当前回收数量即已枚举的装备数量的总数）
参数七: 是否先清空上一个使用的回收数据(默认0,清除以往缓存数据。-1不清除，用于多次脚本执行调用后使用ETTakeItemWitemValue进行回收），注意这个参数可能很多人不理解，请根据例子自行测试！

例子1，单次回收单个物品：

??????
#if
ETCheckItemWitemValue 圣战戒指 1 0 = 0 0
;因为是等于0所以回收没有极品属性的圣战戒指
#Act
ETTakeItemWitemValue N0
;这个命令是配套ETCheckItemWitemValue的直接调用会回收满足检测命令条件的所有装备，要在ETCheckItemWitemValue调用后使用，其他地方调用无效
;回收命令 N0表示回收数量
ETWhile N0 > 0
DEC N0 1
;不减1会进入死循环，注意了！
give 金币 5000
sendmsg 7 回收成功,金币+5000.
ETendWhile

例子2，回收多个装备物品元素属性为0的例子：

??????
#IF
ETCheckItemWitemValue 圣战戒指 1 -1 = 0 0 0
;第七个参数调写0，清除缓存，放置第一个执行
ETCheckItemWitemValue 杀猪刀A 1 -1 = 0 0 -1
;第七个参数改-1，把需要回收检测的装备和上面的数据叠加起来！
ETCheckItemWitemValue 杀猪刀B 1 -1 = 0 0 -1
;第七个参数改-1，把需要回收检测的装备和上面的数据叠加起来！
#Act
;上面三句命令就可以把圣战戒指、杀猪刀A、杀猪刀B需要进行回收的装备数据枚举好了，下面执行ETTakeItemWitemValue
ETTakeItemWitemValue N0
;这个命令是配套ETCheckItemWitemValue的直接调用会回收满足检测命令条件的所有装备，要在ETCheckItemWitemValue调用后使用，其他地方调用无效
;回收命令 N0表示回收数量
ETWhile N0 > 0
DEC N0 1
;不减1会进入死循环，注意了！
give 金币 5000
sendmsg 7 回收成功,金币+5000.
ETendWhile


遍历背包获取,物品的各项信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

功能：遍历背包获取,物品的各项信息
命令：ETGetPlayInfo BAGITEMCOUNT P10

??????
[@main]
#if
#act
ETGetPlayInfo BAGITEMCOUNT P10
Sendmsg 5 提示:您的背包当中有<$STR(p10)>件物品。
ETWHILE P1 < <$STR(P10)>
;意思是一直循环到P1 大于或等于 <$STR(P10)>结束循环！
MOV S1
MOV S2
MOV S3
MOV S4
ETGetItemFieldValueA bagitem<$STR(P1)> name S1
ETGetItemFieldValueA bagitem<$STR(P1)> idx S2
ETGetItemFieldValueA bagitem<$STR(P1)> makeindex S3
ETGetItemFieldValueA bagitem<$STR(P1)> upgradecount S4
Sendmsg 6 提示：第<$STR(P1)>件,物品名称=<$STR(S1)>,IDX=<$STR(S2)>,唯一ID=<$STR(S3)>,星星数=<$STR(S4)>
INC P1 1
；这句不加会死循环
ETENDWHILE
ETGetItemFieldValue 和 ETGetItemFieldValueA 获取物品属性值，是两个不同的命令，这里用的是带A的命令，请注意！！！！
ETWHILE 和 ETENDWHILE 是语法指令，详细使用方法请参考 脚本命令类 - 语法相关类 - 循环判断指令


检测极品元素回收

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETCheckItemWitemValue

??????
参数一：物品名称 圣战戒指 或 *代表全部 检测多个装备名称可使用|进行分割，如：圣战戒指|圣战戒指A|圣战戒指B
参数二：极品类型 0普通属性/1元素属性/2颜色/3星星数
参数三：极品位置  普通属性(0-6)/元素属性(0-19)/数值如果填写-1，即代表计算 - 普通属性(0-6)的总和值 或 元素属性(0-19)总和值
参数四：符号  >、<、=
参数五：值  极品点数
参数六：数量  最大回收数量（0回收全部，如果数量不为0，且参数七为-1，当前回收数量即已枚举的装备数量的总数）
参数七: 是否先清空上一个使用的回收数据(默认0,清除以往缓存数据。-1不清除，用于多次脚本执行调用后使用ETTakeItemWitemValue进行回收），注意这个参数可能很多人不理解，请根据例子自行测试！

例子1，单次回收单个物品：

??????
#if
ETCheckItemWitemValue 圣战戒指 1 0 = 0 0
;因为是等于0所以回收没有极品属性的圣战戒指
#Act
ETTakeItemWitemValue N0
;这个命令是配套ETCheckItemWitemValue的直接调用会回收满足检测命令条件的所有装备，要在ETCheckItemWitemValue调用后使用，其他地方调用无效
;回收命令 N0表示回收数量
ETWhile N0 > 0
DEC N0 1
;不减1会进入死循环，注意了！
give 金币 5000
sendmsg 7 回收成功,金币+5000.
ETendWhile

例子2，回收多个装备物品元素属性为0的例子：

??????
#IF
ETCheckItemWitemValue 圣战戒指 1 -1 = 0 0 0
;第七个参数调写0，清除缓存，放置第一个执行
ETCheckItemWitemValue 杀猪刀A 1 -1 = 0 0 -1
;第七个参数改-1，把需要回收检测的装备和上面的数据叠加起来！
ETCheckItemWitemValue 杀猪刀B 1 -1 = 0 0 -1
;第七个参数改-1，把需要回收检测的装备和上面的数据叠加起来！
#Act
;上面三句命令就可以把圣战戒指、杀猪刀A、杀猪刀B需要进行回收的装备数据枚举好了，下面执行ETTakeItemWitemValue
ETTakeItemWitemValue N0
;这个命令是配套ETCheckItemWitemValue的直接调用会回收满足检测命令条件的所有装备，要在ETCheckItemWitemValue调用后使用，其他地方调用无效
;回收命令 N0表示回收数量
ETWhile N0 > 0
DEC N0 1
;不减1会进入死循环，注意了！
give 金币 5000
sendmsg 7 回收成功,金币+5000.
ETendWhile


获取装备宝石数量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

命令：
获取装备宝石数量

??????
ETGetItemStoneCount 装备位置 宝石名称(不分名称可用??或 all） 变量

获取身上所有装备宝石数量

??????
ETGetStoneCount 宝石名称(不分名称可用??或 all） 变量

示范：

??????
ETGetItemStoneCount 1 * N10
SENDMSG 6 你的【<$WEAPON>】上面共有宝石：<$STR(N10)>
ETGetItemStoneCount 1 攻击青宝石(初级) N10
SENDMSG 6 你的【<$WEAPON>】上面共有【攻击青宝石(初级)】：<$STR(N10)>
ETGetStoneCount * N10
SENDMSG 6 你的身上所有宝石共有宝石：<$STR(N10)>
ETGetStoneCount 攻击青宝石(初级) N10
SENDMSG 6 你的身上【攻击青宝石(初级)】共有宝石：<$STR(N10)>

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

对应变量:
<$DRESS> 衣服
<$WEAPON> 武器
<$RIGHTHAND> 蜡烛
<$HELMET> 头盔
<$NECKLACE> 项链
<$RING_R> 右戒指
<$RING_L> 左戒指
<$ARMRING_R> 右手镯
<$ARMRING_L> 左手镯
<$BUJUK> 护身符
<$BELT> 腰带
<$BOOTS> 鞋子
<$CHARM> 宝石


获取物品来源信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

获取来源信息

??????
ETGETITEMCREATEINFO 装备位置(-2当前1拾取物品 -1时是OK框中的装备, 0-18身上装备19-30生肖位置1001-1012时装首饰) 变量1(0没有物品来源 1GM 2NPC 3商铺 4怪物 5系统 6挖矿) 变量2(自定义来源信息) 变量2(人物名称) 变量4(怪物名称) 变量5(地图名称) 变量6(时间)
??????
[@main]
#act
ETGETITEMCREATEINFO 0 N1

[@main]
#act
ETGETITEMCREATEINFO 0 N1 S1

[@main]
#act
ETGETITEMCREATEINFO 0 N1 S1 S2 S3 S4 S5


检测判断当前攻击模式

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

判断当前攻击模式命令

功能：判断当前攻击模式
命令：ETCHECKATTACTEFF 参数1：0-正常，1-暴击

在攻击掉血前和被攻击掉血前触发下使用（只能在掉血前使用）,或者HOOK类里使用。

QF

??????
[@MagicAttack]

#if
ETCHECKATTACTEFF 1
#act
sendmsg 6 当前属于魔法暴击
#elseact
sendmsg 6 当前不属于魔法暴击

[@Attack]
#if
ETCHECKATTACTEFF 1
#act
sendmsg 6 当前属于物理暴击
#elseact
sendmsg 6 当前不属于物理暴击


拓展获取全身极品属性数值总和

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

获取全身极品数据总和

ETSEPURB

参数 1：部位 （下方有部位说明）
参数 2：类型 （1=防御下限 2=防御上限 3=魔防下线 4=魔防上限 5=攻击下限 6=攻击上线 7=魔法下线 8=魔法上线9=道术下线 10=道术上线 11=攻击速度 12=幸运 13=诅咒 14=星星总数 15=元素总和 16=镶嵌 17=自定义属性 18=准确 19=敏捷 20=体力恢复 21=魔法恢复 22=中毒躲避 23=中毒恢复 24=颜色 25=魔法躲避）
参数 3：序号 （当参数2=15，16，17，24时参数3生效）
当参数2= 1~13 参数3对应位置 0原属性+极品属性 1是极品属性 2 原属性（下限无极品属性注意区分）
当参数2=15的时候参数3对应获取0-19元素
当参数2=16 的时候参数3对应的是 0 打孔数量 1镶嵌数量 2 取镶嵌同名宝石数量（需配合参数5）
当参数2=17 的时候参数3对应获取 0-10个绑定属性
当参数2=24时 参数3对应的是颜色值0-255 (如果部位为指定位置这里可空返回为当前物品颜色)
参数 4：变量
参数 5：宝石名字 （当参数2=16且参数3=2的时候 检查全身同名的宝石数量 如宝石名字：攻击宝石+5） 注：参数2不等于16或参数3不等于2的时候可为空)

装备位置说明：
-1 全身
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装武器
18 时装衣服、
19-30 首饰盒1-12
时装首饰装备位置参考
1001 项链
1002 手镯1
1003 手镯2
1004 戒指1
1005 戒指2
1006 头盔
1007 盾牌
1008 腰带
1009 鞋子
1010 军鼓
1011 宝石
1012 马牌
注：如果使用了无限装备的话请参考无限装备面板里的装备序号

实例：

??????
#act
ETSEPURB -1 12 0 N0
SendMsg 0 当前角色装备的幸运值为 <$STR(N0)>
ETSEPURB -1 16 2 N1 攻击宝石+5
SendMsg 0 全身的装备攻击宝石+5个数为 <$STR(N1)>
ETSEPURB -1 24 249 N2
SendMsg 0 当前角色全身的红色装备为 <$STR(N2)>件

注：
19~21 ：项链
为19时，ac2和mac2代表魔法躲避和幸运
为20时，ac2为准确，mac2为敏捷
为21时，ac2为体力恢复，mac2为魔法恢复
24~26 ：手镯
为24时，ac2代表准确，mac2代表敏捷
为26时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
22~23 ：戒指
为22时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
为23时，ac代表攻击速度+ ， mac代表中毒躲避+ ， mac2代表中毒恢复+
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
(11~19)自定义元素
获取全身极品数据总和

ETSEPURB

参数 1：部位 （下方有部位说明）
参数 2：类型 （1=防御下限 2=防御上限 3=魔防下线 4=魔防上限 5=攻击下限 6=攻击上线 7=魔法下线 8=魔法上线9=道术下线 10=道术上线 11=攻击速度 12=幸运 13=诅咒 14=星星总数 15=元素总和 16=镶嵌 17=自定义属性 18=准确 19=敏捷 20=体力恢复 21=魔法恢复 22=中毒躲避 23=中毒恢复 24=颜色 25=魔法躲避）
参数 3：序号 （当参数2=15，16，17，24时参数3生效）
当参数2= 1~13 参数3对应位置 0原属性+极品属性 1是极品属性 2 原属性（下限无极品属性注意区分）
当参数2=15的时候参数3对应获取0-19元素
当参数2=16 的时候参数3对应的是 0 打孔数量 1镶嵌数量 2 取镶嵌同名宝石数量（需配合参数5）
当参数2=17 的时候参数3对应获取 0-10个绑定属性
当参数2=24时 参数3对应的是颜色值0-255 (如果部位为指定位置这里可空返回为当前物品颜色)
参数 4：变量
参数 5：宝石名字 （当参数2=16且参数3=2的时候 检查全身同名的宝石数量 如宝石名字：攻击宝石+5） 注：参数2不等于16或参数3不等于2的时候可为空)

装备位置说明：
-1 全身
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装武器
18 时装衣服、
19-30 首饰盒1-12
时装首饰装备位置参考
1001 项链
1002 手镯1
1003 手镯2
1004 戒指1
1005 戒指2
1006 头盔
1007 盾牌
1008 腰带
1009 鞋子
1010 军鼓
1011 宝石
1012 马牌
注：如果使用了无限装备的话请参考无限装备面板里的装备序号

实例：

??????
#act
ETSEPURB -1 12 0 N0
SendMsg 0 当前角色装备的幸运值为 <$STR(N0)>
ETSEPURB -1 16 2 N1 攻击宝石+5
SendMsg 0 全身的装备攻击宝石+5个数为 <$STR(N1)>
ETSEPURB -1 24 249 N2
SendMsg 0 当前角色全身的红色装备为 <$STR(N2)>件

注：
19~21 ：项链
为19时，ac2和mac2代表魔法躲避和幸运
为20时，ac2为准确，mac2为敏捷
为21时，ac2为体力恢复，mac2为魔法恢复
24~26 ：手镯
为24时，ac2代表准确，mac2代表敏捷
为26时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
22~23 ：戒指
为22时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
为23时，ac代表攻击速度+ ， mac代表中毒躲避+ ， mac2代表中毒恢复+
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
(11~19)自定义元素


检测获取当前NPC的名称

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETGETNPCNAME 参数1

??????
[@查看NPC名]
#if
#act
ETGetNpcName S1
SendMsg 6 当前NPC名称 <$STR(S1)>


获取格式化后的日期时间

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETGetDateTime 共两个参数

参数一：时间日期格式 参考下表（更多返回请百度）

参数二：变量 返回变量

日期格式 | 返回值(举例)
c | 2024-8-7 9:55:40
d | 1-31 本月几号
dd | 01-31 本月几号（两位显示）
ddd | 星期六 表示星期几
ddddd | 2024-8-7
dddddd | 2024年8月7日
ee | 24（表示24年）
m | 8表示月份
mm | 08表示两位的月份
mmm | 八月
yy04 | 表示年
yyyy2004 | 表示年
t | 10:17
tt | 10:18:46
ttampm | 10:22:57上午
yy-mm-dd | 04-08-07 年月日
hh:nn:ss | 10:32:23 时分秒


检测随机值拓展

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

RandomEx

参数1=随机分子

参数2=随机分母

例子：

RandomEx 1 2 2分之1

RandomEx 4 5 5分之4

RandomEx 7 1000 1000分之7

RandomEx 3 10000 10000分之3

??????
#IF
RandomEx 55 100
#ACT
讲解：100为母，55为子，母是随机范围，当随机值小于或等于子值就执行脚本


检测一个时间段的剩余时间

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

CheckTime

参数一:当前时间

参数二:结束时间

参数三:运算符(< = >)

参数四:判断数值(写数值)

参数五:相差秒数(该参数为变量)

例子1：

;适用各种现时活动等场景

??????
#ACT
MOV S1 2019-05-07-00:00:00
MOV S2 <$TIME>
#IF
CheckTime <$STR(S1)> <$TIME> > 0 D1
#ACT
SENDMSG 6 输出变量值：<$STR(S1)> <$STR(S2)> <$STR(D1)>


检测百分比血蓝量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

检测百分比 HP MP 数值

功能：
CheckHpPer

参数1：> < =
参数2：百分比值
参数3：分母，如果该参数省略则默认按照百分比算

脚本检测百分比人物或怪物血量

CheckHpPer >/</=
CheckMpPer >/</=

??????
[@检查血量百分比30%]
#if
CheckHpPer > 30
#act
sendmsg 6 你的血量在30%以上..
#elseact
sendmsg 6 你的血量低于30%..

[@检查蓝量百分比30%]
#if
CheckMpPer > 30
#act
sendmsg 6 你的蓝量在30%以上..
#elseact
sendmsg 6 你的蓝量低于30%..

[@检查怪物血量百分比30%]
#if
M.CheckHpPer > 30
#act
sendmsg 6 怪物的血量在30%以上..
#elseact
sendmsg 6 怪物的血量低于30%..

[@检查怪物蓝量百分比30%]
#if
M.CheckMpPer > 30
#act
sendmsg 6 怪物的蓝量在30%以上..
#elseact
sendmsg 6 怪物的蓝量低于30%..


检测指定地图内的同行会人数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETMAPGUILDHUMNUM

参数一：判断的地图名(行会根据调用者所在行会)

参数二: 人数检测

如没有加入行会，那条件会直接通过

??????
场景例子1：
进入特定地图的时候，能知道当前行会进入地图的人数。
#IF
ETMapGuildHumNum 攻沙地图 5
#ACT
mapmove 攻沙地图 X Y
#ELSEACT
sendmsg 6 当前攻沙地图,同属行会人数已达5个，无法继续进入！


获取指定玩家的变量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETGetHumVar

参数1：玩家名称
参数2：变量名称
参数3：保存到变量名称

实例：

??????
[@main]
你想知道对方防御力是多少吗,并且不让他知道
请确保对方在线\ <请输入对方名字/@@InPutString3>
对方名字：<$STR(S3)> \

[@InPutString3]
#IF
#ACT
ETGetHumVar S3 <$MAXAC> S4
SENDMSG 6 你已成功取得对方防御力为<$STR(S4)>


检测指定范围内的人物或者怪物

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

类似于探魔球之类的脚本

ETQueryTargetEx

通过脚本查询对象所在位置

参数1:指定地图号
参数2:寻找类型 0 只找玩家 1找怪
参数3:寻找数量 0 所有 大于1为寻找数量
参数4:寻找名称
参数5:保存地图名变量
参数6:保存地图号变量（用来调用命令传送使用）
参数7:保存对象名变量
参数8:保存坐标X变量
参数9:保存坐标Y变量
参数10:共找到数量(如参数3不为0 这里将保存参数3的值)

*注意 保存变量问题 使用方法见示例

??????
[@查询对象]
#if
#act
ETQueryTargetEx 1 1 5 魔龙教主 S$地图名变量 S$地图号变量 S$对象名变量 S$对象X坐标 S$对象Y坐标 N32
#if
#say
<$STR(S$地图名变量_0)> <$STR(S$地图号变量_0)> <$STR(S$对象名变量_0)> <$STR(S$对象X坐标_0)> <$STR(S$对象Y坐标_0)> <去杀怪/@去0>
<$STR(S$地图名变量_1)> <$STR(S$地图号变量_1)> <$STR(S$对象名变量_1)> <$STR(S$对象X坐标_1)> <$STR(S$对象Y坐标_1)> <去杀怪/@去1>
[@去0]
#if
#act
mapmove <$STR(S$地图号变量_0)> <$STR(S$对象X坐标_0)> <$STR(S$对象Y坐标_0)>
[@去1]
#if
#act
mapmove <$STR(S$地图号变量_1)> <$STR(S$对象X坐标_1)> <$STR(S$对象Y坐标_1)>


获取强化加星数量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETGetUpgradeCount

参数1：物品位置
参数2：变量
位置说明：
-1 全身
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装武器
18 时装衣服、
19-30 首饰盒1-12
时装首饰装备位置参考
1001 项链
1002 手镯1
1003 手镯2
1004 戒指1
1005 戒指2
1006 头盔
1007 盾牌
1008 腰带
1009 鞋子
1010 军鼓
1011 宝石
1012 马牌
注：如果使用了无限装备的话请参考无限装备面板里的装备序号

??????
实例：
#act
ETGetUpgradeCount 0 N0
SendMsg 0 衣服的强化星星数为 <$STR(N0)>
ETGetUpgradeCount -1 N1
SendMsg 0 全身的强化星星数为 <$STR(N1)>


获取背包指定物品的数量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

获取背包指定物品的数量

??????
ETGetItemsNumber

参数1：物品名字
参数2：变量名，保存获取到的物品的数量
参数3：需要的数量，如果为空或者为0，则参数2返回背包物品的数量，大于0则判断离条件数量还差多少个，如果数量满足则返回0

??????
实例
[@main]
#if
#act
ETGetItemsNumber 疗伤药 N0
SendMsg 6 你的背包共有疗伤药【<$STR(N0)>】个
#if
#act
ETGetItemsNumber 疗伤药 N0 10
#if
Equal N0 0
#act
SendMsg 6 你需要疗伤药10个，你的背包的疗伤药数量已经足够了
#elseact
SendMsg 6 你需要疗伤药10个，你目前还缺少【<$STR(N0)>】个


根据物品名称获取物品数据库字段参数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

根据物品名获取物品数据库字段参数值

ETGetDBItemFieldValue

参数1：物品名
参数2：字段名
参数3：变量名，用户保存获取到的参数值

??????
实例
[@main]
#if
#act
ETGetDBItemFieldValue 屠龙 Weight N0
SendMsg 6 屠龙的重量是【<$STR(N0)>】点


根据物品IDX获取物品数据库字段参数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

根据物品Idx获取物品数据库字段参数值

ETGetDBIdxItemFieldValue

参数1：物品Idx
参数2：字段名
参数3：变量名，用户保存获取到的参数值
实例

??????
[@main]
#if
#act
ETGetDBItemFieldValue 屠龙 Idx N0
ETGetDBIdxItemFieldValue <$STR(N0)> Weight N1
SendMsg 6 屠龙的IDX是【<$STR(N0)>】，他的重量是【<$STR(N1)>】点


检测OK框内的物品信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

获取OK框物品信息

??????
ETGetBoxItem

参数一 OK框编号(0~7)
参数二 获取类型(0物品名称、1星星数量、2来源类型、3来源地图名、4来源怪物名/来源名、5来源角色名称、6来源时间)
参数三 存放变量

获取物品名称例子

??????
#ACT
ETGetBoxItem 0 0 S1
ETGetBoxItem 0 1 S2
ETGetBoxItem 0 2 S3
ETGetBoxItem 0 3 S4
ETGetBoxItem 0 4 S5
ETGetBoxItem 0 5 S6
ETGetBoxItem 0 6 S7
SendMsg 6 编号0的OK框物品名称为:[<$STR(S1)>],星星数量:[<$STR(S2)>],来源类型:[<$STR(S3)>],来源地图名:[<$STR(S4)>],来源怪物名称:[<$STR(S5)>],来源角色名:[<$STR(S6)>],来源时间:[<$STR(S7)>]


使用脚本命令掉落人物身上装备

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETHumanDropUseItem 参数1 参数2

参数1：装备位置 (-1表示随机位置，0~30为指定装备位置 : 0~16 身上物品 17~18 时装 19~30 十二生肖)，1001~1012 时装装备
参数2：暴出物品后记录物品名字符串变量

注意：该位置没有穿装备则命令无效…

例子：掉落身上装备命令

??????
[@PlayDie]
#IF
#ACT
ETHumanDropUseItem -1 S11

#IF
NOT EQUAL S11
#ACT
SENDMSG 0 255 70 客官，你的装备爆了：<$STR(S11)>

1001 项链
1002 手镯1
1003 手镯2
1004 戒指1
1005 戒指2
1006 头盔
1007 盾牌
1008 腰带
1009 鞋子
1010 军鼓
1011 宝石
1012 马牌
注：如果使用了无限装备的话请参考无限装备面板里的装备序号

注意：掉落的装备是不会触发QF穿戴、取下等字段的。

比如：

[@TakeOff0] 0——18 或 @ETTAKEON 等

用此命令是不会有这些触发的


获取物品属性值

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETGetItemFieldValue 和 ETGetItemFieldValueA 是两个不同的命令，请注意！

??????
ETGetItemFieldValue 物品位置 属性名称 变量名

物品位置：装备位置、首饰盒、神佑、升级框、OK框、DB

??????
ETGetItemFieldValue 参数1 参数2 参数3

参数1：1)身上装备位置 2)-1=OK框位置 100=自定义OK框0 101=自定义OK框1… 3)物品名字
参数2：属性名称（见下表）
参数3：完整的变量名字，用于存放获取到的属性值（用字符变量）例如：<$STR(S0)>

??????
[@main]
请放入需要升级的装备\
<ITEMBOX:0:0:118:20:10:76:76:10,11:254#只允许放入衣服^251#www.ETmir2.com>
<ITEMBOX:1:0:118:96:10:76:76:*:254#所有物品都允许放入^251#www.ETmir2.com>\
<升级/@升级>
[@升级]
#ACT
ETGetItemFieldValue 101 NAME <$STR(S0)>
sendmsg 7 NAME=<$STR(S0)>
ETGetItemFieldValue 101 NEWNAME <$STR(S0)>
sendmsg 7 NEWNAME=<$STR(S0)>
ETGetItemFieldValue 101 STDMODE <$STR(S0)>
sendmsg 7 STDMODE=<$STR(S0)>
ETGetItemFieldValue 101 SHAPE <$STR(S0)>
sendmsg 7 SHAPE=<$STR(S0)>
ETGetItemFieldValue 101 COLOR <$STR(S0)>
sendmsg 7 COLOR=<$STR(S0)>

属性名称表：
MAKEINDEX
IDX
NAME
STDMODE
Shape
Weight
Anicount
Source
Reserved
Looks
DuraMax
Ac
AC2
Mac
Mac2
Dc
Dc2
Mc
Mc2
Sc
Sc2
Need
NeedLevel
Price
Stock
Color
OverLap
HP
MP
Job
Value1
...
Value30
InsuranceGold
InsuranceCurrency

ETGetItemFieldValueA

参考遍历背包获取,物品的各项信息


获取指定行会成员数量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 检测命令

ETGETGUILDMEMCOUNT

??????
//参数1:用于保存数量的变量名称
//参数2:行会名称，若为空的话则表示获取自身所在行会玩家的数量

例子：

??????
[@main]
#if
#act
ETGETGUILDMEMCOUNT N$人数 <$GUILDNAME>
sendmsg 6 你的行会人数为：<$str(N$人数)>


捡取物品关联命令检测操作

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

LINKPICKUPITEM脚本命令

功能：可以对捡取的物品进行关联，该命令只能在捡取触发里[@PickUpItemX]使用

??????
[@PickUpItem0]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR  -1 253
 ;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
  ;修改后的参数，刷新到客户端


检测被自己杀死宝宝的名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检测被自己杀死的宝宝的名字.

注意：此命令只检测直属宝宝,例如道士英雄召唤的神兽不属于直属宝宝.

??????
#IF
CheckKillSlaveName 白野猪
#SAY
你把对方的宝宝<白野猪>杀死了.


检测当前目标类型

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKCURRTARGETRACE 控制符(=,>,<) 数据库Race值

该命令只有在死亡触发和攻击触发中使用

??????
[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#SAY
当前是人物
BREAK
??????
#IF
CHECKCURRTARGETRACE = 1
#SAY
当前是英雄
BREAK
??????
#IF
CHECKCURRTARGETRACE = 60
#SAY
当前是人形怪
BREAK


检测地图范围怪物数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKRANGEMONCOUNTEX 地图名称 怪物名称 X坐标 Y坐标 范围 控制符(=,>,<) 数量
??????
[@main]
#IF
CHECKRANGEMONCOUNTEX 3 333 333 10 > 100
#SAY
大于100个怪物


检测地图假人数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

CHECKMAPDUMMYCOUNT,检测地图假人数量

命令格式

??????
检测地图假人数量 地图 （< > =）

脚本示例

??????
[@main]
#IF
CHECKMAPDUMMYCOUNT 3 > 10
#SAY
地图3假人数量大于10个


检测地图相同怪物数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CheckMapSameMonCount 地图名称 怪物名称 控制符(<,>,=) 数量 是否忽略怪物名称后面的数字(0=检测数字,1=不检测数字)
??????
[@Main]
#IF
CheckMapSameMonCount 3 稻草人 > 10
#SAY
土城的稻草人大于10个


检测地图坐标是否可以到达

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测地图坐标是否可以到达

命令格式

??????
CHECKMAPMOVE 地图名 X坐标 Y坐标
??????
==============================================
[@测试]
#IF
CHECKMAPMOVE 3 333 333
#SAY
盟重省333 333能够到达
#ELSESAY
该坐标不能到达
============================================


检测会员剩余时间

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
检测会员剩余时间 文件名称 过期是否删除(0不删除 1删除) 变量1(到期时间 字符变量) 变量2(剩余天数 数字变量) 变量3(剩余小时 数字变量) 变量4(剩余分钟 数字变量)
??????
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S$1)> <$STR(N$1)> <$STR(N$2)><$STR(N$3)>
#ACT
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253
删除会员还是使用原来的老命令DELNAMEDATELIST


检测技能修炼点数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测技能修炼点数。

命令格式

??????
CHECKTRANPOINT 技能名称 检测符(>,<,=) 点数
??????
;==========================================
[@CHECKTRANPOINT]
#IF
CHECKTRANPOINT 雷电术 = 100
#SAY
你的技能雷电术修炼点数等于100。
;==========================================


检测加入国家

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CheckNational (国家编号 0~100)
??????
[@main]
#IF
CheckNational 0
#SAY
你还没有加入国家
BREAK
??????
#IF
CheckNational 1
#SAY
你已经加入国家，国家编号1
BREAK


检测人物PK值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测人物PK值。

命令格式

??????
CHECKPKPOINTEX 控制符(=,>,<) 数量
??????
;==========================================
[@Main]
#IF
CHECKPKPOINTEX > 100
#SAY
PK值大于 100
#ELSESAY
PK值小于 100
;==========================================


检测人物宝宝名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

命令格式

??????
;==========================================
[@main]
#IF
CHECKSLAVENAME ETmir2
#ACT
SENDMSG 5 提示:你的宝宝叫ETmir2
#ELSEACT
SENDMSG 5 提示:你的宝宝不叫ETmir2
;==========================================


检测人物的伤害吸收

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

说明

检测人物的伤害

命令格式

??????
CheckSuckDamage 操作符(> = <) 数量(1-2000000000)
??????
#IF
CheckSuckDamage > 1000
#SAY
SendMsg 5 你当前拥有的伤害吸收大于1000点.


检测人物荣誉

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKGAMEGLORY (<,>,=) 值
??????
[@Main]
#IF
CHECKGAMEGLORY = 100
#SAY
荣誉等于100

_________________________________________是两个命令自己测试把

检查人物的荣誉值

??????
#IF
CheckNationCredit > 100
#SAY
你的荣誉值大于100点.


检测人物是否挂机

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测人物是否是离线挂机

命令格式

??????
CheckOffline


检测人物是否佩带指定物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测当前人物是否佩带指定物品

命令格式

??????
CHECKITEMW 物品名 数量
??????
[@TEST]
#IF
CHECKITEMW 力量戒指 1
#elsesay
你身上没有力量戒指\ \
#elseact
break
??????
[@TEST1]
#IF
COMPARETEXT <$DRESS> 布衣(男)
#elsesay
你身上没有布衣(男)\ \
#elseact
break


检测人物是否在线

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

checkonline

脚本示例

??????
[@main]
#IF
checkonline
#SAY
在线
??????
[@main]
#IF
H.checkonline
#SAY
你的英雄在线
??????
[@main]
#IF
ETmir2.checkonline
#SAY
ETmir2在线
??????
[@main]
#IF
S1.checkonline
#SAY
<$STR(S1)>在线


检测人物是否重叠

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
IsDupMode 模式(0检测所有对象(包括人物、怪物、NPC)，1只检测是否有人物)
??????
[@Main]
#IF
IsDupMode 1
#SAY
不要和其他人站在一起
??????
[@Main]
#IF
IsDupMode 0
#SAY
不要和其他人或怪物站在一起


检测人物元素属性

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKNEWITEMVALUE 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 检测符(>,<,=) 值(1-100)

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

??????
[@main]
#IF
CHECKNEWITEMVALUE 0 0 > 10
#SAY
暴击几率大于10%


检测人物在线时长

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查人物在线时间长度。

命令格式

??????
ONLINELONGMIN (> < =) 支持变量操作
??????
;==========================================
#if
ONLINELONGMIN > 10
#say
在线时间大于 10分钟
;==========================================


检测杀人者是人物还是怪物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

人物是被怪物杀死还是玩家杀死 死亡触发

命令格式

??????
;==========================================
[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK
??????
#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK
??????
#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK


检测是不是在摆摊

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKSHOPSTALLSTATUS
??????
[@main]
#IF
CHECKSHOPSTALLSTATUS
#SAY
正在摆摊
#ELSE
没有摆摊


检测是否进入攻城的范围

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKCASTLEWARAREA 城堡名称
??????
[@Main]
#IF
CHECKCASTLEWARAREA 沙巴克
#SAY
你已经进入进入攻城的范围


检测是否正在攻城

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKUNDERWAR 城堡名称
??????
[@Main]
#IF
CHECKUNDERWAR 沙巴克
#SAY
沙巴克正在攻击战


检测物品的附加属性值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：获取物品的附加属性值

命令格式

??????
格式: CHECKITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 < > =) 值 保存变量

物品位置:

值/位置 | 说明
0 | 盔甲
1 | 武器
2 | 照明物（蜡烛，此物品属性升级无效）
3 | 项链
4 | 头盔
5 | 右手镯
6 | 左手镯
7 | 右戒指
8 | 右戒指
9 | 无(放护身符位置)
10 | 腰带
11 | 鞋子
12 | 宝石

盔甲

值/位置 | 说明
0 | 防御
1 | 魔御
2 | 攻击
3 | 魔法
4 | 道术
5-13 | 无效果
14 | 持久

武器

值/位置 | 说明
0 | DC2
1 | MC2
2 | SC2
3 | 幸运
4 | 诅咒
5 | 准确
6 | 攻击速度
7 | 强度
8-9 | 暂不知道
10 | 需开封
11-13 | 暂不知道
14 | 持久

头盔

值/位置 | 说明
0 | 防御
1 | 魔御
2 | 攻击
3 | 魔法
4 | 道术
5 | 佩带需求
6 | 佩带级别
7-13 | 无效果
14 | 持久

项链

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8 | reserved
9-13 | 暂不知道
14 | 持久

手镯

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8-13 | 无效果
14 | 持久

戒指

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8-13 | 无效果
14 | 持久
??????
#IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.


检测行会可以容纳多少成员

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CHECKGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示检测自己所在的行会) 检测符(<,>,=) 数量
??????
[@main]
#IF
CHECKGUILDMEMBERMAXLIMITCOUNT > 100
#SAY
你的行会可以容纳成员数大于100个


检测在安全区

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
INSAFEZONE


检测指定范围内的人物数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
CheckRangeHumCount 地图名称 X Y 范围 (<,>,=) 数量


检测组队人数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查人物组队人数。

命令格式

??????
CHECKGROUPMEMBERCOUNT (<,>,=) 数量
??????
;==========================================
#if
CHECKGROUPMEMBERCOUNT > 10
#say
组队人数大于10个人
;==========================================


检查城堡占领天数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查沙巴克占领天数

命令格式

??????
================================
#if
CASTLECHANGEDAY > 7
#say
你已经占领沙城7天以上.
================================


检查城堡战争天数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查上次攻城到现在的天数。

命令格式

??????
CASTLEWARAY 控制符(<=>) 天数
??????
;==========================================
[@Main]
#IF
CASTLEWARAY > 3
#SAY
上次攻城到现在超过三天
#ELSESAY
上次攻城到现在未够三天
;==========================================


检查城门状态

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查沙城门状态。

命令格式

??????
;==========================================
#if
CHECKCASTLEDOOR 损坏
#say
城门损坏
??????
#if
CHECKCASTLEDOOR 开启
#say
城门开启
??????
#if
CHECKCASTLEDOOR 关闭
#say
城门关闭
;==========================================


检查当前所在地图的名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查当前所在地图的名字

命令格式

??????
CHECKMAPNAME 地图名称
??????
;==========================================
#if
CHECKMAPNAME 3
#say
你当前在地图3上\ \
<退出/@exit>
#elsesay
你当前不在地图3上\ \
<退出/@exit>


检查登录帐号与IP是否匹配

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查登录帐号与IP是否匹配。

命令格式

??????
CHECKACCOUNTIPLIST AccountIPList.txt
??????
;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKACCOUNTIPLIST AccountIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================
列表文件格式:
此文件们于目录：Mir200\Envir\
AccountIPList.txt
;==========================================
;登录帐号 IP
lintest 192.168.1.123
lintest1 192.168.1.124
;==========================================


检查地图怪物数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查一个地图内的怪物数量。

命令格式

??????
CheckMonMap 地图号 数量
??????
;==========================================
[@Main]
#IF
CheckMonMap 3 30
#SAY
地图3的内怪物多于100只
#ELSESAY
地图3的怪物少于100只
;==========================================


检查对面人物的等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查对面人物的等级（不要求面对面）。

命令格式

??????
CHECKPOSELEVEL 控制符(=,>,<) 等级数(1 - 65535)
??????
;==========================================
;检查对面人物的等级是否等于指定级别
[@checkposelevel0]
#IF
CHECKPOSELEVEL = 50
#SAY
您对面人物的等级等于50级。
#ELSESAY
您对面人物的等级不等于50级。
;==========================================
;==========================================
;检查对面人物的等级是否大于指定级别
[@checkposelevel1]
#IF
CHECKPOSELEVEL > 50
#SAY
您对面人物的等级大于50级。
#ELSESAY
您对面人物的等级不大于50级。
;==========================================
;==========================================
;检查对面人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKPOSELEVEL < 50
#SAY
您对面人物的等级小于50级。
#ELSESAY
您对面人物的等级不小于50级。
;==========================================


检查对面人物的性别

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查对面人物的性别（不要求面对面）。

命令格式

??????
CHECKPOSEGENDER 性别(MAN,男,WOMAN,女)
??????
;==========================================
;检查对面人物是否为男的
[@checkposegender0]
#IF
CHECKPOSEGENDER MAN
#SAY
你对面的人物是男的。
#ELSESAY
你对面的人物不是男的。
;==========================================
;检查对面人物是否为女的
[@checkposegender1]
#IF
CHECKPOSEGENDER WOMAN
#SAY
你对面的人物是女的。
#ELSESAY
你对面的人物不是女的。
;==========================================


检查对面人物站的位置

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查对面人物站的位置性别（要求面对面）。

命令格式

??????
CHECKPOSEDIR 控制符(1,2)
??????
;==========================================
;检查对面人物是否面对面
[@checkposedir0]
#IF
CHECKPOSEDIR
#SAY
你二个站的位置正确。
#ELSESAY
你二个站的位置不正确。
;==========================================
;==========================================
;检查对面人物是否面对面，而且要求二个人相同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 1
#SAY
你二个站的位置及性别一样。
#ELSESAY
你二个站的位置不正确或性别不一样。
;==========================================
;==========================================
;检查对面人物是否面对面，而且要求二个人不同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 2
#SAY
你二个站的位置及性别不一样。
#ELSESAY
你二个站的位置不正确或性别一样。
;==========================================


检查国家人物总数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CheckNationHumCount 操作符(< = >) 人数
??????
#IF
CheckNationHumCount > 100
#SAY
当前国家大于100人.


检查会员时间

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

相关命令

??????
CHECKUSERDATE 会员.txt   <       30    p0        p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1
??????
加入会员人物及时间：ADDUSERDATE 会员.txt
删除会员人物及时间：DELUSERDATE 会员.txt

相关命令页面

  • ADDUSERDATE
  • DELUSERDATE


检查金刚石数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查金刚石数量。

命令格式

??????
CHECKGAMEDIAMOND 控制符(<、>、 =) 点数
??????
GAMEDIAMOND (+,-,=) 值
<$GAMEDIAMOND>
;==========================================
#IF
CHECKGAMEDIAMOND> 50
#SAY
你的金刚石超过50点
#ELSESAY
你的金刚石少于50点
;==========================================

功能

检查灵符数量。

命令格式

??????
CHECKGAMEGIRD 控制符(<、>、 =) 点数
??????
GAMEGIRD (+,-,=) 值
<$GAMEGIRD>
;==========================================
#IF
CHECKGAMEGIRD > 50
#SAY
你的灵符超过50点
#ELSESAY
你的灵符少于50点
;==========================================

功能

检查荣誉数量。

命令格式

??????
CHECKGAMEGLORY 控制符(<、>、 =) 点数
??????
GAMEGLORY (+,-,=) 值
<$GAMEGLORY>
;==========================================
#IF
CHECKGAMEGLORY > 50
#SAY
你的荣誉超过50点
#ELSESAY
你的荣誉少于50点
;==========================================


检查人物HP值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

用来检查人物HP值的上限及下限值

命令格式

??????
CHECKHP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限
??????
======================
#if
CHECKHP > 29 < 41
#say
你的HP值大于30-40
======================


检查人物MP值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

用来检查人物MP值的上限及下限值

命令格式

??????
CHECKMP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限
??????
==========================
#if
CHECKMP > 29 < 41
#say
你的MP值大于30-40
==========================


检查人物背包空格数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物背包空格数

命令：

??????
CheckBagSize 数量
??????
=======================
[@checkbagsize]
#if
CHECKBAGSIZE 5
#say
身上有5个空格
#elsesay
身上的空格不够。
=======================


检查人物称号的数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物称号的数量

命令格式

??????
CHECKFENGHAOCOUNT 操作符(<,>,=) 数量(0-30)
??????
[@main]
#IF
CHECKFENGHAOCOUNT > 9
#SAY
你已经有了10个称号


检查人物当前经验值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查玩家当前经验值。

命令格式

??????
CHECKEXP 控制符(=,>,<) 经验值(1 - 4000000000)
??????
;==========================================
;检查人物的经验值是否等于指定值
[@checkexp2]
#IF
CHECKEXP = 5000
#SAY
您的经验值等于5000。
#ELSESAY
您的经验值不等于5000。
;==========================================
??????
;==========================================
;检查人物的经验值是否大于指定值
[@checkexp2]
#IF
CHECKEXP > 5000
#SAY
您的经验值大于5000级。
#ELSESAY
您的经验值不大于5000。
;==========================================
??????
;==========================================
;检查人物的经验值是否小于指定值
[@checkexp2]
#IF
CHECKEXP < 5000
#SAY
您的经验值小于5000级。
#ELSESAY
您的经验值不小于5000。
;==========================================


检查人物道术

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

用来检查人物道术的上限及下限值

命令格式

??????
CHECKSC 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限
??????
================
#if
CHECKSC > 29 < 41
#say
你的道术大于30-40
================


检查人物的会员等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查人物的会员等级。

命令格式

??????
CHECKMEMBERLEVEL 类型(1-65535) 控制符(=,>,<) 等级数(1 - 65535)
??????
;==========================================
;检查人物的会员等级是否为指定等级
[@checkmemberlevel0]
#IF
CHECKMEMBERLEVEL 2 = 5
#SAY
您的会员等级为5。
#ELSESAY
您的会员等级不为5。
;==========================================
;==========================================
;检查人物的会员等级是否大于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 > 5
#SAY
您的会员等级大于5。
#ELSESAY
您的会员等级不大于5。
;==========================================
;==========================================
;检查人物的会员等级是否小于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 < 5
#SAY
您的会员等级小于5。
#ELSESAY
您的会员等级不小于5。
;==========================================


检查人物的会员类型

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查人物的会员类型。

命令格式

??????
CHECKMEMBERTYPE 控制符(=,>,<) 类型数(1 - 65535)
??????
;==========================================
;检查人物的会员类型是否为指定类型
[@checkmember0]
#IF
CHECKMEMBERTYPE = 5
#SAY
您的会员类型为5。
#ELSESAY
您的会员类型不为5。
;==========================================
;==========================================
;检查人物的会员类型是否大于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE > 5
#SAY
您的会员类型大于5。
#ELSESAY
您的会员类型不大于5。
;==========================================
;==========================================
;检查人物的会员类型是否小于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE < 5
#SAY
您的会员类型小于5。
#ELSESAY
您的会员类型不小于5。
;==========================================


检查人物的游戏点数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

用于配合泡点功能，检查当前人物身上有多少点数。

命令格式

??????
CHECKGAMEPOINT 控制符(<、>、 =) 点数
??????
;==========================================
#IF
CHECKGAMEPOINT > 50
#SAY
你的游戏点超过50点
#ELSESAY
你的游戏点少于50点
;==========================================

功能

检查当前人物身上有多少游戏币。

命令格式

??????
CHECKGAMEGOLD 控制符(<、>、 =) 点数
??????
;==========================================
#IF
CHECKGAMEGOLD > 50
#SAY
你的游戏币超过50点
#ELSESAY
你的游戏币少于50点
;==========================================


检查人物的转生等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物的转生等级

命令格式

??????
CHECKRENEWLEVEL 控制符(=,>,<) 转生等级数(1 - 255)
??????
;==========================================
;检查人物的转生等级是否等于指定级别
[@checklevel0]
#IF
CHECKRENEWLEVEL = 5
#SAY
您的转生等级等于5级。
#ELSESAY
您的转生等级不等于5级。
;==========================================
??????
;==========================================
;检查人物的转生等级是否大于指定级别
[@checklevel1]
#IF
CHECKRENEWLEVEL > 5
#SAY
您的转生等级大于5级。
#ELSESAY
您的转生等级不大于5级。
;==========================================
??????
;==========================================
;检查人物的转生等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKRENEWLEVEL < 5
#SAY
您的转生等级小于5级。
#ELSESAY
您的转生等级不小于5级。
;==========================================


检查人物登录IP

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物登录IP.

命令格式

??????
CHECKIPLIST 会员.txt
??????
;==========================================
;按IP检查
[@checkiplist0]
#IF
CHECKIPLIST IP会员.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物登录帐号

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物登录帐号.

命令格式

??????
CHECKACCOUNTLIST 帐号.txt
??????
;==========================================
;按登录帐号检查
[@checkaccountlist0]
#IF
CHECKACCOUNTLIST 帐号.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物等级（改进）

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以更为方便地检查玩家等级。

命令格式

??????
CHECKLEVELEX 控制符(=,>,<) 等级数(1 - 65535)
??????
;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKLEVELEX = 50
#SAY
您的等级等于50级。
#ELSESAY
您的等级不等于50级。
;==========================================
;==========================================
;检查人物的等级是否大于指定级别
[@checklevel1]
#IF
CHECKLEVELEX > 50
#SAY
您的等级大于50级。
#ELSESAY
您的等级不大于50级。
;==========================================
;==========================================
;检查人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKLEVELEX < 50
#SAY
您的等级小于50级。
#ELSESAY
您的等级不小于50级。
;==========================================


检查人物附加属性点数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物附加属性点数

命令格式

??????
CHECKBONUSPOINT 控制符(=,>,<) 点数

相关命令

复位属性点数：RESTBONUSPOINT
调整属性点数：BONUSPOINT

相关命令页面

  • RESTBONUSPOINT
  • BONUSPOINT


检查人物攻击力

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

用来检查人物攻击力的上限及下限值

命令格式

??????
CHECKDC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限
??????
====================
#IF
CHECKDC > 29 < 41
#say
你的攻击力大于30-40
====================


检查人物技能(扩展)

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查人物技能

功能

检查人物技能

命令格式

??????
CHECKSKILL 技能名称 检测符(<,>,=) 等级 是否检测强化技能(0或为空时为技能等级,1为强化技能等级)

例：

??????
[@main]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重

相关命令

练习技能：ADDSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL

相关命令页面

  • ADDSKILL
  • DELSKILL
  • DELNOJOBSKILL
  • CLEARSKILL


检查人物名称是否与IP匹配

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查登录帐号与IP是否匹配。

命令格式

??????
CHECKNAMEIPLIST NameIPList.txt
??????
;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKNAMEIPLIST NameIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================
列表文件格式:
此文件们于目录：Mir200\Envir\NameIPList.txt
;==========================================
;人物名称 IP
GM001 192.168.1.123
GM002 192.168.1.124
;==========================================


检查人物魔法力

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

用来检查人物魔法力的上限及下限值

命令格式

??????
CHECKMC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限
??????
======================
#if
CHECKMC > 29 < 41
#say
你的魔法力大于30-40
======================


检查人物身上指定位置是否戴物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物身上指定位置是否戴物品

命令：

??????
CHECKUSEITEM

物品位置(0-12)
物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

??????
[@checkUseItem]
#if
CHECKUSEITEM 0
#say
你身上穿了衣服。
#elsesay
你还没穿衣服呢。


检查人物身上装备类型

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

用来检查人物身上戴物品类型，因为不同类型物品的附加属性值位置不一样，在升级装备物品性时用来控制指定属性值。

命令格式

??????
CHECKITEMTYPE 物品位置 物品类型
物品位置：
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
物品类型：
5 武器
6 武器
10 衣服
11 衣服
15 头盔
19 项链
20 项链
21 项链
22 戒指
23 戒指
24 手镯
25 护身符
26 手镯
28 马牌
29 天使
30 照明物
52 鞋子
53 宝石
54 腰带


检查人物声望点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物声望点

命令格式

??????
CHECKCREDITPOINT 控制符(=,>,<) 声望点数(1 - 255)< /FONT>
??????
;==========================================
;检查声望点是否等于指定点数
[@CHECKCREDITPOINT0]
#IF
CHECKCREDITPOINT = 50
#SAY
您声望点等于50级。
#ELSESAY
您声望点不等于50级。
;==========================================
??????
;==========================================
;检查声望点是否大于指定点数
[@CHECKCREDITPOINT1]
#IF
CHECKCREDITPOINT > 50
#SAY
您声望点大于50级。
#ELSESAY
您声望点不大于50级。
;==========================================
??????
;==========================================
;检查声望点是否小于指定点数
[@CHECKCREDITPOINT2]
#IF
CHECKCREDITPOINT < 50
#SAY
您声望点小于50级。
#ELSESAY
您声望点不小于50级。
;==========================================


检查人物是否付费

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
#if
CHECKPAYMENT 2
#say


检查人物是否加入行会

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查玩家是否加入行会。

命令格式

??????
============================
#IF
HAVEGUILD
#SAY
你已经加入了行会！
#ELSESAY
你没加入行会！
============================


检查人物是否为管理员

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物是否为管理员

命令格式

??????
;==========================================
;检查人物是否为系统管理员
[@IsSysOp]
#IF
ISADMIN
#SAY
你是系统管理员。
#ELSESAY
你不是系统管理员。
;==========================================


检查人物是否为沙城城主

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查玩家是否为沙城老大。

命令格式

??????
============================
#IF
ISCASTLEMASTER
#SAY
你是沙城老大！
#ELSESAY
你不是沙城老大！
============================


检查人物是否为沙城成员

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查玩家是否为沙城成员。

命令格式

??????
============================
#IF
ISCASTLEGUILD
#SAY
你是沙城成员！
#ELSESAY
你不是沙城成员！
============================


检查人物是否为新人

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查玩家是否为新人（即刚注册进入游戏的人，退出后再进就不是新人了）。

命令格式

??????
============================
#IF
ISNEWHUMAN
#SAY
你是新人！
#ELSESAY
你不是新人！
============================


检查人物是否为行会掌门人

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查玩家是否为行会老大。

命令格式

??????
============================
#IF
ISGUILDMASTER
#SAY
你是行会老大！
#ELSESAY
你不是行会老大！
============================


检查人物是否学习了某项魔法

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
#IF
CheckMagicName 烈火剑法
#SAY
你已经学会了烈火剑法.


检查人物是否在攻城区域

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检查人物是否在攻城区域

命令格式

??????
CheckInWarArea
??????
#IF
CheckInWarArea
#SAY
在攻城区域.


检查人物在列表中的位置

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物在列表中的位置。

命令格式

??????
CHECKNAMELISTPOSITION List.txt (> < = ) 10 P0
??????
;==========================================
;
[@checkpostion0]
#IF
CHECKNAMELISTPOSITION AccountIPList.txt < 10 P0
#SAY
您在前10名，当前排名为<$STR(P0)>。
#ELSESAY
您不在前10名，当前排名为<$STR(P0)>。。
;==========================================


检查是否存在某个称号

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查是否存在某个称号

命令格式

??????
CHECKTITLE 称号名称
??????
[@main]
#IF
CHECKTITLE 称号一
#SAY
你已经有了“称号一”的称号


检查是否为组长

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查人物是否为编组的组长

命令格式

??????
ISGROUPMASTER
??????
[@checkgroup]
#if
ISGROUPMASTER
#say
你是组长
#elsesay
你不是组长

相关命令

编组地图传送：GROUPMAPMOVE
编组地图随机传送：GROUPMOVE


检查是否在某地图

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
ISONMAP 地图名称


检查行会名称

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查行会名称

命令格式

??????
================================
#if
CHECKOFGUILD 行会名称
#say
行会正确
================================


检查行会是否在列表中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检查行会是否在列表中

命令格式

??????
================================
[@checkGuild]
#IF
CHECKGUILDLIST GuildList.txt
#SAY
列表中有行会。
#ELSESAY
列表中没有行会。
================================


检查一个地图内人数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查一个地图内的人物数量。

命令格式

??????
CheckMapHumenCount地图号 ('<' '>' '=')数量
??????
;==========================================
[@Main]
#if
CheckMapHumanCount 3 < 100
#say
地图3内人数小于100人
#elsesay
地图3内人数多于100人
;==========================================


检查装备绑定状态

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检查装备绑定状态

命令格式

??????
CheckItemState 装备位置(-1~13,-1时为OK框中物品) 项目(0-6)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出 6 丢弃消失
??????
[@衣服禁止扔]
#IF
CheckItemBind 0
#ACT
GOTO @禁止扔
#ELSEACT
SENDMSG 6 请先绑定
??????
[@禁止扔]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SetItemState 0 0 1
SENDMSG 6 该装备禁止扔


检查字符串是否在指定文件中 包含检测

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查字符串是否在指定文件中 包含检测 检测的字符串不需要完全相同，文件里的字符包含检测的字符，就会成功

??????
[@CheckContainsTextList]
#IF
CheckContainsTextList ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
#SAY
列表里的某一行字符包含<$STR(S2)>
#ELSESAY
列表里的某一行字符包含<$STR(S2)>
??????
[@CheckContainsTextListEx]
#IF
CheckContainsTextListEx ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
#SAY
<$STR(S2)>包含列表里某一行字符
#ELSESAY
<$STR(S2)>不包含列表里某一行字符
??????
CheckContainsTextList 和 CheckContainsTextListEx 区别
CheckContainsTextList 列表文件里保存的是完整的字符。检测列表里的某一行字符是否包含检测的关键字
CheckContainsTextListEx 列表文件里保存的是关键字。检测字符是否包含列表里的某一行关键字


检查字符串是否在指定文件中

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
[@旧格式_不区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S$2)>
#SAY
<$STR(S$2)>在列表中
#ELSESAY
<$STR(S$2)>不在列表中
??????
[@新格式_区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S$2)> <$STR(S$3)>
#SAY
卡号密码正确
#ELSESAY
卡号密码错误
;S$2和S$3的值在“10元卡号.txt”文本中以空格分开


脚本检测命令取反 NOT

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
NOT 命令 > 50 //检测人物物品算不大于50

脚本示例

??????
[@main]
#IF
NOT CHECKGAMEGOLD > 50 //检测人物元宝算不大于50
#ACT
SENDMSG 5 你身上的元宝不大于50
??????
[@main_1]
#IF
NOT CHECKLEVELEX > 80 //检测人物等级不大于80级
#ACT
SENDMSG 5 你的等级不大于80级
??????
[@main_2]
#IF
NOT EQUAL P0 5 //检测变量P0是否不等于5
#ACT
SENDMSG 5 <$STR(P0)>变量不等于5
??????
[@main_3]
#IF
NOT H.CHECKLEVELEX > 80 //检测英雄等级不大于80级
#ACT
SENDMSG 5 你的英雄等级不大于80级


新物品绑定检测

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

CheckItemBind,检测物品是否已经绑定

命令格式

??????
CheckItemBind 装备位置(-1~13,-1时为OK框中物品)

脚本示例

??????
[@衣服绑定]
#IF
CheckItemBind 0
#ACT
SENDMSG 6 该装备已经绑定过了
#ELSEACT
SetItemBind 0 1
SENDMSG 6 绑定完成


行会成员人数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测行会成员人数

命令格式

??????
CheckGuildMemberCount 控制符 <.=.> 数量
??????
#IF
CheckGuildMemberCount > 100
#SAY
行会成员大于100人.


字符串比较处理

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

字符串比较处理。

命令格式

??????
CheckContainsText 字符 字符串检查 //检查字符串是否包涵在另外一个字符串中.
CompareText 字符 字符 // 比较两个字符串是否一样
??????
;==========================================
检查字符串是否包涵在另外一个字符串中
[@Test]
#IF
CheckContainsText www.ETmir2.com ETmir2.com
#Say
包涵
#elsesay
不包涵
;==========================================
??????
;==========================================
比较两个字符串是否一样，不区分大小写
[@Test]
#IF
CompareText www.ETmir2.com www.ETmir2.com
#Say
一样
#elsesay
不一样
;==========================================


检测本月的天数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测是否是本月的第几天.

命令格式

??????
DAYOFMONTH 天数(1-31) 天数(1-31)

说明：第二个参数可省略.

脚本示例

检测是否本月的前7天

??????
[@main]
#IF
DAYOFMONTH 1 10
#SAY
本月10号之前.

脚本示例

检测是否是本月的第一天

??????
[@main]
#IF
DAYOFMONTH 1
#SAY
今天是1号,新的一个月又开始了.


检测当前宝石升级装备的名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测当前通过宝石升级装备的名字

命令格式

??????
CheckUpgradeItemName 位置(0-1) 名字

说明：位置0=升级装备的名字 1=左边一格宝石的名字

注意

此命令只能在QFunction中的@ItemUpgarde下执行.

??????
[@ItemUpgrade]
#IF
CheckGold 5000
CheckUpgradeItemName 0 裁决之杖
#ACT
Take 金币 5000
#ELSESAY
只能升级裁决之杖,或者你没有5000金币.
#ELSEACT
SetUpgradeFail
Break


检测人物的攻击模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

说明：检测人物的攻击模式

命令格式

??????
CheckAttackMode 模式(0-7)
??????
#IF
CheckAttackMode 0
#SAY
全体攻击模式
#IF
CheckAttackMode 1
#SAY
和平攻击模式


检测物品持久

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测人物身上物品持久.

命令格式

??????
CheckItemDura 位置(0-12) 操作法(> = <) 持久(1-65000) 模式(0,1)

说明：默认模式=0表示检测物品持久下限,模式=1时检测物品持久上限.

脚本示例

??????
检测物品持久下限
??????
[@Main]
#IF
CheckItemDura 1 > 30000 0
#SAY
武器持久下限大于30.

脚本示例

??????
检测物品持久上限
??????
[@Main]
#IF
CheckItemDura 1 > 30000 1
#SAY
武器持久上限大于30.


检测物品纯度

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测背包中物品的纯度(持久,品质).

命令格式

??????
CheckMine 物品名称 数量(1-45) 纯度(1-65)

脚本示例

检测背包中是否有5个纯度20的黑铁矿石,并且回收.

??????
[@main]
#IF
CheckMine 黑铁矿石 5 20
#ACT
TakeMine 黑铁矿石 5 20
#SAY
背包中有5个纯度20的黑铁矿石.
#ELSESAY
没有.


检测月份

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测现在是几月

命令格式

??????
MONTHOFYEAR 月份(1-12) 月份(1-12)

说明

第二个参数可省略.

脚本示例

检测是否7月--8月

??????
[@main]
#IF
MONTHOFYEAR 7 8
#SAY
暑假期间大家玩的开心点.

脚本示例

检测是否1月

??????
[@main]
#IF
MONTHOFYEAR 1
#SAY
新的一年开始了.


检测装备的附加属性总和

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测装备的附加属性总和(武器的诅咒不在计算范围之内).

命令格式

??????
格式: CheckItemAddValueEx 位置(0-15) 操作符(> = <) 附加值(0-65000) 新属性(0,1)

说明：第四个参数只在英雄M2下有效,1时计算附加的致命一击等属性.

脚本示例

??????
#IF
CheckItemAddValueEx 1 > 5 1
#SAY
武器的附加属性大于5点.


检测装备名字颜色

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测装备名字的颜色(英雄M2).

命令格式

??????
CheckItemNameColor 位置(0-13) 颜色(0-255)

脚本示例

??????
检测武器颜色是否是紫色.
??????
[@main]
#IF
CheckItemNameColor 1 253
#SAY
武器名字紫色显示.


检测字符串长度命令

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

检测字符串长度命令

命令格式

??????
CheckStringlength 字符串 操作符(<,>,=) 位数

说明：一个汉字位数为2, "》"也为2个字符

??????
[@test]
#IF
CheckStringlength D3dm2 > 3
#SAY
D3dm2大于3个字符
#ELSESAY
D3dm2小于3个字符


检查宝宝数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查玩家所带宠物的数量。

命令格式

??????
CHECKSLAVECOUNT 控制符 <.=.> 数量< FONT>
??????
;==========================================
;检查宝宝数量是否为指定数量
[@checkslavecount0]
#IF
#ACT
CHECKSLAVECOUNT = 5
#SAY
你的宝宝数量为5个。
#ELSESAY
你的宝宝数量不为5个。
;==========================================
;==========================================
;检查宝宝数量是否为大于数量
[@checkslavecount1]
#IF
#ACT
CHECKSLAVECOUNT > 5
#SAY
你的宝宝数量超过5个。
#ELSESAY
你的宝宝数量不超过5个。
;==========================================
;==========================================
;检查宝宝数量是否为小于数量
[@checkslavecount2]
#IF
#ACT
CHECKSLAVECOUNT < 5
#SAY
你的宝宝数量小于5个。
#ELSESAY
你的宝宝数量不小于5个。
;==========================================


检查宝宝最高等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

脚本功能:
检查宝宝的等级。

命令格式

??????
CHECKSLAVELEVEL 控制符(=,>,<) 等级数(7)
??????
;==========================================
;检查宝宝的等级是否等于指定级别
[@checklevel0]
#IF
CHECKSLAVELEVEL = 5
#SAY
宝宝的等级等于5级。
#ELSESAY
宝宝的等级不等于5级。
;==========================================
??????
;==========================================
;检查宝宝的等级是否大于指定级别
[@checklevel1]
#IF
CHECKSLAVELEVEL > 5
#SAY
宝宝的等级大于5级。
#ELSESAY
宝宝的等级不大于5级。
;==========================================
??????
;==========================================
;检查宝宝的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKSLAVELEVEL < 5
#SAY
宝宝的等级小于5级。
#ELSESAY
宝宝的等级不小于5级。
;==========================================


检查地图中的人物是否属于同一个行会

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查当前地图中的人物是否属于同一行会

命令格式

??????
MapHumIsSameGuild 是否忽略没有加人行会的人物(0-1)
??????
#IF
MapHumIsSameGuild 1
#SAY
当前地图中的人物属于同一个行会,不包涵没有加入行会的人物.


检查人物被踢次数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
#IF
CheckNumOfKick 3
#SAY
你已经被踢下线至少3次了.


检查人物杀死怪物的名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检查人物杀死怪物的名字

命令格式

??????
CheckKillMonName 名字 是否清除(0,1)

说明：是否清除参数可以不需要默认0,为了避免杀死某个怪物可重复执行脚本是设置1.

??????
[@main]
#IF
CheckKillMonName 白野猪
#SAY
你把白野猪干掉了!
;检测后立即清除人物内置变量.
??????
[@main]
#IF
CheckKillMonName 白野猪 1
#SAY
你把白野猪干掉了!


检查人物是否在指定范围内

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测人物是否在指定范围之内

命令格式

??????
CheckHumInRange 地图 坐标X 坐标Y 范围(0 -- 500)

说明：地图=Self时表示当前地图.

脚本示例

检测人物是否在盟重安全区.

??????
#IF
CheckHumInRange 3 330 330 5
#SAY
你在盟重安全区发呆呢..


检查人物所在地图是否允许使用记忆,夫妻,师徒传送

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查人物所在地图是否允许使用记忆 夫妻 师徒传送

??????
#IF
CheckRecall 人物名字
#SAY
当前地图不允许被传送.


检查是被人物还是怪物杀死的

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查是被怪物还是人物杀死的.

??????
#IF
KillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$MONKILLER> 在%m 把你干死了!


检查一个范围内怪物数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能

可以检查一个坐标范围内怪物数量。

命令格式

??????
CheckRangeMonCount 地图号 X坐标 Y坐标 范围 控制符(=,>,<) 数量
??????
;==========================================
[@Main]
#IF
CheckRangeMonCount 3 330 330 10 < 100
#SAY
地图3的X330Y330十的范围内怪物少于100只
#ELSESAY
地图3的X330Y330十的范围内怪物多于100只
;==========================================


检查在线最高属性人物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查在线最高攻击,魔法,道术,防御,PK值

??????
#if
IsHigh L
#say
你的级别是全服最高的
#act
break
#if
IsHigh P
#say
你的PK值是全服最高的
#act
break
#if
IsHigh D
#say
你的攻击是全服最高的
#act
break
#if
IsHigh M
#say
你的魔力是全服最高的
#act
break
#if
IsHigh S
#say
你的道术是全服最高的
#act
break


检查正在穿身上装备的名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CheckTakeOnItem 物品名字
??????
#IF
CheckTakeOnItem 布衣(男)
#SAY
你正在穿布衣！


检查正在攻击中的怪物名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

说明：检查正在被自己攻击的怪物的名字.

注意：地图参数中加入HITMON(@XXX)

Q-Function0.txt中

??????
[@XXX]
#IF
CHECKHITMONNAME 白野猪
#SAY
你正在攻击白野猪


检查正在脱身上装备的名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CheckTakeOffItem 物品名字
??????
#IF
CheckTakeOffItem 布衣(男)
#SAY
你的布衣是不是该扔掉了?


检查指定城堡是否在攻城

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
#if
checkcastlewar 2
#say
第三个城堡正在攻城
#elsesay
第三个城堡没有攻城


检查指定范围内人物数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测指定范围内人物数量

命令格式

??????
格式: CheckRangeHumCount 地图 坐标X 坐标Y 范围 操作符(>= <) 数量

说明：地图=Self时表示当前地图

坐标=0时表示当前坐标

脚本示例

??????
检测盟重省安全区的人物数量
??????
#IF
CheckRangeHumCount 3 330 330 10 > 100
#SAY
盟重土城当前人数超过100.


检查指定人物背包空格数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检测指定人物背包空格数量

??????
#IF
CheckHumBag <$STR(S$1)> > 5
#SAY
<$STR(S$1)>的背包有5个以上的空格.


检查装备升级次数 或 星星数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：用来检测通过宝石升级装备的次数. 或 星星数量

命令格式

??????
CheckItemupgradeCount 方式(0,1) 位置(0-12) 操作符(> = <) 次数(0-255)

说明

方式=0时检测正在升级的装备,方式=1时检测人物身上的装备.

检查装备升级次数 或 星星数量

脚本示例

检测武器是否已经升级10次.

??????
#IF
CheckItemUpgradeCount 1 1 > 10
#SAY
你的武器已经升级了10次以上.


检查自己和宝宝之间的距离

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测自己和宝宝之间的距离

命令格式

??????
CheckSlaveInRange 名字 距离

说明：此命令的主要作用是配合128类型的宝宝使用(可模仿押镖任务).

??????
#IF
CheckSlaveInRange 月灵 5
#SAY
你的月灵在身边
#ELSESAY
你的月灵宝宝跑哪里去了?


检测英雄的PK值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
#IF
CheckHeroPkPoint > 100
#SAY
英雄的PK值大于100点.


检测英雄的伤害吸收

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

说明：检测英雄的伤害

命令格式

??????
CheckHeroSuckDamage 操作符(> = <) 数量(1-2000000000)
??????
#IF
CheckHeroSuckDamage > 1000
#SAY
SendMsg 5 你的英雄当前拥有的伤害吸收大于1000点.


检测英雄的忠诚度

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

功能：检测英雄当前的忠诚度

命令格式

??????
CheckHeroLoyal 操作符(< = >) 数值(0 -- 100)

脚本示例

??????
#IF
CheckHeroOnline
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.


检测英雄登录器荣誉

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

命令格式

??????
CheckHumCreditEx 操作符(> = <) 数值(1-65535)
??????
#IF
CheckHumCreditEx < 10
#ACT
ChangeHumCreditEx = 10


检测英雄职业

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令
??????
CheckHeroJob

职业(0,1,2)

??????
#IF
CheckHeroOnline
CheckHeroJob 2
#SAY
你英雄的职业是道士
#ELSESAY
你的英雄没有在线.


检查是否有英雄

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查人物是否有英雄

??????
#IF
CheckHaveHero
#SAY
你已经有英雄了.
#ELSESAY
你还没有英雄.


检查英雄等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

检查英雄当前等级.

命令格式

??????
CheckHerolevel 操作符(> = <) 级别(1-65535)
??????
#IF
CheckHerolevel = 50
#SAY
你的英雄已经50级了


扩展#IF命令参数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 检测命令

注意

变量初始为0表示百分百满足条件。

命令格式

??????
IF(*)
??????
;下面条件需要成立0条，所以在这里是百分百触发act
#IF(0)
checkitem 太阳水 1
checkitem 万年雪霜 1
#ACT
sendmsg 7 ok!
#ELSEACT
sendmsg 7 no!
;==========================================

;需要满足其中任意的2条即可触发ACT
#IF(2)
checkitem 太阳水 1
checkitem 万年雪霜 1
checkitem 强效太阳水 1
#ACT
sendmsg 7 ok!
#ELSEACT
sendmsg 7 no!
;==========================================

;下面条件要满足<$STR(N0)>个，支持变量
#IF(N0)
checkitem 太阳水 1
checkitem 万年雪霜 1
#ACT
sendmsg 7 ok!
#ELSEACT
sendmsg 7 no!
;==========================================

;下面条件要满足<$STR(N<$STR(N0)>)>个，支持嵌套。
#IF(<$STR(N<$STR(N0)>)>)
checkitem 太阳水 1
checkitem 万年雪霜 1
#ACT
sendmsg 7 ok!
#ELSEACT
sendmsg 7 no!
;==========================================


角色出售、角色交易系统

项目：ET引擎说明书　分类：ET引擎脚本文档

功能

角色交易功能开启（0827版引擎支持需用到GameSource.Pak）

命令格式

??????
================================
查看详细信息脚本：

查看角色属性栏最下面的“其他”读取的是SellPlayerInfo.txt文本，手动创建后复制下面的脚本即可！ SellPlayerInfo.txt是显示出售角色信息中的“其他”中的内容，置于Mir200\Envir\目录下。和npc写法相同，不要任何标签和[@main]，不支持触发<触发/@触发>，主要用于显示一些角色信息无法显示的各种变量属性下方为SellPlayerInfo.txt文本内容示范：
用户名:<$UserName>\
等级::<$Level>\
转生等级:<$ReLevel>\
;******************************************分界线******************************************
功能操作命令：

检测自己是否在出售中：CheckIsSellPlayer

检测自己是否为角色出售委托人：CheckIsSellPlayDelegator

打开角色出售对话框：OpenAddSellPlayerDlg

获取委托自己出售的角色数量：GetSellPlayerCount

取消某个委托自己出售的角色：DelSellPlayer 角色名

打开取消角色出售对话框：OpenDelSellPlayerDlg

打开角色出售商店：OpenSellPlayerShopDlg

中止添加角色出售 （仅用于 QFunction-[@PlayerSelling]或[@BeforePlayerSelling]中使用）：BreakAddSellPlayer

;-------------------------------Npc示范脚本：----------------------------

<我要出售角色/@我要出售角色 designtimesp=28216> <取消角色出售委托/@取消角色出售委托 designtimesp=28217> \ \
<我要购买角色/@我要购买角色 designtimesp=28218>
[@我要出售角色]
#if
CheckIsSellPlayer
#act
SendMsg 6 您已经在出售中
break
#if
CheckIsSellPlayDelegator
#act
SendMsg 6 您是别人的委托人，不能出售，如果要出售请先取消委托
break

#if
#act
OpenAddSellPlayerDlg
;打出角色出售对话框，在此前可以加出售条件判断
;此前加的条件可能会被构造的非法封包绕过，建议在QFunction-[@PlayerSelling]或[@BeforePlayerSelling]触发中检测

[@取消角色出售委托]
#if
#act
GetSellPlayerCount n0
;获取正在委托自己出手的信息到变量中，N0修改为服务端没用到其他N变量

#if
Equal n0 0
;判断上面的变量是否为0，如上面N0修改了，本项N0同步修改
#act
SendMsg 6 没有委托您出售的角色
break
#elseact
OpenDelSellPlayerDlg
[@我要购买角色]
#if
#act
OpenSellPlayerShopDlg

;-------------------------------触发：QFunction
---------------------------- QFunction触发字段说明：
1、添加出售角色委托人同意之后触发：@PlayerSelling
2、添加出售在询问委托人确认前触发：@BeforePlayerSelling
3、角色出售成功触发：@PlayerSold
4、购买角色成功触发：@PlayerBuyIn
;-------------------------------QFunction触发示例----------------------------
[@PlayerSold]
#act
;交易成功后将售出的角色强行离婚
unmarryrequestunmarry force
break
[@BeforePlayerSelling]
#if
#act
SendMsg 6 委托人：<$SellPlayDelegater>
SendMsg 6 出售货币：<$SellPlayMoneyType> ;(1:元宝；2:游戏点；3:金币；4:金刚石；5:灵符)
SendMsg 6出售价格：<$SellPlayMoneyValue>
#if
not checklevel 300
#act
BreakAddSellPlayer
SendMsg 6 您的等级不够，不能出售
break
#or
SMALL <$SellPlayMoneyValue> 10
LARGE  <$SellPlayMoneyValue> 1000000
#act
BreakAddSellPlayer
SendMsg 6 请输入正确的价格范围：（10-100W）
break

[@PlayerSelling]
#or
SMALL <$SellPlayMoneyValue> 10
LARGE <$SellPlayMoneyValue> 1000000
#act
BreakAddSellPlayer
SendMsg 6 请输入正确的价格范围：（10-100W）
break

说明：
@PlayerSelling出售前最后一个触发，可用于检测一些特殊项，至于检测什么自己决定
@BeforePlayerSelling 为向委托人发送请求前触发，比如检查等级，出售价格等，如果在@PlayerSelling中触发，感觉不太友好，因为折腾半天到最后一步提示条件不足，不够优雅，简单检测可以用在@BeforePlayerSelling 中进行委托人是他人或自己另外个角色都会进行触发，因为触发为出售人的QF触发，一般用于检测
;-------------------------------购买角色成功QFunction触发示例----------------------------
变量（仅@PlayerBuyIn中可用）：
购买的角色名：<$PlayerBuyUser>
角色出售委托人：<$PlayerBuyUserDelegater>
角色出售价格：<$PlayerBuyPrices>
角色出售货币类型文本：<$PlayerBuyMoneyType>
角色出售货币类型值：<$PlayerBuyMoneyTypeValue>；0:元宝; 1:游戏点; 2:金币；3:金钢石; 4:灵符
[@PlayerBuyIn]
#or
SMALL <$PlayerBuyPrices> 10
LARGE <$PlayerBuyPrices> 1000000
#ACT
StopBuyUser
SendMsg 6 购买失败....价格要求大于10并且小于100W
break
#if
#ACT
SendMsg 6 购买角色“<$PlayerBuyUser>”（委托人：<$PlayerBuyUserDelegater>）成功触发；价格：<$PlayerBuyPrices><$PlayerBuyMoneyType>(货币类型值：<$PlayerBuyMoneyTypeValue>)
break
以上为简单脚本，各种检测需GM自己完善，已经成功后触发需要解除什么关系的需GM自己加
;******************************************分界线******************************************
购买角色前触发：@BeginBuyUser中止人物购买角色：StopBuyUser，仅用于@BeginBuyUser中
[@BeginBuyUser]
#ACT
StopBuyUser
#SAY
购买的角色名：<$PlayerBuyUser>\
角色出售委托人：<$PlayerBuyUserDelegater>\
角色出售价格：<$PlayerBuyPrices>\
角色出售货币类型文本：<$PlayerBuyMoneyType>\
角色出售货币类型值：<$PlayerBuyMoneyTypeValue>；0:元宝; 1:游戏点; 2:金币；3:金钢石; 4:灵符

;******************************************分界线******************************************


开启反外挂加载后触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

玩家反挂插件加载成功时触发 [QFunction-0.txt] 脚本内, [@ET反挂加载] 字段(可在此字段使用插件云功能)

常量

<$ETMACHINEID> 登录器编号

解释

比如我5个登录器 他们登录器文件名名字叫
【ET】ABC-[10].exe
【ET】ABC-[11].exe
【ET】ABC-[15].exe
【ET】ABC-[17].exe
【ET】ABC-[30].exe

那<$ETMACHINEID> 分别等于：10,11,15,17,30

文件名取值计算方式包括 -[ 和 ] 否则不成立！！！

请在[@ET反挂加载] 里读取该常量，只能是数值，用于区别登录器所属类型


开启人物死亡触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关
??????
[@ETPLAYDIE]

经测试发现，原引擎 当被玩家被怪物攻击时，被其他玩家击杀，不能正确显示击杀人物（显示为怪物击杀）.
所以我们增加了一个新的死亡触发
新加常量：
<$ETKILLERRACE> 死亡时击杀者类型 （ 数据库Race值 ）
<$ETKILLERNAME> 死亡时击杀者名字
<$ETKILLERNAMECLIENT> 死亡时击杀者名字去除数字

??????
[@ETPLAYDIE]
#IF
equal <$ETKILLERRACE> 0
#ACT
SENDMSG 你被<$ETKILLERNAME>击杀了


开启烈火、开天、逐日触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

对应触发QF


开启触发版本标记-标识-分渠道

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

触发版本标记字段 [QFunction-0.txt] 脚本内, [@ET版本自定义标记文本],专属变量:<$STR(S$ET版本自定义标记文本)>

反挂下发完成加载后,且选项已勾选时,会检查游戏目录\data\bbzdywb.txt的文件[ANSI编码],如果内容不为空、且文本长度小于等于32,就会传送M2,并触发指定字段,文本内容保存在:<$STR(S$ET版本自定义标记文本)>


开启地图变更触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

开启地图变更,触发[QFunction-0.txt] 脚本内, [@ET地图变更],当地图切换至其他地图时触发,首次开启后人物需重新进入方准确


开启物品爆出掉落反馈触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

开启物品爆出掉落反馈,触发[QFunction-0.txt] 脚本内, [@物品爆出反馈],专属变量:<$STR(S$当前爆出物品名称)>,<$STR(S$当前爆出地图名称)>,<$STR(S$当前爆出怪物名称)>,请在[@物品爆出反馈]里面取值,否则不准确。


开启宝宝攻击触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

宝宝物理攻击触发 [QFunction-0.txt] 脚本内, [@宝宝物理攻击] 字段(注:切割需要使用宝宝专用切割命令)

宝宝魔法攻击触发 [QFunction-0.txt] 脚本内, [@宝宝魔法攻击] 字段(注:切割需要使用宝宝专用切割命令)


开启行会触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

开启行会触发,触发[QFunction-0.txt] 脚本内, [@ET行会加入]、[@ET行会退出],专属变量:<$STR(S$当前行会名称)>,当事人必须在线才会触发,且不适用于聊天框命令输入退出模式。


开启传送控制触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

开启传送控制,触发[QFunction-0.txt] 脚本内, [@ET传送控制],使用ETAllowTag控制最终是否可传送,1=允许、0=不允许,不调用命令默认允许。


开启小退控制触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

开启小退控制,触发[QFunction-0.txt] 脚本内, [@ET小退控制],使用ETAllowTag控制最终是否可小退,1=允许、0=不允许,不调用命令默认允许。


开启装备升级触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

装备升级触发 [QFunction-0.txt] 脚本内, [@ET装备升级成功]、[@ET装备升级失败]、[@ET装备升级破碎]


开启购买商铺。摆摊物品拦截触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

如:HERO摆摊、个人商铺物品

ETALLOWDROP 参数一(1禁止购买,0不禁止,不调用此命令默认允许购买)

??????
[@ETNotShopBuy]
#act
;不调用默认是允许购买,1就是禁止
ETALLOWDROP 1
sendmsg 6 已被禁止购买！


开启商城购买触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

变量:<$STR(S$ET购买商品名称)>

??????
[@ET购买商品物品]
#act
sendmsg 6 <$STR(S$ET购买商品名称)>


开启进入或者离开安全区域触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

QF

??????
[@ET离开安全区]
#ACT
Messagebox 您已经离开安全区域，请注意安全！


开启攻城提示触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关
??????
;S0=城堡名字
;S1=掌门名字
;S2=行会名字
;N0=行会成员数量
;争夺城堡:
??????
[@BattleCastle]
#act
sendmsg 0 【<$STR(S1)>】带领【<$STR(S2)>】行会（共<$STR(N0)>好汉）占领了【<$STR(S0)>】!
;攻城开始触发:
[@BeginCastle]
#act
sendmsg 0 【<$STR(S0)>】攻城战已经开始，请各位勇士擦亮你的大刀准备迎战!
;攻城快结束触发:
[@EndCastleHint]
#act
sendmsg 0 【<$STR(S0)>】攻城战争只剩下[<$STR(N0)>]分钟，请勇士们抓紧时间!
;攻城结束触发:
[@EndCastle]
#act
sendmsg 0 【<$STR(S0)>】争夺战役已经结束【<$STR(S2)>】行会（共<$STR(N0)>好汉）将【<$STR(S1)>】抬上了城主宝座！


开启技能控制触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

;触发字段

??????
[@ETBeginMagic]
;变量
<$ETMagicID>
<$ETMagicName>
<$ETMagicTarget>
<$ETMagicTargetRace>
;操作命令
中断技能使用命令:ETStopMagic
范例:
[@ETBeginMagic]
#IF
EQUAL <$ETMagicName> 野蛮冲撞
EQUAL <$ETMagicTargetRace> 0
<$ETMagicTarget>.CHECKTITLE 不动如山
#ACT
ETStopMagic
Sendmsg 7 目标拥有称号不动如山,无法对其释放野蛮冲撞.


开启查看装备时触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

开启查看装备时触发
QFunction-0脚本触发

??????
[@ETQueryUserState]
#act
;可以使用当前对象的变量来查看
;当前查看对象的常量
;例如:<$C.USERNAME><$C.HP><$C.PKPOINT><$C.GOLDCOUNT><$C.GAMEGOLD>
;对方角色名字，当前HP,PK值，金币，元宝
sendmsg 6 <$C.USERNAME>，<$C.HP>，<$C.PKPOINT>，<$C.GOLDCOUNT>，<$C.GAMEGOLD>

禁止查看对方装备

ETSTOPQUERYUSERSTATE 无参数执行就禁止查看

??????
[@ETQueryUserState]
#act
ETSTOPQUERYUSERSTATE
sendmsg 6 禁止查看对方装备


开启暴击前触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

用于暴击触发前拦截，执行ETReturn即可拦截，自己可在脚本设置几率控制！

??????
[@ETBeforeCritTrigger]
#ACT
ETReturn
sendmsg 6 拦截暴击


开启人物暴击触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

暴击触发

可修改暴击触发后的伤害值

修改暴击伤害值：Return 伤害值

<$ETPARAM1>伤害参数

<$ETPARAM2>技能ID

例子：
QFunction-0.txt

??????
[@ETCritTrigger]
#IF
#ACT
MOV N$暴击 10000
INC N$暴击 <$ETPARAM1>
ETReturn <$STR(N$暴击)>
sendmsg 0 人物本身暴击伤害值：<$ETPARAM1>,修改后伤害：<$STR(N$暴击)>
sendmsg 0 人物使用技能ID：<$ETPARAM2>


开启人物死亡前触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

QF

??????
[@ET死亡前触发]
#ACT
ETDIETAG
;调用后人物血量变为1，脱离死亡
sendmsg 6 人物脱离死亡成功！


开启引擎装备穿戴触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

QF

??????
[@TakeOnALL]
#if
#act
sendmsg 6 佩戴了物品<$ETTakeOnNAME>
sendmsg 6 物品位置<$ETTakeOnIndex>

[@TakeOffALL]
#if
#act
sendmsg 6 取下了物品<$ETTakeOffNAME>
sendmsg 6 物品位置<$ETTakeOffIndex>


打开仓库

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

打开仓库

ETOPENSTORAGE 参数1

参数位置 | 参数说明
参数1 | 参数1（0存物品 1取物品） 只有关闭可视化仓库后生效，开启可视化仓库 参数可为空
??????
[@打开仓库]
#IF
#ACT
ETOPENSTORAGE 1
DELAYGOTO 10 @关闭对话框 （如有想关闭NPC对话框的 可以加此代码 通过DIY控件的命令 关闭NPC对话框）
[@关闭对话框]
#if
#act
ETClientUiChange 2 DMerchantDlg_|0


交易前及技能前触发控制

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

交易前及技能前触发控制

引擎功能扩展 - 脚本触发和功能扩展(二) - 勾选开启交易前触发控制

??????
[@ET交易前触发控制]
#act
;n0=1 打断交易
mov n0 1
sendmsg 7 有内鬼交易被取消！
m.sendmsg 7 有内鬼交易被取消！

引擎功能扩展 - 脚本触发和功能扩展(二) - 勾选开启技能触发前控制

??????
[@ET技能前触发控制]
#act
;n0=1 打断技能
mov n0 1
sendmsg 7 技能被打断，使用魔法ID=<$CURRRUSEMAGICID>


装备穿戴前及脱下前触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

装备穿戴前及脱下前触发 开启方法:引擎功能扩展 - 功能扩展三 - 开启对应选项并保存生效

??????
[@ET脱下前触发]
#act
ETTAKEALLOWTAG 1
SENDMSG 6 禁止脱下，装备名称<$ETITEMNAME>

[@ET穿戴前触发]
#act
ETTAKEALLOWTAG 1
SENDMSG 6 禁止穿戴，装备名称<$ETITEMNAME>


鉴定专用触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

鉴定专用触发

开启方法:引擎功能扩展 - 功能扩展三 - 增加开启物品爆出鉴定触发

注意：受爆率控制影响,触发不代表真实爆出,触发时临时加入背包内,完成后删除背包物品

??????
[@M2DropItem]
#act
sendmsg 7 <$DROPITEMNAME>、<$DROPMONNAME>、<$DROPMAPNAME>、<$DROPMAPNAMES>
;装备名称：<$DROPITEMNAME>
;怪物名称：<$DROPMONNAME>
;地图名称：<$DROPMAPNAMES>
;地图编号：<$DROPMAPNAME>
#if
equal <$DROPITEMNAME> 重盔甲(男)
#act
goto @重盔甲(男)_1

[@重盔甲(男)_1]
#if
random 3
#act
MOV N10 251
CHANGEITEMNAMECOLOR -1 <$str(N10)>
ChangeItemName -1 <$DROPMONNAME><$DLGITEM.NAME>·优秀
break

#if
random 2
#act
MOV N10 249
CHANGEITEMNAMECOLOR -1 <$str(N10)>
ChangeItemName -1 <$DROPMONNAME><$DLGITEM.NAME>·卓越
break

#if
#act
MOV N10 100
CHANGEITEMNAMECOLOR -1 <$str(N10)>
ChangeItemName -1 <$DROPMONNAME><$DLGITEM.NAME>·精良

;MOVR N10 100

;CHANGEITEMNAMECOLOR -1 <$str(N10)>
;ChangeItemUpgradeCount -1 + 10
;ChangeItemName -1 <$DLGITEM.NAME>[<$DROPMONNAME>]
;sendmsg 7 M2DropItem地图[<$DROPMAPNAMES>]怪物[<$DROPMONNAME>]掉落物品[<$DROPITEMNAME>]-掉落


开启聚灵珠使用前触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

聚灵珠使用前触发选项

引擎功能扩展 - 功能扩展三 - 增加开启聚灵珠使用前触发选项

??????
[@ETConfirmUseItem]
#if
equal <$STR(N1)> 503
#act
sendmsg 7 指定类型聚灵珠idx=<$STR(N1)>。
mov n0 1
;使用聚灵珠
#elseact
sendmsg 7 不是指定类型聚灵珠。


增加限次使用物品的次数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

说明: 只对刚刚使用过的类型(StdItem=31Source=1)或者(StdItem=2 Shape=1,3,5,9)的物品有效.

?? ??
[@StdModeFunc10]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura   ;持久增加1
[@StdModeFunc11]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura 100 ;持久增加100


开启人物、背包爆出物品触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

物品爆出后触发QF字段(人物身上爆出)

??????
[@ETDropUseItems]
#if
#act
sendmsg 6 专属变量:爆出物品名：<$DROPUSEITEMS.NAME>、爆出物品制造编号：<$DROPUSEITEMS.MAKEINDEX> 及以下表格内变量

物品爆出后触发QF字段(人物背包爆出)

[@ETDropBagItems]
#if
#act
sendmsg 6 专属变量:爆出物品名：<$DROPUSEITEMS.NAME>、爆出物品制造编号：<$DROPUSEITEMS.MAKEINDEX> 及以下表格内变量

<$DROPUSEITEMS.NAME> 当前物品名称 指人物死亡爆出来
<$DROPUSEITEMS.G_NAME> 当前物品改名名称 指人物死亡爆出来
<$DROPUSEITEMS.STDMODE> 当前物品DB字段StdMode值 指人物死亡爆出来
<$DROPUSEITEMS.SHAPE> 当前物品DB字段Shape值 指人物死亡爆出来
<$DROPUSEITEMS.ANICOUNT> 当前物品DB字段AniCount值 指人物死亡爆出来
<$DROPUSEITEMS.LOOKS> 当前物品DB字段Looks值 指人物死亡爆出来
<$DROPUSEITEMS.DURA> 当前物品当前持久值 指人物死亡爆出来
<$DROPUSEITEMS.DURAMAX> 当前物品最大值 指人物死亡爆出来
<$DROPUSEITEMS.INDEX> 当前物品DB字段Idx值 指人物死亡爆出来
<$DROPUSEITEMS.COLOR> 当前物品DB字段Color值 指人物死亡爆出来
<$DROPUSEITEMS.MAKEINDEX> 当前物品MakeIndex序列号 指人物死亡爆出来


开启大退控制触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

开启大退控制,触发[QFunction-0.txt] 脚本内, [@ET大退控制],使用ETAllowTag控制最终是否可大退,1=允许、0=不允许,不调用命令默认允许。
禁止大退，关闭进程，人物会一直在线。会重复触发禁止大退脚本，直到允许，人物才会下线。


开启新增宝宝触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

玩家获得宝宝时触发 [QFunction-0.txt] 脚本内, [@OnSlaveAdd]字段


使用祝福油触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

使用祝福油时，触发QF[@AddLuck]


人物攻击和被攻击掉血前触发、修改当前伤害血量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

功能说明：人物攻击和被攻击掉血前触发、修改当前伤害血量

格式：ChangeDamageValue 类型(0=值,1=百分比) 操作符(+,-,=) 值

注意：当前伤害血量仅用于以下触发

增加伤害前触发：
人物攻击目标掉血前：@AttackDamage
英雄攻击目标掉血前：@HeroAttackDamage
人物被攻击掉血前：@StruckDamage
英雄被攻击掉血前：@HeroStruckDamage
增加NPC变量，当前伤害掉血量（仅用于以下触发）：<$DamageValue> <$H.DamageValue>

??????
[@AttackDamage]
#act
ChangeDamageValue 0 + 10
SENDMSG 6 人物攻击目标，掉血量为<$DamageValue>，攻击加成10点血量

[@HeroAttackDamage]
#act
H.ChangeDamageValue 0 + 10
SENDMSG 6 英雄攻击目标，掉血量为<$H.DamageValue>，攻击加成10点血量

[@StruckDamage]
#act
ChangeDamageValue 1 - 50
SENDMSG 6 人物被攻击，掉血量为<$DamageValue>，抵御掉血量的50%

[@HeroStruckDamage]
#act
H.ChangeDamageValue 1 - 50
SENDMSG 6 英雄被攻击，掉血量为<$H.DamageValue>，抵御掉血量的50%


摆摊触发脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 触发相关

注意：以下功能是仿HeroM2摆摊功能。如果你使用的是个人商店，请查看个人商店部分 打开摆摊窗口之前首先执行Q-Function中的@StartMyShop脚本段.

取消摆摊触发：@StopMyShop
脚本命令ForbidMyShop用于中断摆摊.

例子:以下脚本放在Q-Function中.

??????
[@StartMyShop]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。
#ACT
ForbidMyShop
BREAK

#IF
NOT INSAFEZONE
#SAY
需要在安全区使用摆摊功能！
#ACT
ForbidMyShop
BREAK

#IF
NOT IsOnMap 3
#SAY
需要在盟重使用摆摊功能.
#ACT
ForbidMyShop
BREAK

#IF
CheckLevelEx < 40
#SAY
需要40级才可以使用摆摊功能！
#ACT
ForbidMyShop

[@StopMyShop]
#IF
#ACT
MESSAGEBOX 取消摆摊成功！


拣物品触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：挂机命令

命令格式

??????
ISDUPMODE (0或空时检测所有对象，1只检测人物)

范例地址：挂机范例脚本


GOTOLABEL触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关
??????
GOTOLABEL 模式(0,1,2,3) 触发字段 范围(模式等于3时有效)

模式=0 小组成员触发
模式=1 行会成员触发
模式=2 当前地图的人物触发
模式=3 以自己坐标为中心指定范围人物触发

??????
[@main]
#IF
#ACT
GOTOLABEL 0 @小组成员触发
GOTOLABEL 1 @行会成员触发
GOTOLABEL 2 @当前地图的人物触发
GOTOLABEL 3 @指定范围人物触发 12
??????
--------------------------------------------------------------------------------------------------
GOTOLABELEX 模式(0组队,1行会) X Y 范围 在什么脚本里触发(0=QF脚本,1=当前NPC脚本) 触发字段
??????
[@main]
#IF
#ACT
GOTOLABELEX 0 <$X> <$Y> 10 0 @aaa


M2启动后触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

QManage.txt中增加一个新的脚本段[@Startup],此脚本段只在M2启动后执行一次.


包裹按钮自定义按钮触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

共5个按钮

在脚本QFunction-0.txt里触发

??????
[@ItemBagButtonClickX] X范围在1-5
[@ItemBagButtonClick1]
[@ItemBagButtonClick2]
[@ItemBagButtonClick3]
[@ItemBagButtonClick4]
[@ItemBagButtonClick5]

可以使用脚本命令SETITEMBAGBUTTONINFO来动态调整按钮的位置，或是否显示某个按钮。

命令格式 SETITEMBAGBUTTONINFO 按钮编号(1~5) 是否可见(0不可见,1可见) 坐标X 坐标Y 提示信息

使用方法：

首先启动登陆器配置器

点击界面UI编辑-界面编辑-OK

然后找到包裹的窗口，鼠标点一下包裹窗口，右边的窗口会有名称，DItemBag_，在这个下面找到 DItemBagButton1 DItemBagButton2 DItemBagButton3 DItemBagButton4 DItemBagButton5
这5个按钮点击会分别触发QF的[@ItemBagButtonClickX]，默认是隐藏的，不显示的，并且没有素材显示，需要设置素材。
鼠标选择其中一个按钮，比如点击DItemBagButton1，然后在左边的窗口，双击图片，就可以设置素材了(具体可以到我们官方网站看视频教程，UI编辑的视频)
在左边的窗口基本属性里-是否可见设置成True。就可以显示按钮，这一步可以省略。可以使用脚本命令SETITEMBAGBUTTONINFO设置。


初始化行会触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

只能用于行会自定义变量的申请

在登陆脚本QManage.txt里触发

??????
[@LoadGuild]
#IF
#ACT
VAR Integer GUILD QQQQ


带上物品时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：带上物品时触发 位置0-18

??????
[@TakeOn0] 0----18
??????
[@TakeOn]
#IF
CheckLevelEx > 0
#SAY
穿上衣服真漂亮！!


地图事件触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

地图事件配置详解 必须在M2-选项-功能设置-基本设置-启用地图事件触发勾上才有效

Mir200\Envir\MapEvent.txt 配置

??????
;触发标识
; 格式:
; 标识:值
;
; 标识:(-1 - 800) -1 代表不检查标识
; 值: (0 - 1)
;
;
??????
;触发条件
??????
; 格式:
; 代码:物品:组队;
; 代码:
; 0:无效
; 1:扔物品
; 2:捡物品
; 3:挖矿
; 4:走路(不支持物品条件)
; 5:跑步(不支持物品条件)
; 6:爆物品
??????
; 物品:(物品名称 - *) * 代表不需要物品
; 组队:(0 - 1) 0为不需要组队，1为必须组队才触发(暂时不支持)
??????
;触发机率
; 数字越大，机率越低
; 范围:(0 - 999999) 0 的机率为100%
??????
;事件类型
; 格式
; 代码:内容
??????
; 代码:(现在只支持脚本事件)
; 0:无效
; 1:调用脚本(调用QFunction-0.txt中的内容)
;注意事项
;
; 在相同地图座标，不支持相同触发标识及条件(触发条件中的物品名称除外)，如果有相同的设置，只有最后一个设置有效
??????
;地图号 座标X 座标Y 范围 触发标识 触发条件 触发机率 事件类型
;和翎风不同的我们这里增加一个范围,如果范围的值是0 那么必须在这个坐标上才能触发，否则只要进入这个坐标的范围就会触发
;坐标为-1时不检测坐标
值/位置 | 说明
3 | 333 333 0 -1:1 1:回城卷:0 2 1:@MapEventDropItem
3 | 333 333 0 -1:1 2:回城卷:0 2 1:@MapEventPickUpItem
3 | 338 331 0 -1:1 3:*:0 2 1:@MapEventMine
3 | 330 330 0 -1:1 4:*:0 2 1:@MapEventWalk
3 | 331 335 0 -1:1 5:*:0 2 1:@MapEventRun
3 -1 | -1 0 -1:0 6:*:0 0 1:@爆物品

QFunction脚本

??????
[@爆物品]
#ACT
;这里的%s表示的爆出的物品名称 %x爆出的物品X坐标 %y爆出的物品Y坐标.
SENDMSG 0 【地图:%m】【物品:%s】【坐标(%x:%y】 255 253
;也可以这样
SENDMSG 0 【地图:%m】【物品:<$SCATTERITEMNAME>】【坐标(<$SCATTERITEMX>:<$SCATTERITEMY>】 255 253


定时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

定时触发 DelayCall 时间毫秒 触发字段


复活时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：复活时触发.

说明：QF脚本触发

??????
[@Revival]
#IF
#ACT
SendMsg 5 你复活了继续折腾把！


个人商店和人物摆摊

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

该触发是引擎默认的个人商店摆摊触发，不是仿HeroM2摆摊触发。仿HeroM2摆摊相关触发完全兼容HeroM2,可以查看兼容HeroM2部分

点击开始摆摊或停止摆摊将触发 QFunction-0 [@ShopStall] 地图参数 ALLOWUSEMYSHOP 允许摆摊(必需先设置摆摊限制在指定地图才会生效)

??????
[@ShopStall]
#IF
INSAFEZONE
;检测在安全区
#ELSEACT
MESSAGEBOX 需要在安全区才能摆摊
BREAK
#IF
CHECKSHOPSTALLSTATUS
;检测是不是在摆摊
#ACT
MESSAGEBOX 你是否确认要停止摆摊 @停止摆摊
#ELSEACT
MESSAGEBOX 你是否确认要开始摆摊 @确定开始
[@确定开始]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。
#ACT
BREAK
#if
#ACT
SHOPSTALL
;使用SHOPSTALL命令，如果正在摆摊就会停止摆摊，如果没有摆摊就会开始摆摊
[停止摆摊]
#if
#ACT
SHOPSTALL
;使用SHOPSTALL命令，如果正在摆摊就会停止摆摊，如果没有摆摊就会开始摆摊

点击我的商店，如果还没有创建将触发[@QueryMyShopFail]
[@QueryMyShopFail]
#ACT
MESSAGEBOX 你还没有个人商店，是否创建你的个人商店？\\点击确定创建个人商店。@创建个人商店  @取消
[@创建个人商店]
亲爱的玩家你好。这里可以申请开店。\
你可以把你的物品放到你的店铺里出售，\
游戏中的玩家可以查询到你要出售的物品。\
也可以把不用的物品放到店铺的仓库里。\
点击客户端中“店”就可以进入到你的店铺中,\
也可以查询其他用户的店铺和物品，\
可以很方便的把仓库物品和出售的物品相互转移。\
还可以进行摆摊操作。\
<我要开店(点击输入你喜欢的店铺名称)/@@InputString1>\
[@InputString1]
#IF
CHECKMYSHOP
#ACT
MESSAGEBOX 你已经有店铺了
BREAK

#IF
CHECKSHOPNAME <$STR(S1)>
#ACT
MESSAGEBOX <$STR(S1)>店铺名称已经存在，请重新选择一个
BREAK

#IF
#ACT
CREATEMYSHOP <$STR(S1)>

[@CreateMyShopOK]
#SAY
你的店铺创建成功

[@CreateMyShopFail]
#SAY
你的店铺创建失败


攻击触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

QFunction-0

??????
;所有触发只有攻击到怪物才会触发，有些魔法不会触发，如魔法盾
;======================魔法攻击触发==========================
[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
??????
[@MagicAttack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK
#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK
??????
;======================物理攻击触发==========================
[@Struck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
??????
[@Attack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK
#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK


拣物品触发 捡取物品触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：拣物品触发 捡取物品触发

??????
@PickUpItemX X是物品数据库中对应的IDX
??????
[@PickUpItem0]
#IF
#SAY
某某某捡到了一个<$CURRTEMNAME>
??????
[@PickUpItemEx]
#IF
#SAY
某某某捡到了一个<$CURRTEMNAME>

捡取物品的相关常量

<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的
<$CURRTEMMAKEINDEX> | 当前物品MakeIndex序列号


界面帮助按钮触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：界面帮助按钮触发

命令格式

QFunction-0.txt

??????
[@Help]
#SAY
Help


骑马触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

QFunction-0

??????
[@OnHorse]
#SAT
骑马
??????
[@OffHorse]
#SAT
下马


取下身上物品时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：取下身上物品时触发,位置0-18

??????
[@TakeOff0] 0----18
??????
[@TakeOff]
#IF
CheckLevelEx > 0
#SAY
不穿衣服小心感冒!


人物大退触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关
??????
[@PlayOffLine] 人物大退触发


人物当前获得经验触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关
??????
@GetExp

例如:

??????
[@GetExp]
#if
#act
SENDMSG 5 ：人物本次获取经验为:<$GetExp>
break


人物升级触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

脚本文件位于: X:\ETmir2\Mir200\Envir\Market_Def\QFunction-0.txt

??????
;此脚为功能脚本，用于实现各种与脚本有关的功能
;人物升级触发
[@PlayLevelUp]
#ACT
MessageBox 升级


人物死亡时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：人物死亡时触发

??????
[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK


人物小退触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关
??????
[@PlayReconnection] 人物小退触发


扔物品触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：扔物品触发

??????
@DropItemX X是物品数据库中对应的IDX
??????
[@DropItem0]
#IF
#SAY
某某某扔了一个<$CURRTEMNAME>

扔物品的相关常量

<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的


杀死怪物时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：杀死怪物时触发

说明

对应地图参数中需要加入ONKILLMON才可生效!

??????
[@OnKillMob]
#IF
CheckKillMonName 白野猪
#SAY
你杀死一头白野猪!


杀死人物宝宝时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：杀死人物宝宝时触发

??????
[@KillSlave]
#IF
CheckKillSlaveName 月灵
#ACT
SendMsg 5 你把对方的月灵宝宝杀死了.


杀死人物触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关
??????
@KillPlay
??????
;杀人触发
[@KillPlay]
#ACT
MessageBox 你杀人了


套装触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关
??????
@GroupItem

例如：

??????
[@GroupItem0]
#IF
#ACT
SENDMSG 0 圣战套装隐藏属性被激发:攻击上限增加5点!
[@GroupItem1]
#IF
#ACT
SENDMSG 0 法神套装隐藏属性被激发:魔法上限增加5点!
[@GroupItem2]
#IF
#ACT
SENDMSG 0 天尊套装隐藏属性被激发:道术上限增加5点!

套装生效触发[@GroupItemOnX],套装失效触发[@GroupItemOffX],英雄对应[@HeroGroupItemOnX],[@HeroGroupItemOffX] X表示套装编号

套装编号在M2-查看-列表信息二-套装系统-套装编号


外挂触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

QFunction-0脚本里[@UsePlugin]字段

??????
[@UsePlugin]
#ACT
ChangeModeEx 10 10
SENDMSG 6 使用外挂，锁定10秒


物品触发脚本功能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能

双击物品可以自动触发指定脚本功能；

使用方法：
1、物品数据库设置1：STDMODE字段设置为：31
2、物品数据库设置2：AniCount字段设置为：X
X为指字数字触发脚本（1-999）
3、\Mir200\Envir\market_def\QFunction-0.txt下设置

??????
[@StdModeFuncX]
#IF
#ACT
sendmsg 7 触发成功！！！
===================================
注：其中X为物品数据库设置2中的X


占领沙巴克触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：占领沙巴克触发

QFunction-0

??????
[@GetCastleX] X表示城堡编号
??????
[@GetCastle0]
#IF
#SAY
沙巴克已经被占领


指定人物触发字段

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

指定人物触发字段 HCALL 人物名称 触发字段


装备持久消失时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：装备持久消失时触发,位置0-18

??????
[@ItemDamage1]
#IF
#ACT
SendMsg 5 你的武器已经损坏.


装备升级触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

执行脚本功能.升级成功时执行@UpgradeOKX,升级失败时执行@UpgradeFailX,
属性被清除时执行@UpgradeClearX,其中X代表装备位置,例如:衣服=0,武器=1


走路和跑步触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

QFunction-0

??????
[@Run]
#SAT
你在跑步
[@Walk]
#SAT
你在走路


组队时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能：创建小组时触发.

说明：队员的名字放在队长S0变量中.

??????
[@GroupCreate]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了组队.
<$STR(S$0)>.SendMsg 5 你加入了组队.
??????
;在组队前触发
[@StartGroup]
#IF
CheckLevelEx < 25
#ACT
CreateGroupFail
SendMsg 5 25级之后才可以组队.

功能：离开队伍时触发.

说明：被删除的队员名字放在队长的S0变量中.

??????
[@LeaveGroup]
#IF
#ACT
SendMsg 5 你退出了组队.

功能：删除小组成员时触发.

说明：被删除的队员名字放在队长的S0变量中.

??????
[@GroupDelMember]
#IF
#ACT
<$STR(S0)>.SendMsg 5 你被队长踢出了组队!

功能：添加小组成员时触发.

说明：队员名字放在队长的S0变量中.

??????
[@GroupAddMember]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了队伍.
<$STR(S$0)>.SendMsg 5 你加入了队伍.

功能：组队杀死怪物时触发.

??????
[@GroupKillMon]
#IF
#ACT
SendMsg 5 组队杀怪.


购买商铺物品时触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

功能说明: 人物通过商铺购买物品成功时触发(英雄M2).
使用方法: Q-Function.txt中@BuyShopItem脚本段,
购买的物品名字放在人物的S0变量中,物品价格放在M0中.

??????
[@BuyShopItem]
#IF
#ACT
SendMsg 5 %s通过商铺购买了<$STR(S0)>,价格是:<$STR(M0)>


技能触发脚本功能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

增加魔法触发功能.自身技能触发. Q-Function.txt中[@MagSelfFuncX]段,其中X表示要触发的魔法ID
增加魔法触发功能.对目标人物使用时自身触发. Q-Function.txt中[@MagTagFuncX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标人物技能触发. Q-Function.txt中[@MagTagFuncExX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标怪物技能触发. Q-Function.txt中[@MagMonFuncX] 段,其中X表示要触发的魔法ID

脚本示例

??????
使用治愈术时触发脚本
??????
[@MagSelfFunc2]
#ACT
SendMsg 5 自己加血
[@MagTagFunc2]
#ACT
SendMsg 5 给别人加血
[@MagMonFunc2]
#ACT
SendMsg 5 给怪物加血.


英雄当前获得经验触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关
??????
@HeroGetExp

例如:

??????
[@HeroGetExp]
#if
#act
SENDMSG 5 ：英雄本次获取经验为:<$HeroGetExp>
break


英雄上线触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

英雄上线触发 @HeroLogin 注意这个触发是由主人执行的所以对英雄的操作请在前面加H

QManage.txt里的配置脚本

??????
[@HeroLogin]
#if
H.CHECKNAMELIST ..\QuestDiary\数据文件\英雄名单.txt
#act
H.DELSKILL 破魂斩
H.DELSKILL 劈星斩
H.DELSKILL 雷霆一击
H.DELSKILL 噬魂沼泽
H.DELSKILL 末日审判
H.DELSKILL 火龙气焰
H.delnamelist ..\QuestDiary\数据文件\英雄名单.txt
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 恶魔长袍(男) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(男) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 恶魔长袍(女) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(女) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 战神盔甲(男) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(男) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 战神盔甲(女) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(女) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 幽灵战衣(男) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(男) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 幽灵战衣(女) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(女) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break


英雄升级触发

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

英雄升级触发 @HeroLevelUp 这个触发也是由主人执行的所以对英雄的操作请在前面加H

例如:

??????
[@HeroLevelUp]
#IF
#ACT
H.give 金条 2
break


点击小地图自动寻路

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 触发相关

增加点击小地图自动寻路功能(可以在M2关闭或开启该功能，使用小地图按键或M键打开)

寻路QF触发
[@FindPathBegin]  开始
[@FindPathStop]   中断
[@FindPathEnd]    到达


无限血条值-无限血量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 无限血条

无限血条值开启 M2-选项-参数设置-游戏选项(1)

注:开启此选项之后，怪物数据库怪物血量值改为-1时，游戏内怪物血量为42亿！！

2、启用后如何编辑怪物扩展血条数量？

首先打开指定引擎目录\Mir200\Envir\MonGen.txt

把需要扩展叠加血条数量的怪物用以下语法包括住，如下：

??????
; #ET{代表开头，1001是怪物血条叠加的数量，假设这个怪物有10血，设置1001就等于：10 +（10*1001）血值，
最高只能设置2147483647，也就是#ET{2147483647

;中间就跟MonGen.txt格式那样，正常操作，如下
bh23 100 100  狂暴双抓   150  80  30   0 250
bh23 100 100  飞龙圣兽[福利BOSS] 150 1  30 0 253
bh23 100 100  赤炎金猊[高级BOSS] 150 1  120 0 249
bh24 100 100  狂暴双锤   100  50  30 0 253
bh24 100 100  狂暴双抓   150  80  30 0 250
bh24 100 100  飞龙圣兽[福利BOSS] 150 2  30 0 253
bh24 100 100  赤炎金猊[高级BOSS] 150 2  120 0 249
;中间就跟MonGen.txt格式那样，正常操作，如上
;这样怪物血值就会叠加，根据绘制模式进行显示！
#ET}
;代表结束

3、如何使用MonGenEx扩展血条数量？

??????
#act
ET{ 899
;et{ 代表开头 空格 血条数量
MonGenEx 3 330 330 白野猪 12 10 0 255
MonGenEx 3 330 330 双头血魔 12 10 0 255
ET}
;结束引用


脚本设置技能冷却时间

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

脚本修改技能冷却

??????
ETSETSKILLCDTIME

通过脚本使对象技能冷却时间缩短

参数1:技能ID
参数2:方式 0 为减少固定时间 1为减少千分比
参数3:减少时间(毫秒)

??????
[@main]
#if
#act
ETSETSKILLCDTIME 66 0 100000
SendMsg 0 你的开天斩技能冷却已缩短100秒
效果是减少当前技能ID冷却时间，非永久性！！！！！

[@main]
#if
#act
ETSETSKILLCDTIME 66 1 800
SendMsg 0 你的开天斩技能冷却已缩短千分之800
效果是减少当前技能ID冷却时间，非永久性！！！！！

注：不要在烈火，开天，逐日，触发下减对应的CD


开启技能框拖动显示冷却时间

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

开启后进入游戏，打开技能框，拖动已经设置好的技能快捷键出游戏界面即可！


技能开启或关闭右侧公告提示

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 技能相关

修复十步一杀锁定错位

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


技能控制和中断释放技能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关
??????
;触发字段
[@ETBeginMagic]
;变量
<$ETMagicID>
;技能ID
<$ETMagicName>
;技能名称
<$ETMagicTarget>
;目标名称
<$ETMagicTargetRace>
;目标类型0=人物 1=英雄 其他怪物、NPC等
??????
;操作命令
中断技能使用命令:ETStopMagic
??????
范例:
[@ETBeginMagic]
#IF
EQUAL <$ETMagicName> 野蛮冲撞
EQUAL <$ETMagicTargetRace> 0
<$ETMagicTarget>.CHECKTITLE 不动如山
#ACT
ETStopMagic
Sendmsg 7 目标拥有称号不动如山,无法对其释放野蛮冲撞.


获取技能相关信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

功能说明：获取技能信息命令

获取技能信息：

??????
ETGetMagicInfo 技能名称 值类型 变量

值类型：
0：技能等级
1：强化等级
2：技能点数

示范：

??????
[@KTZ]
#ACT
ETGetMagicInfo 开天斩 0 N1
ETGetMagicInfo 开天斩 1 N2
ETGetMagicInfo 开天斩 2 N3
SENDMSG 6 技能等级：<$str(N1)>，强化等级：<$str(N2)>，技能点：<$str(N3)>


拓展技能十步一杀强制越过障碍物

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 技能相关

拓展攻击允许快速野蛮

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


拓展支持鼠标指向定向野蛮

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


拓展快捷键 ALT+D 开关内挂走位刺杀

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


拓展技能十步一杀自动锁定人物

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


脚本设置激活三技能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETActivateSkills

参数一:0烈火 1逐日 2开天
参数二:是否无视CD,1为无视CD,0为模拟激活

??????
;此命令同时受控于-ET反挂配置窗口-客户端功能扩展-三技能控制
;不要在@烈火触发等字段使用,会导致无限循环崩溃


脚本命令释放技能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

脚本命令释放技能

??????
ETReleaseMagic

参数1=释放技能id (支持自定义技能)
参数2=技能外观(暂无用,保留参数)
参数3=技能等级
参数4=强化等级
参数5=是否对自己显示技能效果 (0不播放 1=同屏播放，部分技能自身不播放技能效果时写0，如冰咆哮、纵横剑术等)
参数6=技能目标(0自身 1攻击目标,如:M.ETReleaseMagic)

例子1：释放技能雷电术

??????
;释放一个ID为11的雷电术技能，释放到攻击目标
??????
#ACT
M.ETReleaseMagic 11 0 5 0 1 1

注：只支持以下技能
MagID MagName
1 火球术
2 治愈术
5 大火球
6 施毒术
8 抗拒火环
9 地狱火
10 疾光电影
11 雷电术
13 灵魂火符
14 幽灵盾
15 神圣战甲术
17 召唤骷髅
18 隐身术
19 集体隐身术
20 诱惑之光
21 瞬息移动
22 火墙
23 爆裂火焰
24 地狱雷光
26 烈火剑法
28 心灵启示
29 群体治愈术
30 召唤神兽
31 魔法盾
32 圣言术
33 冰咆哮
34 解毒术
37 群体雷电术
38 诅咒术
39 彻地钉
44 寒冰掌
45 灭天火
47 火龙烈炎
48 气功波
49 净化术
50 无极真气
51 群体施毒术
52 飓风破
55 召唤月灵
55 逐日剑法
57 噬血术
58 流星火雨
58 开天
70 心灵召唤
71 擒龙手
74 分身术
81 纵横剑术
82 十步一杀
83 冰镰术
84 冰霜群雨
85 裂神符
86 死亡之眼


设置技能伤害倍数和Buff

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETSetSkillPower

功能：支持战士攻击类技能

命令：

??????
ETSetSkillPower 参数1 参数2 参数3 参数4 参数5 参数6 参数7

参数详解：
参数1 技能id,同个ID,只能附加一种BUFF(战士技能ID写0时，为普通攻击,25为半月、 26烈火、56逐日、66开天等)
参数2 0=全部,1=玩家,2=怪物
参数3 BUFF属性,1倍数,2麻痹,3冻结,4击退,5吸血,6吸蓝,7红毒,8绿毒,9蛛网,10真实伤害
参数4 触发几率(1~100)
参数5 随机最小值(如果参数3是倍数，这里的值需要乘以100,如果参数3是绿毒、红毒，这里就是毒的持续秒数)
参数6 随机最大值(如果参数3是倍数，这里的值需要乘以100，最大值不能小于最小值，高于或等于均可,如果参数3是绿毒、红毒，这里就是毒的伤害值和破防值)
参数7 持续时间(秒) -1=永久，0就是立马关闭

到时间后触发QFunction-0.txt [@ETSkillPowerTimeOutX] X代表魔法ID
例：

??????
[@main]
#ACT
ETSetSkillPower 13 0 1 70 300 500 120
SendMsg 5 你的灵魂火符有70%几率触发3-5倍伤害，该状态持续2分钟。

QFunction-0.txt
[@ETSkillPowerTimeOut13]
#act
sendmsg 6 你的灵魂火符技能已恢复正常！！！

战士攻击附加属性说明：
#act
;战士技能ID写0时，为普通攻击
ETSetSkillPower 0 0 1 70 300 500 120
sendmsg 6 你的普通攻击有70%几率触发3-5倍伤害，该状态持续2分钟...

;战士技能ID 66 = 开天斩
ETSetSkillPower 66 0 2 50 5 10 120
sendmsg 6 你的开天斩50%几率触发麻痹5-10秒，该状态持续2分钟...


设置技能范围伤害buff

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETRangeHarm

参数1 X坐标
参数2 Y坐标
参数3 范围
参数4 伤害值
参数5 附加效果 0=无，1=击退，2=冻结，3=麻痹，4=吸血，5=吸蓝，6=真实伤害，7=冰冻，8=蛛网效果，9=红毒，10=绿毒
参数6 附加属性值 分别对应 击退距离 冻结时间 麻痹时间 吸血值 吸蓝值 真实伤害值(无限血值时,最高可设置9223372036854775807)
参数7 判断类型 0打击所有目标 1只对人物 2只对怪物
参数8 最大打击数量 0代表范围内所有目标
参数9 是否触发QF 0不触发、1触发，当受到此命令打击的人物(参数4有伤害值才行),触发QF中的[@ETRangeHarmX],X代表附加效果序号
参数10 播放自身特效编号 0代表没有,特效编号,在ET功能窗口一-特效编辑设置

??????
ETRangeHarm <$X> <$Y> 8 100 1 5

当前地图 人物坐标范围8之内所有可以攻击的目标都受到100点伤害，并且被击退5格

无限血值范围秒杀例子

??????
#act
ETRangeHarm <$X> <$Y> 8 1 6 9223372036854775807
;秒杀人物8范围以内一切怪物和人物

所有参数都支持变量
伤害和普通伤害一样，需要考虑目标的防御


自创技能脚本，天神召唤

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETShadowclone

参数一：分身名字
参数二：坐标X
参数三：坐标Y
参数四：最大数量，每次调用只召唤一个，这里是写上限
参数五：时间，默认分钟
参数六：默认0，参数五时间单位为分钟，1秒为单位

例子,创建一个分身，时长十分钟消失

ETShadowclone 我是真的 <$X> <$Y> 10 60 0


设置技能快捷键命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETSETMAGICHOTKEY 参数1 参数2

参数1=技能id 或 技能名字

参数2=技能快捷键(F1~F8:49~56)/(Ctrl+F1~F8:69~76)


获取技能快捷键命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETGETMAGICHOTKEY 参数1 参数2

参数1=技能id 或 技能名字

参数2=变量值

例子：

??????
#act
ETGETMAGICHOTKEY 逐日剑法 N1
sendmsg 6 逐日剑法:<$STR(N1)>
；N1数值表示如下
；(F1~F8:49~56)/(Ctrl+F1~F8:69~76)
；0=没有设置快捷键


使用脚本命令解除中毒效果

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETDETOXIFCATION

例子：

;脚本命令解除红绿毒

??????
#ACT
ETDETOXIFCATION
SENDMSG 5 您中的红绿毒已清除。


封一键三技能，快捷设置

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

设置路径：插件面板→客户端功能拓展一→三技能

设置建议:
有开天斩、逐日、烈火的建议设置1000毫秒起步，以此类推


脚本命令释放技能（无动作）

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETReleaseMagicEx??参数1 参数2 参数3 参数4 参数5 参数6 参数7

参数位置 | 参数说明
参数1 | 参数1=释放技能id
参数2 | 参数2=技能等级
参数3 | 参数3=强化等级
参数4 | 参数4=技能目标(0采用自定义XY 1攻击目标XY,如:M.ETReleaseMagicEx 2自身XY)
参数5 | 参数5=是否播放动画(0全部人 1自身)
参数6 | 参数6=X(参数4为0时,采用此参数)
参数7 | 参数7=Y(参数4为0时,采用此参数)

例子1：释放技能雷电术

释放一个ID为11的雷电术技能，释放到攻击目标

??????
#ACT
M.ETReleaseMagicEx 11 1 1 1 0 0 0


超级开天斩

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

SuperSkySplitter??参数1 参数2 参数3

参数位置 | 参数说明
参数1 | 参数1=开关(1为开启，0为关闭)
参数2 | 参数2=威力倍数(100为1倍,120为1.2倍)
参数3 | 参数3=持续时间(0为不限时间)

例子：

??????
#ACT
SuperSkySplitter 1 1000 0


超级逐日剑法

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETSuperSunChaserSword??参数1 参数2 参数3

参数位置 | 参数说明
参数1 | 参数1=开关(1为开启，0为关闭)
参数2 | 参数2=威力倍数(100为1倍,120为1.2倍)
参数3 | 参数3=持续时间(0为不限时间)

例子：

??????
#ACT
ETSuperSunChaserSword 1 1000 0


全屏火符

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETGROUPSYMBOL??参数1 参数2 参数3 参数4

参数位置 | 参数说明
参数1 | 参数1=开关(1为开启，0为关闭)
参数2 | 参数2=威力倍数(100为1倍,120为1.2倍)
参数3 | 参数3=数量
参数4 | 参数4=持续时间(0为不限时间)

例子：

??????
#ACT
ETGROUPSYMBOL 1 100 10 99999


ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 技能相关

野蛮冲撞

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关


全屏冰镰

项目：ET引擎说明书　分类：ET引擎脚本文档 / 技能相关

ETGroupIceSickle 参数1 参数2 参数3 参数4

参数位置 | 参数说明
参数1 | 参数1=开关(1为开启，0为关闭)
参数2 | 参数2=威力倍数(100为1倍,120为1.2倍)
参数3 | 参数3=数量
参数4 | 参数4=持续时间(0为不限时间)

例子：

??????
#ACT
ETGroupIceSickle 1 100 10 99999


调整技能等级(扩展)

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能

脚本调整技能等级。

命令格式

??????
SKILLLEVEL 魔法名称 调整符(+,-,=) 等级 是否调整强化技能(0或为空时为技能等级,1为强化技能等级)
??????
;==========================================
[@skilllevel0]
#IF
#ACT
SKILLLEVEL 雷电术 = 3
#SAY
你的雷电术等级已经为3级。
;==========================================
;==========================================
;
[@skilllevel1]
#IF
#ACT
SKILLLEVEL 雷电术 + 1
#SAY
你的雷电术等级已经升了1级。
;==========================================
;==========================================
;
[@skilllevel2]
#IF
#ACT
SKILLLEVEL 雷电术 - 1
#SAY
你的雷电术等级已经降了1级。
;==========================================
??????
[@skilllevel3]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重


调整技能点数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能

脚本调整技能点数。

命令格式

??????
CHANGETRANPOINT 控制符(+,-,=) 点数
??????
;==========================================
[@CHANGETRANPOINT]
#IF
#ACT
CHANGETRANPOINT 雷电术 = 100
;==========================================


开启第四个连击技能的命令

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能：开启第四个连击技能的命令

命令格式

??????
无

说明

例：

??????
[@main]
#if
CHECKOPENLASTSKILL
#say
第四个连击技能已经开启
#elseact
OPENLASTSKILL


练习技能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能

脚本增加技能。

命令格式

??????
ADDSKILL 技能名称
??????
;==========================================
;增加技能
[@addskill]
#IF
#ACT
ADDSKILL 雷电术
#SAY
你已经练习雷电术了。
;==========================================

相关命令

删除技能：DELSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL

相关命令页面

  • DELSKILL
  • CHECKSKILL
  • DELNOJOBSKILL
  • CLEARSKILL


删除非本职业的所有技能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能

清除人物非本职业的所有技能。

命令格式

??????
DELNOJOBSKILL
??????
;==========================================
;清除非本职业的所有技能
[@clearskill]
#IF
#ACT
DELNOJOBSKILL
#SAY
你的非法技能已经清除了。
;==========================================

相关命令

练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除所有技能：CLEARSKILL

相关命令页面

  • ADDSKILL
  • CHECKSKILL
  • DELSKILL
  • CLEARSKILL


删除所有技能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能

清除人物的所有技能。

命令格式

??????
CLEARSKILL
??????
;==========================================
;清除所有技能
[@clearskill]
#IF
#ACT
CLEARSKILL
#SAY
你的所有技能已经清除了。
;==========================================

相关命令

练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL

相关命令页面

  • ADDSKILL
  • CHECKSKILL
  • DELSKILL
  • DELNOJOBSKILL


删除指定技能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能

脚本删除指定技能。

命令格式

??????
DELSKILL 技能名称
??????
;==========================================
;删除技能
[@delskill]
#IF
#ACT
DELSKILL 雷电术
#SAY
你的雷电术已删除了。
;==========================================

相关命令

练习技能：ADDSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL

相关命令页面

  • ADDSKILL
  • CHECKSKILL
  • DELNOJOBSKILL
  • CLEARSKILL


在地图上播放魔法效果

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

命令格式

??????
MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数(-1时表示不限制次数) 播放速度(毫秒) 播放效果(0普通 1特效) (该参数值范围0~5，0表示没有亮度，在关闭禁止免蜡时有效)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

??????
[@main]
#ACT
MAPEFFECT 3 333 333 0 0 10 1 300 1 0


在屏幕上播放魔法效果

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

命令格式

??????
SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0=普通，1=魔法效果) 模式(0=自己，1=所有人)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

??????
[@main]
#ACT
SCREENEFFECT 0 0 0 0 10 1 300 0


清除英雄所有技能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

注意：如果清除后英雄技能依然显示存在,那么请更新最新登录器.

??????
#IF
#ACT
ClearHeroAllSkill


新技能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能：新技能(商业版登录器可使用)

命令格式

??????
无

说明：技能数据库设置,请直接使用我们提供的数据库既可

例：

81;纵横剑术;2;56;12;0;0;3;0;0;0;42;50;44;100;46;200;50;400;55;800;60;1600;66;3200;72;6400;79;12800;86;25600;94;51200;103;102400;113;204800;124;409600;136;819200;0;;3;
82;十步一杀;2;57;12;0;0;3;0;0;0;42;50;44;100;46;200;50;400;55;800;60;1600;66;3200;72;6400;79;12800;86;25600;94;51200;103;102400;113;204800;124;409600;136;819200;0;;3;
83;冰镰术;2;58;12;15;19;30;16;16;1;35;50;37;100;40;200;44;400;48;800;52;1600;57;3200;62;6400;68;12800;74;25600;81;51200;89;102400;97;204800;106;409600;116;819200;60;;3;
84;冰霜群雨;2;59;12;15;19;30;16;16;1;35;50;37;100;40;200;44;400;48;800;52;1600;57;3200;62;6400;68;12800;74;25600;81;51200;89;102400;97;204800;106;409600;116;819200;60;;3;
85;裂神符;8;70;5;30;40;10;20;20;2;18;50;21;100;24;200;26;400;28;800;30;1600;33;3200;36;6400;39;12800;42;25600;46;51200;50;102400;55;204800;60;409600;66;819200;60;;3;
86;死亡之眼;2;71;5;30;40;10;20;20;2;18;50;21;100;24;200;26;400;28;800;30;1600;33;3200;36;6400;39;12800;42;25600;46;51200;50;102400;55;204800;60;409600;66;819200;60;;3;


英雄合击技能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

功能：技能

命令格式

??????
无

说明：技能数据库设置,请直接使用我们提供的数据库既可

例：

60;破魂斩;4;3;1;60;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
61;劈星斩;4;3;1;61;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
62;雷霆一击;4;3;1;62;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
63;噬魂沼泽;4;3;1;63;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
64;末日审判;4;3;1;64;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
65;火龙气焰;4;3;1;65;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;


技能备注功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

技能备注功能

在传奇客户端 Data\SkillDesc.dat 可以使用记事本打开编辑


内功系统

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物

物品DB：
(金牛装备：需等级 同时可内力恢复速度)
DB设置：
Need=18(表示穿戴需等级，装备可提高内力恢复速度) NeedLevel=50(等级条件) Stock=3(提高内力恢复速度)
Need=19(表示穿戴需攻击力，装备可提高内力恢复速度%) NeedLevel=50(攻击力条件) Stock=3(提高内力恢复速度%)
Need=20(表示穿戴需魔法，装备可提高内力恢复速度%) NeedLevel=50(魔法条件) Stock=3(提高内力恢复速度%)
Need=21(表示穿戴需道术，装备可提高内力恢复速度%) NeedLevel=50(道术条件) Stock=3(提高内力恢复速度%)
Need=22(表示穿戴需等级，装备可提高内力恢复速度+点) NeedLevel=50(等级条件) Stock=3(每次可提高内力值)
Need=23(表示穿戴需攻击力，装备可提高内力恢复速度+点) NeedLevel=50(攻击力条件) Stock=3(每次可提高内力值)
Need=24(表示穿戴需魔法，装备可提高内力恢复速度+点) NeedLevel=50(魔法条件) Stock=3(每次可提高内力值)
Need=25(表示穿戴需道术，装备可提高内力恢复速度+点) NeedLevel=50(道术条件) Stock=3(每次可提高内力值)

脚本命令：
功能:学习内功
格式:READSKILLNG

说明:
1.判断玩家是学过内功,学过则进入@ReadNGFail,英雄则进入@ReadNGHeroFail
2.学习成功进入@ReadNGOK,英雄则进入@ReadNGHeroOK
3.主号学习过后,英雄才能学习

功能: 清除人物的经络等级.
格式: ClearAllPulse

功能:调整内力经验点数。
格式:CHANGENGEXP 控制符(=,+,-) 经验点数

功能:检查是否学过内功
格式:CHECKREADSKILLNG

功能:检查内功等级
格式:CHECKNGLEVEL 操作符 (<,>,=) 等级数(1-255)

功能:调整内功等级
格式:CHANGENGLEVEL 控制符(=,+,-) 等级数(1-255)


强化技能功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

强化技能功能

使用脚本命令调整强化技能等级，威力和效果会有变化

[@调整冰咆哮强化技能等级]
#IF
CHECKSKILL 冰咆哮 = 0   1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重


飞剑术

ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 技能相关

飞剑术脚本(使用脚本或数据库添加技能召唤飞剑)

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关
飞剑术PAK密码etmir2: 点击下载

飞剑术技能ID=118;飞剑术;2;56;12;0;0;3;0;0;0;42;50;44;100;46;200;50;400;55;800;60;1600;66;3200;72;6400;79;12800;86;25600;94;51200; 103;102400;113;204800;124;409600;136;819200;0;;3;

命令：OPENFLYINGSWORD

参数位置 | 参数说明
参数1 | 飞剑数量 (1~4)
参数2 | 持续秒数 (填写 0 永久开启直到脚本关闭或人物死亡)
参数3 | 攻击次数 （找到目标后，这一轮连续攻击多少次）
参数4 | 攻击延迟 （每次出剑到造成伤害的时间同时决定客户端飞行路径时间）
参数5 | 伤害倍率 (每把剑造成的伤害倍率; 100 是普通攻击的100%)
参数6 | 出剑间隔 (一轮攻击结束后，多少毫秒再次出剑)
参数7 | 攻击范围 （自动寻找这个范围内的目标，不能超过服务端可视范围）
参数8 | 目标模式 （0~6）
参数9 | 分配模式 （0~3）
参数10 | 目标类型 （0~2 0：人物 1：怪物2：所有目标）

命令：CLOSEFLYINGSWORD 关闭飞剑

命令：CHECKFLYINGSWORD 飞剑技能是否开启中

参数8：目标模式

数值 | 模式 | 实际行为
0 | 锁定攻击 | 优先攻击人物当前目标；没有当前目标时选择最近目标；锁定后持续攻击
1 | 轮换目标 | 每轮按照可见目标列表轮流更换攻击目标
2 | 追击最近 | 每次攻击重新选择当前最近目标；飞剑留在目标附近连续衔接下一次攻击
3 | 集中连击 | 所有飞剑锁定同一个目标；飞剑留在目标附近连续攻击
4 | 随机攻击 | 每次重新随机选择目标；飞剑留在目标附近连续飞行
5 | 单剑车轮 | 每次只派出一把剑，四把剑轮流攻击；攻击完成后返回人物
6 | 全剑突袭 | 当前所有飞剑同时攻击一次，然后返回人物；攻击次数按照该模式固定处理

目标模式 0、1、5：
每次命中后会先返回人物，再进行下一次攻击。

目标模式 2、3、4：
不会每次返回人物，而是在目标附近继续飞行并衔接下一次攻击。

数值 | 分配方式 | 实际行为
0 | 顺序分配 | 第一把剑攻击主目标，后面的剑按照目标列表依次分配
1 | 集中一人 | 所有出剑都攻击同一个目标
2 | 每剑随机 | 每把剑单独随机选择目标，可能重复攻击同一目标
3 | 尽量分散 | 尽量让每把剑攻击不同目标；目标不足时允许重复攻击

目标模式 3：
会强制使用命中分配 1，也就是所有飞剑集中攻击一个目标。

??????
[@main]
#if
#act
OPENFLYINGSWORD 4 60 100 1500 150 3000 8 4 2
SendMsg 0 召唤4把飞剑成功，持续60秒

[@main]
#IF
CHECKFLYINGSWORD
#ACT
SENDMSG 6 飞剑当前已经开启！
#ELSEACT
SENDMSG 6 飞剑未开启！


空气扰动

ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 技能相关

设置指定技能空气扰动

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关
空气扰动PAK密码etmir2: 点击下载

命令：SKILLDISTORTION 技能ID 是否开启

??????
参数说明：
技能ID	支持的技能编号
是否开启1=开启，0=关闭
支持的技能：
技能ID	技能
1	火球术
13	灵魂火符
14	幽灵盾
15	神圣战甲术
22	火墙
26	烈火剑法
56	逐日剑法
58	流星火雨
66	开天斩
??????
[@main]
#ACT
SKILLDISTORTION 26 1
sendmsg 7 已开启烈火扰动


雷电术辐射/树状雷电

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关
雷电术辐射/树状雷电PAK密码etmir2: 点击下载

命令：OPENLIGHTNINGTREE 分支范围 每层分支数 允许目标重叠 每层伤害降低 最大深度

参数位置 | 参数说明
参数1 | 分支范围 （1～20格）
参数2 | 每层分支数 (1～100)
参数3 | 允许目标重叠 （ 0=同一层尽量不重复 1=允许不同分支命中同一目标）
参数4 | 每层伤害降低 （每层伤害降低：0～100 %）
参数5 | 最大深度 (1～100层)

命令：CLOSELIGHTNINGTREE 关闭雷电术辐射/树状雷电

命令：CHECKLIGHTNINGTREE 雷电术辐射/树状雷电技能是否开启中

??????
[@main]
#if
#act
OPENLIGHTNINGTREE  5 2 0 20 3
SendMsg 0 雷电术命中后，每个节点在5格内分出2条雷电，同层不重复目标，每深入一层降低20%伤害，最多3层。

[@main]
#IF
CHECKLIGHTNINGTREE
#ACT
CLOSELIGHTNINGTREE
SENDMSG 6 已关闭雷电术辐射！
#ELSEACT
SENDMSG 6 雷电术辐射未开启！


剑刃风暴

ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 技能相关

剑刃风暴脚本(使用脚本或数据库添加技能剑刃风暴)

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关
剑刃风暴PAK密码etmir2: 点击下载

剑刃风暴技能ID=120;剑刃风暴;2;56;12;0;0;3;0;0;0;42;50;44;100;46;200;50;400;55;800;60;1600;66;3200;72;6400;79;12800;86;25600;94;51200; 103;102400;113;204800;124;409600;136;819200;0;;3;

命令：SETBLADESTORM 伤害范围 风暴效果 是否旋转对象 攻击对象 伤害倍率 移动模式

参数位置 | 参数说明
参数1 | 伤害范围 （1～服务器最大视野范围）
参数2 | 风暴效果 (0初级 / 1中级 / 2高级)
参数3 | 是否旋转对象 （ 0不旋转 / 1旋转）
参数4 | 攻击对象 （0人物和英雄 / 1怪物 / 2所有目标 注：人物不会被旋转）
参数5 | 伤害倍率 (1～1000 百分比)
参数6 | 移动模式 (0只允许走 / 1只允许跑 / 2走跑均可)

命令：CLOSEBLADESTORM 关闭剑刃风暴

??????
[@main]
#if
#act
SETBLADESTORM  6 2 1 2 200 2
SendMsg 0 开启高级剑刃风暴：对自身周围 6 格内的人物、英雄及怪物等所有目标并造成 200% 伤害倍率，技能发动期间角色走跑都可以且怪物会跟随风暴旋转。

[@main]
#IF
#ACT
CLOSEBLADESTORM
SENDMSG 6 已关闭剑刃风暴！


查看指定玩家装备

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETQUERYUSERSTATE 参数1

参数1 = 玩家名字

例子：

??????
#act
ETQUERYUSERSTATE 玩家名字


通过脚本删除角色物品

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
ETDELUSERITEM    ;删除角色物品
??????
通过脚本删除角色物品

参数1:物品名 (当参数3为1时,物品名支持模糊匹配.如 圣战*，支持时装首饰装备)
参数2:系列号 (不指定物品ID填写0)
参数3;模糊匹配 1为使用
参数4;0为全部 1为背包 2为身上
??????
[@main]
#if
#act
ETDelUserItem 圣战项链 0 0 1
SendMsg 0 你的背包中圣战项链已删除
[@main]
#if
#act
ETDelUserItem 圣战* 0 1 0
SendMsg 0 你的身上及背包中所有圣战系列装备已删除


背包宝石拖动人物身上装备栏升级

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

背包宝石拖动人物身上装备栏升级

使用宝石升级或鉴定

宝石物品shape值需要等于255，方可拖到到身上装备触发,暂不支持时装装备扩展！

通过脚本命令实现装备升级，只需将物品放到身上装备上即可。

??????
[@ETBSClickUserItem*]   QF触发这个字段 *代表装备位置 0-16
??????
ETCLICKFAIL 用于返回鼠标选中的物品到背包（一般条件不满足时使用）
ETDELETEBS 用于强化后删除该物品 （一般升级完成或者升级失败后使用）
<$STR(S$ETCLICKNAME)> 变量 显示当前使用宝石或升级材料名称。
<$STR(S$ETCLICKWHERE)> 变量 显示当前所指装备位置。

装备位置:

??????
;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================
??????
QF中触发脚本示例
[@ETBSClickUserItem0]
#if
equal <$STR(S$ETCLICKNAME)> 防御之石+20
;记得要判断下名字，防止玩家拉其他物品到这，你不判断就升级！
CHECKGAMEGOLD > 2000
#act
SetNewItemValue <$STR(S$ETCLICKWHERE)> 0 + 10
ETDELETEBS  // 删除该强化所用的宝石，记得成功后调用，防止被卡
sendmsg 6 装备升级成功 暴击率加10
#elseact
ETCLICKFAIL  // 此命令代表升级失败 物品返回到背包 或者也可以改成扣除物品 不返回
sendmsg 6 装备升级失败,宝石名称：:<$STR(S$ETCLICKNAME)>，身上序号：<$STR(S$ETCLICKWHERE)>


删除满足条件的聚灵珠

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
ETTakeMineEX       ;删除满足条件的聚灵珠
参数1 聚灵珠名称
参数2 数量
参数3 聚灵珠经验
??????
[@测试]
#IF
ETCheckMineEX 聚灵珠(小) 5 20
#ACT
ETTakeMineEX 聚灵珠(小) 5 20
#SAY
回收5个满20w经验的聚灵珠(大)成功。
#ELSESAY
没有可以回收的聚灵珠(大)。
??????
ETTAKEDURAITEM
 参数1 物品名
 参数2是否聚满(0=未满的，1=已满的)
 参数3 数量
??????
[@main]
#IF
ETCHECKITEMDURACOUNT 聚灵珠(大) 1 > 9
#ACT
ETTAKEDURAITEM 聚灵珠(大) 1 10
#SAY
回收聚灵珠(大)成功。
#ELSESAY
没有可以10个聚满经验的聚灵珠(大)。


给与满经验的聚灵珠

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
ETGiveFullBead    ;给予满经验的聚灵珠
给予指定数量满经验的聚灵珠
参数1 聚灵珠名称
参数2 数量
??????
[@聚灵珠]
#if
#act
ETGIVEFUllBEAD 聚灵珠(小) 5
Sendmsg 给你5个聚满经验的`聚灵珠(大)
break


脚本设置人物、怪物顶戴花翎特效

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

脚本设置人物、怪物头顶称号特效

ETSetIconEx

参数1=(0=人物 1=当前人物攻击的对象 2=宝宝)
参数2=此参数默认为0 当参数1=2时 指定某个宝宝的名字 ALL=所有宝宝
参数3=位置(0-255)
参数4=WIL文件序号
参数5=图片序号(0-65535)
参数6=X
参数7=Y
参数8=播放张数
参数9=播放效果(0普通 1特效)
参数10=播放速度(毫秒)
参数11=是否只有自己看见(0=所有人都可以看见 1=仅仅自己可以看见)
参数12=生效时间，单位秒，-1等于无限，0等于关闭（例生效时间填写10秒 ，参数十二填写 10|1 即为新算法格式，不加|1老算法 ）

1、给刷怪怪物添加永久特效

首先打开指定引擎目录\Mir200\Envir\MonGen.txt

把需要扩展的怪物用以下语法包括住，如下：

#ETSetIconEx{WIL文件序号 图片序号 X Y 播放张数 播放效果 播放速度
;#ETSetIconEx{代表开头，参数之间使用空格分割,共7个参数。
;中间就跟MonGen.txt格式那样，正常操作，如下
bh23 100 100 狂暴双抓 150 80 30 0 250
bh23 100 100 飞龙圣兽[福利BOSS] 150 1 30 0 253
bh23 100 100 赤炎金猊[高级BOSS] 150 1 120 0 249
bh24 100 100 狂暴双锤 100 50 30 0 253
bh24 100 100 狂暴双抓 150 80 30 0 250
bh24 100 100 飞龙圣兽[福利BOSS] 150 2 30 0 253
bh24 100 100 赤炎金猊[高级BOSS] 150 2 120 0 249
;中间就跟MonGen.txt格式那样，正常操作，如上
;这样怪物就会播放你设定的特效
#ETSetIconEx}

;代表结束

2、脚本命令刷怪如何设置怪物特效

ETSetIconEx{ WIL文件序号 图片序号 X Y 播放张数 播放效果 播放速度
;ETSetIconEx{代表开头，参数之间使用空格分割,共7个参数。
MonGenEx 3 330 330 白野猪 12 10 0 255
MonGenEx 3 330 330 双头血魔 12 10 0 255
;引擎刷怪命令
ETSetIconEx}
;代表结束
无限血怪物顶戴用法格式（无限血参数在外面）:
#ET {13888
#ETSetIconEx{74 30 25 0 10 0 200
猪洞1 33 33 白野猪 200 5 10 0 0
猪洞1 33 33 白野猪 200 5 10 0 0
#ETSetIconEx
#ET}


脚本设置人物外观、装备外观、时装外观

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

自定义人物装备外观，时装外观，武器外观

1、ETSETITEMSHAPE
2、ETSETHUMANSHAPE
3、ETSHOWFASHION

【一】
命令：ETSETITEMSHAPE
说明：设置装备外观（0=衣服 1=武器 2=斗笠 10=时装衣服 11=时装武器）
注意：对应的装备需要佩戴

??????
[@main]
#act
ETSETITEMSHAPE 0 4
;你当前衣服shape更改为4
ETSETITEMSHAPE 1 6
;你当前武器shape更改为6
ETSETITEMSHAPE 2 8
;你当前斗笠shape更改为8

【二】
命令：ETSETHUMANSHAPE
说明：设置人物外观（0=衣服 1=武器 2=斗笠）
注意：设置人物外观后原衣服、武器、斗笠外观失效

??????
[@main]
#act
ETSETHUMANSHAPE 0 4
;人物外观衣服shape更改为4
ETSETHUMANSHAPE 1 6
;人物外观武器shape更改为6
ETSETHUMANSHAPE 2 8
;人物外观斗笠shape更改为8

【三】
命令：ETSHOWFASHION
说明：外显时装
注意：控制人物的时装显示状态

??????
[@main]
#act
ETSHOWFASHION 1
;开启外显时装
[@main]
#act
ETSHOWFASHION 0
;关闭外显时装


脚本控制人物、上马、下马

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

例子1

??????
#act
ETOFFHORSE
;下马

例子2
#act
ETONHORSE
;骑马


脚本设置人物临时属性

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

人物临时属性命令
说明：ET新增临时属性命令，增加了属性索引参数，更方便GM编写功能增加人物属性功能。

ETChangeHumAbility 参数1 参数2 参数3 参数4

参数位置 参数说明
参数1 属性索引
参数2 属性类型(1-40)最大支持21亿,HP、MP最大值支持42亿
参数3 操作符(+ 、- 、=)
参数4 数值
参数5 时效(秒) 时间到了自动消除当前索引属性

??????
[@测试1]
#IF
CHECKLEVELEX > 0
#ACT
ETChangeHumAbility 0 5 + 100
ETChangeHumAbility 0 6 + 100
SENDMSG 5 临时属性索引为0，人物临时属性攻击增加100-100
break
??????
[@测试2]
#IF
CHECKLEVELEX > 0
#ACT
ETChangeHumAbility 1 1 + 100
ETChangeHumAbility 1 2 + 100
SENDMSG 5 临时属性索引为1，人物临时属性防御增加100-100
break

清除指定临时属性命令

??????
ETCLEARHUMABILITY 参数1

参数位置 参数说明
参数1 属性索引

??????
[@测试]
#IF
CHECKLEVELEX > 0
#ACT
ETCLEARHUMABILITY 0
SENDMSG 5 临时属性索引为0的属性全部清除
break

获取执行属性索引的临时属性值
常量 说明

??????
<$ETHUMABILITY[X].VALUE(Y)>    X:属性索引， Y:属性类型
??????
[@测试]
<$ETHUMABILITY[0].VALUE(5)>   //获取人物属性索引为0所附加攻击下限值
<$ETHUMABILITY[0].VALUE(6)>   //获取人物属性索引为0所附加攻击上限值
<$ETHUMABILITY[1].VALUE(1)>   //获取人物属性索引为1所附加防御下限值
<$ETHUMABILITY[1].VALUE(2)>   //获取人物属性索引为1所附加防御上限值

属性类型参照表
属性参数 参数说明
1 防御下限
2 防御上限
3 魔御下限
4 魔御上限
5 攻击下限
6 攻击上限
7 魔法下限
8 魔法上限
9 道术下限
10 道术上限
11 最大生命值
12 最大魔法值
13 HP恢复
14 MP恢复
15 中毒恢复
16 中毒躲避
17 魔法躲避
18 准确
19 敏捷
20 幸运
21 暴击几率增加
22 增加攻击伤害
23 物理伤害减少
24 魔法伤害减少
25 忽视目标防御
26 所有伤害反弹
27 增加目标暴率
28 人物体力增加
29 人物魔力增加
30 怒气恢复增加
31 合击攻击增加
32 扩展元素一
33 扩展元素二
34 扩展元素三
35 扩展元素四
36 扩展元素五
37 扩展元素六
38 扩展元素七
39 扩展元素八
40 扩展元素九


脚本设置人物主动暴击次数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
ETSETBASHEX   ;参数1:主动暴击的次数
$ETBASHEXCOUNT;暴击剩余有效的次数，每次触发暴击，将会扣减次数
??????
#act
ETSETBASHEX 10
;设置暴击次数

;暴击前触发，需要在脚本触发和功能扩展(二)勾选选项方会生效，具体查看触发脚本类
??????
[@ETBeforeCritTrigger]
#IF
LARGE <$ETBASHEXCOUNT> 0
#ACT
sendmsg 6 暴击触发，剩余主动暴击次数为：<$ETBASHEXCOUNT>
Break
#ELSEACT
;---------------------拦截暴击触发使用方法，这里屏蔽！！！
ETReturn
sendmsg 6 暴击触发，剩余主动暴击次数为：<$ETBASHEXCOUNT>。触发失败。


脚本设置锁定人物最高等级

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETSETLOCKLEVEL

参数一:锁定等级

一般在QM里使用，每次登录都要设置！

QM

??????
[@login]
#act
ETSETLOCKLEVEL 47
sendmsg 6 锁定人物等级最高47！

QF

??????
[@关闭锁定等级]
#act
ETSETLOCKLEVEL 0
sendmsg 6 已关闭锁定人物等级！


脚本修改客户端显示窗口标题

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETSENDCLIENTTITLEMSG

参数1：内容

??????
改写例子
#act
ETSENDCLIENTTITLEMSG ETmir2

清空例子
#act
ETSENDCLIENTTITLEMSG

注：需要在反挂加载后使用，请在[@ET反挂加载] 里调用，具体查看触发脚本类


扔物品和穿戴取下关联LINKPICKUPITEM

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

LINKPICKUPITEM脚本命令
功能：可以对捡取的物品进行关联，该命令只能在捡取触发里[@PickUpItemX]、[@DropItemX]、[@TakeOffX]使用

??????
[@TAKEOFFX]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚取下的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
;修改后的参数，刷新到客户端
SENDUPGRADEITEM
??????
[@DropItemX]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚丢弃的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
;修改后的参数，刷新到客户端
SENDUPGRADEITEM


GIVE给与物品关联LINKPICKUPITEM

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

注：只支持装备物品等触发，可叠加的物品无法触发！！！！

??????
[@ETGIVE]
#ACT
SENDMSG 6 当前GIVE制造的物品名称：<$CURRTEMNAME>
;<$CURRTEMNAME> 引擎自带的常量，还有其他就不列举。

LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚制造的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
;修改后的参数，刷新到客户端
SENDUPGRADEITEM


脚本设置物品ID关联到OK框中

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETBAGITEMMAKEINDEX

参数1:物品唯一ID

参数2:自定义OK框编号(0~7)

参数3:允许放入的物品类型。DB库的StdMode值，如果有多个使用“,”隔开，如果为“*”时，允许所有物品(这里不能为空，按需求填写，否则会被判定非法OK框)

请在NPC脚本中触发，如成功触发@ItemIntoBoxX，和引擎一致，但客户端OK框无法进行刷新，用户可以不设置OK框脚本！


创建定时器。销毁定时器

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

功能：
个人定时器。

格式：

??????
ETSETONTIMER 定时器索引编号(0-30) 定时间隔（单位为毫秒）
ETSETOFFTIMER 定时器索引编号(0-30) //停止定时器
??????
设置定时器
[@Test]
#IF
#ACT
ETSetOnTimer 10 100

QF
[@ETOnTimer10]
#ACT
SendMsg 5 你目前位于%m的(%x：%y)
;==========================================
;==========================================
停止定时器
[@Test]
#IF
#ACT
ETSetOffTimer 10


输出显示文本内容到引擎主面板信息框

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETMAINOUTMESSAGE

参数1:输出的内容

???
#ACT
ETMAINOUTMESSAGE 这里是需要输出的信息，显示在引擎信息框。


解除人物buff效果

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETDETOXIFCATIONEX

参数1 DEBUFF类型(1:绿毒 2:红毒 3:麻痹 4:冰冻 5:蜘蛛)
参数2 0或1(省略时默认为0，为1时宝宝解毒）

例子

??????
#IF
CHECKLEVELEX > 0
#ACT
ETDETOXIFCATIONEX 1 1
SENDMSG 5 您和您的宝宝解除了绿毒效果


使用脚本开启快捷键锁定人物

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETOPENLOCK 1

??????
首先后台勾选功能，然后再调用脚本命令开启
例子
#act
ETOPENLOCK 1
然后进入游戏，打开F12内挂-战斗，就可以看见效果图


循环判断指令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

1、请在#act下使用，如果条件设置有问题，会导致一直循环，请注意语法使用

??????
ETwhile 循环开始 支持嵌套
ETendwhile 循环结束 支持嵌套
ETexitwhile 跳出循环 支持嵌套

循环头命令:

命令 ETwhile

参数位置 | 参数说明
参数1 | 变量
参数2 | 检测符号
参数3 | 判断参数
参数4 | 自增（为-则自减）仅对参数1为变量时生效。

循环尾命令(用于标记循环尾): 命令 ETexitwhile

参数位置 | 参数说明
参数1 | 变量
参数2 | 检测符号
参数3 | 判断参数

使用方法(请注意逻辑，有误，会导致一直卡M2，插件未必会提示的！)：

这里可以设置循环上限次数，防止一些意外的情况，根据自己情况设定数值，默认为0，不生效！

#待插入图片

嵌套循环例子:

??????
[@main]
#act
mov N0 5
mov N1 5

ETwhile N0 > 1 -1
sendmsg 7 n0循环=<$STR(N0)>.

ETwhile N1 > 1 -1
sendmsg 7 n1循环=<$STR(N1)>.

ETendwhile 跳出n1循环
sendmsg 7 n1循环执行完毕

ETendwhile
sendmsg 7 n0循环执行完毕

跳出循环例子:

??????
[@main]
#act
mov N0 5

ETwhile N0 > 1 -1
sendmsg 7 n0循环=<$STR(N0)>.

ETexitwhile N0 = 3
;N0等于3的时候结束循环的作用

ETendwhile
sendmsg 7 n0循环执行完毕


设置循环脚本运行次数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETLoopGoto

ETLoopgoto @脚本 脚本运行次数（为空或0时，运行1次,1就运行一次,100就运行100次）

例子：

??????
[@循环]
#ACT
mov N1 0
mov N2 1
ETLoopgoto @运算 100
sendmsg 6 1加到100的结果为：<$STR(N1)>

[@运算]
#ACT
Inc <$STR(N1)> <$STR(N2)>
Inc N2 1


人物切割命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

百分比切割

DelMonHp

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2::以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0都切割 1:本次切割只切割角色 2:本次切割只切割英雄 3:本次切割只切割怪物

参数5=分母基数(<=100等于100)

参数6=是否播放切割动画(空或0不播放,1播放)

??????
例子1：
#ACT
；本次切割只切割怪物10点HP
DELMONHP 10 1 0 3

例子2：

#ACT
；本次切割只切割人物当前血量百分之8
DELMONHP 8 0 0 1

例子3：

#ACT
；本次切割只切割人物当前血量千分之8
DELMONHP 8 0 0 1 1000

例子4:
#ACT
；本次切割只切割人物当前血量千分之8,并播放切割特效
DELMONHP 8 0 0 1 1000 1

范围百分比切割

DelMonHpEx

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2:以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0以自身范围 1以攻击目标范围

参数5=X坐标

参数6=Y坐标

参数7=范围

参数8=0都切割 1:本次切割只切割角色，2:本体切割只切割英雄，3:本次切割只切割怪物。

参数9=分母基数(<=100等于100)

参数10=是否播放切割动画(空或0不播放,1播放)

参数11=判断怪物等级(运算符 < > =. =0不判断，其他数值的话。怪物等级接按照运算符参数进行切割)

??????
例子1：
#ACT
;切割自身1格坐标范围的怪物10/100 HP
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3

例子2：

#ACT
;切割自身1格坐标范围的怪物10/1000 HP
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3 1000

例子3:

#ACT
;切割自身1格坐标范围的怪物10/1000 HP,并播放切割特效
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3 1000 1 >50


人物范围切割命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

范围百分比切割

DelMonHpEx

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2:以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0以自身范围 1以攻击目标范围

参数5=X坐标

参数6=Y坐标

参数7=范围

参数8=0都切割 1:本次切割只切割角色，2:本体切割只切割英雄，3:本次切割只切割怪物。

参数9=分母基数(<=100等于100)

参数10=是否播放切割动画(空或0不播放,1播放)

参数11=判断怪物等级(运算符 < > =. =0不判断，其他数值的话。怪物等级接按照运算符参数进行切割)

??????
例子1：
#ACT
;切割自身1格坐标范围的怪物10/100 HP
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3

例子2：

#ACT
;切割自身1格坐标范围的怪物10/1000 HP
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3 1000

例子3:

#ACT
;切割自身1格坐标范围的怪物10/1000 HP,并播放切割特效
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3 1000 1 >50


脚本命令修改账号密码信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

需搭配最新版ET防扫号网关和文件,方可使用此功能！

??????
[@修改账号密码信息]
#ACT
ETChangeAccountInfo 账号 密码 用户名 生日 提问1 回答1 提问2 回答2
ETChangeAccountInfo 888888 778899 6月1日购买 2021/06/01 1 2 3 4
ETChangeAccountInfo 脚本执行前要检测玩家输入是否完整，资料长度是否符合要求，
生日格式是否符合要求，再执行修改;生日这块填写如果是1988/1/1,会被插件修改成1988/01/01

触发QF

??????
[@ETChangeAccountInfoOK]
账号信息修改成功！
??????
[@ETChangeAccountInfoError]
账号不正确或提交的密保不完整！
??????
[@ETChangeAccountInfoBusy]
同一时间不允许多个账号修改，请几秒后重试…
??????
[@ETChangeAccountInfoError1]
防扫号网关未正确安装、启动或未使用最新版
??????
[@ETChangeAccountInfoError2]
未知原因修改失败


动态设置特殊属性脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ChangeSP

参数1：特殊属性编号 0=神秘人 1=传送 2=麻痹 3=防麻痹 4=复活 5=破复活 6=护身 7=防护身 8=技巧 9= 探测

10= 复活成功率(默认100,复活成功率0~100)
11= 麻痹几率(1~100,默认100,0也是100)
12= 防麻痹几率(1~100,默认100,0也是100)
13= 破复活几率(1~100,默认100,0也是100)
14=破护身几率(1~100,默认100,0也是100)

所有带几率的属性，如想其发挥作用,前者必须带有此属性效果,如装备带有相同属性的效果,尽量避免使用。

参数20=对怪隐身

参数21=防暴击

参数2: 0=关闭 1=开启

参数3: 持续时间 单位秒 参数0或空=无限制，参数大于0为时长，(参数1是10、11、12、13、14时,此参数3变为几率控制)

注意事项：此命令下线失效，有特殊属性的装备并不会冲突,也不会因为冲突导致失效,但应注意使用逻辑，不支持假人！！！！

场景1:带复活戒指的人物且开启了复活属性10秒，十秒复活到达后，带有复活戒指情况下，是会继续复活的，两者是不冲突

场景2:带复活戒指的人物且开启了复活属性10秒，十秒未到达前,卸掉了复活戒指，此时复活属性依然有效，除非你关闭了。

复活成功率:在原复活基础下进行判断，满足原基础复活条件下，进行几率判断，几率不满足的取消复活。

注:关闭指定属性编号,效果会立即取消，如关闭神秘人属性就会立即取消神秘人效果。

多次调用同一个属性编号，参数取最后调用，如前者设置了1000秒防复活，后者设置了10秒防复活，最终生效时间取后者(10秒，持续时间设置为0时效率最优且一直生效)。

此命令充分分析了引擎运行机制，采用最优方案进行贴合设计，效率和设计快捷性达到最完美。

到时间后触发QFunction-0.txt [@ChangeSPTimeOutX] X代表属性编号,不提供参数1的10、11、12、13、14模式的触发

赋予玩家防暴击属性

??????
#ACT
ChangeSP 21 1 10
sendmsg 6 激活防暴击十秒

[@ChangeSPTimeOut21]
#act
sendmsg 6 防暴击失效！！！！！！！！！

赋予玩家复活成功几率(前者必须有复活属性,无时间控制,无时间到期反馈)

??????
#ACT
ChangeSP 10 1 50
sendmsg 6 您的复活成功率更改为百分之50

赋予玩家防复活属性

#ACT
ChangeSP 5 1 10
sendmsg 6 防复活特殊属性生效，持续10秒。

QFunction-0.txt 任意位置添加

[@ChangeSPTimeOut5]
#act
sendmsg 6 防复活属性失效！！！

对怪隐身

#ACT
ChangeSP 20 1 10
sendmsg 6 对怪隐身生效，持续10秒。

QFunction-0.txt 任意位置添加

[@ChangeSPTimeOut20]
#act
sendmsg 6 对怪隐身失效！！！


脚本设置攻击倍数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

脚本设置伤害倍数

ETChangeDamage

功能：改变人物对怪物对其他人物的最终伤害倍数

命令：

ETChangeDamage 参数1 参数2 参数3

参数详解:

参数1=0全部,1=玩家,2=怪物

参数2=威力倍数 (威力倍数默认100 除以100 = 真实倍数，如200表示2倍)

参数3=持续时间(秒) -1=在线一直有效

到时间后触发QFunction-0.txt [@ETChangePowerTimeOutX]

例：

??????
[@main]
#ACT
ETChangeDamage 1 200 120
ETChangeDamage 2 500 180
SendMsg 5 你对杀怪物的最终伤害为5倍，持续3分钟！对人物的最终伤害为2倍，持续2分钟！

QFunction-0.txt
[@ETChangePowerTimeOut1]
#act
sendmsg 6 你对人物的倍攻已恢复正常！！！

[@ETChangePowerTimeOut2]
#act
sendmsg 6 你对怪物的倍攻已恢复正常！！！


脚本命令设置人物禁止移动buff

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

可用于写buff，定身、之类的

ETNOWALK

禁止人物移动

参数一 1开启、0关闭

??????
;开启例子
#act
ETNOWALK 1
sendmsg 6 当前人物进入禁止移动状态！！！

;开启例子
#act
ETNOWALK 0
sendmsg 6 当前人物已解除禁止移动状态！！！


脚本命令设置玩家失明buff

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETChangeStatus

参数一 (0=失明)
参数二 (参数一=0时 失明的范围0~14之间有效,其他参数视为立即关闭）

参数三(时间,秒，0=无限)

??????
例子1：
;失明了，只能看到屏幕5格内目标，10秒后恢复正常
#ACT
ETChangeStatus 0 5 10

例子2：
;对方失明了，只能看到屏幕5格内目标，10秒后恢复正常
#ACT
M.ETChangeStatus 0 5 10


调整人物伤害减免，免伤

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
调整人物物理伤害减免
ETSetDamageDec
//参数1:伤害减免类型（1=通用，2=人物，3=怪物）
//参数2: 减免百分比 （1-100）
//参数3: 持续时间 单位 ：s

到时触发qf：
@ETDamageDecTimeOutX X表示参数一的类型
实例：

??????
[@main]
#act
ETSetDamageDec 2 50 600
sendmsg 6 受到人物物理伤害降低50%持续10分钟
qf:
[@ETDamageDecTimeOut2]
#act
sendmsg 6 加成结束！！
??????
调整人物魔法伤害减免
ETSetMagicDamageDec
//参数1:伤害减免类型（1=通用，2=人物，3=怪物）
//参数2: 减免百分比 （1-100）
//参数3: 持续时间 单位 ：s

到时触发qf：
@ETMagDamageDecTimeOutX X表示参数一的类型

实例：

??????
[@main]
#act
ETSetMagicDamageDec 1 30 600
sendmsg 6 受到魔法伤害降低30%持续10分钟

qf:

[@ETMagDamageDecTimeOut1]
#act
sendmsg 6 加成结束！！


设置指定玩家的变量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETSetHumVar

参数1：玩家名称
参数2：变量名称
参数3：设置的变量名称

实例：

??????
[@main]
你要把你最大生命值数值传给别人,让他知道你的最大生命值是多少吗
请确保对方在线\ <请输入对方名字/@@InPutString1>
对方名字：<$STR(S1)> \

[@InPutString1]
#IF
#ACT
ETSetHumVar S1 S2 <$MAXHP>
SENDMSG 6 成功把你的最大生命值数值传递给对方的 S2 变量


将秒数转换为时间格式

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

将秒数转为X天X小时X分钟X秒

ETDecodeTime

参数一(返回转换后的结果到字符变量)
参数二(需要转化的秒数 支持变量)
参数三(0~1可空) 0或空时，时间格式为X天X时X分X秒，为1时格式为X时X分X秒
例子1:

????
;秒数转为时间格式，方便玩家快速理解活动倒计时等
??????
#act
mov G24 2880
ETDecodeTime S50 <$STR(G24)>

S50=0天0时48分0秒


脚本命令复制字符到粘贴板

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

SetClipboardData

用于实现右键粘贴指定内容的命令

例子:

SetClipboardData 任意文字测试


HOOK物理攻击伤害

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

HookAttack

此命令只针对物理攻击回调,不支持假人

参数1=开关状态(1:回调 0:不回调)

参数2=攻击对象类型(使用N变量存储,这里填写数字0~99,不需要填N,0为人物，1为英雄,大于1的都是怪物等)

参数3=技能ID(使用N变量存储，这里填写0~99)

参数4=攻击伤害(使用N变量存储,这里填写数字0~99,不需要填N,修改此N变量可以实现最终伤害修改)

物理攻击后伤害触发 [QFunction-0.txt] 脚本内, [@HookAttack] 字段,需要在此字段进行N伤害变量修改方可实现HOOK

常量:
被攻击对象名称,请勿其他地方使用
<$ETCURRRTARGETNAME>

开启例子:

??????
[@Login]
#IF
#ACT
HookAttack 1 50 51 52
??????
;1 设置开启回调
;50 攻击对象类型存储在N50变量里
;51 技能ID存储在N51变量里
;52 攻击伤害存储在N52里，触发的时候修改此变量可以控制伤害

关闭例子:

??????
HookAttack 0


HOOK魔法攻击伤害

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

HookMagic

此命令只针对魔法攻击回调,不支持假人

参数1=开关状态(1:回调 0:不回调)

参数2=攻击对象类型(使用N变量存储,这里填写数字0~99,不需要填N,0为人物，1为英雄,大于1的都是怪物等)

参数3=技能ID(使用N变量存储，这里填写0~99)

参数4=攻击伤害(使用N变量存储,这里填写数字0~99,不需要填N,修改此N变量可以实现最终伤害修改)

魔法攻击后伤害触发 [QFunction-0.txt] 脚本内, [@HookMagic] 字段,需要在此字段进行N伤害变量修改方可实现HOOK

常量:
被攻击对象名称,请勿其他地方使用
<$ETCURRRTARGETNAME>

开启例子:

??????
[@Login]
#IF
#ACT
HookMagic 1 50 51 52
??????
;1 设置开启回调
;50 攻击对象类型存储在N50变量里
;51 技能ID存储在N51变量里
;52 攻击伤害存储在N52里，触发的时候修改此变量可以控制伤害

关闭例子:

??????
HookMagic 0


HOOK被物理攻击伤害

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

HookStruck

此命令只针对人物被物理攻击后回调,不支持假人

参数1=开关状态(1:回调 0:不回调)

参数2=攻击对象类型(使用N变量存储,这里填写数字0~99,不需要填N,0为人物，1为英雄,大于1的都是怪物等)

参数3=技能ID(使用N变量存储，这里填写0~99)

参数4=攻击伤害(使用N变量存储,这里填写数字0~99,不需要填N,修改此N变量可以实现最终伤害修改)

被物理攻击后伤害触发 [QFunction-0.txt] 脚本内, [@HookStruck] 字段,需要在此字段进行N伤害变量修改方可实现HOOK

常量:
攻击对象名称,请勿其他地方使用
<$ETCURRRTARGETNAME>

开启例子:

??????
[@Login]
#IF
#ACT
HookStruck 1 50 51 52
;1 设置开启回调
;50 攻击对象类型存储在N50变量里
;51 技能ID存储在N51变量里
;52 攻击伤害存储在N52里，触发的时候修改此变量可以控制伤害

关闭例子:

??????
HookStruck 0


HOOK被魔法攻击伤害

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

HookMagicStruck

此命令只针对人物被魔法攻击后回调,不支持假人

参数1=开关状态(1:回调 0:不回调)

参数2=攻击对象类型(使用N变量存储,这里填写数字0~99,不需要填N,0为人物，1为英雄,大于1的都是怪物等)

参数3=技能ID(使用N变量存储，这里填写0~99)

参数4=攻击伤害(使用N变量存储,这里填写数字0~99,不需要填N,修改此N变量可以实现最终伤害修改)

被魔法攻击后伤害触发 [QFunction-0.txt] 脚本内, [@HookMagicStruck] 字段,需要在此字段进行N伤害变量修改方可实现HOOK

常量:
攻击对象名称,请勿其他地方使用
<$ETCURRRTARGETNAME>

开启例子:

??????
[@Login]
#IF
#ACT
HookMagicStruck 1 50 51 52
??????
;1 设置开启回调
;50 攻击对象类型存储在N50变量里
;51 技能ID存储在N51变量里
;52 攻击伤害存储在N52里，触发的时候修改此变量可以控制伤害

关闭例子:

??????
HookMagicStruck 0


百分比调整 血蓝 HP MP 控制

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

功能：

脚本设置人物或怪物血量

AddhpPer +/-/=
AddmpPer +/-/=

参数详解：

参数1:符号
参数2:血量百分比

例：

QFunction-0.txt 攻击怪物触发

??????
[@攻击怪物触发]
#IF
CHECKHITMONNAME 白野猪
#act
m.AddHPPer - 10
sendmsg 6 白野猪血量减少10%


脚本控制持续掉血

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETContinuedDecrease

参数1：掉血值
参数2：持续时间 单位秒 (持续时间填0时则清除)
参数3：掉血类型（0=当前血量百分比，1=固定值，2=最大血量百分比）
参数4: 是否属扣血 (0=默认,就是扣血，1=变成加血)

只能对玩家使用，无论是加血还是扣血，只要参数2写0，都会关闭此触发所有效果！
自身例子：

??????
#act
ETContinuedDecrease 10000 20 1 0
;屏幕中间显示文字命令 文字颜色 背景颜色 字体大小 行间隔 发送模式 显示毫秒 内容
;给自己看
ETSendCenterMsg 251 255 12 10 0 5000 你中了埃博拉病毒，每秒掉血10000点，持续20秒！

被攻击者例子：

??????
m.ETContinuedDecrease 10000 20 1 0
;发送到被攻击的人物
m.ETSendCenterMsg 251 255 12 10 0 5000 你中了埃博拉病毒，每秒掉血10000点，持续20秒！
ETSendCenterMsg 251 255 12 10 0 5000 对方已中了埃博拉病毒，每秒掉血10000点，持续20秒！

支持多级调用


脚本命令整理背包

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

QueryBag

实例

??????
[@main]
#if
#act
QueryBag
SendMsg 0 你的背包已经整理好了


脚本设置死亡不掉装备物品次数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETNotDropItemCount 设置死亡不掉装备次数

参数一:次数

例子

??????
ETNotDropItemCount 5

这条命令均是小退清除设置,如需一直保存或动态扣减的，可通过引擎死亡触发回调等手段进行动态控制

简单一点实现记录的算法,可以通过全局变量进行记录,赋予一个基础值,每次触发死亡就扣减,登录或复活后重新设置死亡不掉装备次数


脚本在地面放置刷出物品

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
ETThrowItemEx2
//参数1:物品名
//参数2:数量

注：物品来源和击杀怪物一致
实例：

??????
[@ONKILLMOB]
#if
#act
M.ETThrowItemEx2 屠龙
配合其他命令使用
; 可随机抽取物品，最后一个随机物品几率务必为1/1
#ACT
ETRandomText RANDOM*{1/15}5钻石|{1/11}2钻石|{1/9}1钻石|{1/7}100元宝|{1/5}50元宝|{1/3}20元宝|{1/2}10元宝|{1/1}5元宝* | S3
M.ETThrowItemEx2 <$STR(S3)>

需要使用ET物品来源


脚本制造物品指定来源

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETGiveExA

功能：

NPC直接给物品到背包脚本，带指定物品来源

命令：

ETGiveExA 参数1|参数2|参数3|参数4|参数5|参数6|参数7

参数详解：

参数1:装备名称
参数2:来源类型 2=自定义来源 4=杀怪掉落
参数3:地图名
参数4:怪物名/来源名
参数5:角色名称(省略或使用%s时获取当前人物名)
参数6:来源时间(省略或使用%s时获取当前时间)
参数7:修改物品叠加数量或持久(物品叠加数量请直接输入数字，持久的话，1=1000，填写3000，等于当前持久为3，0等于不修改)

提示：参数1到参数7支持变量

例：

??????
杀死怪物获得(部分参数自动获取):
ETGiveExA 裁决之杖|4|死亡棺材|暗之触龙神|%s|%s|0

功能：

NPC直接给物品到背包脚本，带指定物品来源

命令：

ETGiveEx 参数1 参数2 参数3 参数4 参数5 参数6

参数详解：

参数1:装备名称
参数2:来源类型 2=自定义来源 4=杀怪掉落
参数3:地图名
参数4:怪物名/来源名
参数5:角色名称(省略或使用%s时获取当前人物名)
参数6:来源时间(省略或使用%s时获取当前时间)
提示：参数1到参数6支持变量

例：

??????
杀死怪物获得(部分参数自动获取):
ETGiveEx 裁决之杖 4 死亡棺材 暗之触龙神 %s %s

杀死怪物获得(指定所有参数):
ETGiveEx 裁决之杖 4 死亡棺材 暗之触龙神 龙在天下 2010-01-01 00:00:01

通过活动获得(部分参数自动获取):
ETGiveEx 裁决之杖 2 盟重省 土城酷跑活动 %s %s

通过活动获得(指定所有参数):
ETGiveEx 裁决之杖 2 盟重省 土城酷跑活动 吃吃 2010-01-01 00:00:01

或变量操作：

??????
mov s1 裁决之杖
mov s2 4
mov s3 死亡棺材
mov s4 暗之触龙神
mov s5 %s
mov s6 %s
ETGiveEx <$str(s1)> <$str(s2)> <$str(s3)> <$str(s4)> <$str(s5)> <$str(s6)>


脚本修改物品来源信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

插件增加修改物品来源命令 ETCHANGEMAKEITEMINFO

??????
位置(0-18穿在身上的装备19-30生肖1001-1012时装首饰)
类型(0没有物品来源 1GM 2NPC 3商铺 4怪物 5系统 6挖矿)
地图名称（不能为空）
人物名称(如果没有用 * 代替,不能为空)
怪物名称(如果没有用 * 代替，不能为空)
是否修改物品来源时间（1为修改当前时间，为空不修改)

例如
ETCHANGEMAKEITEMINFO 0 1 3 * * 1
代表 衣服 修改成GM制造,并且修改为当前系统时间


脚本传送至指定地图范围

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
ETMapMOveEx

参数1 地图名
参数2 坐标X
参数3 坐标Y
参数4 随机范围值

??????
#ACT
ETMapMOveEx 3 319 220 5


脚本计算百分比

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETCalcPercent 值 百分比 结果变量

示例:

??????
[@mail]
#act
ETCalcPercent 200 5 N1
SendMsg 6 200的5%为<$STR(N1)>


使用脚本进行四则运算

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETMoveXP

参数1=变量名
参数2=运算表达式
参数3=是否不保留小数(0则四舍五入，保留2位小数，1取整) 注：若运算失败则返回0

??????
支持以下运算符号:
+-*/\%()0~9.

/:除法,带小数
\:整除,不要小数
%:只能用在*90%这样的格式
ETMoveXP S$运算 <$STR(N$输入数值)>*90%

例子：

??????
;获取90%的值
#ACT
MOV N$输入数值 252
ETMoveXP S$实际数值 <$STR(N$输入数值)>*90%
SENDMSG 6 原计算数值：<$STR(N$输入数值)>元，取百分之90%，实际数值：<$STR(S$实际数值)>

;计算攻城奖励
#ACT
MOV G6 12050
ETMoveXP N$今日攻城奖励 <$STR(G6)>-<$STR(G6)>*10% 1
ETMoveXP N$今日攻城胜利方 (<$STR(G6)>-<$STR(G6)>*10%)*70% 1
ETMoveXP N$今日攻城失败方 (<$STR(G6)>-<$STR(G6)>*10%)*30% 1
SENDMSG 6 兄弟！今日攻城扣除10%服务费共奖励：<$STR(N$今日攻城奖励)>，胜利方奖励70%：<$STR(N$今日攻城胜利方)>，失败方奖励30%：<$STR(N$今日攻城失败方)>


脚本开启行会战

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETStartGuildWar

参数1:行会名称1
参数2:行会名称2

??????
#ACT
ETStartGuildWar 九天神魔 十方妖孽
SENDMSG 6 九天神魔行会和十方妖孽行会开启了行会战！


脚本开启内挂、隐藏内挂

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ShowWindow

参数1=1(显示)，0(隐藏)，2021(呼出主动挂机系统)

显示例子:

??????
ShowWindow 1

隐藏例子:

??????
ShowWindow 0

呼出自动挂机窗口例子:

??????
ShowWindow 2021


脚本开启自动穿戴功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

AutoWear

用于开关指定用户是否开启穿戴推荐

开启例子

??????
AutoWear 1

关闭例子

??????
AutoWear 0

同时需要后台开启选项
#待插入图片


发送自定义透明消息框，清除自定义消息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

SendMessage

参数1：计算模式(0:以参数2、3作为直接绘制点 | 1:以自身角色XY作为计算基础点，再加上参数2、3 | 2:以游戏鼠标XY作为计算基础点，再加上参数2、3)

参数2：X,支持负数

参数3：Y,支持负数

参数4：显示毫秒，0代表不限时，以毫秒为单位，1000等于1秒

参数5：是否可以ESC关闭，1可以，0不可以

参数6：颜色值，参考引擎

参数7：内容，支持变量，空格使用[#]代替

例子参考:

??????
;需要在功能扩展勾选ET反挂加载触发，以下字段方会触发
??????
[@ET反挂加载]
#IF
#ACT
;清除以往自定义透明消息
ClearMessage

;以模式0
SendMessage 0 0 200 0 1 250 ET自定义透明框
此命令在B版进行了改进，颜色参数和显示方式有作出改进

------------------------------------

ClearMessage

例子：

#IF
#ACT
ClearMessage
;可以清除以往自定义透明消息框


在客户端屏幕中间显示公告

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETSendCenterMsg

格式：ETSendCenterMsg 参数1 参数2 参数3 参数4 参数5 参数6
注:如未完成加载插件,将暂时采用聊天框输出提示,而不采用插件方式显示。

参数1=文字颜色
参数2=背景颜色
参数3=字体大小
参数4=行间距
参数5=发送模式(0=自己，1=组队，2=行会，3=地图，4=所有人)
参数6=显示时间(毫秒,1秒=1000)
参数7=内容(如果需要其他字有颜色需要用格式如下{显示的字|颜色代码0~255})

发送行会例子

??????
[@main]
#ACT
;命令 文字颜色 背景颜色 字体大小 行间隔 发送模式 毫秒 内容
ETSendCenterMsg 251 255 12 10 2 3000 {<$USERNAME>|252},ET功能演示,时间：2021年2月2日13:23:21

发送攻击敌人例子

??????
[@main]
#ACT
;命令 文字颜色 背景颜色 字体大小 行间隔 发送模式 毫秒 内容
m.ETSendCenterMsg 251 255 12 10 0 3000 {<$USERNAME>|252},ET功能演示,时间：2021年2月2日13:23:21


使用脚本打开浏览器，访问指定url

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

OpenUrl

参数1:网址

例子1:

??????
#ACT
OpenUrl http://www.ETmir2.com/


客户端游戏界面左右侧喇叭信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETSendMoveCenterMsg

游戏界面左右侧喇叭提示

??????
ETSendMoveCenterMsg

参数1=文字信息(如果需要其他字有颜色需要用格式如下{显示的字|颜色代码0~255})
参数2=文字颜色
参数3=背景颜色
参数4=X坐标
参数5=Y坐标
参数6=持续时间(毫秒)
参数7=模式 0=屏幕左下侧 1=屏幕右下侧
参数8=信息类型(0=自己，1=组队，2=行会，3=地图，4=所有人)

??????
例子1：
;发送一条左侧公告,最多同时显示10条内容
#ACT
ETSendMoveCenterMsg {<$USERNAME>|252}：我是左侧公告！ 70 0 0 0 5000 0 0

；左侧公告如需播放特效，需安装ETpm.pak素材，压缩包自带！

例子2：
;发送一条右侧公告,最多同时显示10条内容
#ACT
ETSendMoveCenterMsg 这是一个屏幕右侧公告,最多同时显示{10|249}条内容！  70 0 0 0 8000 1 0


使用脚本发送客户端窗口抖动

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
#ACT
FLASHWINDOW

执行此指令需要开启云端反挂

调用后将对此玩家发送窗口抖动,类似QQ抖动效果。


脚本主动触发防脱机验证

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETProactiveverification 验证时间(毫秒,需要多少毫秒内完成)

例子：

??????
#act
;需要2分钟内完成验证
ETProactiveverification 120000


脚本向客户端发送云指令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

光柱

ETSENDCOMMAND

参数1:指令类型(1光柱)
参数2:开关状态(1开启 0关闭)

光柱开启例子

??????
ETSENDCOMMAND 1 1

光柱关闭例子

??????
ETSENDCOMMAND 1 0

开始自动挂机(先满足并激活挂机脚本命令)

??????
ETSENDCOMMAND 2024 1

关闭自动挂机

??????
ETSENDCOMMAND 2024 0


脚本播放人物动画特效

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETPlayEffect 参数1

参数1 特效编号(特效编号在ET功能窗口二-特效编辑设置)

可以用在[范围伤害脚本命令]里的QF触发,实现被打击的人物播放特效

??????
[@ETRangeHarmX]
#ACT
ETPlayEffect 特效序号


脚本设置武器免疫诅咒功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETSetWeaponCurseTime

参数一: 秒单位

参数二: (0覆盖 1叠加) 默认为0

武器免疫诅咒功能，开通后，可以免费诅咒半小时.
堵门的小号太多。或者不想武器掉诅咒。开通免费诅咒 时间自定义.

例子

??????
#act
ETSetWeaponCurseTime 1800    ;30分钟


脚本强制开启攻城战命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETLaunchCastlBattle

参数1：城堡名称

参数2：提前结束时长(分钟)

成功即调用QF

;S0=城堡名字

;攻城开始触发QF @BeginCastle

??????
[@BeginCastle]
#act
sendmsg 0 【<$STR(S0)>】攻城战已经开始，请各位勇士擦亮你的大刀准备迎战!


自定义红、蓝素 HP 、 MP材绘制脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

使用方法：
需在插件面板勾选 开启反外挂加载触发。否则无法使用下面的脚本
需在插件面板勾选 开启反外挂加载触发。否则无法使用下面的脚本
需在插件面板勾选 开启反外挂加载触发。否则无法使用下面的脚本

此脚本需放在QF [@ET反挂加载] 触发标签下加载，否则无效。
此脚本需放在QF [@ET反挂加载] 触发标签下加载，否则无效。
此脚本需放在QF [@ET反挂加载] 触发标签下加载，否则无效。

??????
脚本例子

[@ET反挂加载]

[@自定义血蓝]
#if
#act
ETSINGLEHP 39 DBottomLeft 40 92 101 101 372 14 200
ETSINGLEMP 39 DBottomRight 40 92 101 101 398 14 200

参数1 wil资源号 参数2 父窗口对象名 参数3 左边 参数4 右边 参数5 宽度 参数6 高度 参数7 素材开始 参数8 素材数量 参数9 播放间隔参数10 是否置顶


设置物品或金币丢弃限制

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

设置物品或金币丢弃限制

??????
[@ETSETDROPITEM]
#if
#act
;0 允许丢物 1 禁止丢物
ETSETDROPITEM 0


设置交易限制

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

设置交易限制

??????
[@ETSETDEALTRY]
#if
#act
;0 允许交易 1 禁止交易
ETSETDEALTRY 0


交易前触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

交易前触发(引擎功能扩展 - 扩展二 - 勾选开启交易前触发选项)

??????
QF
[@ETDEALTRY]
#IF
#ACT
SENDMSG 6 被交易对象 <$STR(S$ETDEALTRYNAME)>
;0 允许交易 1 禁止交易
ETSETDEALTRY 1


时间戳转换月日年时分秒

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

时间戳转换月日年时分秒

ETUNIXTOSTR 时间戳 变量1 变量2

参数位置 | 参数说明
参数1 | 时间戳
参数2 | S1获取保存变量1(格式为:2022/11/2914:59:27)
参数3 | S2获取保存变量1(格式为:2022-11-29-14-59-27)
??????
[@MAIN]
#if
#act
ETUNIXTOSTR 1669705167 S1 S2
sendmsg  6   <$str(S1)>     //获取到的变量格式为:2022/11/29 14:59:27
sendmsg  6   <$str(S2)>     //获取到的变量格式为:2022-11-29-14-59-27\

新时间戳转换北京时间

ETUNIXTOSTREX 参数1 参数2 参数3

参数位置 | 参数说明
参数1 | <$UTCNOW8>或数值
参数2 | S1获取保存变量1(格式为:2022/11/29 14:59:27)
参数3 | S2获取保存变量1(格式为:2022-11-29-14-59-27)
??????
@main
#ACT
ETUNIXTOSTREX  <$UTCNOW8>  S1  S2
sendmsg  6  时间戳转北京时间<$str(S1)>
sendmsg  6  时间戳转北京时间<$str(S2)>


删除指定行会

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

删除指定行会

ETDELGUILD 参数1

参数位置 | 参数说明
参数1 | 行会名称
??????
@main
#ACT
ETDELGUILD ET行会


地图黑夜脚本功能命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

地图黑夜脚本功能命令

注：客户端功能扩展三 - 地图场景 - 增加地图黑色设置指定怪物蜡烛亮度

ETCHANGENIGHTMODE 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8

参数位置 | 参数说明 | 附加说明
参数1 | 是否启动 | 1,启动 0,关闭 2,全局启动 (如果非全局启动2,在引擎客户端设置 - 天气系统 设置对应时辰亮度参数,开启需要设置非”白天”选项,这样命令效果方为生效)
参数2 | 绘制模式 | 100~122 默认107，请自行测试 （部分绘制模式设置后无法更换，需要重新进游戏）
参数3 | 可视区域颜色 | 0~255 或 RGB
参数4 | 透明度 | 10~255 10颜色最深 255最浅
参数5 | 自身照亮范围 | 1~6 0默认（蜡烛、勋章）
参数6 | 他人照亮范围 | 1~6 0默认
参数7 | 怪物照亮范围 | 1~6 0默认
参数8 | NPC照亮范围 | 1~6 0默认
??????
[@main]
#act
ETCHANGENIGHTMODE 2 107 255 50 1 1 1 1


获取地图人数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

获取地图人数

ETGetMapHumCount 参数1 参数2 参数3

参数位置 | 参数说明
参数1 | 地图编号
参数2 | 是否包含假人(0不包含假人/1包含假人)
参数3 | 返回变量
??????
[@main]
#ACT
ETGetMapHumCount 3 1 N1
Sendmsg 7 当前土城有<$STR(N1)>人


设置禁止拾取命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

设置禁止拾取命令

ETSETPICKSTATE 参数1

参数位置 | 参数说明
参数1 | (1禁止拾取,0恢复)
??????
[@main]
#ACT
;禁止人物拾取物品,包括自动拾取
ETSETPICKSTATE 1

[@main]
#ACT
;恢复拾取
ETSETPICKSTATE 0


过滤全服提示信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

ETFILTERGLOBALMSG 参数1 参数2

参数位置 | 参数说明
参数1 | 过滤类型(0=全部过滤(包括SENDMSG)1=左右侧公告提示，2=跨区喇叭信息，3=屏幕中间显示信息，4=过滤物品掉落提示，5=过滤居中公告提示)
参数2 | 是否过滤(0不过滤，1过滤)
??????
[@main]
#ACT
;过滤ETSendMoveCenterMsg左右侧公告提示
ETFILTERGLOBALMSG 1 1

[@main]
#ACT
;过滤ETSendCrossMsg跨区喇叭信息
ETFILTERGLOBALMSG 2 1

[@main]
#ACT
;过滤ETSENDCENTERMSG屏幕中间显示信息
ETFILTERGLOBALMSG 3 1

[@main]
#ACT
;过滤物品掉落提示
ETFILTERGLOBALMSG 4 1

[@main]
#ACT
;过滤SendCenterMsg居中公告提示
ETFILTERGLOBALMSG 5 1

ET 引擎补充

功能

过滤全服提示信息

命令格式

??????
FILTERGLOBALMSG 是否过滤(0不过滤，1过滤)
??????
[@main]
#IF
#ACT
FILTERGLOBALMSG 1
SENDMSG 6 开启过滤全服提示信息，你不在接受如SENDMSG、GuildNoticeMsg等等脚本命令发送的全服提示信息。


扩展回收命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

TakeBagItemEx 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8 参数9 参数10 参数11

参数位置 | 参数说明
参数1 | 物品名称(支持多个物品)
参数2 | 收取数量
参数3 | 每个物品增加元宝数量(默认为0)
参数4 | 每个物品增加金币数量(默认为0)
参数5 | 每个物品增加泡点数量(默认为0)
参数6 | 每个物品增加金刚石数量(默认为0)
参数7 | 每个物品增加灵符数量(默认为0)
参数8 | 每个物品增加荣誉点数量(默认为0)
参数9 | 每个物品增加泡点经验(默认为0)
参数10 | 变量(储存回收物品数量)
参数11 | 聚灵珠经验(为空或0时不增加聚灵珠经验 1时同时增加聚灵珠经验)
??????
[@回收]
#ACT
TakeBagItemEx 木剑 99 1000 0 0 0 0 0 0 N1 0
SENDMSG 6 您成功回收了<$STR(N1)>件装备！！


CSV自定义常量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

CSV自定义常量

本功能需要的csv表格以及参考实例需要下载压缩包查看

CSV脚本参考: 点击下载

命令：LOADCONLIST

参数位置 | 参数说明
参数1 | 文件路径
参数2 | 表头所在列(A，B，C，…….) 留空默认“A”
参数3 | 标签所在行(1，2，3，…….) 留空默认“1”

如例子中的Mon.csv，我们定义了A列的关键字用来索引行，1行的关键字用来索引列。 <$CL_Mon(白野猪.变量攻击2)>，表示的是表Mon.csv中D3项内容。(白野猪所在行是3，变量攻击2所在列是D) 注意1：LOADCONLIST二次或多次调用则会重新刷新常量内容，建议固定内容放QM启动时调用一次！注意2：特别重要的，文件名称不能重复！！！不用路径的文件名称也不能重复！！！

??????
[@main]
#say
扩展常量\
<载入常量文件/@载入常量文件>    <显示怪物常量/@显示怪物常量>    <显示装备常量/@显示装备常量>\
扩展常量1\
<载入常量文件/@载入常量文件1>    <显示工作常量/@显示工作常量1>\
扩展常量2\
<载入常量文件/@载入常量文件2>    <显示工作常量/@显示工作常量2>\
扩展常量3\
<载入常量文件/@载入常量文件3>    <显示工作常量/@显示工作常量3>\

[@载入常量文件3]
#act
LOADCONLIST .\工作3.csv D 3
sendmsg 7 载入工作表3
break

[@显示工作常量3]
<返回/@main>\
<显示工作常量3>\
<$CL_工作3(1.3)>.序号=<$CL_工作3(1.4)>\
<$CL_工作3(1.3)>.班级=<$CL_工作3(1.1)>\
<$CL_工作3(1.3)>.宿舍=<$CL_工作3(1.2)>\

[@载入常量文件2]
#act
LOADCONLIST .\工作2.csv D 2
sendmsg 7 载入工作表2
break

[@显示工作常量2]
<返回/@main>\
<显示工作常量2>\
张爽.序号=<$CL_工作2(张爽.标签1)>\
张爽.班级=<$CL_工作2(张爽.标签2)>\
张爽.宿舍=<$CL_工作2(张爽.标签3)>\

[@载入常量文件1]
#act
LOADCONLIST .\工作1.csv D 1
sendmsg 7 载入工作表1
break

[@显示工作常量1]
<返回/@main>\
<显示工作常量1>\
张爽.序号=<$CL_工作1(张爽.序号)>\
张爽.班级=<$CL_工作1(张爽.班级)>\
张爽.宿舍=<$CL_工作1(张爽.宿舍)>\

[@载入常量文件]
#act
LOADCONLIST .\Mon.csv A 1
sendmsg 7 载入怪物常量表
LOADCONLIST .\item.csv A 1
sendmsg 7 载入装备常量表
break

[@显示怪物常量]
<返回/@main>\
白野猪血量=<$CL_Mon(白野猪.变量血量)>\
白野猪攻击1=<$CL_Mon(白野猪.变量攻击1)>\
白野猪攻击2=<$CL_Mon(白野猪.变量攻击2)>\
白野猪攻击3=<$CL_Mon(白野猪.变量攻击3)>\
[@显示装备常量]
<返回/@main>\
屠龙血量=<$CL_Item(屠龙.装备血量)>\
屠龙攻击1=<$CL_Item(屠龙.装备攻击1)>\
屠龙攻击2=<$CL_Item(屠龙.装备攻击2)>\
屠龙攻击3=<$CL_Item(屠龙.装备攻击3)>\


检测背包空格数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

检测背包空格数量 命令：CHECKBAGSIZE 参数1(数量)

??????
例子：
[@main]
#if
CHECKBAGSIZE 5
#say
身上有5个空格
#elsesay
身上的空格不够。


获取角色背包信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

命令 GetBagInfo 参数1 参数2(保存变量) 参数3(stdmode的值)

参数1：信息类型可取如下值：
ItemCount: 物品数量(每个背包物品都算一个数量，不管是否为叠加物品)
ItemMakeIndex:所有背包物品的MakeIndex；参数2即保存变量必须为元素类型
ItemIdx:所有背包物品的数据库idx；参数2即保存变量必须为元素类型
ItemName:所有背包物品的名称；参数2即保存变量必须为元素类型

参数3(stdmode值)：留空为获取背包所有物品数量，填写5只获取stdmode值为5的武器数量，可以 5|6|10|11 只取背包武器衣服

**获取背包物品的字段值 ** 命令:GetBagItemFieldValue 参数1 参数2 字段名称 保存变量

参数1: 可取如下值
0: 根据背包物品序号取物品（即取背包第几个物品），参数2就是序号（从0开始）
1: 根据背包物品的MakeIndex取物品，参数2就是MakeIndex
将对应的物品字段保存到变量中

获取背包剩余格子数量 命令：GetBagInfo AvailableCount 保存变量

??????
示例脚本：
；获取背包剩余格子数量
#act
GetBagInfo AvailableCount N99
SendMsg 6 背包剩余格子数量为<$STR(N99)>格

;取背包物品数量保存到变量
#act
GetBagInfo ItemCount N99
SendMsg 6 背包物品数量为<$STR(N99)>

Mov N1 0
GetBagInfo ItemCount N99
WHILE N1 < <$STR(N99)>
Mov S1
Mov S2
; 第一个参数: (0根据顺序号/1根据MakeIndex)；参数2：表示取第几个；参数3：字段名称；参数4：
GetBagItemFieldValue 0 <$STR(N1)> name S1
GetBagItemFieldValue 0 <$STR(N1)> upgradecount S2
Sendmsg 6 提示：第<$STR(N1)>件,物品名称=<$STR(S1)>,星星数=<$STR(S2)>
INC N1 1
ENDWHILE

;取背包所有物品的MakeIndex保存到元素变量中
GetBagInfo ItemMakeIndex L$背包物品
SendMsg 6 背包物品MakeIndex:<$STR(L$背包物品)>

;根据MakeIndex取得对应背包物品的字段值并保存到变量中
GetBagItemFieldValue 1 <$STR(L$背包物品[0])> name S1
Sendmsg 6 提示：第0件,物品名称=<$STR(S1)>;MakeIndex=<$STR(L$背包物品[0])>

;取背包所有物品的数据库Idx保存到元素变量中
GetBagInfo ItemIdx L$背包物品
SendMsg 6 背包物品数据库Idx:<$STR(L$背包物品)>

;取背包所有物品名称保存到元素变量中
GetBagInfo ItemName L$背包物品
SendMsg 6 背包物品名称:<$STR(L$背包物品)>

示例脚本2：

<获取背包物品的字段值/@获取背包物品的字段值1> <获取背包物品的字段值index获取/@获取背包物品的字段值2> \

[@获取背包物品的字段值1]
#act
GetBagItemFieldValue 0 9 NAME S$name

[@获取背包物品的字段值2]
#act
GetBagItemFieldValue 1 14950 NAME S$name


扩展关联背包物品

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

命令：LinkBagItem 参数一[物品MakeIndex(唯一ID)]

??????
脚本示例:
[@StdModeFuncEx1]
#act
SendMsg 6 当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>；本物品使用完后会直接消失

[@StdModeFuncEx2]
#if
Random 3
#act
SendMsg 6 人物当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>；本次删除
LinkBagItem <$UseItemMakeIndex>
DelLinkItem
#elseact
SendMsg 6 人物当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>；本物品还可以使用
LinkBagItem <$UseItemMakeIndex>
ChangeItemName -1 新的名字3
ClearLinkItem

命令：DelLinkItem 参数一[物品数量(用于叠加物品，0整个物品删除，大于0从叠加中删除指定数量)]

??????
[@HeroStdModeFuncEx2]
#if
Random 10
#act
SendMsg 6 英雄当前使用的物品名:<$H.UseItemName>，唯一ID:<$H.UseItemMakeIndex>；本次删除
H.LinkBagItem <$H.UseItemMakeIndex>

命令：CLEARLINKITEM 该命令对应LinkBagItem 关联的物品


CSV脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

普通CSV 命令：RWCSV 参数1 参数2 参数3 参数4

参数位置 | 参数说明
参数1 | 文件路径
参数2 | 0=读 1=写 2=取CSV参数(行数，列数)
参数3 | N变量
参数4 | N变量
参数5 | 变量或要写入的文本内容 如:S0

注意：根据自己的脚本去选择要使用的变量

??????
读：
RWCSV .\111.CSV 0 1 2 S0
读取CSV 第1行 第2列数据到S0

写：
RWCSV .\111.CSV 1 1 2 变量
将"内容"写到CSV第1行 第2列

取:
RWCSV .\111.CSV 2 N0 N1
取出CSV行数保存到N0，取出CSV列数保存到N1

高速缓存CSV 命令：CACHELOADCSV 参数1 参数2

参数位置 参数说明
参数1 文件路径
参数2 0载入,存在则覆盖 1存在则不重复载入

注：使用高速缓存CSV必须先调用此命令载入，此命令建议放在引擎启动时用于初始化。

命令：CACHERWCSV 参数1 参数2 参数3 参数4

参数位置 | 参数说明
参数1 | 文件路径
参数2 | -1保存 0读 1写 2取CSV参数 3列，正找关键行 4列，倒找关键行
??????
保存：
CACHERWCSV .\111.CSV -1 .\222.CSV
将高速缓存CSV保存到新的222.CSV，若.\222.CSV不填写则覆盖原文件

读：
CACHERWCSV .\111.CSV 0 1 2 S0
读取CSV 第1行 第2列数据到S0

写：
CACHERWCSV .\111.CSV 1 1 2 内容
将"内容"写到CSV第1行 第2列
缓存CSV写入不影响原文件，需要改变原文件请使用保存参数

取:
CACHERWCSV .\111.CSV 2 N0 N1
取出CSV行数保存到N0，取出CSV列数保存到N1

列找关键字所在行，从首部开始找：
CACHERWCSV .\111.CSV 3 2 内容
首部开始找出第2列关键字“内容”所在行

列找关键字所在行，从尾部开始找：
CACHERWCSV .\111.CSV 4 2 内容
从尾部开始找出第2列关键字“内容”所在行

常量命令：（仅支持高速缓存CSV）
<$CSV_111(0,1,2)>
结构：$CSV_    111为CSV文件名不需要后缀   (0,1,2) 0=读 1=行 2=列
解释：读缓存111.CSV第1行第2列内容

<$CSV_111(1)>
结构：$CSV_    111为CSV文件名不需要后缀   (1) 取行数
解释：取缓存111.CSV总共有多少行

<$CSV_111(2)>
结构：$CSV_    111为CSV文件名不需要后缀   (2) 取列数
解释：取缓存111.CSV总共有多少列

<$CSV_111(3,2,内容)>
结构：$CSV_    111为CSV文件名不需要后缀   (3,2,内容) 列找关键字所在行，从首部开始找
解释：缓存111.CSV从首部开始找出第2列关键字“内容”所在行

<$CSV_111(4,2,内容)>
结构：$CSV_    111为CSV文件名不需要后缀   (4,2,内容) 列找关键字所在行，从首部开始找
解释：缓存111.CSV从尾部开始找出第2列关键字“内容”所在行


修改物品的附加属性值

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

CHANGEITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备 17-18时装 30-41生肖) 属性位置(0-14) (符号 + - =) 值

??????
[@修改附加属性]
#IF
#ACT
CHANGEITEMADDVALUE 19 2 + 3
CHANGEITEMADDVALUE 41 2 + 3

ET 引擎补充

功能：修改物品的附加属性值

命令格式

??????
CHANGEITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 + - =) 值

物品位置:

值/位置 | 说明
0 | 盔甲
1 | 武器
2 | 照明物（蜡烛，此物品属性升级无效）
3 | 项链
4 | 头盔
5 | 右手镯
6 | 左手镯
7 | 右戒指
8 | 右戒指
9 | 无(放护身符位置)
10 | 腰带
11 | 鞋子
12 | 宝石

盔甲

值/位置 | 说明
0 | 防御
1 | 魔御
2 | 攻击
3 | 魔法
4 | 道术
5-13 | 无效果
14 | 持久

武器

值/位置 | 说明
0 | DC2
1 | MC2
2 | SC2
3 | 幸运
4 | 诅咒
5 | 准确
6 | 攻击速度
7 | 强度
8-9 | 暂不知道
10 | 需开封
11-13 | 暂不知道
14 | 持久

头盔

值/位置 | 说明
0 | 防御
1 | 魔御
2 | 攻击
3 | 魔法
4 | 道术
5 | 佩带需求
6 | 佩带级别
7-13 | 无效果
14 | 持久

项链

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8 | reserved
9-13 | 暂不知道
14 | 持久

手镯

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8-13 | 无效果
14 | 持久

戒指

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8-13 | 无效果
14 | 持久

脚本示例

??????
[@Test]
#IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.

ETmir2 相关命令页面

  • CheckItemAddValue


mapmove传送

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

mapmove??地图名 坐标A 坐标B 范围 ;同上，只是指定了坐标（范围留空或者0则为定点传送）

??????
  [@传送]
  #act
  MAPMOVE 3 333 333 5


Npc对话框动态进度条功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
[@aaa]
;<ProgressBar:X:Y:F:B:P:C:T:X2:Y2:N:X:V:D:L:X3:Y3:显示文字:备注信息>
X, Y: 微调坐标
F: WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
B:??进度条背景为文件中的第几个图片
P:??进度条进度部分为文件中的第几个图片
C:??进度条进度部分播放张数
T:??进度条进度部分播放间隔
X2:??进度条进度部分X坐标偏移
Y2:??进度条进度部分Y坐标偏移
N:??进度条最小值
X:??进度条最大值
V:??进度条当前值
D:??进度条方向(0:左向右, 1:右向左, 2:上向下, 3:下向上)
L:??进度条文字颜色(0-255)
X3:??进度条文字偏移X
Y3:??进度条文字偏移Y
显示文字：%p当前值, %m最大值, %r百分比


NPC对话框调用身上装备信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
<UserItem:D:X:Y:Z:W/@Labell>

参数说明：
d= 装备位置（0-29:身上装备; 30-35:首饰盒; 40-51:神佑)
X Y = 微调坐标 排版的
Z= 是否显示物品框，0为不显示，1为显示 (当为1时，读取NewopUI.pak:47)，值>1 (NewopUI.pak中指定素材)
W：0 自己，1 当前目标
G：灰色，1 开启
R：对齐方式
H: 宽度
S：0 使用 Items.wzl，1 使用 StdItem.wzl
鼠标放上去显示物品属性。类似图标的用法
@Label是点击图片时需要触发的脚本标签. (不需要跳转则可不需填写，如：<USERITEM:0:0:0:0:0:1:0:40:0>)


NPC对话框调用装备信息

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令
??????
<ItemShow:D:F:X:Y:Z:W:G/@Label>

参数说明：
d= 数据物品ID
F= 数量(数量设置小于1则不显示)
X Y = 微调坐标 排版的
Z= 是否显示物品框，0为不显示，1为显示(当为1时，读取NewopUI.pak:47)，值>1 (NewopUI.pak中指定素材)
G= 灰化显示(0或空=正常，1=灰化)
W= 对齐方式
U= 宽度
鼠标放上去显示物品属性。类似<Img>图标的用法
@Label是点击图片时需要触发的脚本标签. (不需要跳转则可不需填写，如：<ItemShow:D:F:X:Y:Z:G:W:U>)


获取指定地图、指定怪物的数量和坐标。

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

脚本格式：
getMapMonsterNumXY 地图 怪物 数字变量 变量X 变量Y

功能：获取指定地图、指定怪物的数量和坐标。

??????
示例：
#act
getMapMonsterNumXY 3 白野猪 <$STR(S1)> <$STR(S2)> <$STR(S3)>
sendmsg 5 <$STR(S1)> <$STR(S2)> <$STR(S3)>


添加或删除自定义按钮

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

添加或删除自定义按钮

QF简单创建例子

??????
[@ET反挂加载]
#act
sendmsg 6 反挂加载后调用此命令
ETADDBUTTONEX 1|0|0|0|1 GameSource.PAK 296|297|298 GameSource.PAK 97|5|300|0|0|0|1 123|5|300|0|0|0 353|5|300|0|0|0 253/这是一个
功能按钮\249/你可以进行点击测试\249/324234234342|123124124:255:0:50:0:宋体:20:1 10

;创建了触发序号1的按钮

[@ETButtonClickEx1]
#act
sendmsg 0 点击自定义按钮1

详细描述(20240529更新)

[@main]
 <创建按钮1/@addan1>\ \
 <删除按钮1/@delan1>
[@addan1]
#Act
;下面是旧的
;ETADDBUTTONEX 1|0|0|0|1 GameSource.PAK 296|297|298 GameSource.PAK 97|5|300|0|0|0|1 123|5|300|0|0|0 353|5|300|0|0|0 253/这是一个
功能按钮\你可以进行点击测试 0

;下面是新的  2024-05-28         支持按钮文字显示，每行备注颜色自定义

ETADDBUTTONEX 1|0|0|0|1 GameSource.PAK 296|297|298 GameSource.PAK 97|5|300|0|0|0|1 123|5|300|0|0|0 353|5|300|0|0|0 253/这是一个
功能按钮\249/你可以进行点击测试\249/324234234342|123124124:255:0:50:0:宋体:20:1 0

[@delan1]
#act
ETDELBUTTONEX 1
参数介绍
参数1 触发序号|坐标X|坐标Y|是否移动|对齐方式 有4个参数，每个参数用“|”隔开。(“对齐方式”参数不使用可忽略)
参数2 按钮WIL补丁 方式一：编号可在引擎M2 -> 查看 -> 查看列表信息二 -> WIL资源   方式二：直接输入补丁名  XXX.PAK
参数3 鼠标默认图片编号|鼠标碰触图片编号|鼠标按下图片编号 有3个参数，每个参数用“|”隔开
参数4 按钮特效WIL补丁 方式一：编号可在引擎M2 -> 查看 -> 查看列表信息二 -> WIL资源   方式二：直接输入补丁名  XXX.PAK
参数5 按钮默认状态特效图片编号|播放张数|播放速度|绘制模式|微调X坐标|微调Y坐标|切换状态时隐藏默认特效 有7个参数，每个参数用“|”隔
      开。不使用特效整个参数可使用“*”代替
参数6 按钮碰触状态特效图片编号|播放张数|播放速度|绘制模式|微调X坐标|微调Y坐标 有6个参数，每个参数用“|”隔开。不使用特效整个参数可
      使用“*”代替
参数7 按钮按下状态特效图片编号|播放张数|播放速度|绘制模式|微调X坐标|微调Y坐标 有6个参数，每个参数用“|”隔开。不使用特效整个参数可
      使用“*”代替
参数8 鼠标碰触按钮tips|按钮文字 有2个参数，每个参数用“|”隔开。不使用按钮文字使用“-1”代替
参数9 创建窗口标识 方式一：支持(0-17)不同窗口上进行绘制 (窗口标识参数详解见详情)  方式二：组件名（登录器配置器UI里面对应的组件名
      称）

*2024-05-28  参数8
   换行符号   \
   鼠标碰触按钮tips  格式 :   颜色1/备注文字信息1\颜色2/备注文字信息1
   按钮文字              格式：文字描述:字体颜色:背景颜色:左边:顶边:字体名称:字体大小:样式

参数说明
触发序号 触发序号支持1-200
是否移动 0:不可移动 / 1:可以移动
对齐方式 0:左上 / 1:右上 / 2:左下 / 3:右下 / 4:上中 / 5:下中 / 6:左中 / 7:右中 / 8:居中
播放速度 单位：毫秒
绘制模式 0:特效绘制 / 1:普通绘制
鼠标碰触按钮tips “\”表示换行，“/”颜色分割符
窗口标识 0:游戏主界面 / 1:人物装备对话框 / 2:装备页面 / 3:时装页面 / 4:状态页面 / 5:属性页面 / 6:称号页面 / 7:技能页面 / 8:出战页
        面 / 9:包裹界面 / 10:聊天框左侧界面 / 11:聊天框右侧界面 / 12:商铺界面 / 13:查看对方装备对话框 / 14:查看对方装备页面 /
        15:查看对方时装页面 / 16:查看对称号页面 / 17:大地图界面

切换状态时隐藏默认特效 当鼠标经过或者按下隐藏默认特效


脚本刷新背包负重

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

脚本刷新背包负重

ETWeightChanged

例子

??????
#act
;可以在回收完成最后一条指令使用
ETWeightChanged


脚本控制人物、上马、下马

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

脚本控制人物、上马、下马

例子1

??????
#act
ETOFFHORSE
;下马

例子2
#act
ETONHORSE
;骑马


检测指定地图内的同行会人数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

检测指定地图内的同行会人数

ETMAPGUILDHUMNUM

参数一：判断的地图名(行会根据调用者所在行会)

参数二: 人数检测

如没有加入行会，那条件会直接通过

??????
场景例子1：
进入特定地图的时候，能知道当前行会进入地图的人数。
#IF
ETMapGuildHumNum 攻沙地图 5
#ACT
mapmove 攻沙地图 X Y
#ELSEACT
sendmsg 6 当前攻沙地图,同属行会人数已达5个，无法继续进入！


打开指定控件界面

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

打开指定控件界面

打开指定控件界面

通过点击NPC对话框内容打开指定界面

ETOpenClientDlg 参数1 参数2 参数3 参数4

参数位置 | 参数说明
参数1 | 参数1（指定界面 1:系统商铺; 2:个人商店; 3:任务 4: 日志 5: 小地图; 6:交易 7:行会 8:组队 9:关系 10:帮助 11:排行榜 12:挑战 13:私聊信息 14:属性点分配 15:背包 16:装备 17:时装;18:状态;19:属性;20:称号;21:技能;22:出战;23:允许公聊;24:允许喊话;25:允许私聊;26:允许行会;27:自动喊话;28:特殊命令;29:小退;30:大退;31:声音;32:生肖)
参数2 | 参数2 0 (不设置坐标 ) 1 (指定显示坐标) 2 (关闭显示控件)
参数3 | 参数3 坐标X (参数2 不为1时无效)
参数4 | 参数4 坐标Y (参数2 不为1时无效)
??????
[@main]
#if
#act
ETOpenClientDlg 16 1 0 0  //打开装备栏 并强制坐标到坐标 X 0 Y 0 的位置 （注意是整体窗口而不是素材的实际窗口）

[@main]
#if
#act
ETOpenClientDlg 16 2 0 0  //关闭装备栏


配置文件读写(包含TXT,INI,CSV)支持绝对路径

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

配置文件读写(包含TXT,INI,CSV)支持绝对路径

配置文件读写(包含TXT,INI,CSV)支持绝对路径

ETREADWRITEFILE 参数1 参数2 参数3 参数4 参数5 参数6

参数位置 | 参数说明
参数1 | 路径
参数2 | 格式（TXT,INI,CSV）
参数3 | 读写（0 读 1 写）
参数4 | 写入内容或读取用到的保存变量 如（S0）
参数5 | 行数 (TXT中用到，CSV中用到，INI 中为节名)
参数6 | 列数 (CSV中用到，INI 中为键名)
??????
写入
[@main]
#ACT
ETREADWRITEFILE d:\转区\转区数据.txt INI 1 123 账号转区配置 abc

读取
[@main]
#ACT
ETREADWRITEFILE d:\转区\转区数据.txt INI 0 S0 账号转区配置 abc
sendmsg 6 <$str(S0)>


跳转指定的自定义输入框标签

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

跳转指定的自定义输入框标签

云功能,需要加载插件后方会有效
触发NPC某个标签,可用于点击某个自定义输入标签弹出输入框输入，省略多次操作
注意：M2参数上面点击npc字段的游戏速度要设置为0

ETOPENINPUTBOX 参数1

参数位置 | 参数说明
参数1 | @@InPutStringXX
??????
[@main]
#say
 <弹出输入框/@弹出输入框>
<text::-65535:-65535/@@InPutString22>
;注意: <text::-65535:-65535/@@InPutStringXX> 这行必须要有XX对应输入框序号

[@弹出输入框]
#IF
#act
ETOPENINPUTBOX @@InPutString22

[@InPutString22]
#IF
#ACT
GAMEGOLD + 50000
SENDMSG 7 提示：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>


自定义按钮

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

命令：ADDBUTTON

例子

#IF

#ACT

ADDBUTTON 3 1 283 284 285 10 200 1 -1 253/自定义按钮1\254/测试增加按钮

其他说明：

按钮序号只能为1-120，因为最多就添加120个自定义按钮

命令 | 参数详解
ADDBUTTON | 增加自定义按钮命令
参数一 | WIL补丁序号，此序号在M2-查看-列表信息二-WIL资源 里面编辑
参数二 | 按钮点击后的脚本触发序号，触发QF里面的[@ButtonClickX]X即为触发序号
参数三 | 按钮默认图片编号
参数四 | 鼠标经过图片编号
参数五 | 按钮按下图片编号
参数六 | 距离窗口左边的距离(此参数建议用分辨率宽变量计算)
参数七 | 距离窗口顶边的距离(此参数建议用分辨率高变量计算)
参数八 | 按钮是否可以移动0=不能移动1=可以移动
参数九 | 按钮上面显示的文字标题,-1时为空标题(用于不显示标题)支持颜色换行和倒计时显示，倒计时格式支持三种展示方式（默认、动态、秒数）。 使用倒计时格式: <COUNTDOWN:倒计时时间(秒):次数(0无限次):M> 参数M为显示格式： 以90秒和50秒为例 0或空时 默认显示方式 00:01:30 00:00:50 1 根据是否有小时/分动态显示 01:30 50 2 以秒显示 90 50
参数十 | 鼠标移动到按钮显示的悬浮框备注信息 “\”表示换行 “/”颜色分割符 如果需要用到锚点，又不要描述参数10填写NULL
参数十一 | 窗口锚点 默认左上 (0=左上角,1=右上角,2=左下角,3=右下角,4=左中,5=上中，6=右中,7=下中,8=正中，9=人物头顶)（20260705 Update 16 及以上支持）

命令：DELBUTTON

例子

#IF

#ACT

DELBUTTON 1

命令 | 参数详解
DELBUTTON | 删除自定义按钮命令
参数一 | 按钮序号(1-120)
参数二 | 0或空的时删除自己的，1时删除全服用户的


NPC界面调用人物、怪物、技能外观

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

<Effect:I:T:C:A:D:S:C:X:Y>
-- -- 特效
-- -- I 特效id
-- -- t 特效类型 0.特效 1.npc 2.怪物 3.技能 4.人物 5.武器 6.翅膀 7.发型 8.盾牌
-- -- C 播放次数
-- -- A 特效动作 0.待机 1.走 2.攻击 3.施法 4.死亡 5.跑步 6.受击 7.蹲下
-- -- D 特效方向 0上，1右上，2右，3右下，4下，5左下，6左，7左上
-- -- S 速度间隔
-- -- C 缩放比例 1.正常缩放
-- -- X 微调 X坐标
-- -- Y 微调 Y坐标
特效类型 ：2 是 特效ID 填写怪物APPR 特效类型 ：3 是 特效ID 填写数据库magid 特效类型 ：4 是 特效ID填写 衣服外观shape 需注意shape * 2 男的 shape * 2 + 1 女的 例如重盔甲shape 3 特效ID就填写6

灵魂火符等飞行类技能新增俩个参数目标X 目标Y
<Effect:13:3:0:2:2:100:1:140:280:360:280>


清理火墙命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

清理火墙命令

清理火墙命令

> ETClearFireBurn 参数1 参数2

参数位置 | 参数说明
参数1 | 清理方式(0:清理自己所在地图火墙 / 1:清理所有地图火墙 / 2:清理指定玩家火墙 / 3:清理指定地图火墙)
参数2 | 清理参数
??????
[@测试]
#IF
CHECKLEVELEX > 0
#ACT
ETClearFireBurn 0
SENDMSG 5 清理自己所在地图火墙效果
break`

[@测试]
#IF
CHECKLEVELEX > 0
#ACT
ETClearFireBurn 1
SENDMSG 5 清理游戏所有地图火墙效果
break

[@测试]
#IF
CHECKLEVELEX > 0
#ACT
ETClearFireBurn 2 ET
SENDMSG 5 清理玩家“ET”所释放的火墙效果
break

[@测试]
#IF
CHECKLEVELEX > 0
#ACT
ETClearFireBurn 3 D401
SENDMSG 5 清理玩家地图ID为“D401”释放的火墙效果
break


自定义货币

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

自定义货币

自定义货币脚本参考: 点击下载

注：
开启请到客户端功能扩展三 - 自定义货币 按照说明进行操作,首次开启需要重启引擎生效。
开启自定义货币后,可在 [在线管理与限制 ]右键对应玩家，选择[调整自定义货币数量]修改对应货币数量，也可使用远程管理修改自定义货币。

货币名称
金币
元宝
美元

类型
oldCurrency：引擎已有货币
NewCurrency：新增的自定义货币

关联货币
Gold：金币
GameGold：元宝
GameDiamond：金刚石
GameGird：灵符
GamePoint：泡点
GameGlory：荣誉
ExpHitter：经验

??????
;以上是保留字，不要占用

关联货币的比例是1:1
例如定义了新货币【美元】关联货币【元宝|金刚石|灵符】，在美元不足的情况下会用元宝代替，元宝不足会继续用金刚石代替，以此类推。

显示窗口
0:游戏主界面 / 1:人物装备对话框 / 2:装备页面 / 3:时装页面 / 4:状态页面 / 5:属性页面 / 6:称号页面 / 7:技能页面 / 8:出战页面 / 9:包裹界面
10:聊天框左侧界面 / 11:聊天框右侧界面 / 12:商铺界面 / 13:查看对方装备对话框 / 14:查看对方装备页面 / 15:查看对方时装页面 / 16:查看对称号页面 / 17:大地图界面

显示名称
%d表示货币对应的数量

货币变更触发

QF
变更的货币名称=<$str(S1)>

??????
[@MoneyChange]
#act
sendmsg 7 货币更新,<$str(S1)>!

checkMoney 参数1 参数2 参数3

参数位置 | 参数说明
参数1 | 自定义货币名称
参数2 | 数量
参数3 | 0或留空检测关联货币，1只检测本币

ChangeMoney 参数1 参数2 参数3 参数4

参数位置 | 参数说明
参数1 | 自定义货币名称
参数2 | 操作符(+、-、=)
参数3 | 数量
参数4 | 0或留空检测关联货币，1：只增加扣除本币

常量：
<$MONEY(自定义货币)> 显示自定义货币数量
<$MONEYALL(自定义货币)> 显示自定义货币及关联货币总数量

??????
[@main]
美元:<$MONEY(美元)>  总:<$MONEYALL(美元)>\
日元:<$MONEY(日元)>  总:<$MONEYALL(日元)>\
欧元:<$MONEY(欧元)>  总:<$MONEYALL(欧元)>\
<增加美元/@增加美元>    <增加日元/@增加日元>    <增加欧元/@增加欧元>\
<减少美元/@减少美元>    <减少日元/@减少日元>    <减少欧元/@减少欧元>\
<检测美元/@检测美元>    <检测日元/@检测日元>    <检测欧元/@检测欧元>\
[@检测美元]
#if
checkMoney 美元 100
#Act
sendmsg 7 美元和关联货币满足100！
goto @main
#elseact
sendmsg 7 美元和关联货币不足100！
goto @main
[@检测日元]
#if
checkMoney 日元 100
#Act
sendmsg 7 日元和关联货币满足100！
goto @main
#elseact
sendmsg 7 日元和关联货币不足100！
goto @main
[@检测欧元]
#if
checkMoney 欧元 100
#Act
sendmsg 7 欧元和关联货币满足100！
goto @main
#elseact
sendmsg 7 欧元和关联货币不足100！
goto @main
[@减少欧元]
#Act
ChangeMoney 欧元 - 10
goto @main
[@减少日元]
#Act
ChangeMoney 日元 - 10
goto @main
[@减少美元]
#Act
ChangeMoney 美元 - 10
goto @main
[@增加欧元]
#Act
ChangeMoney 欧元 + 10
goto @main
[@增加日元]
#Act
ChangeMoney 日元 + 10
goto @main
[@增加美元]
#Act
ChangeMoney 美元 + 10
goto @main


获取技能等级功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 脚本命令

获取技能等级功能

格式：GetMagicLevel 参数1 参数2 参数3
参数1：技能名称
参数2：查询类型（0普通技能 1强化技能 2当前技能熟练度 3当前技能等级最大熟练度）
参数3：存入变量 ;例子

英雄获取技能等级功能
格式：H.GetMagicLevel 参数1 参数2 参数3
参数1：英雄技能名称(例:英雄烈火剑法)
参数2：查询类型（0普通技能 1强化技能 2当前技能熟练度 3当前技能等级最大熟练度）
参数3：存入变量 ;例子

??????
[@获取技能等级]
#IF
#ACT
GetMagicLevel 烈火剑法 0 N1
SENDMSG 0 你的烈火剑法等级为:<$STR(N1)>


按地图列表移动

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

先设定每一张地图停留的地间，再把地图列表添加一下，人物会
从第一张地图开始一张一张移动到最后一张

脚本示例

??????
[@Test]
#IF
#ACT
batchDelay 1 ;(暂停时间)
addbatch B102 ;步进地图名1
addbatch B103 ;步进地图名2
addbatch B104 ;步进地图名3
addbatch B105 ;步进地图名4
addbatch B106 ;步进地图名5
addbatch B107 ;步进地图名6
batchmove ;开始从第一个步进地图移动到最后一个步进地图(这里是6)


把人物加入行会

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
ADDGUILDMEMBER 行会名称 人物名称(人物名称为空时把自己加入到行会)
??????
[@main]
#ACT
ADDGUILDMEMBER 行会名称


把行会加入攻城列表

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为*号时所有行会加入到攻城列表) 天数(几天后开始攻城，该参数可以为空，为空时按照引擎设置的天数)
??????
[@main]
#ACT
ADDTOCASTLEWARLIST 沙巴克 1


编组地图传送

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
GROUPMAPMOVE 地图号 X Y 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)
[@main]
#IF
#ACT
GROUPMAPMOVE 3 333 333 1 @GROUPMAPMOVE
??????
[@GROUPMAPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令

编组地图随机传送：GROUPMOVE
检查是否为组长：ISGROUPMASTER

相关命令页面

  • ISGROUPMASTER


编组地图随机传送

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
GROUPMOVE 地图号 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)
[@main]
#IF
#ACT
GROUPMOVE 3 1 @GROUPMOVE
??????
[@GROUPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令

编组地图传送：GROUPMAPMOVE
检查是否为组长：ISGROUPMASTER

相关命令页面

  • ISGROUPMASTER


播放人物效果

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
PLAYEFFECT WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 绘制模式(0特效绘制，1普通绘制)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

??????
[@main]
#ACT
PLAYEFFECT 0 0 10 1 300


调整金刚石数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整金刚石和灵符数量。

命令格式

??????
GAMEDIAMOND 控制符(=,+,-) 点数(0 到 2147483647)
GAMEGIRD 控制符(=,+,-) 点数(0 到 2147483647)
??????
;==========================================
;将人物的金刚石设置为指定点数，不能为负数
#IF
#ACT
GAMEDIAMOND = 0
#SAY
你的金刚石数量为0
;==========================================
;==========================================
;将人物的灵符设置为指定点数，不能为负数
#IF
#ACT
GAMEGIRD = 0
#SAY
你的灵符数量为0
;==========================================


调整人物的HP或MP

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物的HP或MP

命令格式

HUMANHP（+ - =）数字

HUMANMP（+ - =）数字

??????
=========================
[@HUMANHP0]
#IF
#ACT
HUMANHP + 100
[@HUMANHP1]
#IF
#ACT
HUMANHP - 100
[@HUMANHP2]
#IF
#ACT
HUMANHP = 100
=========================
??????
=========================
[@HUMANMP0]
#IF
#ACT
HUMANMP + 100
[@HUMANMP1]
#IF
#ACT
HUMANMP - 100
[@HUMANMP2]
#IF
#ACT
HUMANMP = 100
=========================


调整人物的荣誉值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
#IF
CheckLevelEx > 50
#ACT
ChangeNationCredit + 100

—————————————————————两个命令自己测试

命令格式

??????
GAMEGLORY (+,-,=) 值
??????
[@main]
#ACT
GAMEGLORY + 5
#SAY
荣誉值+5


调整人物会员等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物会员等级。

命令格式

??????
SETMEMBERLEVEL 控制符(=,+,-) 等级数(1-65535)
??????
;==========================================
;设置人物会员等级
[@changememberlevel0]
#IF
#ACT
SETMEMBERLEVEL = 5
#SAY
你的会员等级为5。
;==========================================
;==========================================
;增加人物会员等级
[@changememberlevel1]
#IF
#ACT
SETMEMBERLEVEL + 1
#SAY
你的会员等级已经改变。
;==========================================
;==========================================
;减少人物会员等级
[@changememberlevel2]
#IF
#ACT
SETMEMBERLEVEL - 1
#SAY
你的会员等级已经改变。
;==========================================


调整人物会员类型

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物会员类型。

命令格式

??????
SETMEMBERTYPE 控制符(=,+,-) 类型数(1-65535)
??????
;==========================================
;设置人物会员类型
[@changemembertype0]
#IF
#ACT
SETMEMBERTYPE = 5
#SAY
你的会员类型为5。
;==========================================
;==========================================
;增加人物会员类型
[@changemembertype1]
#IF
#ACT
SETMEMBERTYPE + 1
#SAY
你的会员类型已经改变。
;==========================================
;==========================================
;减少人物会员类型
[@changemembertype2]
#IF
#ACT
SETMEMBERTYPE - 1
#SAY
你的会员类型已经改变。
;==========================================


调整人物属性

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：调整人物属性

命令格式

??????
ChangeHumAbility 属性(1-20) 操作符(+ = -) 效果(1-65535) 时间秒

说明：属性1-12分别对应人物 防御下限 防御上限 魔御下限 魔御上限 攻击下限 攻击上限 魔法下限 魔法上限 道术下限 道术上限 MaxHP MaxMP HP恢复 MP恢复 毒恢复 毒躲避 魔法躲避 准确 敏捷 幸运

注意：整后的属性效果只在人物在线时有效.? 不带时间为在线一直有效

脚本示例

??????
[@Test]
#IF
#ACT
ChangeHumAbility 2 + 10 60
#SAY
你的防御上限增加10点.60秒后恢复


调整人物游戏点数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物游戏点。

命令格式

??????
GAMEPOINT 控制符(=,+,-) 点数(1-100)
??????
;==========================================
;设置人物游戏点
[@GAMEPOINT0]
#IF
#ACT
GAMEPOINT = 8
#SAY
你的游戏点已经为8了。
;==========================================
??????
;==========================================
;增加人物游戏点
[@GAMEPOINT1]
#IF
#ACT
GAMEPOINT + 1
#SAY
你的游戏点已经加了1点。
;==========================================
??????
;==========================================
;降人物游戏点
[@GAMEPOINT2]
#IF
#ACT
GAMEPOINT - 1
#SAY
你的游戏点已经降了1点。
;==========================================


调整声望点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物声望点。

命令格式

??????
CREDITPOINT 控制符(=,+,-) 点数(1-100)
??????
;==========================================
;设置人物声望点
[@CREDITPOINT0]
#IF
#ACT
CREDITPOINT = 8
#SAY
你的声望点已经为8了。
;==========================================
??????
;==========================================
;增加人物声望点
[@CREDITPOINT1]
#IF
#ACT
CREDITPOINT + 1
#SAY
你的声望点已经加了1点。
;==========================================
??????
;==========================================
;降人物声望点
[@CREDITPOINT2]
#IF
#ACT
CREDITPOINT - 1
#SAY
你的声望点已经降了1点。
;==========================================


调整属性点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物属性点。

命令格式

??????
BONUSPOINT 控制符(=,+) 点数(0-1000)
??????
;==========================================
;设置属性点
[@BONUSPOINT0]
#IF
#ACT
BONUSPOINT = 0
#SAY
你的属性点点已全部清0了。
;==========================================
??????
;==========================================
;增加属性点
[@BONUSPOINT1]
#IF
#ACT
BONUSPOINT + 1
#SAY
你的属性点已经加了1点。
;==========================================

相关命令

复位属性点数：RESTBONUSPOINT
检查属性点数：CHECKBONUSPOINT

相关命令页面

  • RESTBONUSPOINT
  • CHECKBONUSPOINT


调整物品名字颜色

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：调整人物身上物品装备名字颜色(英雄M2)

命令格式

??????
ChangeItemNameColor 物品位置(0-16，-1位OK框物品) 颜色(0-255)

说明：颜色=0时恢复默认颜色.

??????
[@main]
#IF
#ACT
ChangeItemNameColor 1 253
#SAY
你装备名字的颜色变成紫色了.


调整物品元素属性

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
SetNewItemValue 位置(-1时是OK框中的装备, 0-16时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)

属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

点击OK键后触发字段[@UpgradeDlgItem]

??????
[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\
??????
[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM


调整行会可以容纳最多成员

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
CHANGEGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示调整自己所在的行会) 调整符(+,-,=) 数量
??????
[@main]
#IF
CHANGEGUILDMEMBERMAXLIMITCOUNT = 100
#SAY
你的行会可以容纳100个成员


调整行会人数上限

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：调整当前行会的人数上限.

说明

只能由行会老大使用.每个行会会自动读取!Setup.txt中的行会人数限制,之后可以用此命令重新调整行会人数限制,也就是说调整后不受!Setup.txt中行会人数限制参数的限制.

命令格式

??????
AddGuildMemberCount 操作符(+ - = ) 数量(0--1000)
??????
#IF
CheckItem 金条 1
#ACT
Take 金条 1
AddGuildMemberCount + 5
#ELSESAY
你没有金条或者你不是行会老大.


调整游戏速度

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
ChangeSpeed 速度类型 速度值 有效时间(秒，该参数为空时表示不限制时间)
速度类型 1为 移动速度 2为攻击速度 3为魔法速度
速度值(-10和10之间 小于0为减速 等于0不变速)
??????
[@main]
#ACT
CHANGESPEED 1 5
#SAY
移动速度增加


调整装备升级次数或星星数量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：调整装备升级次数或星星数量.

命令格式

??????
ChangeItemUpgradeCount 物品位置(0~16,-1时为OK框物品) (+,-,=) 次数(0~255)
物品位置:
??????
;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================
??????
#IF
CheckItem 金条 1
#ACT
Take 金条 1
ChangeItemUpgradeCount 0 + 10
SendMsg 5 盔甲升级次数增加10次
#ELSESAY
你没有金条


复活人物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
REALIVE
??????
[@main]
#ACT
REALIVE


改变人体颜色

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
SETBODYCOLOR 颜色(0~255)255时清除颜色 改变时长(秒)
??????
[@main]
#ACT
SETBODYCOLOR 253
H.SETBODYCOLOR 253


改变人物攻击模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
ChangeAttatckMode (0~7)
??????
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击 6-红名攻击 7-国家攻击


改变人物状态

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
MAKEPOSION 类型(0-5,0和1是绿毒和红毒 5是麻痹 12冰冻 13蛛网 其他无效) 时间(秒) 威力

例：

??????
[@main]
#ACT
MAKEPOSION 5 10 10
#SAY
你被麻痹了
??????
[@main]
#ACT
MAKEPOSION 12 10
#SAY
你被冰冻了
??????
[@main]
#ACT
MAKEPOSION 13 10
#SAY
你被蛛网缠绕


改变用户模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

增加脚本命令ChangeModeEx
改变人物当前模式(无敌,隐身,生命,魔法,攻击力,魔法力,道术力,攻击速度,禁止攻击,锁定,禁锢,冰冻,蛛网,防麻痹,防禁锢,防冰冻,防蛛网,麻痹,护身，吸血,吸蓝)

??????
//格式: ChangeModeEx 模式(1-10) 时间(1-65535) 附加值(1-21亿)
//说明: 1=无敌 2=隐身 3=HP 4=MP 5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定
//第三个参数无敌,隐身,禁止攻击时没有使用.
//如果是禁锢时，第三个参数表示禁锢范围
//11 禁锢(释放一个类似困魔咒的光圈，敌对人物或怪物只能在这个圈子里移动，无法走出圈子外面，所有传送失效，不能小退)
//12 冰冻
//13 蛛网
//14 防麻痹
//15 防禁锢
//16 防冰冻
//17 防蛛网
//18 麻痹
//19 护身
//20 吸血
//21 吸蓝

脚本示例

??????
[@Test]
#IF
#ACT
ChangeModeEx 1 60
#SAY
给你1分钟的无敌时间,好好利用哦!
#IF
#ACT
ChangeModeEx 5 60 20
#SAY
60秒之内攻击力增加20点.

[@Main]
#ACT
ChangeModeEx 11 10 3
SENDMSG 6 你被禁锢10秒

ChangeModeEx 12 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标冰冻，冰冻机率5(数字越大机率越低)，冰冻时长3秒

ChangeModeEx 13 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标中蛛网，中蛛网机率5(数字越大机率越低)，中蛛网时长3秒

ChangeModeEx 14 10
SENDMSG 6 10秒内可以防麻痹

ChangeModeEx 15 10
SENDMSG 6 10秒内可以防禁锢

ChangeModeEx 16 10
SENDMSG 6 10秒内可以防冰冻

ChangeModeEx 17 10
SENDMSG 6 10秒内可以防蛛网

ChangeModeEx 18 10 5 3
SENDMSG 6 10秒内攻击目标，可以使目标麻痹，麻痹机率5(数字越大机率越低)，麻痹时长3秒

ChangeModeEx 19 10
SENDMSG 6 护身，有效10秒

ChangeModeEx 20 10 100 50
SENDMSG 6 10秒内攻击目标，可以吸血，吸血机率100(数字越大机率越高 100表示每次都会吸血)，吸血百分比50%(比如攻击伤害值是10000，50%的吸血比例，可以吸血5000)

ChangeModeEx 21 10 100 50
SENDMSG 6 10秒内攻击目标，可以吸蓝，吸蓝机率100(数字越大机率越高 100表示每次都会吸蓝)，吸蓝百分比50%(比如攻击伤害值是10000，50%的吸蓝比例，可以吸蓝5000)


给予带绑定状态装备

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

给予带绑定状态装备。主要方便设置不能配带的装备绑定状态

命令格式

命令格式

??????
CheckItemBind 装备位置(-1~16,-1时为OK框中物品)
GiveStateItem 物品名称 项目1 项目2 项目3 项目4 项目5 项目6 项目7(0为正常,1为绑定) 数量
;项目1--禁止扔，项目2--禁止交易，项目3--禁止存，项目4--禁止修，项目5--禁止出售,项目6--禁止爆出的装备,项目7--丢弃消失
??????
[@给一个绑定的装备]
#ACT
GiveStateItem 木剑 1 0 0 0 0 0 0 1
SENDMSG 6 给你一个绑定木剑并且禁止扔


更改人物颜色

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

更改人物颜色。

命令格式

??????
CHANGENAMECOLOR 颜色代码(0-255)
??????
;==========================================
;设置人物的名称颜色
[@changeexp0]
#IF
#ACT
CHANGENAMECOLOR 2
#SAY
你的颜色已改变。
;==========================================


更改头发类型

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

更改头发类型

命令格式

??????
;============================
[@ChangeHair]
#if
#act
HAIRSTYLE 0
#say
你的头发已更改
;============================


更换性别

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

更换性别。

命令格式

??????
CHANGEGENDER 性別(男 0 女 1)
??????
;==========================================
[@toman]
#IF
#ACT
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \
??????
[@towoman]
#IF
#ACT
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \


获取对面人物的名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

说明：获取对面人物的名字

命令格式

??????
GetOppositeHumName 变量
??????
#IF
#ACT
GetOppositeHumName S0
SendMsg 5 你对面的人物是: <$STR(S0)>


加入国家

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
JoinNational (国家编号 0~100 0表示从当前国家中删除，也就是退出该国家)
??????
;==========================================
[@main]
#IF
CheckNational 0
#ACT
JoinNational 1
SENDMSG 6 你成功加入<$NATIONNAME>，当前国家总人数:<$NATIONPEOPLE>
#ELASEACT
MESSAGEBOX 你已经加入了<$NATIONNAME>，是否要注销国籍？ @yes
[@yes]
#ACT
JoinNational 0
SENDMSG 6 你成功注销国籍
;==========================================


加入会员人物及时间

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

加入会员人物及时间： ADDUSERDATE 会员.txt

相关命令

??????
CHECKUSERDATE 会员.txt    <       30    p0        p1

检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1
删除会员人物及时间： DELUSERDATE 会员.txt

相关命令页面

  • CHECKUSERDATE
  • DELUSERDATE


脚本调整人物PK点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物PK点数。

命令格式

??????
CHANGEPKPOINT 控制符(=,+,-) PK点数
??????
;==========================================
;将人物的PK点数设置为指定点数，不能为负数
[@changepkpoint0]
#IF
#ACT
CHANGEPKPOINT = 0
#SAY
你的PK点数已经清除。
;==========================================
;==========================================
;将人物的PK点数加100点数，不能为负数
[@changepkpoint1]
#IF
#ACT
CHANGEPKPOINT + 100
#SAY
你的PK点数已经增加100点。
;==========================================
;==========================================
;将人物的PK点数减100点数，不能为负数，如果人物点数小于100则指定为0
[@changepkpoint2]
#IF
#ACT
CHANGEPKPOINT - 100
#SAY
你的PK点数已经减少100点。
;==========================================


脚本调整升级经验

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物经验点数。

命令格式

??????
CHANGEEXP 参数1(=,+,-) 参数2(经验值) 参数3(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验)
??????
;==========================================
;将人物的经验点数设置为指定点数，不能为负数
[@changeexp0]
#IF
#ACT
CHANGEEXP = 20000
#SAY
你当前的经验点数为 20000。
;==========================================
;==========================================
;将人物的经验点数加1000点数，不能为负数
[@changeexp1]
#IF
#ACT
CHANGEEXP + 1000
#SAY
你的经验点数已经增加1000点。
;==========================================
;==========================================
;将人物的经验点数减1000点数，不能为负数，如果人物点数小于1000则指定为0
[@changeexp2]
#IF
#ACT
CHANGEEXP - 1000
#SAY
你的经验点数已经减少1000点。
;==========================================


脚本控制人物等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物等级。

命令格式

??????
CHANGELEVEL 控制符(=,+,-) 等级数(1-500)
??????
;==========================================
;设置人物等级
[@changelevel0]
#IF
#ACT
CHANGELEVEL = 80
#SAY
你的等级已经为80级了。
;==========================================
;==========================================
;增加人物等级
[@changelevel1]
#IF
#ACT
CHANGELEVEL + 1
#SAY
你的等级已经升了1级。
;==========================================
;==========================================
;降人物等级
[@changelevel2]
#IF
#ACT
CHANGELEVEL - 1
#SAY
你的等级已经降了1级。
;==========================================


禁止骑马

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

在骑马触发里使用

??????
[@OnHorse]
#ACT
HORSERIDINGBAN
SENGMSG 6 禁止骑马


扩展GIVE命令

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

给物品到用户包裹

??????
GIVE 物品名称 数量 极品属性(13个参数，可以参考UPGRADEITEMEX命令 属性位置的介绍，或自己实际测试看效果) 元素属性(11个参数,从暴击机率开始)

例：

??????
GIVE 布衣(男) 1 100|100|100|100|100|100|100|100|100|100|100|100|100 100|100|100|100|100|100|100|100|100|100|100|100|100


清除地图物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

清理地图上指定名字的物品.

命令格式

??????
CLEARITEMMAP 地图 X Y 范围 物品名称 (清除地图物品，不带物品名称则清除所有)

说明

物品名字等于*时表示指定范围内的所有物品.

??????
;清除盟重安全区内的回城卷
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10 回城卷
#SAY
盟重安全区内的回城卷都被清除了。
清除盟重安全区内所有物品
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10
#SAY
盟重安全区内的所有物品都被清除了。


清除结婚信息

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
;============================
[@delMarry]
#if
DELMARRY
#say
你的结婚信息已清除
;============================


清除人物的仓库密码

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

清除人物的仓库密码

命令格式

??????
CLEARPASSWORD
??????
;==========================================
;设置人物的名称颜色
[@clearpassword]
#IF
#ACT
CLEARPASSWORD
#SAY
你的仓库密码已清除。
;==========================================


清除人物转生

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

清除人物转生数据(即人物转生后恢复到未转生状态)

命令格式

??????
;==========================================
[@ClearRenewLevel]
#IF
#ACT
RestRenewLevel
;==========================================


清除延时移动

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

清除延时移动

命令格式

??????
BREAKTIMERECALL
??????
============================
[@Test]
#IF
#ACT
BREAKTIMERECALL
#Say
延时移动已清除
===========================


取对面角色人物名

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

取对面角色人物名到变量

命令格式

??????
GETPOSENAME 变量名

功能

??????
================================
[@AddAccountList]
#IF#act
GETPOSENAME a1
#SAY
对面的人物名：<$STR(a1)>
================================


杀死人物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

杀死人物.

命令格式

??????
CLEARPASSWORD
??????
;==========================================
;杀死人物
KILL 0 人物死亡,不显示凶手信息
KILL 1 人物死亡不掉物品,不显示凶手信息
KILL 2 人物死亡,显示凶手信息为NPC
KILL 3 人物死亡不掉物品,显示凶手信息为NPC
;==========================================
[@KILL]
#IF
#ACT
KILL 2
;==========================================


删除会员人物及时间

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

删除会员人物及时间： DELUSERDATE 会员.txt

相关命令

??????
CHECKUSERDATE 会员.txt <          30    p0        p1

检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1
加入会员人物及时间： ADDUSERDATE 会员.txt

相关命令页面

  • CHECKUSERDATE
  • ADDUSERDATE


删除人物称号

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
DEPRIVETITLE 称号名称
??????
DEPRIVETITLE ALL //删除所有称号


删除行会成员

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

删除行会成员。

命令格式

??????
DelGuildMember 行会名称 人物名称
（删除掌门无效）
??????
;==========================================
[@Test]
#if
#act
DelGuildMember 测试行会 <$USERNAME>
#say
你已经从[测试行会]中脱离出来
;==========================================


设置攻击力倍数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

设置攻击力倍数

命令格式

??????
POWERRATE 倍率 有效时间
倍率 为杀攻击力倍数，倍数除以100为真正的倍率(200为2倍攻击，150为1.5倍攻击)支持变量操作
??????
;==========================================
[@POWERRATE]
#IF
#ACT
POWERRATE 1000 600
#SAY
您当前攻击力倍数为 10倍，有效时间 600秒。
;==========================================


设置人物当前模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

设置人物当前模式。（1管理模式、2无敌模式、3隐身模式）

命令格式

??????
CHANGEMODE 模式类型 开关（1为开，0为关）
??????
;==========================================
[@test]
#IF
#ACT
CHANGEMODE 1 1
CHANGEMODE 2 1
CHANGEMODE 3 1
;==========================================


设置人物当前权限

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

设置人物当前权限（0-10）

命令格式

??????
(提升到超级GM)
??????
;==========================================
[@test]
#IF
#ACT
CHANGEPERMISSION 10
;==========================================


设置人物名称 称号

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

设置人物名称称号 M2-选项-参数设置-游戏选项(1)-开启称号。不能勾选，勾选了，这个脚本命令无效

??????
SETRANKLEVELNAME 称号内容(必须包含一个%s)


设置物品和人物绑定

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：设置新的装备绑定功能.(专用登录器)

SetItemBind,设置物品和人物绑定 绑定后物品属性会显示“已绑定”

命令格式

??????
SetItemBind 装备位置(-1~16,-1时为OK框中物品) 绑定(0-1)

说明：参数2 0=取消 1=绑定

脚本示例

??????
绑定武器.
??????
#IF
CheckGold 10000
#ACT
SetItemBind 1 1
Take 金币 10000

脚本示例

取消绑定

??????
#IF
CheckGold 10000
CheckItemBind 1
#ACT
SetItemBind 1 0
Take 金币 10000
#ELSESAY
你没有10000金币,或者当前物品没绑定.


设置装备绑定状态

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：设置装备绑定状态。

命令格式

??????
SetItemState 装备位置(-1~16,-1时为OK框中物品) 项目(0-6) 属性(0为正常,1为绑定)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出 6 丢弃消失
??????
[@衣服禁止扔]
#IF
CheckItemBind 0
#ACT
GOTO @禁止扔
#ELSEACT
SENDMSG 6 请先绑定

[@禁止扔]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SetItemState 0 0 1
SENDMSG 6 该装备禁止扔


设置装备发光特效

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
SETITEMEFFECT 位置(-1时是OK框中的装备, 0-16时是穿在身上的装备) 特效编号(0-65535,0为清除特效)

特效编号需要在M2里编辑好的

??????
[@main]
#ACT
SETITEMEFFECT 0 0


所有行会同时攻城

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：所有行会在当晚同时攻城

??????
AddAttackSabukAll 城堡号(0)
??????
#IF
#SAY
所有行会将于今晚同时攻城!
#ACT
AddAttackSabukAll 0


踢除服务器挂机人物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

踢除服务器所有挂机人物。

命令格式

??????
KICKOFFLINE //踢除服务器所有挂机人物
??????
;==========================================
例：
#IF
#ACT
KICKOFFLINE
#Say
挂机人员全体下线
;==========================================


踢除服务器所有人物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

踢除服务器所有人物。

命令格式

??????
KICKALLPLAY //踢除服务器所有在线人物
??????
;==========================================
例：
#IF
#ACT
KICKALLPLAY
#Say
全体下线
;==========================================


踢人物下线

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

踢人物下线.

命令格式

??????
KICK
??????
;==========================================
[@KICK]
#IF
#ACT
SENDMSG 5 %s，非法登录游戏
KICK
;==========================================


添加行会成员

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

添加行会成员。

命令格式

??????
AddGuildMember 行会名称 人物名称
??????
;==========================================
[@Test]
#if
#act
AddGuildMember 测试行会 <$USERNAME>
#say
你已经成功加入[测试行会]行会中
;==========================================


新游戏点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

检测命令 CHECKGAMEGOLDEX 检测符(<,>,=) 值
操作命令 GAMEGOLDEX 操作符(+,-,=) 值
显示变量 <$GAMEGOLDEX>


行会地图传送

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
GUILDMAPMOVE 地图号 X Y 最低等级
只有行会掌门，才可以使用
??????
[@guildmapmove]
#if
#act
GUILDMAPMOVE 3 330 330 0


行会地图随机传送

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
GUILDMOVE 地图号 最低等级
只有行会掌门，才可以使用
??????
[@guildmove]
#if
#act
GUILDMOVE 3 0


行会建设相关

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

修改行会建筑度:

命令格式

??????
GUILDBUILDPOINT 控制符（+-）数字
修改行会人气度:

命令格式

??????
GUILDAURAEPOINT控制符（+-）数字
修改行会安定度:

命令格式

??????
GUILDSTABILITYPOINT控制符（+-）数字
修改行会繁荣度:

命令格式

??????
GUILDFLOURISHPOINT控制符（+-）数字

检测行会建筑度：

命令格式

??????
CHECKGUILDBUILDPOINT 控制符（<>=）数字

检测行会行会人气度:

命令格式

??????
CHECKGUILDAURAEPOINT 控制符（<>=）数字
检测行会安定度:

命令格式

??????
CHECKGUILDSTABILITYPOINT 控制符（<>=）数字

检测行会繁荣度：

命令格式

??????
CHECKGUILDFLOURISHPOINT 控制符（<>=）数字

变量：

??????
<$GUILDBUILDPOINT> 行会建筑度
<$GUILDAURAEPOINT> 行会人气度
<$GUILDSTABILITYPOINT> 行会安定度
<$GUILDFLOURISHPOINT> 行会繁荣度


延时移动

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

延时移动

命令格式

??????
TIMERECALL 时间(分钟)
??????
============================
[@Test]
#IF
#ACT
timerecall 60
map G012
give 回城卷 1
SENDMSG 0 [%s]使用了元宝练级卷.进入快速升级地图,1小时后会将您传回土城!
===========================


移动到回城点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

移动到回城点

??????
[@main]
#if
#act
GoHome
#say
你已经回城了


永久增加人物属性点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

永久增加人物属性点。(支持英雄)

命令格式

??????
USEBONUSPOINT 属性位置（1-14） 控制符（+,-,=） 点数
1-攻击力 2-魔法力 3-道术力 4-防御力 5-魔防力 6-生命值 7-魔法值 8- 准确 9-躲避 10-防御下限 11-防御上限 12-魔御下限 13-魔御上限 14-吸收伤害
??????
;==========================================
[@Main]
#ACT
USEBONUSPOINT 1 + 20
SENDMSG 7 攻击力增加20点.

[@Main]
#ACT
USEBONUSPOINT 2 + 20
SENDMSG 7 魔法力增加20点.

[@Main]
#ACT
USEBONUSPOINT 3 + 20
SENDMSG 7 道术力增加20点.

[@Main]
#ACT
USEBONUSPOINT 4 + 20
SENDMSG 7 防御力增加20点.

[@Main]
#ACT
USEBONUSPOINT 5 + 20
SENDMSG 7 魔防力增加20点.

[@Main]
#ACT
USEBONUSPOINT 6 + 20
SENDMSG 7 生命值上限增加20点

[@Main]
#ACT
USEBONUSPOINT 7 + 20
SENDMSG 7 魔法值上限增加20点.

[@Main]
#ACT
USEBONUSPOINT 8 + 20
SENDMSG 7 准确增加20点.

[@Main]
#ACT
USEBONUSPOINT 9 + 20
SENDMSG 7 躲避增加20点.
;==========================================


游戏币控制

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

调整人物游戏币及根据时间自动增减游戏币（可用来做会员时间用）。

命令格式

??????
GAMEGOLD 控制符(=,+,-) （1-100）
??????
;==========================================
;设置人物游戏币
[@GAMEGOLD0]
#IF
#ACT
GAMEGOLD = 8
#SAY
你的游戏点已经为8了。
;==========================================

;==========================================
;增加人物游戏币
[@GAMEGOLD1]
#IF
#ACT
GAMEGOLD + 1
#SAY
你的游戏点已经加了1点。
;==========================================

;==========================================
;降人物游戏币
[@GAMEPOINT2]
#IF
#ACT
GAMEGOLD - 1
#SAY
你的游戏币已经降了1点。
;==========================================

功能

设置是否自动增加游戏币。

命令格式

??????
AUTOADDGAMEGOLD 控制符(START,STOP)
??????
;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOADDGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个
;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOADDGAMEGOLD STOP
#SAY
现退出自动增加游戏币模式
;==========================================

功能

设置是否自动减少游戏币。

命令格式

??????
AUTOADDGAMEGOLD 控制符(START,STOP)
??????
;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOSUBGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个
;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOSUBGAMEGOLD STOP
#SAY
现退出自动减少游戏币模式
;==========================================


在地图上放物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
THROWITEM 地图名称 X坐标 Y坐标 范围 物品名称 数量|时间(秒) 是否掉落提示(0不提示,1提示) 是否可以立即捡取(0不能立即捡取,1可以立即捡取)
??????
[@main]
#IF
Random 100
#ACT
ThrowItem 3 330 330 10 回城卷 5|60


增加会员时间

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

增加会员时间 文件名称 天 时 分

脚本示例

??????
[@Test]
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S$1)> <$STR(N$1)> <$STR(N$2)> <$STR(N$3)>
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 0 0
SENDMSG 5 <$USERNAME>会员充值成功，增加30天0小时0分会员时间！
SENDMSG 6 你的会员到期时间是<$STR(S$1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253


增加人物称号

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
CONFERTITLE 称号名称(需要到物品数据库里添加，详见说明书称号系统) 是否设置为当前称号(1=设置为当前称号)


重新分配人物附加属性点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

将人物附加的属性点复位到未分配状态；

命令格式

??????
#if
#act
RESTBONUSPOINT
#say
你的属性点已经重新分配；

相关命令

检查属性点数：CHECKBONUSPOINT
调整属性点数：BONUSPOINT

相关命令页面

  • CHECKBONUSPOINT
  • BONUSPOINT


转换职业

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

转换职业。

命令格式

??????
CHANGEJOB 职业名称(Warrior,Wizard,Taoist)
??????
;==========================================
;转职业为武士
[@changejob0]
#IF
#ACT
CHANGEJOB Warrior
#SAY
你的职业已经变成武士了。
;==========================================
;==========================================
;转职业为法师
[@changejob1]
#IF
#ACT
CHANGEJOB Wizard
#SAY
你的职业已经变成法师了。
;==========================================
;==========================================
;转职业为道士
[@changejob2]
#IF
#ACT
CHANGEJOB Taoist
#SAY
你的职业已经变成道士了。
;==========================================


查看动态地图链接点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

说明

查看使用AddMapRoute设置的动态链接点.

命令格式

??????
GetMapRouteInfo 链接标示 查看方式(0-1) 坐标X 坐标Y

脚本示例

查看地图链接点

??????
[@ViewRoute]
#IF
#ACT
;查看链接坐标,参数2等于0查看连接地图,等于1查看待连接地图.
GetMapRouteInfo 1 0 A0 G0 G1
GetMapRouteInfo 1 1 A1 G2 G3
SendMsg 5 [地图<$STR(A0)>坐标:<$STR(G0)>:<$STR(G1)>]->[地图<$STR(A1)>坐标:<$STR(G2)>:<$STR(G3)>]


地图动态链接点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：给地图增加动态链接点.

说明

此功能需要两个脚本命令配套使用才可生效.
AddMapRoute用于添加一个地图链接点,SetMapRoute配合设置一个地图链接点.

命令格式

??????
AddMapRoute 动态链接标示(1-65535) 连接地图 坐标X 坐标Y
SetMapRoute 动态链接标示(1-65535) 待连接地图 坐标X 坐标Y

脚本示例

??????
链接地图3和地图5的特定坐标, 地图 3 335 330 地图 5 658 463
[@AddRoute]
#IF
#ACT
AddMapRoute 1 3 335 330
SetMapRoute 1 5 658 463


动态修改地图名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：动态修改地图显示名字.

命令格式

??????
ChangeMapDesc 新名字 是否保存(0,1)

说明

直接修改MapInfo.txt中对应地图的显示名字.

脚本示例

??????
修改盟重省的名字,并且保存.
#IF
#ACT
ChangeMapDesc 新盟重 1


改变人物的模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

改变人物当前模式(无敌,隐身,生命,魔法,攻击力,道术力,魔法力,攻击速度,禁止攻击)

命令格式

??????
ChangeModeEx 模式(1-10) 时间(1-65535) 附加值(1-65535)说明：1=无敌 2=隐身 3=HP 4=MP 5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定
第三个参数无敌,隐身,禁止攻击时没有使用.
??????
#IF
#ACT
ChangeModeEx 1 60
#SAY
给你1分钟的无敌时间,好好利用哦!
#IF
#ACT
ChangeModeEx 5 60 20
#SAY
60秒之内攻击力增加20点.


改变物品的持久

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

修改指定位置装备的当前最大持久.

命令格式

??????
ChangeItemDura 装备位置(0-12) 操作符(+,-,=) 持久(0-65000) 当前持久大于最大持久时是否改变当前支持(0-1)
#IF
#ACT
ChangeItemDura 0 - 1000
#SAY
你的物品最大持久降低1点.


改变衣服翅膀效果

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

改变人物衣服翅膀效果

说明：客户端需要有HumEffect.wil

??????
#IF
#ACT
ChangeDressEffect 3


改变指定行会的掌门人

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

改变行会掌门人

??????
[@changeguildmaster]
#IF
#ACT
ChangeGuildMaster 华山派
#SAY
贡献,你现在是华山派掌门人了.


恢复发言

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

恢复人物发言.

??????
#IF
CheckLevelEx > 1
#ACT
ENABLESENDSAY


获取玩家名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能

取得玩家名字.

命令格式

??????
GetUserName 0-99之间的数字,或者范围是0-99之间的数值型变量.
如下将玩家名字放入S10中
#IF
#ACT
GetUserName S10


建立新行会

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

增加一个新的行会.可以指定某人成为该行会掌门(必须在线)

说明：第二个参数等于Self时掌门是自己.否则是在线玩家.

??????
[@AddGuild]
#IF
#ACT
AddGuild 华山派 Self


强制攻击模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：强制人物的攻击模式

命令格式

??????
SetHumAttackMode 攻击模式(0-7) 时间(秒)

说明：0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击 6-红名攻击 7-国家攻击

脚本示例

??????
强制人物和平模式
??????
#IF
CheckPkPoint 2
#ACT
SetHumAttackMode 1 3600


取下人物身上装备

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

把人物身上装备放入背包中.

命令格式

??????
TakeEx (0-16)
#IF
#ACT
TakeEx 1


取装备名字

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

取指定位置的装备名字

命令格式

??????
GetUserItemName 位置(0-12) S变量(0-99)

说明：S变量是人物私有变量(0-99)

脚本示例

把武器的名字放如S10变量中

??????
#IF
#ACT
GetUserItemName 1 10
SendMsg 5 武器的名字: <$STR(S10)>


删除地图动态链接点

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：删除使用AddMapRoute设置的地图链接点.

命令格式

??????
DelMapRoute 动态链接标示(1-65535)

脚本示例

删除链接表示等于1的链接点.

??????
#IF
#ACT
DelMapRoute 1


设置人物伤害吸收

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

说明：设置人物可吸收收到的攻击伤害.

命令格式

??????
SetSuckDamage 操作符(+ - =) 总吸收直(1-2000000000) 吸收比例(1-1000) 成功率(1-100)
吸收比例 1=0.1% 500=50% 1000=100%

脚本示例

设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%

??????
#IF
CheckGold 10000
#ACT
SetSuckDamage + 1000 200 95
Take 金币 10000

特别说明:当人物设置伤害吸收后,收到攻击后会按照一定比例减少受到的伤害.
例如:当前拥有5000点伤害吸收,每次吸收20%,成功率100%.当前攻击受到100点伤害,那么本次攻击实际受到的伤害是80点.当前伤害吸收剩余4980点,此状态直到伤害吸收等于0时恢复,下线可保存装备.


设置人物商铺购买价格比例

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：设置人物商铺购买物品的价格比例.

命令格式

??????
SetShopItemPriceRate 比例(1-100)

注意：人物下线后状态消失.

其他：列表信息中可设置单个物品是否允许打折购买.

例如:大于100级人物商铺购买物品的价格比例是90%,人物上线时在登录脚本设置价格比例即可.

??????
[@Login]
#IF
CheckLevelEx > 99
#ACT
SetShopItemPriceRate 90


设置装备发光

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：设置装备发光

说明：衣服,武器和头盔不支持次功能.

适用: 英雄M2

命令格式

??????
SetItemsLight 位置(0-12) 值(1=发光效果1 2=发光效果2 0=不发光).

其他

选择效果点击 M2\选项\功能设置\内挂控制
发光效果1:

??????
#IF
#ACT
SetItemsLight 3 1

发光效果2:

??????
#IF
#ACT
SetItemsLight 3 2
取消发光:
#IF
#ACT
SetItemsLight 3 0


移动某地图全部人物到另外一个地图

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

把某个地图中的玩家全部移动到另外一个地图.

??????
#IF
#ACT
MoveMapPlay 0 3 333 333
#SAY
地图0中的人物已经全部移动到地图3中.


创建副将英雄脚本

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
;@@BuHero 是创建和删除副将英雄的标志
;以下是酒馆_辰星的脚本
(@@BuHero @PlayDrink )
[@main]
魔法不单是华丽的攻击，更需要在战斗中感受它的使用技巧。现\
在是时间让年轻的卧龙英雄们去体会战斗中的艰辛了。如果能在修\
行中遇到值追随一生的伙伴，对他们来说也许就更有意义！\ \
<召唤卧龙英雄/@召唤卧龙英雄>\
<寄存领回英雄/@寄领英雄> \
<主将副将英雄培养/@主副英雄培养> \
<我不想再带领卧龙英雄/@不带英雄>\
[@召唤卧龙英雄]
<我想找卧龙英雄做为我的历练伙伴/@领取卧龙英雄>\ \
<返回/@main>
[@寄领英雄]
<我想找您帮个忙，我想寄放英雄/@寄放英雄>\
<我想领回英雄/@领回英雄> \ \
<返回/@main>
[@主副英雄培养]
#if
CheckHeroAutoPractice
#say
看来你的副将英雄正在进行自我修炼....\ \
<我要停止副将英雄的自我修炼/@停止自我修炼>\ \
<查看副将英雄修炼时间/@查看修炼时间>
#elsesay
随着我们多年以来对英雄的训练，我们发现了一种新的培养方式和\
战斗方式。新的培养方式能够让同一英雄以三职业不同状态出战。\
新的战斗方式能够让你在战斗中召唤第二个英雄替换英雄进行战斗，\
从而对战局产生变化。\
当然，要想实现这一切的前提是必须对你的卧龙英雄和白日门英雄\
进行评定，选出主将和副将，才能够进行新的培养方式。\
<主将副将英雄评定/@主副将评定> <副将英雄自我修炼/@自我修炼> <英雄的历史/@英雄历史>\
<主将副将英雄指南/@英雄指南>\
<返回/@main>
[@停止自我修炼]
#if
#ACT
StopHeroAutoPractice
Close
[@StopHeroAuto]
#if
#ACT
give 金创药 1
Close
[@查看修炼时间]
你的副将英雄本次的修炼时间为:<$HEROAUTOTIME>秒\
<返回/@主副英雄培养>
[@主副将评定]
#if
#act
ASSESSMENTHERO
[@自我修炼]
#if
CheckDeputyHero
;检测当前在线的是卧龙英雄
#say
请注意：副将英雄的等级上限为主将英雄当前等级减三，副将\
英雄的内功等级上限为主将英雄当前内功等级减三。一旦副将\
英雄的等级或内功等级达到上限，自动修炼将不能获得相应的\
经验或内功经验。\
当且仅当副将英雄自动修炼满2小时，且在酒馆英雄NPC处终止\
训练时，将有几率带回训练过程中拾取的物品。\ \
<副将英雄自动修炼/@自动修炼>
#elsesay
请先召唤出你的副将英雄吧......\
[@自动修炼]
#if
#ACT
OpenHeroAutoPractice
Close
[@领回英雄]
<$USERNAME>,想和你的英雄一起闯荡玛珐大陆吗？\ \
<是的，我是来接他走的/@GetHero>\ \
<不了，还要托你照顾一段时间/@exit>\
[@GetHero]
#if
#act
GetHero
[~PlayDrink_Already]
#if
#act
#Say
嗯......真是香醇的美酒,令我心情舒畅。\<寄放英雄/@SaveHero>
[~PlayDrink_Already_NotHero]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\
[~PlayDrink_Already_HeroBegin]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>
[@领取卧龙英雄]
#if
HAVHERO TRUE
#say
你已经有卧龙英雄了,还想再领取?\
#elsesay
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
\
<没有问题，我这里有上好的美酒/@请喝酒>\
\
<我不会喝酒……/@exit>\
[@请喝酒]
#if
HAVHERO
#say
你精力有限,只能带领一位英雄在玛法大陆历练。\
如果你想再带领一位英雄,可以先将身边的英雄安顿在我们这里\
#elsesay
好！好！快拿酒来，让小二倒进六个坛中。\
每个坛里的酒有多有少，喝多喝少就看运气。\
我们就来拿这六坛酒来斗一斗！\ \
<好的，来吧/@斗酒规则>\
[@斗酒规则]
#if
#act
Mov M0 1
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了,摆酒吧/@PlayDrink>\
[@PlayDrink]
请把酒放上去
[~PlayDrink_Game]
#if
#act
OPENPLAYDRINK 2 晨星 DRINK
PLAYDRINKMSG 1 <$USERNAME>，酒之道也可以算作我修行的一部\分，让我看看你的表现吧。
PLAYDRINKMSG 2 嘿嘿……我可不会比你先醉倒，保管陪\你喝爽了！
[~PlayDrink_Self_Loss]
#if
#act
PLAYDRINKMSG 1 这点酒量，我怎么放心让我的弟子\跟随你啊！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>
[~PlayDrink_SelfToNpc]
#if
#act
PLAYDRINKMSG 1 好！
PLAYDRINKMSG 2 就这坛了！请前辈来喝!
[~PlayDrink_SelfToSelf]
#if
#act
PLAYDRINKMSG 1 ……
PLAYDRINKMSG 2 就这坛了！我自己喝！
[~PlayDrink_NpcToSelf]
#if
#act
PLAYDRINKMSG 1 就这坛了！你来喝吧！
PLAYDRINKMSG 2 谢谢前辈！
[~PlayDrink_NpcToNpc]
#if
#act
PLAYDRINKMSG 1 就这坛了！我来喝！
PLAYDRINKMSG 2 前辈尽管喝！
[~PlayDrink_Dogfall]
#if
#act
PLAYDRINKMSG 1 那再来一局吧。
PLAYDRINKMSG 2 来就来！
[~PlayDrink_NpcWil]
#if
#act
PLAYDRINKMSG 1 嗯，不错，那我选了。
PLAYDRINKMSG 2 真倒霉，我就不信赢不了你。
[~PlayDrink_PlayWil]
#if
#act
PLAYDRINKMSG 1 <$USERNAME>，你选吧。
PLAYDRINKMSG 2 哈哈哈，还是我厉害吧~\选哪一坛好呢？
[~PlayDrink_Self_Drunk]
#if
#act
PLAYDRINKMSG 1 看你这么努力，英雄我就交给你了\！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>
[~PlayDrink_Npc_Drunk]
#if
#act
PLAYDRINKMSG 1 呃,看来令天我是有点喝多了……！
PLAYDRINKMSG 2 啊……前辈,您别醉呀……\<招幕英雄/@CrHero>
[@CloseDrink]
#if
#act
CLOSEDRINK
[~PlayDrink_Npc_Loss]
#if
equal M0 1
#act
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<招幕英雄/@CrHero>!
#elseact
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<删除英雄/@DelMyHero>!
[@CrHero]
#if
#act
CLOSEDRINK
#say
恩……好酒啊，既然你请我喝酒了。\
请先给您的卧龙英雄取个名字吧。\
<英雄起名/@@buHero>\
[@@buHero]
你要带一个男法师还是法师士卧龙英雄呢？\
<卧龙男法师英雄/@CREATEHERO_TAOS_MAN>\
<卧龙女法师英雄/@CREATEHERO_TAOS_WOM>\
\
[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 1 0 TRUE
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 1 1 TRUE
//返回消息
[@HAVHERO]
您已经有英雄了。\ \
<噢，也许是我记错了/@exit>
[@SetHeroName]
请先给您的卧龙英雄取个名字吧。\ \
<关闭/@exit>
[@寄放英雄]
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
\
<没有问题，我这里有上好的美酒/@Drink>\
\
<我不会喝酒……/@exit>\
[@Drink]
#if
#act
OPENPLAYDRINK 2 辰星
PLAYDRINKMSG 1 酒意需要品味，生命的动人之处常会在不经意\之间显现。我们在小酌中慢慢体会\吧。
PLAYDRINKMSG 2 小提示：请将包裹栏中的酒放至酒碟上。
[~PlayDrink_Ok]
#if
#act
PLAYDRINKMSG 1 天道自然，在自然之中追寻平衡本百易事，但\这酒令我有了一些顿悟。\<寄放英雄/@SaveHero>
[@SaveHero]
#if
#act
SAVEHERO
[@NoSaveHero2]
还是不要寄放了吧，让你的主将英雄同你一起战斗吧......
[@NoSaveHero3]
还是不要寄放了吧，让你的副将英雄同你一起战斗吧......
[~PlayDrink_HeroOk]
#if
#act
CLOSEDRINK
[~PlayDrink_NotHero]
#if
#act
CLOSEDRINK
PLAYDRINKMSG 1 你没喝多吧？你身边空无一人，还说要把英雄\托付我？\
[~PlayDrink_HeroBegin]
#if
#act
PLAYDRINKMSG 1 你你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>
[@不带英雄]
你想把你的伙伴送回卧龙山庄？\
你要知道，修行结束回到卧龙山庄的子弟,\
不可能再次像现在这样随你一同探索玛法大陆了。\
你真的想这样么？你要是决定了，我们就来斗上一盘酒!\
待我喝好了，我就帮你的伙伴送回山庄。\
<是的，拜托你了/@是的> \
\
<我还想与我的伙伴一起继续战斗/@exit>\
[@是的]
好！好！快拿酒来，让小二倒进六个酒坛中。\
没个酒坛中的酒有多有少，喝多喝少就看运气了。\
我们就拿这六个酒坛中的酒来斗一斗！\ \
<好的，来吧/@DJSM>\
[@DJSM]
#if
#act
Mov M0 2
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了/@PlayDrink>\
[@DelMyHero]
#ACT
DELETEHERO
[@NotHAVHERO]
你没有英雄。\ \
<噢，也许是我记错了/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！在来找我吧！\
\
<好的/@exit>
[@NotDelHero]
评定主副将英雄后，不能进行删除英雄！\
\
<好的/@exit>
[@DeleteHeroOK]
既然你请我喝酒了，那我就答应你的要求。\
我会尽快把你的英雄送回山庄的\\
<那谢谢你了/@exit>
[@英雄历史]
玛法大陆上有两个重要的势力，白日门和卧龙山庄。\
在这两个地方，勇士们都能够召唤到英雄来协助自已。\
每一个势力最多只能领取一个英雄。一直以来，勇士们只能率领一\
名英雄征战玛法。另一名的英雄被寄存在酒馆外的翔天等人处。\
勇士们通过苍月岛仓库里的神秘人找到英雄地的长老，在他那里召\
唤<白日门英雄/fcolor=249>，通过酒馆外的翔天等人处召唤<卧龙英雄/fcolor=249>。\
现在，当你同时拥有两个英雄后，可以在酒馆外的翔天等人接受\
<新的英雄培养/fcolor=249>。新英雄时代即将来临！\
<返回/@主副英雄培养>
[@英雄指南]
《主将副将英雄指南》\ \
1、<如何将卧龙英雄、白日门英雄评定为主将英雄、副将英雄？/@如何评定>\
2、<主将、副将英雄有何特色？/@有何特色>\
3、<副将英雄的操作与训练。/@如何操作>\
4、<什么时候是复仇模式?/@复仇模式>\ \
<返回/@主副英雄培养>
[@如何评定]
必须首先拥有白日门英雄和卧龙英雄，才能够对其进行评定，成为\
主将英雄和副将英雄。白日门英雄可以通过苍月岛的仓库内神秘人获\
得。卧龙英雄，可以通过酒馆外的翔天等人处召唤。拥有两名英雄名，\
将其寄放在酒馆外的翔天等人处，即可使其参与英雄评定，\
从而决定主将英雄和副将英雄的人选。\
<请注意：一旦评定成功，将不可更改，且英雄无法删除！/fcolor=249>\ \
<我知道了/@英雄指南>
[@有何特色]
一旦成功评定主将英雄和副将英雄，两个英雄将可轮流召唤出战。\
主将英雄的实力决定了副将英雄成长的空间。只有当主将英雄的等级、\
内功等级比副将英雄高3级，副将英雄才能分别获得经验、内功经验。\
副将英雄可以战、法、道的不同形态出战。主将英雄累积的经验、\
内功经验等，在召唤出副将英雄时，能够直接向副将英雄传功。\ \
<我知道了/@英雄指南>
[@如何操作]
在英雄包裹按键右侧新增副将英雄的召唤按钮，也可在F12辅助\
工具中，设置召唤的快捷键。成功评定出主将英雄和副将英雄后，\
必须在酒馆外的翔天等人处参与副将英雄的初次训练后，\
才能开始副将英雄的自我修炼。初次训练过程中获得的经验奖励\
与副将英雄的等级相关，等级越高，获得的经验奖励越多。\
副将英雄的自我修炼可根据不同的修炼地图和强度，选择适合的\
修炼方式 。小退或下线将不计入修炼时间。\ \
<我知道了/@英雄指南>
[@复仇模式]
当主将英雄死亡时，开始1分钟复仇倒计时。在倒计时时间内，\
成功召唤出副将英雄，则副将英雄进入到复仇状态，\
其基础属性将获得大幅提升，提升效果持续3分钟。\ \
<我知道了/@英雄指南>


创建主将英雄脚本

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
??????
;@@CreateHero 是创建和删除主将英雄的标志
(@@CreateHero)
[@main]
创建英雄：<英雄取名/@@CreateHero>\ \
删除英雄：<删除英雄/@DelMyHero>\ \
<退出/@exit>
[@CreateHero]
//CREATEHERO 职业 性别 请创建英雄：\ \
<男战士/@CREATEHERO_WARR_MAN> <女战士/@CREATEHERO_WARR_WOM>\
<男法师/@CREATEHERO_WIZA_MAN> <女法师/@CREATEHERO_WIZA_WOM>\
<男道士/@CREATEHERO_TAOS_MAN> <女道士/@CREATEHERO_TAOS_WOM>\ \
<关闭/@exit>
[@CREATEHERO_WARR_MAN]
#ACT
CREATEHERO 0 0
[@CREATEHERO_WARR_WOM]
#ACT
CREATEHERO 0 1
[@CREATEHERO_WIZA_MAN]
#ACT
CREATEHERO 1 0
[@CREATEHERO_WIZA_WOM]
#ACT
CREATEHERO 1 1
[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 2 0
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 2 1
//返回消息
[@CreateingHero]
系统正在接受申请，请稍候……\ \
<关闭/@exit>
[@HaveHero]
您已经有英雄了。\ \
<关闭/@exit>
[@HeroNameFilter]
英雄名字存在非法字符。\ \
<关闭/@exit>
[@SetHeroName]
请先给您的英雄取名字。\ \
<关闭/@exit>
;;--------------------删除英雄触发------------------
[@DelMyHero]
#ACT
DELETEHERO
//返回消息
[@NotHaveHero]
你没有英雄。\ \
<关闭/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！\ \
<关闭/@exit>
[@DeleteHeroOK]
删除英雄成功。\ \
<关闭/@exit>
??????
;---------------------QF脚本触发--------------------
[@CreateHeroOK]
英雄创建成功。\ \
<关闭/@exit>
[@HeroNameExists]
英雄名称已经存在了，请重新换一个名称。\ \
<关闭/@exit>
[@HeroOverChrCount]
英雄的数量超出限制。\ \
<关闭/@exit>
[@CreateHeroFail]
英雄创建失败。\ \
<关闭/@exit>
[@CreateHeroFailEx]
英雄创建失败。\ \
<关闭/@exit>
[@HeroNameFilter]
英雄名字存在非法字符。\ \
<关闭/@exit>
;--------------------------------
[@DeleteHeroOK]
英雄删除成功。\ \
<关闭/@exit>
[@DeleteHeroFail]
英雄删除失败。\ \
<关闭/@exit>


调整英雄的PK值

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

调整英雄PK值

??????
#IF
CheckHeroOnline
#ACT
ChangeHeroPkPoint + 100
#SAY
你英雄的PK值增加100点.


调整英雄的忠诚度

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
ChangeHeroLoyal 操作符(+ - =) 数值(0 -- 10000)

注意：第二个参数+1那么英雄增加0.01点忠诚+100那么英雄增加1点忠诚

脚本示例

??????
增加英雄1点忠诚
#IF
H.CHECKONLINE
#ACT
ChangeHeroLoyal + 100
SendMsg 5 您的英雄忠诚度增加[1]

功能：检测英雄当前的忠诚度

命令格式

??????
CheckHeroLoyal 操作符(< = >) 数值(0 - 100)

脚本示例

??????
#IF
H.CHECKONLINE
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.


调整英雄等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

调整人物英雄等级.

??????
ChangeHeroLevel 操作符(+ - =) 级别(1-65535)
??????
#IF
CheckHeroOnline
#ACT
ChangeHeroLevel = 50
#SAY
你的英雄50级了.


调整英雄职业

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
ChangeHeroJob 职业(0,1,2)
??????
#IF
CheckHeroOnline
#ACT
ChangeHeroJob 2
#SAY
你英雄现在的职业是道士.


设置英雄伤害吸收

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

说明：设置英雄可吸收收到的攻击伤害.

命令格式

??????
SetHeroSuckDamage 操作符(+ - =) 总吸收直(1-2000000) 吸收比例(1-1000) 成功率(1-100)
吸收比例 1=0.1% 500=50% 1000=100%

脚本示例

设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%

??????
#IF
CheckGold 10000
#ACT
SetHeroSuckDamage + 1000 200 95
Take 金币 10000

特别说明:查看SetSuckDamage


收回人物的英雄

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：收回人物的英雄.

命令格式

??????
TakeHero
??????
[@main]
#IF
CheckHeroOnline
#ACT
TakeHero


英雄登录器荣誉

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

英雄登录器专用荣誉

命令格式

??????
ChangeHumCreditEx 操作符(+ - =) 数值(1-65535)
??????
#IF
#ACT
ChangeHumCreditEx + 10


动态创建镜像地图

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

动态创建一个镜像地图

ADDMIRRORMAP
格式：AddMirrorMap A B C D E F
功能：动态创建一个镜像地图
说明：创建成功后，人物D99变量返回1，否则返回0
A，原地图编号，在地图配置文件中存在的地图！
B，新地图编号，临时使用的地图编号，就和镜像地图功能一样！
C，新地图名，这里指客户端显示的名字
D，该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
E，人物退出时返回的地图编号
F, 小地图编号

DelMirrorMap
格式：DelMirrorMap 地图名
功能：删除动态创建的镜像地图

MirrorMapTime
格式：MirrorMapTime 地图名 时间（单位：秒）
功能：设置/获取镜像地图的时间
说明：如果时间不写，则表示获取当前地图的剩余时间，时间返回在D99变量
如果获取地图失败或不是镜像地图，则D99返回-1

CheckMirrorMap
格式：CheckMirrorMap 地图名
功能：检测镜像地图是否已经创建


假人配置

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

功能：假人配置
格式：无
说明：假人是和人物一样的，所有人物的命令假人都可以使用，比如可以使用加入行会的命令，把假人加入某个行会
例：

;====================================华丽的分割线====================================

增加假人登录脚本命令DUMMYLOGON。会自动登录“D:\MirServer\Mir200\Envir\DummyNameList.txt”中的假人

格式:DUMMYLOGON 地图 X Y 数量

;====================================华丽的分割线====================================

;QManage.txt

;====================================人物登录触发====================================
[@Login]
#IF
;检测是否是假人
ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人，这句必须要的。
LOADDUMMYCONFIGFILE

;更改攻击模式
;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击
;6-红名攻击(不主动攻击，受攻击后反击)
ChangeAttatckMode 0
;--------------------------下面是英雄相关的，如果假人不召唤英雄，下面的脚本就不需要了--------------------------

;从假人列表或假人英雄列表中获取一个没有登录过的名称
;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
;格式 GETDUMMYNAME 保存变量 列表类型(0=人物列表 1=英雄列表) 获取类型(0=顺序获取 1=随机获取)
GETDUMMYNAME <$STR(S1)> 1 1

;把获取到的英雄名称给假人，假人就可以召唤英雄了，这句必须要的，否则召唤不了英雄
;格式 SETDUMMYHERONAME 英雄名称
SETDUMMYHERONAME <$STR(S1)>

;召唤英雄
RECALLHERO
;-------------------------------------------------------------------------------------

;假人开始自动打怪，这句必须的，否则假人就站着不会动。如果就在安全区挂着，可以不要。
;对应使用的命令 DUMMYSTOP 停止自动打怪
DUMMYSTART

;====================================英雄登录触发====================================
[@HeroLogin]
#IF
;检测是否是假人英雄
H.ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
H.SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人英雄，这句必须要的。
H.LOADDUMMYCONFIGFILE

;====================================假人配置文件====================================
[Info]

;自动捡物，1=捡，0=不捡
AutoPickUpItem=1

;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击
;6-红名攻击(不主动攻击，受攻击后反击)
AttatckMode=0

;说话机率(英雄无效)
SayRate=10;

;装备极品机率
ItemAddValueRate = 10;

;装备元素机率
ItemNewAddValueRate= 10;

;掉身上装备，1=掉，0=不掉
DropUseItem=0

;掉身上装备机率
DropUseItemRate=15

;掉包裹物品，1=掉，0=不掉
DropBagItem=1

;职业
Job=2

;性别
Gender=1

;头发
Hair=1

;等级
Level=60

;使用毒符物品(道士有效)
;1：身上或包裹中都不需要符或毒，就可以直接使用魔法
;2：需要身上佩戴符或毒，才可以使用魔法
;3：首先使用身上佩戴符或毒，如果身上没有佩戴，就使用包裹中的符或毒。
NeedMagicItem=1

;使用魔法
UseSkill=灵魂火符,施毒术,召唤月灵,召唤神兽,治愈术,神圣战甲术,幽灵盾

;包裹物品
BagItems=护身符,黄色药粉(大量),灰色药粉(大量)

[灵魂火符]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[施毒术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤月灵]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤神兽]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[治愈术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[神圣战甲术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[幽灵盾]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[UseItems]
;衣服
UseItems0=天师长袍
;武器
UseItems1=逍遥扇
;照明物
UseItems2=
;项链
UseItems3=天尊项链
;头盔
UseItems4=天尊头盔
;左手镯
UseItems5=天尊手镯
;右手镯
UseItems6=天尊手镯
;左戒指
UseItems7=天尊戒指
;右戒指
UseItems8=天尊戒指
;物品
UseItems9=护身符
;腰带
UseItems10=
;鞋子
UseItems11=
;宝石
UseItems12=

;攻击时的说话信息(英雄无效)
[Say]
0=没钱买装备玩什么游戏
1=装备差就不要出来混
2=垃圾装备也出来丢人现眼
3=刚花了500买的装备

;QFunction-0.txt
;使用假人开始挂机命令DummyStart触发[@DummyStart]
[@DummyStart]

;使用假人停止挂机命令DummyStop或者假人在挂机过程中移动失败，触发[@DummyStop]
[@DummyStop]

;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
需要把这2个文件里的名称，复制到D:\MirServer\DBServer\DenyChrName.txt这样玩家就不可以注册假人的角色名

;============================================================================
功能：检查服务器假人数
格式：CHECKDUMMYCOUNT 检测符(>,<,=) 人数


镜像副本

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

动态创建一个镜像地图

ADDMIRRORMAP
格式：AddMirrorMap A B C D E F
功能：动态创建一个镜像地图
说明：创建成功后，人物D99变量返回1，否则返回0
A，原地图编号，在地图配置文件中存在的地图！
B，新地图编号，临时使用的地图编号，就和镜像地图功能一样！
C，新地图名，这里指客户端显示的名字
D，该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
E，人物退出时返回的地图编号
F, 小地图编号

DelMirrorMap
格式：DelMirrorMap 地图名
功能：删除动态创建的镜像地图

MirrorMapTime
格式：MirrorMapTime 地图名 时间（单位：秒）
功能：设置/获取镜像地图的时间
说明：如果时间不写，则表示获取当前地图的剩余时间，时间返回在D99变量
如果获取地图失败或不是镜像地图，则D99返回-1

CheckMirrorMap
格式：CheckMirrorMap 地图名
功能：检测镜像地图是否已经创建

-------------------------------下面是使用例子---------------------------------

;使用人物名称做为副本地图的名称创建副本
[@main]
#if
#act
MirrorMapTime <$USERNAME>
#SAY
剩余时间：<$STR(D99)>秒\ \
<创建副本/@创建副本>\
<进入副本/@进入副本>\
<删除副本/@删除副本>\
[@删除副本]
#ACT
DELMIRRORMAP <$USERNAME>
goto @main
[@进入副本]
#IF
LARGE D99 0
#ACT
give 回城卷 1
map <$USERNAME>
#ELSEACT
goto @main
SENDMSG 6 副本地图还没有创建
[@创建副本]
#if
CheckMirrorMap <$USERNAME>
#ACT
goto @main
SENDMSG 6 该副本地图已经创建
BREAK
#IF
#ACT
AddMirrorMap 0 <$USERNAME> 比奇副本 60 0159 101
;创建一个连接，地图3 坐标 X:333 Y:333 连接到新创建的副本地图坐标 X:333 Y:333
AddMapGate 连接 3 333 333 1 <$USERNAME> 333 333 60
#if
Equal D99 1
#ACT
goto @main
SENDMSG 6 创建成功
#ELSEACT
goto @main
SENDMSG 6 创建失败


内挂自动挂机

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令
内挂自动挂机使用说明：
使用快捷键CTRL+ALT+X或点击挂机按钮会触发QF里的[@StartAutoPlayGame]
停止挂机触发QF里的[@StopAutoPlayGame]

格式:
StartAutoPlayGame 参数1 参数2 参数3

参数1:挂机范围(挂机点以人物当前坐标生成范围)
参数2:2个挂机点之间的距离(登录器会根据该参数自动生成挂机点,该值可以控制挂机点的密度)
参数3:模式(0=需要用户设置挂机点，否则无法挂机，1=如果用户没有设置挂机点，会自动生成挂机点, 2=不管有没有用户有没有设置挂机点都会清空所有挂机点，然后自动生成挂机点)

[@StartAutoPlayGame]
#IF
CHECKMAPNAME 0
#ACT
SENDMSG 6 当前地图禁止挂机
break
#IF
#ACT
StartAutoPlayGame 100 60 1
SENDMSG 6 开始挂机，使用快捷键“CTRL+ALT+X”停止挂机
[@StopAutoPlayGame]
#ACT
SENDMSG 6 挂机结束，使用快捷键“CTRL+ALT+X”开始挂机

—————————————————————————————————————————脚本命令停止挂机—————————

[@main]
#IF
#ACT
StopAutoPlayGame
SENDMSG 6 命令停止挂机，使用快捷键“CTRL+ALT+X”开始挂机


人物在线改名系统（完整脚本）

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

人物在线改名系统

-----------------------------------人物在线改名------------------------------
[@Main]
<查询名称是否可以使用/@@InputString1(请输入新的名称：)>\
<我要改名/@@InputString2(请输入新的名称：)>>\
[@InputString1]
#IF
Equal S1
#ACT
SENDMSG 6 请输入一个正确的名称
Break
#OR
CheckStringlength S1 > 20
CheckStringlength S1 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break
#IF
#ACT
QUERYHUMNAMEEXIST S1
[@InputString2]
#IF
Equal S2
#ACT
SENDMSG 6 请输入一个正确的名称
Break
#OR
CheckStringlength S2 > 20
CheckStringlength S2 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break
#IF
#ACT
CHANGEHUMNAME S2

QFunction-0.txt脚本相关触发

[@QueryingHumName]
正在查询请稍后。。。\ \
<关闭/@exit>\
[@QueryHumNameOK]
查询成功，该名称可以使用\ \
<关闭/@exit>\
[@ChangeingHumName]
正在修改请稍后。。。\ \
<关闭/@exit>\
[@ChangeHumNameOK]
#ACT
;这个命令是用来修改，你的变量保存文件和人物名称列表文件里面的人物名称的，如果没有这些可以不使用这个命令
;这个命令也只能放在这个地方，放其他地方无效
CHANGEHUMNAMEFILE ..\QuestDiary\变量文件\HQCQASave.txt
CHANGEHUMNAMEFILE ..\QuestDiary\会员名称.txt
#SAY
你的名字修改成功，旧名称：<$USERNAME> 新名称：<$USERNEWNAME>！\ \
<关闭/@exit>\
[@NameLengthFail]
名字长度不允许超过30个字符！\ \
<关闭/@exit>\
[@HumNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\
[@HumNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\
[@ChangeHumNameFail]
改名失败！\ \
<关闭/@exit>\


物品合成系统

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

物品合成系统

功能：物品合成系统
格式：无
说明：M2: 查看->列表信息2->铸造物品
例：

.

使用说明: 以合成求婚戒指为例:
首先在物品列表中找到求婚戒指,然后点击下面的添加按钮将求婚戒指添加到物品列表中.
接着在左边的物品列表中点击求婚戒指,右边的所需物品列表中的添加按钮处于激活状态后就可以添加合成求婚戒指需要的
材料和装备了.(目前除了StdItems.DB中的物品外还可以直接支持 金币 元宝 声望 能量点) 图中合成求婚戒指需要铜矿5块
银矿金矿各一块.添加完成之后点保存按钮即可.

特别说明:成功几率=100时合成物品必定成功,99=99%90=90%1=1%的成功率.如果需要更低的成功率那么设置大于100即可,这时设置多少就是多少分之一的成功率例如1000=1/1000的成功率.当合成物品有成功率时,失败消失=1时 如果物品合成失败那么
此物品将会消失,失败消失=0时物品不会消失(另外物品合成成功之后所有所需物品都会消失).

脚本说明: CheckFoundryItem 检测背包中合成物品的材料是否足够 GiveFoundryItem 回收合成材料同时将合成后的物品放入背包.
合成失败后自动执行@FoundryFail段的脚本.

合成
求婚戒指
脚本如下:
[@Main]
<合成
求婚戒指/@合成求婚戒指>\
[@合成求婚戒指]
#IF
CheckFoundryItem
求婚戒指
#ACT
GiveFoundryItem
求婚戒指
#ELSEACT
SendMsg 5 缺少合成物品<%Item>
[@FoundryFail]
#ACT
SendMsg 5 合成
<%Item> 失败!
合成多个物品的脚本可以参考如下脚本(以@FoundryItem_开头后面跟要合成的物品,
%FoundryItem是M2自动转换后的合成物品名称):
[@Main]
<合成求婚戒指/@FoundryItem_求婚戒指>
<查看所需物品/@ShowItem_求婚戒指>\
<合成护身戒指/@FoundryItem_护身戒指>
<查看所需物品/@ShowItem_护身戒指>\
<合成负载戒指/@FoundryItem_负载戒指>
<查看所需物品/@ShowItem_负载戒指>\

[@FoundryItem_]
#IF
CheckFoundryItem %FoundryItem
#ACT
GiveFoundryItem %FoundryItem
#ELSEACT
;SendMsg 5 缺少合成物品<%Item>
ShowFoundryItem
%FoundryItem
[@FoundryFail]
#ACT
SendMsg 5 合成 <%Item>
失败!

[@ShowItem_]
<$ShowItem>


自定义OK框

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

自定义OK框

<ITEMBOX:N:F:M:X:Y:W:H:S:T>\
N=编号(0~7)
F=OK框的背景的WIL序号，-1时不绘制背景
M=OK框的背景的图片序号
X Y = 微调坐标
W=宽度
H=高度
S=允许放入的物品类型。DB库的StdMode值，如果有多个使用“,”隔开，如果为“*”时，允许所有物品
T=未放入装备时，鼠标移动显示信息

<$BOXITEM[X].INDEX> DB里的IDX字段值加1，例如DB里的IDX值是1，这个变量获取到的值就是2
<$BOXITEM[X].NAME> 当前自定义OK框中的物品名称
<$BOXITEM[X].NAME_G> 当前自定义OK框中的物品改名名称
<$BOXITEM[X].DURA> 当前自定义OK框中的物品持久
<$BOXITEM[X].DURAMAX> 当前自定义OK框中的物品最大持久
<$BOXITEM[X].MAKEINDEX> 当前自定义OK框中的物品序列号
<$BOXITEM[X].STDMODE> 当前自定义OK框中的物品StdMode字段值
<$BOXITEM[X].SHAPE> 当前自定义OK框中的物品Shape字段值
<$BOXITEM[X].LOOKS> 当前自定义OK框中的物品Looks字段值
<$BOXITEM[X].COLOR> 当前自定义OK框中的物品Color字段值
<$BOXITEM[X].UPGRADECOUNT> 当前自定义OK框中的物品星星数
<$BOXITEM[X].HP> 当前自定义OK框中的物品HP字段值
<$BOXITEM[X].MP> 当前自定义OK框中的物品MP字段值
<$BOXITEM[X].LAC> 当前自定义OK框中的物品的防御下限
<$BOXITEM[X].HAC> 当前自定义OK框中的物品的防御上限
<$BOXITEM[X].LMAC> 当前自定义OK框中的物品的魔防下限
<$BOXITEM[X].HMAC> 当前自定义OK框中的物品的魔防上限
<$BOXITEM[X].LDC> 当前自定义OK框中的物品的攻击下限
<$BOXITEM[X].HDC> 当前自定义OK框中的物品的攻击上限
<$BOXITEM[X].LMC> 当前自定义OK框中的物品的魔法下限
<$BOXITEM[X].HMC> 当前自定义OK框中的物品的魔法上限
<$BOXITEM[X].LSC> 当前自定义OK框中的物品的道术下限
<$BOXITEM[X].HSC> 当前自定义OK框中的物品的道术上限

<$BOXITEM[X].EFFECTINDEX> 当前自定义OK框中的物品的自定义特效编号

<$BOXITEM[X].DRILL1> 当前自定义OK框中的物品 镶嵌宝石的 第一个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL2> 当前自定义OK框中的物品 镶嵌宝石的 第二个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL3> 当前自定义OK框中的物品 镶嵌宝石的 第三个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL4> 当前自定义OK框中的物品 镶嵌宝石的 第四个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL5> 当前自定义OK框中的物品 镶嵌宝石的 第五个孔是否已经打孔(0=没有打孔 1=已打孔)

<$BOXITEM[X].GINDEX1> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX2> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX3> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX4> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX5> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)

<$BOXITEM[X].GNAME1> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME2> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME3> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME4> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME5> 当前自定义OK框中的物品 镶嵌宝石的名称

<$BOXITEM[X].VALUE1> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE2> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE3> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE4> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE5> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE6> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE7> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE8> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE9> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE10> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE11> 当前自定义OK框中的物品 元素属性值

<$BOXITEM[X].CUSTOMTEXT> 当前自定义OK框中的物品 自定义文本内容
<$BOXITEM[X].CUSTOMTEXTCOLOR> 当前自定义OK框中的物品 自定义文本显示的颜色

<$BOXITEM[X].CUSTOMVALUE.VALUE1> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE2> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE3> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE4> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE5> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE6> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE7> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE8> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE9> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE10> 当前自定义OK框中的物品 自定义属性值

<$BOXITEM[X].CUSTOMVALUE.COLOR1> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR2> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR3> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR4> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR5> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR6> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR7> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR8> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR9> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR10> 当前自定义OK框中的物品 自定义属性值显示的颜色

<$BOXITEM[X].CUSTOMVALUE.TYPE1> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE2> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE3> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE4> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE5> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE6> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE7> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE8> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE9> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE10> 当前自定义OK框中的物品 自定义属性类型

<$BOXITEM[X].CUSTOMVALUE.POS1> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS2> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS3> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS4> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS5> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS6> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS7> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS8> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS9> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS10> 当前自定义OK框中的物品 自定义属性显示位置

<$BOXITEM[X].CUSTOMVALUE.RATE1> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE2> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE3> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE4> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE5> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE6> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE7> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE8> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE9> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE10> 当前自定义OK框中的物品 自定义属性是否是百分比类型

<$BOXITEM[X].PROGRESSBAR1.OPEN> 当前自定义OK框中的物品 第一个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR1.NAME> 当前自定义OK框中的物品 第一个进度条的名称
<$BOXITEM[X].PROGRESSBAR1.COLOR> 当前自定义OK框中的物品 第一个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR1.POSITION> 当前自定义OK框中的物品 第一个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR1.MAX> 当前自定义OK框中的物品 第一个进度条的最大值
<$BOXITEM[X].PROGRESSBAR1.IMAGEINDEX> 当前自定义OK框中的物品 第一个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR1.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第一个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR1.LEVEL> 当前自定义OK框中的物品 第一个进度条等级

<$BOXITEM[X].PROGRESSBAR2.OPEN> 当前自定义OK框中的物品 第二个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR2.NAME> 当前自定义OK框中的物品 第二个进度条的名称
<$BOXITEM[X].PROGRESSBAR2.COLOR> 当前自定义OK框中的物品 第二个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR2.POSITION> 当前自定义OK框中的物品 第二个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR2.MAX> 当前自定义OK框中的物品 第二个进度条的最大值
<$BOXITEM[X].PROGRESSBAR2.IMAGEINDEX> 当前自定义OK框中的物品 第二个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR2.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第二个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR2.LEVEL> 当前自定义OK框中的物品 第二个进度条等级

X范围=0~7

[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76:10,11:254#只允许放入衣服^251#www.gameofmir.com>\ \ \
<ITEMBOX:1:2:117:96:10:76:76:*:254#所有物品都允许放入^251#www.gameofmir.com>\

BAGITEMINTOBOX 物品名称 OK框编号(0~7)
把包裹中的物品放入OK框中

CHECKBAITEMCOUNTEX 物品名称 数量
检测包裹中物品的数量(排除已经放入自定义OK框的物品)

UNALLOWITEMINTOBOX
禁止放入命令，在OK框里放入物品时触发使用

CheckBoxItemCount OK框编号(0~7) 物品数量(该参数只有是叠加物品时才会有效)
检测OK框中是否有物品

ReturnBoxItem OK框编号(0~7)
OK框物品返回到包裹

DELBOXITEM OK框编号(0~7) 删除数量(该参数只有是叠加物品时才会有效，如果没有全部删除掉，需要使用UpDateBoxItem命令进行刷新，否则客户端不能立即显示删除掉的数量。如果该参数为空时，表示该OK框里的叠加物品不管有多少数量，都全部删除)
删除OK框物品

自定义OK框放入物品后在当前NPC脚本中触发，X值为0~7
[@ItemIntoBoxX]
#ACT
;禁止放入命令，可以检测是否可以升级的物品，可以使用此命令禁止放入
UNALLOWITEMINTOBOX

把自定义OK框中的物品放入包裹后，在当前NPC脚本中触发，X值为0~7
[@ItemOutBoxX]

例:
[@main]
请放入需要升级的装备\ \
<把包裹物品自动放OK框/@自动放物品>\ \
<ITEMBOX:0:2:117:20:10:76:76>\ \ \ \
<ITEMBOX:1:2:117:20:10:76:76>\ \ \ \

<开始升级/@开始升级>\

[@自动放物品]
#IF
CHECKBAITEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 0
;放到0号OK框

#IF
CHECKBAITEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 1
;放到1号OK框

[@开始升级]
#IF
#ACT
;关联到OK框物品 所有操作或检测自定义OK框的脚本命令才能正常使用
SetUpgradeItem 0

#IF
;检测OK框中是否有物品
CheckBoxItemCount 0 1
#ACT

;修改该OK框物品的名称颜色 -1表示是OK框
CHANGEITEMNAMECOLOR -1 253

;修改OK框物品星星数量 -1表示是OK框
CHANGEITEMUPGRADECOUNT -1 + 1

;刷新到客户端
UpDateBoxItem 0

;物品返回到包裹
ReturnBoxItem 0
SENDMSG 6 装备升级成功
#ELSEACT
SENDMSG 6 请放入需要升级的装备


自定义装备进度条 类似刀魂功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

自定义装备进度条 类似刀魂功能

功能说明：可以给装备自定义进度条，支持2个进度条。显示在装备名称的下面一行

必备补丁NewopUI.PAK 490 是第一个进度条的背景图片 491~499 为静态的进度条图 500~509 为动态的进度条图

必备补丁NewopUI.PAK 510 是第二个进度条的背景图片 511~519 为静态的进度条图 520~529 为动态的进度条图

检测进度条是否开启：
CHECKCUSTOMITEMPROGRESSBAR 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条)

[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

检测进度条值：
CHECKCUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测类型(0当前进度值,1进度条最大值,2进度条等级(0~65535)) 检测符(<,>,=) 检测值

检测进度条百分比：
CHECKCUSTOMITEMPROGRESSBARPERCENT 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测符(<,>,=) 检测值(0~100)

修改自定义装备进度条属性：
CHANGECUSTOMITEMPROGRESSBAR 参数1 参数2 参数3 参数4

参数1:装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备)
参数2:进度条序号。参数范围(0,1)0=表示第一个进度条 1表示第二个进度条
参数3:修改类型，参数范围(0~4) 0显示或关闭进度条 1进度条名称(会显示在进度条左边) 2进度条名称颜色(0~255) 3进度条图片张数(1~9) 4显示进度的数值(0~2)

参数4:
参数3=0时，范围(0关闭进度条,1显示进度条)
参数3=1时，进度条名称(15个字符)支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
参数3=2时，进度条名称颜色(0~255)<br>参数3=3时，进度条图片张数(1~191~9表示绘制单张的，如果是第一个进度条，如果参数4=1就会绘制491，如果参数4=2就会绘制492。如果参数4在10~19之间，表示循环绘制，如果参数4=10 表示绘制500，如果参数4=11 表示在500~501之间循环绘制，如果参数4=12 表示在500~502之间循环绘制)
参数3=4时，显示进度的数值(0不显示,1百分比显示方式 2数值显示方式)

修改自定义装备进度条属性值：
CHANGECUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条 1表示第二个进度条) 类型(0表示当前进度 1表示进度条最大值,2表示进度条等级(0~65535)) 操作符(+,-,=) 值

例：
[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

[@检测衣服的第一个进度条最大值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 1 > 99
#ACT
SENDMSG 6 衣服的第一个进度条最大值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条最大值不大于99

[@检测衣服的第一个进度条当前值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条当前值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条当前值不大于99

[@检测衣服的第一个进度条等级]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 2 > 99
#ACT
SENDMSG 6 衣服的第一个进度条等级大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条等级不大于99

[@检测衣服的第一个进度条百分比]
#IF
CHECKCUSTOMITEMPROGRESSBARPERCENT 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条百分比为100%

[@显示衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 1

[@显示衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 1

[@关闭衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 0

[@关闭衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 0

[@修改衣服的第一个进度条的名称]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂
;支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
;例如:
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %l
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %r
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %p-%m

[@修改衣服的第一个进度条的名称颜色]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 2 254

[@修改衣服的第一个进度条静态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1
SENDMSG 6 衣服的第一个进度条静态图片素材,使用NewopUI.PAK第491号

[@修改衣服的第一个进度条动态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 19
SENDMSG 6 衣服的第一个进度条动态图片素材,使用NewopUI.PAK第500~509号之间循环播放

[@修改衣服的第一个进度条图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1

[@修改衣服的第一个进度条百分比显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 1

[@修改衣服的第一个进度条数值显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 2

[@修改衣服的第一个进度条的最大值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 1 = 100
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。这里最大值设置为100

[@修改衣服的第一个进度条的当前进度值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 0 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。

[@修改衣服的第一个进度条的等级]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 2 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。


自定义装备属性 自定义装备文本

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

自定义装备文本 该数据保存在人物Mir.DB里

功能说明：可以给装备自定义一行文字，文字长度20个字符，也就是10个汉字。

修改自定义装备文字内容：
CHANGECUSTOMITEMTEXT 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 文字内容

修改自定义装备文字内容显示的颜色：
CHANGECUSTOMITEMTEXTCOLOR 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 文字颜色(0~255)

例：
[@main]
<设置衣服自定义文字(不超过10个汉字)/@@InputString1>\
<设置衣服自定义文字颜色(0~255)/@@InputInteger1>\

[@InputInteger1]
#ACT
CHANGECUSTOMITEMTEXTCOLOR 0 N1

[@InputString1]
#ACT
CHANGECUSTOMITEMTEXT 0 S1

自定义装备属性 该数据保存在人物Mir.DB里

功能说明：可以自定义装备的属性值，支持10个属性

自定义装备属性的名称控制(M2-选项-客户端设置-自定义属性)

检测自定义装备属性值：
CHECKCUSTOMITEMVALUE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值

检测自定义装备属性绑定类型：
CHECKCUSTOMITEMVALUETYPE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值(0~17 0没有绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的)

修改自定义装备属性值：
CHANGECUSTOMITEMVALUE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (控制符+，-，=) 值

获取人物所穿装备的自定义属性值：
GETHUMCUSTOMITEMVALUE 属性位置(-1表示10个属性全部获取,0~9 装备自定义10个属性） 绑定的属性类型(0~17 0没有绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的) 变量1(保存属性值) 变量2(如果属性是百分比的，保存在这个变量)

修改自定义装备属性：
CHANGECUSTOMITEMABIL 参数1 参数2 参数3 参数4

参数1:
装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备)

参数2:
属性位置(0~9）每个装备可以自定义10个属性

参数3:
修改类型(0~4)
0表示修改该属性显示的颜色(等于1时，参数4的范围在 0~255)
1表示该属性绑定哪个属性,必须绑定，否则该属性无效，登陆器也不会显示(参数4的范围在0~17 0取消绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的 更多属性持续增加中)
2表示在属性框里的显示位置
3表示该属性是否是百分比属性(0,1) 0不是百分比 1是百分比

参数4:
参数3=0时 修改的值0~255
参数3=1时 修改的值0~17
参数3=2时 修改的值0~255
参数3=3时 修改的值0~1

例：

[@检测衣服的第一个自定义装备属性的绑定类型]
#IF
CHECKCUSTOMITEMVALUETYPE 0 0 = 1
#ACT
SENDMSG 6 你的衣服的第一个自定义属性绑定的是AC

[@修改衣服的自定义属性值]
#ACT
CHANGECUSTOMITEMVALUE 0 0 = 10
CHANGECUSTOMITEMVALUE 0 1 = 20
SENDMSG 6 衣服的第一个自定义属性的值修改成10，第二个自定义属性值修改成20

[@修改衣服的自定义属性值显示颜色]
#ACT
CHANGECUSTOMITEMABIL 0 0 0 249
CHANGECUSTOMITEMABIL 0 1 0 180
SENDMSG 6 衣服的第一个自定义属性显示颜色修改成红色，第二个自定义属性显示颜色修改成蓝色

[@修改衣服的自定义属性绑定类型]
#ACT
CHANGECUSTOMITEMABIL 0 0 1 1
CHANGECUSTOMITEMABIL 0 1 1 2
SENDMSG 6 衣服的第一个自定义属性绑定防御属性，可以增加人物防御，第二个自定义属性绑定魔防属性，可以增加人物魔防

[@修改衣服的自定义属性显示在同一行]
#ACT
CHANGECUSTOMITEMABIL 0 0 2 0
CHANGECUSTOMITEMABIL 0 1 2 0
;第四个参数相同的会显示在同一行
SENDMSG 6 衣服的第一个自定义属性和第二个自定义属性显示在同一行

[@修改衣服的自定义属性不显示在同一行]
#ACT
CHANGECUSTOMITEMABIL 0 0 2 0
CHANGECUSTOMITEMABIL 0 1  2 1
;第四个参数不相同的会分开显示，不会在同一行
SENDMSG 6 衣服的第一个自定义属性显示在第一行，第二个自定义属性显示在第二行

[@修改衣服的自定义属性值是否是百分比]
#ACT
CHANGECUSTOMITEMABIL 0 0 3 0
CHANGECUSTOMITEMABIL 0 1 3 1
SENDMSG 6 衣服的第一个自定义属性不是百分比属性，第二个自定义属性为百分比属性


自动登录离线挂机人物

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

自动登录离线挂机人物

功能：自动登录离线挂机人物
格式：无
说明：然后在M2操作-控制-加载脱机人物
例：

使用DBServer导出数据，导出的文件保存到X:\MirServer\Mir200\Envir\AutoLoadOffline.txt


击退当前目标

ET引擎说明书首页

击退当前攻击目标

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
KNOCKBACK 击退距离（1-20 ）
??????
[@main]
#ACT
KNOCKBACK 4


击飞当前目标

ET引擎说明书首页

击飞当前攻击目标

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 脚本命令

命令格式

??????
KNOCKUP 击飞时间（100-60000 毫秒） 是否旋转（0,1）
??????
[@main]
#ACT
KNOCKUP 1200 1


新版怪物爆率拓展

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

扩展爆率格式1：

??????
以下是采用#call设置怪物爆率
例如：白野猪.txt
#CALL [\\爆率系统\基础爆率.txt] @药水

文件内容路径：D:\MirServer\Mir200\Envir\QuestDiary\爆率系统\基础爆率.txt

TXT必须用ANSI编码,如果没用这个编码，是会导致解析不正常的，这是一个需要特别注意的地方,把所有CALL爆率都集中在一个文件,这样可以加快爆率解析速度

??????
[@药水]
{
#CHILD 1/1 RANDOM
(
1/1 超强金创药
1/1 超强魔法药
1/1 太阳水
)
}

—————————————以上是CALL路径的基础爆率设置——————————————————————————-

扩展爆率格式2：

??????
写法参考1:G3变量大于34 且 U3变量大于14 且 U4变量小于U2变量

#CHILD 1/1 RANDOM [G3>34,U3>14,U4<U2] ( 1/1 称号神石 1/1 魔王之心 ) 写法参考2:N$随意字符=1 且 U4变量=14 #CHILD 1/1 RANDOM [N$随意字符=1,U4=14] ( 1/10 龙牙 ) 写法参考3:金刚石大于99 且 U3变量大于444 且 U4变量大于U3变量 #CHILD 1/1 RANDOM [<$GAMEDIAMOND>>99,U3>444,U4>U3]
(
1/10 龙牙
)

写法参考4:金刚石=99 且 U3变量大于444 且 U4变量大于U3变量

#CHILD 1/1 RANDOM [<$GAMEDIAMOND>=99,U3>444,U4>U3]
(
1/10 龙牙
)

写法参考5:金刚石大于99

#CHILD 1/1 RANDOM [<$GAMEDIAMOND>>99]
(
1/10 龙牙
)

[示例]
原爆率格式

??????
#CHILD 1/20 RANDOM //此爆率代表1/20的概率在下面物品中随机产出一件
(
1/1 1元价值物品
1/1 2元价值物品
1/1 5元价值物品
)

扩展格式

??????
#CHILD 1/20 RANDOM [G3>4,U3>4,U4>U3] //此爆率代表只有当G3>4且U3>4且U4>U3时才会进入1/20的随机，如果条件不满足则不会进入随机，用于精准控制物品产出

支持P变量、D变量、M变量、N变量、N扩展遍历、I变量、G变量、U变量，脚本变量(如:<$GAMEDIAMOND>)，支持逻辑方式大于(>)、小于(<)、等于(=)
用[]包裹,英文逗号分隔多条件,注意符号不要用拼音符号,变量写法格式参考上面的写法
(
1/1 1元价值物品
1/1 2元价值物品
1/1 5元价值物品
)

1、如何实现物品爆出反馈,做精准控制？

ET并没有直接提供爆出物品反馈,要实现这些控制,必须搭配ET的可视化爆率控制,把需要监控的装备加入可视化列表里(可以什么都不设计,只需加入),然后勾可视化爆率II里的爆出物品反馈,只要有你列表的物品,杀怪爆出后就会反馈字段,然后在这个字段里执行你的代码运算即可

2、与可视化爆率控制是否冲突？

两者并不冲突,都需要满足条件后方会最终爆出

3、一个小细节

重载爆率文件,M2会产生小小的垃圾内存,最好重载完爆率文件后重启M2,如果开区中,那就无视,这只是一个技术细节。


怪物爆出物品触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

爆出物品时触发QF,检测人物数据决定是否爆出物品

功能：杀死怪物时，触发QF脚本 检测人物数据后决定是否爆出物品

命令：ETALLOWDROP 参数1

参数1： 0=不允许掉落物品 1=允许掉落物品 不调用命令,默认不允许

常量：<$DROPITEMNAME> 杀死怪物正在爆出的物品名称

触发：在爆率中装备名字后面加|@触发字段 如：1/10 开天|@爆开天触发检测

例子：

怪物爆率文件：D:\Mirserver_ETmir2\Mir200\Envir\MonItems\黑野猪教主.txt

爆率内容：
1/2 比奇传送石
1/2 万年雪霜
1/10 圣战戒指
1/10 法神戒指
1/10 天尊戒指

1/50 怒斩
1/50 逍遥扇
1/50 龙牙

1/100 屠龙|@爆稀有装备检测
1/100 嗜魂法杖|@爆稀有装备检测
1/100 命运之刃|@爆稀有装备检测

??????
QF中脚本例子：
;检测是否为指定的物品名称
[@爆稀有装备检测]
#if
#OR
equal <$DROPITEMNAME> 屠龙
equal <$DROPITEMNAME> 嗜魂法杖
equal <$DROPITEMNAME> 命运之刃
#act
goto @爆出稀有装备条件检测
break

[@爆出稀有装备条件检测]
#if
checkgamegold < 10000
#act
;元宝小于1W，设置不允许爆出物品
ETALLOWDROP 0
break
#elseact
;元宝大于1W，设置允许爆出物品
ETALLOWDROP 1

支持 #CHILD 1/1 RANDOM 爆率写法


开启或关闭怪物透视爆率

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

首先在功能窗口二里的[怪物爆率透视]设置好、开启好

然后使用此命令

开启例子:

??????
#Act
ETStartSee 1

关闭例子:

#Act
ETStartSee 0


全屏吸怪脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

全屏吸怪脚本

MoveMonsters 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8

参数位置 | 参数说明
参数1 | 中心X
参数2 | 中心Y
参数3 | 影响范围(0-999)
参数4 | 目标类型(0=怪物 1=人物 2=怪物+人物)
参数5 | 最大吸取数量(0=不限制数量)
参数6 | 判断怪物等级(0=不判断，其他数值的话。怪物等级小于等于参数6吸取)
参数7 | 判断是否嘲讽状态（0=不判断 1=静止的怪才吸取, 避免吸取其他玩家的怪）
参数8 | 是否吸附同一位置(1为是)

注：引擎功能扩展 - 插件命令相关 - 可设置过滤吸怪怪物名单

??????
例子1
[@attack]
#IF
#ACT
MoveMonsters <$X> <$Y> 20 0 0 0 0
sendmsg 6 范围20的所有怪物都吸过来了

例子2
[@attack]
#IF
#ACT
MoveMonsters <$X> <$Y> 20 0 0 0 1
sendmsg 6 范围20的所有怪物都吸过来了,不包括活跃的怪物


杀怪鞭尸脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

ETMonItems

使用例子:
在QF里的[@KillMon]等使用

??????
[@KillMon]
#ACT
ETMonItems
;让刚刚杀死的怪物，再次触发爆率
SENDMSG 6 ET鞭尸触发！


范围嘲讽引怪脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

ETDoTauntEx

参数1=最大范围
参数2=最小范围
参数3=怪物等级，写0则可嘲讽所有级别怪物
参数4=单次嘲讽数量，0表示不限制数量

??????
例子：
#ACT
ETDoTauntEx 7 1 0 5


可视化爆率-物品可爆出数量控制脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

脚本控制可视化爆率，爆出物品数量，已爆出物品数量

CHANGENUMBER

参数1:物品全称

参数2:设置新数值

前提要把物品添加进去,要不然调用此命令无效

例子:

??????
#ACT
CHANGENUMBER 琼楼玉镯 5

------------------------------------
脚本控制已爆出物品数量

![Description](http://www.ETmir2.com/EThelp/topics/%E7%89%A9%E5%93%81%E5%B7%B2%E7%88%86%E6%95%B0%E9%87%8F%E8%AE%BE%E7%BD%AE.bmp)

RESETITEM
参数1:物品全称
参数2:数量

前提要把物品添加进去,要不然调用此命令无效

#ACT
RESETITEM 琼楼玉镯 0

脚本控制可叠加物品爆出数量
AddNumber

参数1:物品全称

参数2:叠加数量

前提要把物品添加进去,要不然调用此命令无效

如果原先物品可爆数量是5,在这原基础下增加5个数量,用以下方法

例子:

??????
AddNumber 重生金丹 5

;此物品可爆数量叠加5


脚本刷出逃亡怪物

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

脚本刷出逃亡怪物

ETMONESC 地图代码 要刷的怪物 命名怪物新名字 要刷的怪物数量 出生坐标X 出生坐标Y 逃亡坐标X 逃亡坐标Y

例子

??????
#act
ETMONESC 3 黑野猪 黑野猪0 11 364 353 345 340


按死亡时间刷怪

项目：ET引擎说明书　分类：ET引擎脚本文档 / 怪物相关

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1) 是否死亡刷新 触发qf


脚本命令刷怪

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

命令格式

??????
MonGenEx 地图文件名称 X Y 怪物名称 范围 数量 是否内功怪物(0否,1是) 名称颜色(0~255) 国家名称(属于哪个国家的怪物，没有可以为空) 同一个国家玩家是否可攻击怪怪物(0不可以,1可以)

最后2个参数是国家怪物设置，如果没有可以留空

??????
[@main]
#if
#act
MonGenEx 3 330 330 白野猪 12 10 0 255


清除地图中的怪物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

功能

用于清除指定地图里的怪物，人物的宝宝不在此范围以内，禁止清除怪物列表中的怪物不会被清除。
此功能一般用于动态刷怪方式，在有人的地图出现怪物，没人时地图上的怪物全部清除，以大大节约机器资源。

命令格式

??????
CLEARMAPMON 地图号

脚本示例

??????
#ACT
CLEARMAPMON D717
#say
<返回/@main>


设置地图的杀怪经验倍数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

功能

设置地图的杀怪经验倍数

命令格式

??????
MAPKILLMONEXPRATE 地图文件名称(*号表示所有地图) 倍率
倍率 为杀怪经验倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍,0表示关闭地图的杀怪经验倍数)
??????
;==========================================
[@MAPKILLMONEXPRATE]
#IF
#ACT
MAPKILLMONEXPRATE 0 1000
#SAY
您在比奇的杀怪经验倍数为 10倍
;==========================================
??????
[@MAPKILLMONEXPRATE]
#IF
#ACT
MAPKILLMONEXPRATE * 1000
#SAY
所有地图杀怪经验倍数为 10倍
;==========================================


设置杀怪经验倍数

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

功能

设置杀怪经验倍数.(支持内功经验，经络经验倍数)

命令格式

??????
KILLMONEXPRATE 倍率 有效时间
倍率 为杀怪经验倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍)
??????
;==========================================
[@KILLMONEXPRATE]
#IF
#ACT
KILLMONEXPRATE 1000 600
#SAY
您当前杀怪经验倍数为 10倍，有效时间 600秒。
;==========================================


杀死地图中的怪物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

功能：随机杀死地图中的怪物.

格式: RandomKillMon 地图 怪物名字 数量(1-255) 掉落物品(0,1)

说明：地图=Self时表示当前地图.

脚本示例

??????
[@main]
#IF
#ACT
RandomKillMon Self 稻草人 5


移动怪物到新坐标

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

功能：移动指定坐标的怪物到新的位置.

命令格式

??????
MoveMonToPos 怪物 地图 老坐标X 老坐标Y 新坐标X 新坐标Y

脚本示例

??????
#IF
CheckRangeMonCountEx K004 51 43 魔王弓箭手 > 0
#ACT
MoveMonToPos 魔王弓箭手 K004 51 43 48 47


怪物名称颜色自定义功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

增加怪物名称颜色自定义功能

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物


怪物伤害封顶

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

增加怪物伤害封顶，封顶数值等于怪物BD中的MP数值，若DB中怪物MP值=0则不计算伤害封顶


怪物属性扩展

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

增加怪物属性扩展：Envir\MonSpAbilList.txt

格式：怪物名 忽视防御(0~100) 增加伤害(0~255) 伤害反弹(0~100) 物伤减少(0~100) 魔伤减少(0~100) 麻痹-几率-时间(0~1 0~10 0~10) 防麻痹(0~1) 防全毒(0~1) 防火墙(0~1) 防诱惑(0~1) 破复活(0~1) 破护身(0~1)


怪物说话配置

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

功能：怪物说话配置
格式：无
说明：配置文件位置Mir200\Envir\MonSayMsg.txt
例：

;状态(0为杀人，1为被攻击，2为死亡，3为刚刷出来) 刚刷出来发的文字为广播文字全服务器都可以看到。
;机率(数字越大，说话机率越小)
;颜色(0为红色，1为绿色，2为蓝色，3为白色) 白色文字，显示在怪物头顶上所有旁边的人都可以看到，其它颜色则显示在人物聊到框中只有对应的人物可以看到。

;状态 机率 颜色 怪物名称 文字内容

1 30 0 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 1 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 2 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 3 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 4 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 稻草人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 森林雪人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽战士 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 1 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 2 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 3 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 4 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

2 30 1 鹿 %s不要打我，%d我挂了！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 0 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 1 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 2 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 3 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 4 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

3 1 4 白野猪0 %s老猪来也%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标


怪物探索设置说明

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

怪物探索设置说明

功能：怪物探索设置说明
格式：无
说明：在Mir200\Envir\MonUseItems里添加对应怪物名称的两个文件(xxxx.txt xxxx-item.txt格式和人形怪的配置差不多)
例：

狂热火蜥蜴.txt
[INFO]
;挖取身上装备收费模式(0金币，1元宝，2金刚石，3灵符)
ButchChargeClass=0
;挖取身上装备每次收费点数
ButchChargeCount=1
;未挖到物品是否减灵符 1=是，0=否
ButchNotItemDelGold=0
狂热火蜥蜴-Item.txt
1/5 龙牙
1/50 凰天魔衣
1/50 天龙圣剑
1/50 银星勋章(法)


人型怪物设置方法

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

功能：人型怪物设置方法
格式：无
说明：无
例：

1、在Envir目录下增加MonUseItems目录，放置怪的配置文件，见MonUseItems目录

2、Monster.DB范例：
战士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

3、此类怪物支持暴背包物品(MonItems目录下建立暴物品列表)，同时支持暴身上物品(MonUseItems目录，见MonUseItems目录)

注意：如果觉得怪物速度太慢！可以自己调节怪物的攻击速度。走动速度。防御等等！！！！增加新怪，RACE=60

示例：

Monster.DB范例：
战士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

MonUseItems文件夹下：

道士.TXT

设置内容如下：

[Info]

;职业
Job=2
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=神圣战甲术,幽灵盾,灵魂火符,施毒术,群体施毒术,无极真气,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=光芒道袍(男)
;武器
UseItems1=玄天
;照明物
UseItems2=
;项链
UseItems3=光芒项链
;头盔
UseItems4=天龙盔
;左手镯
UseItems5=光芒护腕
;右手镯
UseItems6=光芒护腕
;左戒指
UseItems7=光芒道戒
;右戒指
UseItems8=光芒道戒
;物品
UseItems9=护身符(大)
;腰带
UseItems10=光芒腰带
;鞋子
UseItems11=光芒道靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

=============================================================

法师.txt

设置如下：

[Info]

;职业
Job=1
;性别
Gender=1
;头发
Hair=1
;使用魔法
UseSkill=雷电术,冰咆哮,抗拒火环,火墙,地狱雷光,圣言术,魔法盾,灭天火,火龙气焰,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=魔法长袍(女)
;武器
UseItems1=镇天
;照明物
UseItems2=
;项链
UseItems3=烈焰项链
;头盔
UseItems4=魔龙盔
;左手镯
UseItems5=烈焰护腕
;右手镯
UseItems6=烈焰护腕
;左戒指
UseItems7=烈焰魔戒
;右戒指
UseItems8=烈焰魔戒
;物品
UseItems9=
;腰带
UseItems10=烈焰腰带
;鞋子
UseItems11=烈焰魔靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

======================================================================

战士.txt

设置如下：

[Info]

;职业
Job=0
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=烈火剑法,半月弯刀,刺杀剑术,狮子吼,彻地钉,擒龙手,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=雷霆战甲(男)
;武器
UseItems1=开天
;照明物
UseItems2=
;项链
UseItems3=雷霆项链
;头盔
UseItems4=圣龙盔
;左手镯
UseItems5=雷霆护腕
;右手镯
UseItems6=雷霆护腕
;左戒指
UseItems7=雷霆战戒
;右戒指
UseItems8=雷霆战戒
;物品
UseItems9=
;腰带
UseItems10=雷霆腰带
;鞋子
UseItems11=雷霆战靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠


自定义怪物系统

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 怪物相关

自定义怪物系统

M2-选项-怪物设置-自定义怪物


装备悬浮标题图形化使用方法

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展
??????
悬浮标题，tips 插件设置格式说明

--------------------------物品备注和套装备注支持显示图片----------------------------

物品图片显示:
格式：<LOOKS:L:T:X:Y:Z>
L表示物品DB的Looks值
T0表示包裹物品图片 1表示地面物品图片
XY 表示微调坐标
Z0表示不显示背景 1表示显示背景

任意图片显示:
格式：<Img:N:F:X:Y>
N表示播放开始图片
F表示WIL文件序号
X,Y表示微调坐标

动态图片播放:
格式: <PlayImg:F:N:C:T:X:Y:M>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制  2普通绘制带偏移

--------------------------物品备注和套装备注支持显示图片----------------------------

插件后台设置参考图,注意参数这里的37跟你的服不一样，请根据添加WIL资源编号填写！
(例子)任意图片显示:
格式：<Img:N:F:X:Y>
N表示播放开始图片
F表示WIL文件序号
X,Y表示微调坐标
<Img:1:37:0:0>
<Img:2:37:0:0>
<Img:4:37:0:0>
<Img:3:37:0:0>
<Img:0:37:3:3>
<Img:5:37:0:0>
可留空,代表不生效该代码！

M2后台设置参考图，图编号为37,对应也要把压缩包里的img.pak放置游戏自定义补丁里，代码格式参数对应pak里的图片序号


拓展聊天栏查看装备

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展

扩展聊天框查看装备

Ctrl+左键背包物品即可发送装备，支持普通、私聊、组队、行会发送，对方可通过点击查看装备

发送固定装备例子

??????
[@main]
;一次发送多个物品可以用多个OK框，或者用变量依次记录装备的名字和makeidx
;组成 {装备名字&Makeidx}格式即可
;多个{装备名字1&Makeidx1}、{装备名字2&Makeidx2}、{装备名字3&Makeidx3}、{装备名字4&Makeidx4}.....
发布装备到固顶聊天框中\
请放入需要发布的固顶装备\
→
<ITEMBOX:0:-1:-1:0:-15:72:72:*:254#所有物品都允许放入^251#www.ETmir2.com>←\→            ←\→            ←\
<发布装备信息/@发布装备信息>

[@发布装备信息]
#if
equal <$BOXITEM[0].NAME>
#act
messagebox 不能发布空装备
#elseact
SENDTOPCHATBOARDMSG 0 149 235 60 需要{<$BOXITEM[0].NAME>&<$BOXITEM[0].MAKEINDEX>}请与我联系！！！


拓展多窗口脚本功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展

扩展多窗口脚本
此功能需要反挂支持，所以要在反挂加载后使用，我们使用插件的反挂加载触发

效果类似NPC弹框，插件实现了自定义绑定到任意窗口和位置，具体怎么用，靠自己发挥

QF

??????
[@ET反挂加载]
#act
#CALL [多窗口脚本例子.txt] @例子

具体使用方法请阅读必读说明

多窗口脚本例子.txt - 在该文档标签下面，自己复制出来，另存为对应的路径

如下：

D:\Mirserver1\Mir200\Envir\QuestDiary\多窗口脚本例子.txt

一、窗口调用 在#say或对话框脚本开头(必须第一行顶格)加入$ETwindow则调用ET多窗口脚本
注：凡是要在ET窗口显示的脚本都必须在对话框脚本开头加入此参数

例如1：
注：$ETWindow 9 560 180$ 也可以写作 $ETWindow_9_560_180$ 或 $ETWindow-9-560-180$

??????
[@main]
$ETWindow 9 560 180$
你好ET窗口！

;表示在窗口9，X坐标560，Y坐标180显示脚本内容 你好ET窗口！

上面的例子等同
[@main]
#Say
$ETWindow 9 560 180$
你好ET窗口！

二、脚本调用 ET窗口调用脚本执行统一跳转到QF处执行 QF执行规则必须加入前缀@ET#，目的是防止外挂点击QF任意字段 特别注意：只要是@ET#开头的且QF中存在的字段，用户不受点击限制，请务必做好检测命令，防止被刷！（其他字段依然按照原安全级别执行） 例如：

??????
[@main]
$ETWindow 9 560 180$
你好ET窗口！\
<你好ET/@ET#你好ET>

QF脚本中:
[@ET#你好ET]
$ETWindow 9 560 180$
感谢你对ET的支持,你点击了ET窗口标签

窗口位置参考
0:游戏主界面/ 1:人物装备对话框/ 2:装备页面/ 3:时装页面/ 4:状态页面/ 5:属性页面/ 6:称号页面/ 7:技能页面/ 8:出战页面/ 9:包裹界面10:聊天框左侧界面/ 11:聊天框右侧界面/ 12:商铺界面/ 13:查看对方装备对话框/ 14:查看对方装备页面/ 15:查看对方时装页面/ 16:查看对称号页面/ 17:大地图界面

或直接写入组件名称，组件名称参考登录器配置器UI名字

脚本文档
多窗口脚本例子.txt

??????
[@例子]
{
#if
#act
mov S$背包脚本 $ETWindow_9_380_440$
#Say
<$STR(S$背包脚本)>
请选择页码\
<1/@ET#1>  <2/@ET#2>  <3/@ET#3>  <4/@ET#4>

[@ET#1]
<$STR(S$背包脚本)>
当前第1页\
<回收一级沃玛装备/@ET#回收一级沃玛装备>\
<回收一级祖玛装备/@ET#回收一级祖玛装备>\
<回收一级赤月装备/@ET#回收一级赤月装备>\
<1>  <2/@ET#2>  <3/@ET#3>  <4/@ET#4>
[@ET#2]
<$STR(S$背包脚本)>
当前第2页\
<回收二级沃玛装备/@ET#回收二级沃玛装备>\
<回收二级祖玛装备/@ET#回收二级祖玛装备>\
<回收二级赤月装备/@ET#回收二级赤月装备>\
<1/@ET#1>  <2>  <3/@ET#3>  <4/@ET#4>
[@ET#3]
<$STR(S$背包脚本)>
当前第3页\
<回收三级沃玛装备/@ET#回收三级沃玛装备>\
<回收三级祖玛装备/@ET#回收三级祖玛装备>\
<回收三级赤月装备/@ET#回收三级赤月装备>\
<1/@ET#1>  <2/@ET#2>  <3>  <4/@ET#4>
[@ET#4]
<$STR(S$背包脚本)>
当前第4页\
<回收四级沃玛装备/@ET#回收四级沃玛装备>\
<回收四级祖玛装备/@ET#回收四级祖玛装备>\
<回收四级赤月装备/@ET#回收四级赤月装备>\
<1/@ET#1>  <2/@ET#2>  <3/@ET#3>  <4>

[@ET#回收一级沃玛装备]
#act
sendmsg 7 回收一级沃玛装备
[@ET#回收一级祖玛装备]
#act
sendmsg 7 回收一级祖玛装备
[@ET#回收一级赤月装备]
#act
sendmsg 7 回收一级赤月装备
[@ET#回收二级沃玛装备]
#act
sendmsg 7 回收二级沃玛装备
[@ET#回收二级祖玛装备]
#act
sendmsg 7 回收二级祖玛装备
[@ET#回收二级赤月装备]
#act
sendmsg 7 回收二级赤月装备
[@ET#回收三级沃玛装备]
#act
sendmsg 7 回收三级沃玛装备
[@ET#回收三级祖玛装备]
#act
sendmsg 7 回收三级祖玛装备
[@ET#回收三级赤月装备]
#act
sendmsg 7 回收三级赤月装备
[@ET#回收四级沃玛装备]
#act
sendmsg 7 回收四级沃玛装备
[@ET#回收四级祖玛装备]
#act
sendmsg 7 回收四级祖玛装备
[@ET#回收四级赤月装备]
#act
sendmsg 7 回收四级赤月装备
}


ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 其他拓展

增加极品改色

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展


BUFF列表

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展

BUFF列表

检查指定人物BUFF是否存在

ETCHECKBUFF 参数1 参数2

参数位置 | 参数说明
参数1 | 参数1 BUFF编号
参数2 | 参数2 检查数量(0或1时检测是否存在此BUFF编号,存在即成立,大于1即检测所属编号的BUFF数量是否满足数量)
??????
[@main]
#if
ETCHECKBUFF 1 0 //0或1时检测是否存在此BUFF编号,存在即成立,大于1即检测所属编号的BUFF数量是否满足数量
#act

添加人物BUFF

ETADDBUFF 参数1 参数2 参数3

参数位置 | 参数说明
参数1 | 参数1 BUFF编号
参数2 | 参数2 添加次数(0或1即为1次,支持叠加多次效果)
参数3 | 参数3 持续秒数(0=无限,10=十秒后失效)
??????
[@main]
#if
#act
ETADDBUFF 1 1 5

删除人物BUFF

ETDELBUFF 参数1 参数2

参数位置 | 参数说明
参数1 | 参数1 BUFF编号
参数2 | 参数2 删除数量(0或1即为1次)
??????
[@main]
#if
#act
ETDELBUFF 1 1

注:所有BUFF属性值最大叠加只能到达255上限 支持多级调用


祝福罐

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展
??????
1702;祝福罐;2;0;1;123;110;0;1174;50000;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;251;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;

SOURCE 编号 110 对应UnbindList.txt文本里

110 祝福油
储存方式：装备到毒符位置 可以把祝福油 直接拖到储存罐内


掉落提示增加支持物品属性信息查看

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展
??????
默认：
DropItemHint=物品\[%Item\]从\[%Name\]身上掉落在地图%Map(%X,%Y)处

如果需要掉落显示物品属性请到String.ini文件内将DropItemHint项修改如下即可：

DropItemHint=物品\[%ShowItem\]从\[%Name\]身上掉落在地图%Map(%X,%Y)处

%ShowItem 显示当前掉落物品名字

%ShowDBItem 显示数据库名字 就算改名了也显示数据库的

人物掉落提示/怪物掉落提示：HumDropItemHint，DropItemHint，增加数据库名变量%DBItem (原默认的%Item修改为支持掉落触发改名后的名字显示)


人物在线改名系统

项目：ET引擎说明书　分类：ET引擎脚本文档 / 其他拓展

人物在线改名系统 -----------------------------------人物在线改名------------------------------

??????
[@Main]
<查询名称是否可以使用/@@InputString1(请输入新的名称：)>\
<我要改名/@@InputString2(请输入新的名称：)>>\
[@InputString1]
#IF
Equal S1
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S1 > 20
CheckStringlength S1 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
QUERYHUMNAMEEXIST S1

[@InputString2]
#IF
Equal S2
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S2 > 20
CheckStringlength S2 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
CHANGEHUMNAME S2

QFunction-0.txt脚本相关触发

[@QueryingHumName]
正在查询请稍后。。。\ \
<关闭/@exit>\

[@QueryHumNameOK]
查询成功，该名称可以使用\ \
<关闭/@exit>\

[@ChangeingHumName]
正在修改请稍后。。。\ \
<关闭/@exit>\

[@ChangeHumNameOK]
#ACT
;这个命令是用来修改，你的变量保存文件和人物名称列表文件里面的人物名称的，如果没有这些可以不使用这个命令
;这个命令也只能放在这个地方，放其他地方无效
CHANGEHUMNAMEFILE ..\QuestDiary\变量文件\HQCQASave.txt
CHANGEHUMNAMEFILE ..\QuestDiary\会员名称.txt
#SAY
你的名字修改成功，旧名称：<$USERNAME> 新名称：<$USERNEWNAME>！\ \
<关闭/@exit>\

[@NameLengthFail]
名字长度不允许超过30个字符！\ \
<关闭/@exit>\

[@HumNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\

[@HumNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\

[@ChangeHumNameFail]
改名失败！\ \
<关闭/@exit>\


DEC对字符型变量操作命令

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

MOV命令做了一些改进。

??????
[@Main]
#ACT
MOV S1 ETmir2引擎M2
MOV S2 ETmir2引擎M2
DEC S1 ETmir2引擎 ;删除S1中的“ETmir2引擎”字符串
DEC S2 1 3 ;删除S2中的第1至第3个字符串 这个要注意，一个汉字是2个字节长度，不要删除半个汉字的情况，否则会乱码。

结果 S1=M2
S2=引擎M2


查看人物私聊信息

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

此功能可以实时侦听指定人物的私聊信息，将指定人物发送及接收的私聊信息发送到自己。

命令格式

??????
@ViewWhisper 人物名称

重复输入取消侦听私听信息。


程序变量说明

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

P0-P99 (私人变量，数字型) 打开对话框重置为0。
D0-D99 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M99 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N99 (私人变量，数字型) 下线不保存.小退归0.
S0-S99 (私人变量，字符型) 下线不保存.小退清空.
I0-I99 (全局变量，数字型) 下线不保存.小退归0.
G0-G499 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A499 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
U0-U49 (私人变量，数字型) 可保存。（存放在人物数据库Mir.db里面）
T0-T49 (私人变量，字符型) 可保存。（存放在人物数据库Mir.db里面）

注意：自定义变量名称不要以P、D、M、N、S、I、G、A开头

【变量属性】

P(0-9)

『属性说明』：该变量只对当前对话NPC内有效果。如果中途点其他NPC或者对话产生close、关闭时所有P变量均归0。该变量取值范围：（0-？）根据M2最大值不同
『用法』：该变量没有NPC间传递性作为临时变量多重复使用效果十分好。而且因为脚本命令有对该变量进行加/减/赋值/随机取值等运算，他和goto的配合可以使脚本中出现仿for循环的效果。并且因为他不传递的性质其
随机取值也能与RANDOM媲美。

D(0-9)

『属性说明』：该变量在人物不下线时对全局NPC通用传递。该变量取值范围：同P变量
『用法』：既有像[0-？]变量一样的人物属性私有变量的效果又有像P变量一样的运算功能！唯一不足就是下线 后该变量会被清空。可是如果配合上[000]变量或者namelist变量的记录性。实在是功能强大的个人隐私属性！

G(0-499)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同P变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）

A(0-499)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同D变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）


传奇脚本命令详解

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

===========================================================

传奇脚本命令详解
====================********************************========================

[@段] ;段用英文或数字表示

goto @段 ;跳转到指定段，开始执行相当于B中的goto语句

#say 语句 ;语句设定为字符，不用加任何定界符

#act 执行命令 ;符合3.0规定的任何系统已定义命令

give 物品 数量 ;给多少东西,除了物器数据库中有的物品，还有金币，

take 物品 数量 ;同上，只是与上面相反，一个是给东西，一个是收回东西

map 地图名 ;移动到这个地图的随机坐标，地图名为地图的数字人码

mapmove 地图名 坐标A 坐标B ;同上，只是指定了坐标

monclear 地图名 ;清除这个地图上刷的怪物

MonGen 怪物名称 数量 时间 ;刷怪物，与刷怪角本用法相同

TimeRecall 数值 ;数值为分钟，定义进入某地的时间限制。

BreakTimeRecall ;中断上面那个语句设定的时间

hairstyle 数值 ;改变头发类型

haircolor 红值 绿值 蓝值 ;值域为0 ~ 255 设定头发颜色

close ; 关闭对话框

======================****************************========================
---------------------- 程 序 中 的 变 量 与 常 量 ------------------------
======================****************************========================

变量 ;变量用字母表示，在程序中可以赋任何数据 名称只限于P0-P9,D0-D9
mov 变量 数值 ;给变量赋值

inc 变量 数值 ;让变量自动加指定数值到变量，相当于程序中的x=x+n

sum 变量A 变量B ;变量求和不要与int混淆,需要下面的组合语名才能实现

MOV 变量X 0 ;变量X，初值。

sum 变量A 变量B ;X=A+B

sum 变量C ;X=X+C 最后在程序中得到的是X值，实际X=A+B+C

;如果只写中间一句是无意义的，只能导致错误

movr 变量 数值 ;定义随机变量，变量值为 “0 到 数值”

random 数值 ;当数值=随机数时则为1否则为0

<$STR(变量)> ;显示变量时用，可以将变量值显示在游戏里，用在 #say后面。

=========================*******************************========================
------------------------- 程 序 中 的 逻 辑 判 断 语 句 ------------------------
=========================*******************************========================

[n] ;n为1-1024正整数，是逻辑变量，有0值和1值，初始0值

#IF
条件--执行
#elsesay 或者 #elseact
否定--执行 ;相当于程序中的条件判断

SET [n] 1 ;设置逻辑变量为真

--------------------关于reset命令的详解------------------------------------

reset [XXX] 7 意思是将从XXX开始的7个变量回复到原始值0

比如：reset [100] 7 就是把100 101 102 103 104 105 106 107这7个变量赋值为0。

它等同与：set [100] 0

set [101] 0

set [102] 0

set [103] 0

set [104] 0

set [105] 0

set [106] 0

--------------------------------------------------------

Check [n] 1 ;测试逻辑变量是否为真，可以测试是否已经完成了任务

small 变量 数值 ;如果“变量 < 数值”则为1否则为0

large 变量 数值 ;如果“变量 > 数值”则为1否则为0

equal 变量 数值 ;如果“变量 = 数据”则为1否则为0

checkjob Warr(Wizard、Taos) ;测试职业 成功为1否则为0

checkgold 数值 ;拥有金币数>=数值为1否则为0

checklevel 数值 ;人物等级>=数值为1否则为0

checkitem 物品 数值 ;测试拥用物品的数量

genderman ;测试性别为男，如果为男则为1否则为0

checkbaggage ;测试背包是否已满，满时为1否则为0

checkpkpoint 数值 ;数值为PK值，PK值数>值时为1否则为0

checkluckypoint 数值 ;同上，只是测的是幸运值

checkmonmap 地图名 数值 ;同上，只是测的是怪物数量

checkduraeva 物品名 数值 ;同上，只是测试有品质的物品的品质

checkhum 地图名 数值 ;同上，测试这个地图的人数

checkitemw 物品 检测身上所带的物品

takew 物品 直接从身上回收物品

checkmagic 技能名称 检测已经修炼的技能

脚本大全 [喜欢脚本的来]
传奇商用NPC开头解释(部分,补足请补足)
%100 代表买东西是原价格还是双倍价格
+40 买肉
+1 卖肉
+43 武器有关(修)
+15 头盔
+10 买衣服
+11 修衣服
+26 修手镯类
+0 买各种药水
+42 卖各种药水
+30 蜡烛等.
+25 特殊水
+3 买卷轴,书类
+4 卖书类
+19 项链
+20 项链
+21 项链
+22 买戒指
+23 卖戒指
+24 买手镯
+26 卖手镯
+5 修炼武器或买武器
+6 修炼武器或卖武器
================================

checkjob (Warr, Wizard, Taos) ;测试职业
checkgold (金币数) ;测试金币
checklevel (等级) ;测试等级
checkitem (物品名) (数量) ;测试物品及数量
give gold (金币数) ;给钱
give (物品名) (数量) ;给物及数量
take gold (金币数) ;拿走钱
take (物品名) (数量) ;拿走物及数量
checkpkpoint (pk值) ;测试PK值
checkluckypoint (幸运值) ;幸运值正值为好,负值为差
checkduraeva (物品名) (数值) ;一般测试矿物等物品的品质
checkhum (地图名) (数值) ;测试这个地图的人数
checkmonmap (地图名) (数值) ;测试这个地图的怪物数
map (地图名) ;移动到这个地图
mapmove (地图名) (坐标A) (坐标B) ;移动到这个地图指定坐标
monclear 地图清除
close 关闭对话框
TimeRecall (设定时间值) ;分钟,一般指进入地图时间限制
BreakTimeRecall ;中断设定时间
ExchangeMap (地图名) ;与指定地图里的人交换位置
daytime sunset ;一天时间
checkbaggage ;测试背包满没
small (变量) (数值) ;测试变量是不是小于指定数值
large (变量) (数值) ;测试变量是不是大于指定数值
equal (变量) (数值) ;测试变量是不是等于指定数值
mov (变量) (数值) ;让变量等于指定数值
sum (变量A) (变量B) ;A+B 注意,如果还要家第3个数直接换行写sum (变量C)
注:关于SUM的详解
首先有MOV (变量X) 0 ;(变量X)清0
sum (变量A) (变量B) ;X=A+B
sum (变量C) ;X=X+C
movr (变量) (数值) ;随机把指定数值以下的数(正数)给变量
inc (变量) (数值) ;让变量自动加指定数值到变量
playdice (骰子数) @xxx ;玩骰子,跳转到标签[@xxx]
random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT
Check [条件数] 1 ;测试[条件数]触发与否 1(触发)
SET [条件数] 1 ;设置[条件数]触发
Monclear 地图 清理这个地图！
Param1 地图 地图名
Param2 横坐标 坐标
Param3 纵坐标 坐标
MonGen 怪物名称 数量 时间
TimeRecall 时间 时间限制

二。脚本变量：
<$USERNAME> 当前用户名
<$GUILDWARFEE>行会战金币数
<$LORD>沙巴克行会头名
<$OWNERGUILD>沙巴克行会名
<$UPGRADEWEAPONFEE>升级武器价格
<$USERWEAPON> 放在对话框里的武器名字
<$STR(变量)> 把变量转换为字符型 random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列
#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT


关于国战

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

Envir\Nations\Nations.ini中的NationalNames1 -- NationalNames100是国家的名字,只有定义了国家名字之后加入国家才有效!

??????
Nations.ini

[Names]
NationalNames1=
NationalNames2=
NationalNames3=
NationalNames4=
NationalNames5=
NationalNames6=
NationalNames7=
NationalNames8=
NationalNames9=
NationalNames10=
NationalNames11=
NationalNames12=
NationalNames13=
NationalNames14=
NationalNames15=
NationalNames16=
NationalNames17=
NationalNames18=
NationalNames19=
NationalNames20=
NationalNames21=
NationalNames22=
NationalNames23=
NationalNames24=
NationalNames25=
NationalNames26=
NationalNames27=
NationalNames28=
NationalNames29=
NationalNames30=
NationalNames31=
NationalNames32=
NationalNames33=
NationalNames34=
NationalNames35=
NationalNames36=
NationalNames37=
NationalNames38=
NationalNames39=
NationalNames40=
NationalNames41=
NationalNames42=
NationalNames43=
NationalNames44=
NationalNames45=
NationalNames46=
NationalNames47=
NationalNames48=
NationalNames49=
NationalNames50=
NationalNames51=
NationalNames52=
NationalNames53=
NationalNames54=
NationalNames55=
NationalNames56=
NationalNames57=
NationalNames58=
NationalNames59=
NationalNames60=
NationalNames61=
NationalNames62=
NationalNames63=
NationalNames64=
NationalNames65=
NationalNames66=
NationalNames67=
NationalNames68=
NationalNames69=
NationalNames70=
NationalNames71=
NationalNames72=
NationalNames73=
NationalNames74=
NationalNames75=
NationalNames76=
NationalNames77=
NationalNames78=
NationalNames79=
NationalNames80=
NationalNames81=
NationalNames82=
NationalNames83=
NationalNames84=
NationalNames85=
NationalNames86=
NationalNames87=
NationalNames88=
NationalNames89=
NationalNames90=
NationalNames91=
NationalNames92=
NationalNames93=
NationalNames94=
NationalNames95=
NationalNames96=
NationalNames97=
NationalNames98=
NationalNames99=
NationalNames100=


脚本变量大全

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

脚本变量

人物信息

变量名称 | 说明
<$USERNAME> | 人物名称
<$GUILDNAME> | 行会名称
<$RANKNAME> | 行会职位名称
<$LEVEL> | 等级
<$HP> | 生命值
<$AC> | 防御力
<$MAXAC> | 最高防御力
<$MAC> | 魔法防御力
<$MAXMAC> | 最高魔法防御力
<$DC> | 物理攻击力
<$MAXDC> | 最高物理攻击力
<$MC> | 魔法力
<$MAXMC> | 最高魔法力
<$SC> | 道术
<$MAXSC> | 最高道术
<$EXP> | 当前经验值
<$MAXEXP> | 升级经验值
<$MAXHP> | HP上限
<$MAXMP> | MP上限
<$DIR> | 方向
<$PKPOINT> | PK点数
<$CREDITPOINT> | 声望点数
<$GOLDCOUNT> | 金币数量
<$GAMEGOLD> | 游戏币数
<$GAMEPOINT> | 游戏点数
<$HW> | 腕力
<$MAXHW> | 最高腕力
<$BW> | 背包重量
<$MAXBW> | 最高背包重量
<$WW> | 负重力
<$MAXWW> | 最高负重
<$HUNGER> | 饥饿程度
<$LOGINTIME> | 登录时间
<$LOGINLONG> | 登录时长
<$DRESS> | 衣服
<$WEAPON> | 武器
<$RIGHTHAND> | 蜡烛
<$HELMET> | 头盔
<$NECKLACE> | 项链
<$RING_R> | 右戒指
<$RING_L> | 左戒指
<$ARMRING_R> | 右手镯
<$ARMRING_L> | 左手镯
<$BUJUK> | 护身符
<$BELT> | 腰带
<$BOOTS> | 鞋子
<$CHARM> | 宝石
<$HAT> | 斗笠
<$DRUM> | 军鼓
<$HORSE> | 马牌
<$SHIELD> | 盾牌
<$SDRESS> | 时装衣服
<$SWEAPON> | 时装武器
<$SUCKDAMAGE> | 伤害吸收值 脚本命令USEBONUSPOINT增加的，该值保存人物数据库里，下线不消失
<$SUCKDAMAGEPOINT> | 伤害吸收值 脚本命令SETSUCKDAMAGE增加的，下线消失
<$G_DRESS> | 衣服 改名名称
<$G_WEAPON> | 武器 改名名称
<$G_RIGHTHAND> | 蜡烛 改名名称
<$G_HELMET> | 头盔 改名名称
<$G_NECKLACE> | 项链 改名名称
<$G_RING_R> | 右戒指 改名名称
<$G_RING_L> | 左戒指 改名名称
<$G_ARMRING_R> | 右手镯 改名名称
<$G_ARMRING_L> | 左手镯 改名名称
<$G_BUJUK> | 护身符 改名名称
<$G_BELT> | 腰带 改名名称
<$G_BOOTS> | 鞋子 改名名称
<$G_CHARM> | 宝石 改名名称
<$G_HAT> | 斗笠 改名名称
<$G_DRUM> | 军鼓 改名名称
<$G_HORSE> | 马牌 改名名称
<$G_SHIELD> | 盾牌 改名名称
<$G_SDRESS> | 时装衣服 改名名称
<$G_SWEAPON> | 时装武器 改名名称
<$CASTLENAME> | 沙城名称
<$GAMEDIAMOND> | 金刚石
<$GAMEGIRD> | 灵符
<$MAP> | 当前地图代码
<$RELEVEL> | 显示转生等级
<$STATSERVERTIME> | 显示M2启动时间
<$RUNDATETIME> | 开区间隔时间
<$KILLER> | 杀人者变量
<$RANDOMNO> | 随机值变量
<$X> | 人物X坐标
<$Y> | 人物Y坐标
<$USERALLNAME> | 人物完整名称
<$GAMEGLORY> | 人物荣誉值
<$MapTitle> | 取地图名称
<$GetExp> | 人物当前获得经验变量
<$CASTLEGAMEGOLD> | 显示沙城税收的元宝值
<$USERID> | 人物登录帐号
<$KILLMONNAME> | 人物杀死的怪物名称
<$KILLMONX> <$KILLMONY> | 人物杀死怪物的坐标
<$HIT> | 准确
<$SPD> | 敏捷
<$HITSPD> | 攻速
<$YEAR> | 当前年份
<$MONTH> | 当前月份
<$DAY> | 当前日期
<$HOUR> | 当前小时
<$MINUTE> | 当前分钟
<$SECOND> | 当前秒
<$TEAM0>..<$TEAMX> | 用于显示组队成员,<$TEAM0>代表队长,成员从<$TEAM1>开始
<$STNAME> | 师徒名称变量
<$KILLMONEXPRATE> | 杀怪经验倍数
<$KILLMONEXPRATETIME> | 杀怪经验倍数时长
<$GAMEGOLDEX> | 新游戏点数
<$REVIVALTIME> | 复活间隔变量
<$POWERRATE> | 复当前攻击力倍数
<$POWERRATETIME> | 当前攻击力倍数剩余时间
<$GROUPMEMBERCOUNT> | 当前组队人数
<$X> | 人物当前坐标X
<$Y> | 人物当前坐标Y
<$VALUE1>..<$VALUE11> | 人物元素的属性值的常量共11个。1到11
<$SCREENWIDTH> | 分辨率 宽
<$SCREENHEIGHT> | 分辨率 高
<$PASSWORD> | 注册账号时用户输入的密码
<$BIRTHDAT> | 注册账号时用户输入的生日
<$QUIZ1> | 注册账号时用户输入的问题1
<$ANSWER1> | 注册账号时用户输入的答案1
<$QUIZ2> | 注册账号时用户输入的问题2
<$ANSWER2> | 注册账号时用户输入的答案2
<$EMAIL> | 注册账号时用户输入的邮箱
<$PHONE> | 注册账号时用户输入的电话
<$MOBILEPHONE> | 注册账号时用户输入的手机
<$ACCOUNTUSERNAME> | 注册账号时用户输入的用户名
<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的
<$CURRHERONAME> | 当前召唤出来的英雄名称，如果没有召唤英雄，该值为空
<$HERONAME> | 英雄名称。如果没有创建过英雄，该值为空
<$DEPUTYHERONAME> | 副将英雄名称。如果没有创建过副将英雄，该值为空

英雄信息

变量名称 | 说明
<$H.USERNAME> | 人物名称
<$H.LEVEL> | 等级
<$H.HP> | 生命值
<$H.AC> | 防御力
<$H.MAXAC> | 最高防御力
<$H.MAC> | 魔法防御力
<$H.MAXMAC> | 最高魔法防御力
<$H.DC> | 物理攻击力
<$H.MAXDC> | 最高物理攻击力
<$H.MC> | 魔法力
<$H.MAXMC> | 最高魔法力
<$H.SC> | 道术
<$H.MAXSC> | 最高道术
<$H.EXP> | 当前经验值
<$H.MAXEXP> | 升级经验值
<$H.MAXHP> | HP上限
<$H.MAXMP> | MP上限
<$H.DIR> | 方向
<$H.PKPOINT> | PK点数
<$H.HW> | 腕力
<$H.MAXHW> | 最高腕力
<$H.BW> | 背包重量
<$H.MAXBW> | 最高背包重量
<$H.WW> | 负重力
<$H.MAXWW> | 最高负重
<$H.HUNGER> | 饥饿程度
<$H.SUCKDAMAGE> | 伤害吸收值 脚本命令H.USEBONUSPOINT增加的，该值保存英雄数据库里，下线不消失
<$H.SUCKDAMAGEPOINT> | 伤害吸收值 脚本命令H.SETSUCKDAMAGE或SETHEROSUCKDAMAGE增加的，下线消失
<$H.DRESS> | 衣服 英雄
<$H.WEAPON> | 武器 英雄
<$H.RIGHTHAND> | 蜡烛 英雄
<$H.HELMET> | 头盔 英雄
<$H.NECKLACE> | 项链 英雄
<$H.RING_R> | 右戒指 英雄
<$H.RING_L> | 左戒指 英雄
<$H.ARMRING_R> | 右手镯 英雄
<$H.ARMRING_L> | 左手镯 英雄
<$H.BUJUK> | 护身符 英雄
<$H.BELT> | 腰带 英雄
<$H.BOOTS> | 鞋子 英雄
<$H.CHARM> | 宝石 英雄
<$H.HAT> | 斗笠 英雄
<$H.DRUM> | 军鼓 英雄
<$H.HORSE> | 马牌 英雄
<$H.SHIELD> | 盾牌 英雄
<$H.SDRESS> | 时装衣服 英雄
<$H.SWEAPON> | 时装武器 英雄
<$H.G_DRESS> | 衣服 改名名称 英雄
<$H.G_WEAPON> | 武器 改名名称 英雄
<$H.G_RIGHTHAND> | 蜡烛 改名名称 英雄
<$H.G_HELMET> | 头盔 改名名称 英雄
<$H.G_NECKLACE> | 项链 改名名称 英雄
<$H.G_RING_R> | 右戒指 改名名称 英雄
<$H.G_RING_L> | 左戒指 改名名称 英雄
<$H.G_ARMRING_R> | 右手镯 改名名称 英雄
<$H.G_ARMRING_L> | 左手镯 改名名称 英雄
<$H.G_BUJUK> | 护身符 改名名称 英雄
<$H.G_BELT> | 腰带 改名名称 英雄
<$H.G_BOOTS> | 鞋子 改名名称 英雄
<$H.G_CHARM> | 宝石 改名名称 英雄
<$H.G_HAT> | 斗笠 改名名称 英雄
<$H.G_DRUM> | 军鼓 改名名称 英雄
<$H.G_HORSE> | 马牌 改名名称 英雄
<$H.G_SHIELD> | 盾牌 改名名称 英雄
<$H.G_SDRESS> | 时装衣服 改名名称 英雄
<$H.G_SWEAPON> | 时装武器 改名名称 英雄
<$H.MAP> | 当前地图代码
<$H.RELEVEL> | 显示转生等级
<$H.X> | 人物X坐标
<$H.Y> | 人物Y坐标
<$H.USERALLNAME> | 人物完整名称
<$H.MapTitle> | 取地图名称
<$HeroGetExp> | 英雄当前获得经验变量
<$H.HIT> | 准确
<$H.SPD> | 敏捷
<$H.HITSPD> | 攻速
<$HEROGENDER> | 英雄性别
<$HEROJOB> | 英雄职业
<$HEROLEVEL> | 英雄级别
<$HERONAME> | 英雄名字
<$HMapTitle> | 英雄地图名字
<$HMAP> | 英雄地图编号
<$HX> | 英雄前坐标X
<$HY> | 英雄前坐标Y

天地结晶变量

变量名称 | 说明
<$GETCRYSTALEXP> | 天地结晶可提取的经验
<$GETCRYSTALNGEXP> | 天地结晶可提取的内功经验
<$CRYSTALEXP> | 天地结晶当前的经验
<$CRYSTALNGEXP> | 天地结晶当前的内功经验
<$CRYSTALLEVEL> | 天地结晶等级

人物内力变量

变量名称 | 说明
<$NH> | 内力
<$MAXNH> | 内力上限
<$NGEXP> | 内功经验
<$NGMAXEXP> | 内功升级经验
<$NGLEVEL> | 内功等级

英雄内力变量

变量名称 | 说明
<$H.NH> | 英雄内力
<$H.MAXNH> | 英雄内力上限
<$H.NGEXP> | 英雄内功经验
<$H.NGMAXEXP> | 英雄内功升级经验
<$H.NGLEVEL> | 英雄内功等级
?? | 所有英雄的变量都是在人物的变量; 前面加“H.”; 例如：<$H.MAXHP> <$H.MAXMP>
<$H.VALUE1>..<$H.VALUE11> | 英雄元素的属性值的常量共11个。1到11

连击变量

变量名称 | 说明
<$NGLEVEL> | 内功等级
<$HEROPULSEXP> | 英雄经络经验
<$GETNGEXP> | 当前得到的内功经验
<$HEROGETNGEXP> | 英雄当前得到的内功经验

国家变量

变量名称 | 说明
<$NATIONNAME> | 国家名称??
<$NATIONPEOPLE> | 国家人数

服务器信息

变量名称 | 说?????? 明
<$SERVERNAME> | 服务器名字
<$SERVERIP> | 服务器IP地址
<$WEBSITE> | 游戏网址
<$BBSSITE> | 论坛网址
<$CLIENTDOWNLOAD> | 客户端程序下载地址
<$QQ> | 联系QQ号
<$PHONE> | 联系电话号码
<$BANKACCOUNT0> | 银行帐号信息
<$BANKACCOUNT1> | 银行帐号信息
<$BANKACCOUNT2> | 银行帐号信息
<$BANKACCOUNT3> | 银行帐号信息
<$BANKACCOUNT4> | 银行帐号信息
<$BANKACCOUNT5> | 银行帐号信息
<$BANKACCOUNT6> | 银行帐号信息
<$BANKACCOUNT7> | 银行帐号信息
<$BANKACCOUNT8> | 银行帐号信息
<$BANKACCOUNT9> | 银行帐号信息
<$GAMEGOLDNAME> | 游戏币名称
<$USERCOUNT> | 在线人数
<$DATETIME> | 当前日期时间
<$GAMEGOLDNAME> | 游戏币名称
<$HIGHLEVELINFO> | 最高等人物信息
<$HIGHPKINFO> | 最高PK点数人物信息
<$HIGHDCINFO> | 最高攻击力人物信息
<$HIGHMCINFO> | 最高魔法力人物信息
<$HIGHSCINFO> | 最高道术人物信息


设置显示名称格式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

一、显示名称设置方法

1、相关配置

配置文件：String.ini

以下为相关配置内容：

CastleGuildName=%guildname[%castlename(%rankname)]
NoCastleGuildName=%guildname(%rankname)
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*
ManDearName=%s的老公
WoManDearName=%s的老婆
MasterName=%s的师父
NoMasterName=%s的徒弟
HumanShowName=%chrname\%guildname\%dearname\%mastername

??????
CastleGuildName

沙城成员显示行会格式

??????
NoCastleGuildName 普通已加入行会人员显示行会格式

%guildname 行会名称
%castlename 城堡名称
%rankname 职位名称

??????
WarrReNewName 武士转生后名称显示
WizardReNewName

法师转生后名称显示

??????
TaosReNewName 道士转生后名称显示

%chrname 人物名称

??????
ManDearName 结婚后男的显示名称
WoManDearName

结婚后女的显示名称

??????
MasterName 师父显示名称
NoMasterName

徒弟显示名称

??????
HumanShowName

显示完整名称格式
游戏中显示出来的名称是根据以上格式组合出来的，大家可以根据自己的要求，自行调行组合及格式。


物品绑定人物

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

功能

物品绑定人物

绑定类型:
帐号，角色名，IP

命令格式

??????
@BindUseItem 人物名称 物品类型 绑定类型
例：@BindUseItem 人物名称 武器 帐号
此时将指定的人物及其身上的武器绑定在该人的帐号上
========================================================

物品类型:
衣服，武器，照明物，项链，头盔，左手镯，右手镯，左戒指，右戒指，物品
腰带，鞋子，宝石

??????
BindUseItem   ;显示绑定物品到人物信息
ShowUseItemInfo   ;显示人物身上带装备信息


物品位置

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展
??????
;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================


新怪物数据

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

-------------------人形怪范例------------------------------------------------------------------------------------------------------------------------------

1、在Envir目录下增加MonUseItems目录，放置怪的配置文件，见MonUseItems目录

2、Monster.DB范例：

??????
;人形怪 此类怪物支持暴背包物品(MonItems目录下建立暴物品列表)，同时支持暴身上物品(MonUseItems目录，见MonUseItems目录)
战士;60;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;

月灵;99;56;172;80;0;100;3000;1000;1000;40;50;70;0;1000;20;50;500;1;0;1200;0;

??????
;镖车
普通镖车;128;19;290;70;1;0;6000;20000;0;15;15;20;50;0;0;20;50;600;1;0;1200;
中等镖车;128;19;291;80;1;0;12000;40000;0;15;15;20;50;0;0;15;50;700;1;0;1200;
贵重镖车;128;19;292;90;1;0;24000;80000;0;15;15;20;50;0;0;10;50;800;1;0;1200;
行会镖车;128;19;292;90;1;0;24000;80000;0;15;15;20;50;0;0;5;50;1000;1;0;1200;
??????
;魔王岭
红野猪99;108;19;110;32;1;0;60;330;0;0;0;0;0;0;0;0;1200;1;0;2000;640;
黑野猪99;108;19;111;35;1;0;200;330;0;0;0;0;0;0;0;0;1200;1;0;2000;760;
白野猪99;108;19;112;50;1;0;300;330;0;0;0;0;0;0;0;0;1200;1;0;1800;3200;
半兽人99;108;19;100;15;0;0;30;330;0;0;4;9;0;0;15;6;1500;1;0;2500;50;
多钩猫99;108;17;25;13;0;0;22;330;0;0;2;4;0;0;12;5;1500;1;0;2500;34;
牛魔王99;108;72;207;99;1;1;300;330;0;0;0;0;0;0;0;0;1200;1;0;1200;8000;

----------------新怪范例23之前的随便找个版本都支持了-----------------------------------------------------------------------------------------------------------------

Mon23-0;139;116;220;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon23-1;81;100;221;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon23-2;81;101;222;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon23-3;81;101;223;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-0;81;19;230;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-1;124;19;231;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-2;81;101;232;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-3;81;101;233;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-4;101;102;234;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-5;81;19;235;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-6;81;19;236;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-7;121;101;237;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-8;81;19;238;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon24-9;81;19;239;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon25-0;123;103;240;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon25-1;123;104;241;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon25-2;81;19;242;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon25-3;81;102;243;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-0;123;103;250;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-1;123;105;251;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-2;124;19;252;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-3;125;19;253;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-4;126;19;254;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-5;123;115;255;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-6;123;106;256;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-7;81;19;257;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-8;81;19;258;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-9;81;19;259;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-0;81;19;260;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-1;81;19;261;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-2;123;115;262;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-3;127;107;263;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-4;81;107;263;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-5;81;19;264;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-6;81;19;265;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-7;123;106;266;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-8;123;106;267;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon29-0;81;19;280;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon29-1;81;19;281;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon30-0;128;19;290;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon30-1;128;19;291;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon30-2;128;19;292;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-0;129;101;320;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-1;130;101;320;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-2;131;101;321;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-3;132;101;321;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-4;131;101;322;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-5;133;101;322;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-6;104;45;323;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-7;135;108;324;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-8;81;109;325;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-9;81;109;326;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-10;136;110;327;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-11;104;45;328;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon33-12;104;45;329;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-0;137;111;330;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-1;81;19;331;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-2;81;19;332;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-3;137;111;333;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-4;81;19;334;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-5;81;19;335;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-6;134;112;336;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon34-7;134;112;337;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon35-0;138;113;340;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon35-1;107;114;341;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon35-2;107;114;342;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
圣兽一;140;54;270;48;1;0;1;350;0;25;20;25;30;0;0;20;30;0;1;0;0;
圣兽一1;141;55;271;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽二;142;54;272;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽二1;143;55;273;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽三;144;54;274;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;
圣兽三1;145;55;275;48;1;0;1;350;0;35;30;30;45;0;0;20;30;0;1;0;0;


新增GM命令

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

新增部分游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

传送相关命令
@recall | 将人物召唤到自己身边
@Regoto | 传送到对方身边??????????????????
@Ting | 将对方随机传送
@SuperTing | 将指定范围内人物随机传送
@Mapmove | 将指定地图所有人物传送到指定地图
@Move | 移动到指定地图
@PositionMove | 移动到指定地图座标
人物控制相关命令
@GameMaster | 进入/退出管理员模式
@Observer | 进入/退出隐身模式
@Superman | 进入/退出无敌模式
@Level | 调整自己的等级
@Kick | 将指定的人物踢下线
@Kill | 将指定的人物杀死
@Realive | 将死亡的人物复活
@Setpermission | 设置人物的游戏权限，可将普通人物提升为GM
@Info | 显示人物详细信息
@MobLevel | 显示身边所有怪物或人物信息
@FreePK | 清除指定人物的PK点
@PKpoint | 显示指定人物的PK点
@IncPkPoint | 增加指定人物的PK点
@AdjustLevel | 调整他人级别
@AdjustExp | 调整他人经验
怪物控制相关命令
@Mob | 在身边放置一个指定的怪物
@RecallMob | 召唤一个怪物为宝宝
@Mission | 设置怪物集中点(用于开展怪物攻城)
@MobPlace | 放置怪物，怪物向集中点集中，大刀守卫不攻击怪物(用于开展怪物攻城)
聊天信息相关命令
@DisableSendMsg | 将指定人物加入禁言列表，人物发信息只能自己看到别人看不到
@EnableSendMsg | 将指定人物从禁言列表中删除
@DisableSendMsgList | 显示禁言列表中的人物名称
@ViewWhisper | 查看指定人物的私聊信息
@MobNpc | 制造一个NPC（可不用重启M2做增加NPC制作脚本）；
@DelNpc | 删除NPC
重新加载设置相关命令
@ReloadAdmin | 重新加载管理员列表
@ReloadNpc | 重新加载NPC脚本
@ReloadMonItems | 重新加载怪物爆物品列表
@ReloadLineNotice | 重新加载游戏公告
@ReloadManage | 重新加载登录脚本
@ReloadItemDB | 重新加载物品数据库
@ReloadMagicDB | 重新加载魔法数据库(暂时无效)
@ReloadMonsterDB | 重新加载怪物数据库
@ReloadRobotManage | 重新加载游戏登录文本
物品控制相关命令
@make | 制造指定的物品
@SuperMake | 调整给指定物品属性值
@BindUseItem | 物品绑定人物信息
@GiveMine 数量 纯度 | 给指定纯度的矿石.
仓库、登录密码相关命令
@CLEARPASSWORD | GM专用命令
人物分配点数控制相关命令
@BonusPoint | 增加人物属性点
@DelBonusPoint | 删除人物属性点(删除所有已分配及未分配的属性点)
@RestBonusPoint | 将人物属性点复位(已分配的复位到未分配的点数)
地图控制相关命令
@SetMapMode | 设置地图模式
@Map | 查看当前所在地图相关信息
游戏点、币相关命令
@GameGold | 调整人物游戏币数量
@GamePoint | 调整人物游戏点数量(泡点数量)
@CREDITPOINT | 调整人物声望点(1-255)
@DelGold | 减少人物金币
@AddGold | 增加人物金币
其他相关命令
@Showflag | 显示标识
@showopen | 显示打开
@showunit | 显示单位
@setflag | 设置标识
@setopen | 设置打开
@setunit | 设置单位
@Reconnection | 更换网关的命令
行会相关命令
@AddGuild | 添加一个行会
@DelGuild | 删除一个行会
@SabukWallGold | 更改沙城所属性行会
@ForcedWallconquest | 强行开始或结果攻城战
@SabukWallGold | 查看沙城金币数


用户游戏命令详解

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

用户游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

相关命令
@Date | 显示当前服务器上的日期时间
@禁止私聊 |
@禁止群聊 |
@禁止交易 |
@加入行会 |
@退出行会 |
@禁止行会聊天 |
@允许行会联盟 |
@联盟 |
@取消联盟 |
@允许天地合一 |
@天地合一 |
@仓库解锁 |
@仓库开锁 |
@设置仓库密码 |
@修改仓库密码 |
@Rest |
@传送 | 传送物品移动命令
@Dear | 夫妻查询位置
@Master | 师徒查询位置
@DearRecall | 夫妻传送
@MasterRecall | 师徒传送
@AllowDearRecall | 允许夫妻传送
@AllowMasterRecall | 允许师徒传送
@GuildRecall | 行会合一
@AllowGuildRecall | @允许天地合一
@AttackMode | 调整攻击模式
仓库、登录密码相关命令
@SetPassword | 设置仓库密码
@Chgpassword | 修改仓库密码
@UnLock | 打开密码锁
@UnLockStorage | 仓库解锁
@Lock | 仓库加锁


宝石升级系统

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

说明：1.打开人物背包点右下脚的升级按钮进行升级.也可使用OpenUpgradeDialog命令打开界面.

3.放好物品点升级时先执行Q-Function中的@ItemUpgrade脚本段.
例如:升级装备需要5000金币,此脚本放入Q-Function.txt中.

??????
[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break
--------------------------------------------------------------------------------------------------------------

升级宝石StdMode=55,56,57,58,59

宝石类型1:

StdMode=55(升级指定类型的装备)
Shape=(指定升级哪种类型的装备,此处添写和要升级类型的StdMode一样的值即可,例如武器设定为5)
AniCount=(指定可以升级加几以下的装备,例如:设定为10,那么该宝石可以升级次数小于10次的装备)
DuraMax=(指定宝石升级装备的成功机率,例如:设定为20既为20%成功机率)
Need=(升级失败后可执行的操作,如果该值等于1-100时,则失败后把装备副加属性全部清零.如果该等于101-200时,则失败后装备消失.等于201-300时,升级失败后装备当前属性不变.)
NeedLevel=(指定宝石升级范围,等于0时不限制,例如:该宝石只允许升级+5到+10之间的装备,那么Need=5*65535+10,计算规则=低限*65535+上限)
Ac,Ac2,Mac,Mac2,Dc,Dc2,Mc,Mc2,Sc,SC2=(指定该宝石升级成功后给装备加的属性，设定方法跟设置装备属性一样，不同的装备设置也不一样)

宝石类型2:
StdMode=57(升级符合类型的装备)
Source=(等于1)
Shape=(等于0升级符合类型的装备,指定类型时填写待升级装备的StdMode值)
区别:其他设置方法参照宝石类型1

注意：此类宝石只增加防御和魔御.

AC2,MAC2=(升级装备的防御,魔御,必须是可增加防御和魔御的装备才可以升级,例如:衣服,手镯等)

宝石类型3:
StdMode=57(升级符合类型的装备)
Source=(等于2)
Shape=(等于0升级符合类型的装备,指定类型时填写待升级装备的StdMode值)
区别:其他设置方法参照宝石类型1

注意：此类宝石只增加攻击,道术和魔法.

DC2,MC2,SC2=(升级装备的攻击,魔法等,必须是可增加攻击和魔法等属性的装备才可以升级,例如:武器,项链等)

宝石类型4:
StdMode=58(随成升级装备属性)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
AniCount=(升级点数)
区别:其他设置参照宝石类型1,此类宝石升级时随机增加装备属性,例如:AniCount等于5时,那么随机增加装备5点属性.

注意：升级失败后如果Need小于100那么随机清除某项或者多项附加属性.

宝石类型5:
StdMode=59(增加升级成功率)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
DuraMax=(提高成功机率,例如:设定5即为提高5%的机率)
以下是最新更新后的部分新特性:

1.55,56,57,58这几种类型宝石失败后默认不会降低装备升级的星星数.如果升级失败时需要降低装备的星星数那么设置物品的Reserved字段,0时不降,大于0时设置几就降几点.
例如宝石的Reserved=2 装备的星星数=3 升级失败后星星就会减去2，剩下1个星星

2.58类型的升级宝石Weight=1时随机升级所以属性,Weight=2时只随机升级攻击,魔法,道术.


毒素武器

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

使用方法:\Envir\UserData\PoisonWeapon.txt

命令格式

??????
武器名称 成功几率 减HP值 基本时间 扩展时间
成功率100以下时设置多少就是多少的成功率例如:80就是80%的成功率50就是50%的成功率
扩展时间是一个随即值,假如设置为10那么它的值就是1-10之间的值. 持续时间=基本时间+扩展时间所产生的随机值
例如:木剑 90 10 10 5


NewopUI.Pak文件说明

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

NewopUI.pak文件为登录器必备补丁，如果没有登录器无法正常启动。
可以使用我们提供的专用WIL编辑器打开编辑。该文件格式支持密码功能。
NewopUI.pak文件密码为空或者输入ETmir2

00108~00163 个人商店相关图片
00180~00193 仿HeroM2摆摊相关图片
00210~00225 黑夜白天功能相关的图片
00732~0748 配置器选择连击版，登录窗口图片

01370~01375是1024界面相关图片(配置器的 显示1024的界面 不勾选就不会使用这些图片)

血条
00170 血条背景
00171 人物血条
00172 高亮血条
00173 内功血条
00174 NPC血条
00175 怪物血条
00176 大刀、弓箭手血条

雷达
00240 自己
00241 其他人
00242 我的英雄
00243 NPC
00244 怪物
00245 大刀、弓箭手

00470~00475 是1.76和1.85登录界面

以上如果有不使用的功能，可以用编辑器把相关图片删除，减小登录器的大小。删除图片时，编辑器选择用空图片代替不是删除


补丁读取规则

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

补丁读取规则

功能：补丁读取规则
格式：Resources目录
说明：以读取Prguse.wil为例， 先读取Resources\Data\Prguse.pak, 如果Resources\Data\Prguse.pak不存在,读取Data\Prguse.wil, 如果Data\Prguse.wil不存在,读取Data\Prguse.wzl。

例:
优先读取Resources\Data\Hum.pak 如果这个文件不存在，则读取Data\Hum.wil。
优先读取Resources\Map\0.map 如果这个文件不存在，则读取Map\0.map。
优先读取Resources\Wav\0.wav 如果这个文件不存在，则读取Wav\0.wav。

增加支持 Resources\Data\ItemDesc.Dat(物品备注) 2013-02-20更新后的备注在m2--列表二里直接修改
增加支持 Resources\Data\TZItemDesc.Dat(套装备注)
增加支持 Resources\Data\SkillDesc.Dat(技能备注)
增加支持 Resources\Data\MapDesc.Dat(外传的小地图备注)
增加支持 Resources\Data\MapDesc1.Dat(小地图备注)

增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始

改进小地图扩展mmap10.wil从10001开始

增加扩展Npc10.wil Npc代码从1000

增加支持:
武器和衣服时可按照一件武器一个.wil文件的方式配置.
武器放在传奇目录的\Graphics\Weapon\
衣服放在\Graphics\Human\下.
物品数据库中单个武器和衣服的Shape值从1000开始算起.
单个武器和衣服素材的文件名必须和物品数据库中的Shape值一样,
例如:数据库中设置Shape=1000,那么单个武器或者素材的文件就是1000.wil,如果Shape=1001那么文件名就是1001.wil


登录点安全区

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

登录点安全区

功能：登录点安全区
格式：无
说明：配置文件 D:\MirServer\Mir200\Envir\StartPoint.txt
例：

文件格式：

;地图号 | 座标X | 座标Y | 禁止说话 | 大小范围 | 光环类型 | PKZONE | PKFIRE
0 | 289 | 618 | 0 | 10 | 4 | 0 | 0
0 | 650 | 631 | 0 | 10 | 4 | 0 | 0
0 | 334 | 266 | 0 | 10 | 4 | 0 | 0
2 | 503 | 483 | 0 | 10 | 4 | 0 | 0
3 | 330 | 330 | 0 | 10 | 4 | 0 | 0

地图号：安全区所在地图
座标X：安全区所在地图座标X
座标Y：安全区所在地图座标Y
禁止说话：安全区内是否禁止说话(此功能未完成)
大小范围：安全区范围大小(此功能未完成)
光环类型：安全区边界显示类型 1是僵尸钻的洞 3是石块 4是困魔光 5是火墙 6是祖码教主裂开的石头 7,8,9三种火墙效果
PKZONE：安全区是否为PK比赛区域(此功能未完成)
PKFIRE：安全区PK区域边界显示类型(此功能未完成)


界面的魔法球血球效果

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

播放界面的魔法球血球效果：

PLAYMAGICBALLEFFECT WIL文件序号 图片开始序号 播放张数 播放速度(毫秒) 有效时间(秒 -1时永久有效) 类型(0=HP 1=MP) 绘制高度(0=完整绘制 1=按照HP或者MP的高度绘制) 绘制模式(0=完整绘制 1=切割绘制(一张图包含HP和MP的效果，左边是HP右边是MP，会根据HP或MP只绘制一半图片)) 微调坐标X 微调坐标Y


天气效果

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

天气效果

功能：天气效果
格式：无
说明：无
例：

地图参数 DARK 黑暗效果
地图参数 DAY 白天效果
如果同时存在以DAY参数效果为准

以下三个效果读取客户端的Effect_EX.Wil和Effect_SE.Wil如果客户端没有这2个文件，效果显示不了

增加天气效果脚本命令SETWEATHEREFFECT
格式:SETWEATHEREFFECT 地图号 天气效果(0=关闭天气效果 1=黄沙效果 2=花瓣效果 3=下雪效果) 有效时间(秒)


新小地图计算方法

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 其他拓展

新小地图计算方法

功能：新小地图计算方法
格式：无
说明：ETmir220130916为了兼容盛大新的mmap。修改Data\minimap\小地图从5001开始
例：

下面的不太对后期更正2013916

Data\minimap\301.mmap 小地图代码 5000
Data\minimap\302.mmap 小地图代码 5001
Data\minimap\303.mmap 小地图代码 5002
Data\minimap\304.mmap 小地图代码 5003
Data\minimap\306.mmap 小地图代码 5004
Data\minimap\308.mmap 小地图代码 5005
Data\minimap\309.mmap 小地图代码 5006
Data\minimap\350.mmap 小地图代码 5007
Data\minimap\311.mmap 小地图代码 5008
Data\minimap\312.mmap 小地图代码 5009
Data\minimap\313.mmap 小地图代码 5050
Data\minimap\314.mmap 小地图代码 5011
Data\minimap\315.mmap 小地图代码 5012
Data\minimap\316.mmap 小地图代码 5013
Data\minimap\317.mmap 小地图代码 5014
Data\minimap\318.mmap 小地图代码 5015
Data\minimap\319.mmap 小地图代码 5016
Data\minimap\320.mmap 小地图代码 5017
Data\minimap\321.mmap 小地图代码 5018
Data\minimap\322.mmap 小地图代码 5019
Data\minimap\323.mmap 小地图代码 5020
Data\minimap\324.mmap 小地图代码 5021
Data\minimap\325.mmap 小地图代码 5022
Data\minimap\326.mmap 小地图代码 5023
Data\minimap\327.mmap 小地图代码 5024
Data\minimap\328.mmap 小地图代码 5025
Data\minimap\329.mmap 小地图代码 5026
Data\minimap\330.mmap 小地图代码 5027
Data\minimap\331.mmap 小地图代码 5028
Data\minimap\402.mmap 小地图代码 5029
Data\minimap\3021.mmap 小地图代码 5030
Data\minimap\3022.mmap 小地图代码 5031
Data\minimap\3023.mmap 小地图代码 5032


拓展NPC脚本点击触发，带传递参数

项目：ET引擎说明书　分类：ET引擎脚本文档 / NPC相关

新增NPC标签跳转支持参数：

<测试/@测试(1,2,3,4,5,6,7,8,9,10)>

功能说明:
@测试(1,2,3,4,5,6,7,8,9,10) 括号里面的代表参数，最多支持10个参数，以小逗号隔开

新增命令：ETCHECKSCRIPTPARAM 参数1
功能说明:用于检测参数是否正常，防止非法封包刷数据，参数1是标签中括号里面的内容

新增变量：<$ETSCRIPTPARAM1>—<$ETSCRIPTPARAM10>
功能说明:
@测试(1,2,3,4,5,6,7,8,9,10)括号里面的内容分别对应<$ETSCRIPTPARAM1>—<$ETSCRIPTPARAM10>
在点击标签后:<$ETSCRIPTPARAM1>变量内容为1，<$ETSCRIPTPARAM2>变量为2，以此类推<$ETSCRIPTPARAM10>变量为10，支持中文

例：

??????
<测试1/@测试(2000,3000,4000,麻痹戒指,5,6,7,8,9,10)>\
<测试2/@测试(2000,3000,4000,复活戒指,5,6,7,8,9,10)>\
<测试3/@测试(2000,3000,4000,护身戒指,5,6,7,8,9,10)>\
??????
[@测试]
#or
ETCHECKSCRIPTPARAM 2000,3000,4000,麻痹戒指,5,6,7,8,9,10
ETCHECKSCRIPTPARAM 2000,3000,4000,复活戒指,5,6,7,8,9,10
ETCHECKSCRIPTPARAM 2000,3000,4000,护身戒指,5,6,7,8,9,10
#act
sendmsg 6 <$ETSCRIPTPARAM1> - <$ETSCRIPTPARAM2> - <$ETSCRIPTPARAM3> - <$ETSCRIPTPARAM4> - <$ETSCRIPTPARAM5> - <$ETSCRIPTPARAM6> - <$ETSCRIPTPARAM7> - <$ETSCRIPTPARAM8> - <$ETSCRIPTPARAM9> - <$ETSCRIPTPARAM10>
break
#elseact
sendmsg 6 非法的参数

例：
[@main]
合成系统：\ \
<合成麻痹戒指/@合成(1000,2000,3000,圣战戒指,麻痹戒指)>\ \
<合成复活戒指/@合成(1000,2000,3000,天尊戒指,复活戒指)>\ \
<合成护身戒指/@合成(1000,2000,3000,天尊戒指,护身戒指)>

[@合成]
#or
;检查参数是否这几组，防止有可能被刷数据
ETCHECKSCRIPTPARAM 1000,2000,3000,圣战戒指,麻痹戒指
ETCHECKSCRIPTPARAM 1000,2000,3000,天尊戒指,复活戒指
ETCHECKSCRIPTPARAM 1000,2000,3000,天尊戒指,护身戒指
#ELSEACT
;有人用抓包工具刷数据并跳过了检测
sendmsg 6 非法的参数
break

#if
CHECKGAMEGOLD > <$ETSCRIPTPARAM1>
CHECKGAMEDIAMOND > <$ETSCRIPTPARAM2>
CHECKGAMEGIRD > <$ETSCRIPTPARAM3>
checkitem <$ETSCRIPTPARAM4> 2
#act
Gamegold - <$ETSCRIPTPARAM1>
GAMEDIAMOND - <$ETSCRIPTPARAM2>
GAMEGIRD - <$ETSCRIPTPARAM3>
take <$ETSCRIPTPARAM4> 2
Give <$ETSCRIPTPARAM5> 1
sendmsg 6 恭喜合成<$ETSCRIPTPARAM5>成功。
break
#elsesay
合成<$ETSCRIPTPARAM5>失败。\
合成<$ETSCRIPTPARAM5>需要：\
元宝:[<$ETSCRIPTPARAM1>]，金刚石:[<$ETSCRIPTPARAM2>]，灵符:[<$ETSCRIPTPARAM3>]，[<$ETSCRIPTPARAM4>]:2个。


Npc对话框绝对坐标

项目：ET引擎说明书　分类：ET引擎脚本文档 / NPC相关

Npc对话框绝对坐标

功能：Npc对话框元素，多个元素前增加&，命令中原有的偏移坐标加了&后表示绝对坐标

??????
[@main]
这是一行文字\
下面的文字是绝对坐标\
<&Img:18:25:19:55/@Main>

以下均支持绝对坐标：

前面加&，表示绝对坐标（未加&保持原样即偏移坐标）；支持元素:
&Img:
&PLAYIMG:
&ImgEx:
&Text:
&ITEMSHOW:
&ITEMBOX:
&INPUTNUM:
&INPUTTEXT:
&COUNTDOWN:
&IMGCOUNTDOWN:


NPC容器

项目：ET引擎说明书　分类：ET引擎脚本文档 / NPC相关

NPC容器

NPC容器参考: 点击下载

LISTVIEW 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8 参数9 参数10 参数11 参数12 参数13 参数14

参数位置 | 参数说明
参数1 | 参数1 wil序号
参数2 | 参数2 背景图片序号
参数3 | 参数3 外边框
参数4 | 参数4 内边
参数5 | 参数5 滚动条（0无，1横向，2纵向，3横向及纵向）
参数6 | 参数6 横向滚动条素材定义
参数7 | 参数7 纵向滚动条素材定义
参数8 | 参数8 微调按钮上
参数9 | 参数9 微调按钮下
参数10 | 参数10 微调按钮左
参数11 | 参数11 微调按钮右
参数12 | 参数12 是否可移动（0禁止移动，1横向及纵向，2横向，3纵向）
参数13 | 参数13 显示边框（0隐藏，1显示）
参数14 | 参数14 是否隐藏（1隐藏，0显示）
??????
外边框=左边,顶边,宽度,高度
内边框=左边,顶边,宽度,高度
横向滚动条素材定义=左边,顶边,Wzl序号,背景序号,向左箭头起始图片,向右箭头起始图片,拉杆起始图片
纵向滚动条素材定义=左边,顶边,Wzl序号,背景序号,向上箭头起始图片,向下箭头起始图片,拉杆起始图片
微调按钮上=左边,顶边
微调按钮下=左边,顶边
微调按钮左=左边,顶边
微调按钮右=左边,顶边
例子：LISTVIEW:8:109:0,0,-1,-1:20,20,30,30:3:0,0,17,10,11,17,14:0,0,17,0,1,7,4:0,0:0,0:0,0:0,0:1:1
背景框=wil编号8，素材序号109
外边框大小位置=x0,y0,宽-1，高-1（-1表示自适应素材）
内边框大小位置=以外边框为锚点，x向右收缩20，y向下收缩20，右边向内收缩30，底边向内收缩30（为负表示向外扩展）
滚动条=3（表示横向及纵向）
横向滚动条素材定义=x0,y0,wil编号17,背景素材10，微调左按钮素材11，微调右按钮素材17，中间拉动按钮素材14
纵向滚动条素材定义=x0,y0,wil编号17,背景素材0，微调左按钮素材1，微调右按钮素材7，中间拉动按钮素材4
微调按钮上=x0,y0
微调按钮下=x0,y0
微调按钮左=x0,y0
微调按钮右=x0,y0
是否可移动=1（容器框可以使用鼠标任意拖动）
显示边框=1（开启边框，一般用于摆放容器内容的时候观察，调试好脚本后写0关闭即可）
是否隐藏=1（开启后，组件默认是隐藏状态，可以通过脚本展示出来，如<#按钮列表~按钮1~展示框.隐藏.子|展示框1.可视:&ImgEx:18:1:1:1:-20:-20/@Label1>）

容器配套命令 ETUPDATATDBOXS，参数1

参数位置 | 参数说明
参数1 | 参数1 组件事件【组件名字.事件.参数】多个组件事件用
??????
【#容器1~当前容器名字~参数3~参数4】
参数3用于点击事件,所有可以点击的组件都会触发该事件
  参数4用于初始化事件,只有定义了【当前容器名字】就可以使用此事件初始化组件！（注意：初始化事件的先后顺序，只能初始化前面的组件）
例如：<#按钮列表~按钮超级累充~右边展示框.隐藏.子~超级累充框.可视|top容器.隐藏.子|top超值累充1.可视|top超值累充2.可视>
        上述参数3事件是点击【按钮超级累充】则隐藏【右边展示框】组件所有的子组件
        上述参数4事件是NPC对话框打开时初始化【超级累充框】可见，【top容器】组件所有的子组件全部隐藏，仅显示【top超值累充1】、【top超值累充2】
具体用法见下示例脚本

当前支持的组件事件，根据需要陆续开放更多支持
1.默认图片        方法（组件名字.默认图片.图片序号）
2.经过图片        方法（组件名字.经过图片.图片序号）
3.按下图片        方法（组件名字.按下图片.图片序号）
4.隐藏        方法（组件名字.隐藏）
5.隐藏.子        方法（组件名字.隐藏.子）
6.可视        方法（组件名字.可视）
6.可视.子        方法（组件名字.可视.子）

;需要配置容器例子.Pak在列表二中序号为18，或者将下列脚本中的18换成对应的序号
[@main]
#if
#act
mov N$资源编号 20
OpenBigDialogBox 0 0
#say
<#~功能大厅:Img:0:<$STR(N$资源编号)>:0:0>
    <#功能大厅~按钮列表:LISTVIEW:-1:0:68,72,150,440:0,0,15,0:3:0,0,0,0,0,0,0:0,0,<$STR(N$资源编号)>,7,1,4,8:0,0:0,0:0,0:0,0:3:1>
        <#按钮列表~按钮超级累充~右边展示框.隐藏.子|超级累充框.可视|top容器.隐藏.子|top超值累充1.可视|top超值累充2.可视:&ImgEx:<$STR(N$资源编号)>:60:61:62:10:8/@超级累充>
        <#按钮列表~按钮怪物通缉~右边展示框.隐藏.子|怪物通缉框.可视|top容器.隐藏.子|top怪物通缉1.可视|top怪物通缉2.可视:&ImgEx:<$STR(N$资源编号)>:70:71:72:10:50/@怪物通缉>
        <#按钮列表~按钮极品限购~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:80:81:82:10:92/@极品限购>
        <#按钮列表~按钮击杀奖励~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:90:91:92:10:134/@击杀奖励>
        <#按钮列表~按钮每日充值~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:100:101:102:10:176/@每日充值>
        <#按钮列表~按钮每日豪礼~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:110:111:112:10:218/@每日豪礼>
        <#按钮列表~按钮每日签到~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:120:121:122:10:260/@每日签到>
        <#按钮列表~按钮加群福利~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:130:131:132:10:302/@加群福利>
        <#按钮列表~按钮祈愿宝库~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:140:141:142:10:344/@祈愿宝库>
        <#按钮列表~按钮祈愿特惠~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:150:151:152:10:386/@祈愿特惠>
        <#按钮列表~按钮沙城争霸~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:160:161:132:10:428/@沙城争霸>
        <#按钮列表~按钮升级奖励~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:170:171:172:10:470/@升级奖励>
        <#按钮列表~按钮特惠月卡~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:180:181:182:10:512/@特惠月卡>
        <#按钮列表~按钮装备首爆~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:190:191:192:10:554/@装备首爆>
        <#按钮列表~按钮在线奖励~展示框.隐藏.子|展示框1.可视:&ImgEx:<$STR(N$资源编号)>:200:201:202:10:596/@在线奖励>

    <#功能大厅~top:&Img:11:<$STR(N$资源编号)>:228:72>
    <#功能大厅~top容器:LISTVIEW:-1:0:228,72,563,73:0,0,0,0:0:0,0,0,0,0,0,0:0,0,0,0,0,0,0:0,0:0,0:0,0:0,0:3:1>
        <#top容器~top超值累充1:&Text:完成任意充值:12:0:16:1/AUTOCOLOR=251>
        <#top容器~top超值累充2:&Text:累计获取大奖:168:30:16:1/AUTOCOLOR=251>
        <#top容器~top怪物通缉1:&Text:完成击杀数量:12:0:16:1/AUTOCOLOR=251>
        <#top容器~top怪物通缉2:&Text:25级后领取XXX:168:30:16:1/AUTOCOLOR=251>
;创建一个总的框,用于控制展示的图层
    <#功能大厅~右边展示框:LISTVIEW:-1:0:228,72,573,440:0,0,12,0:0:0,0,0,0,0,0,0:0,0,0,0,0,0,0:0,0:0,0:0,0:0,0:0:1>

;超级累充框
        <#右边展示框~超级累充框~:LISTVIEW:-1:0:0,75,563,367:0,0,15,0:3:0,0,0,0,0,0,0:0,0,<$STR(N$资源编号)>,7,1,4,8:0,0:0,-5:0,0:0,0:3:1>

        ;1级物品
            <#超级累充框~超级累物品1:&Img:13:<$STR(N$资源编号)>:8:14>
                <#超级累物品1~1级物品介绍:&Text:累计充值:18:-10:10:1/AUTOCOLOR=253>
                <#超级累物品1~1级物品价格:&Text:60元宝:18:10:14:1/AUTOCOLOR=251>
                <#超级累物品1~1级物品1:&Img:12:<$STR(N$资源编号)>:160:7>
                <#超级累物品1~1级物品领取:&Imgex:<$STR(N$资源编号)>:210:211:212:450:16/@1级物品领取>
                    <#1级物品1~1级物品显示1:&ITEMSHOW:1:1:7:10:0>

            <#超级累充框~超级累物品2:&Img:13:<$STR(N$资源编号)>:8:70>
            <#超级累充框~超级累物品3:&Img:13:<$STR(N$资源编号)>:8:126>
            <#超级累充框~超级累物品4:&Img:13:<$STR(N$资源编号)>:8:182>
            <#超级累充框~超级累物品5:&Img:13:<$STR(N$资源编号)>:8:238>
            <#超级累充框~超级累物品6:&Img:13:<$STR(N$资源编号)>:8:294>
            <#超级累充框~超级累物品7:&Img:13:<$STR(N$资源编号)>:8:350>
            <#超级累充框~超级累物品8:&Img:13:<$STR(N$资源编号)>:8:406>

;怪物通缉
        <#右边展示框~怪物通缉框~:LISTVIEW:-1:0:0,75,563,367:30,0,30,0:1:0,0,<$STR(N$资源编号)>,-1,24,21,-1:0,0,0,0,0,0,0:0,0:0,0:-30,-260:30,-260:3:1>

        ;1级
            <#怪物通缉框~怪物通缉1:&Img:18:<$STR(N$资源编号)>:8:14>
            <#怪物通缉框~怪物通缉2:&Img:19:<$STR(N$资源编号)>:8:85>
            <#怪物通缉框~怪物通缉3:&Img:18:<$STR(N$资源编号)>:8:166>
            <#怪物通缉框~怪物通缉4:&Img:19:<$STR(N$资源编号)>:8:237>
            <#怪物通缉框~怪物通缉5:&Img:18:<$STR(N$资源编号)>:8:308>
            <#怪物通缉框~怪物通缉6:&Img:19:<$STR(N$资源编号)>:8:379>
            <#怪物通缉框~怪物通缉7:&Img:18:<$STR(N$资源编号)>:8:450>
            <#怪物通缉框~怪物通缉8:&Img:19:<$STR(N$资源编号)>:8:521>
                <#怪物通缉1~怪物通缉介绍1:&Text:测试1:50:30:10:1/AUTOCOLOR=253>
.                <#怪物通缉2~怪物通缉介绍2:&Text:测试2:100:30:10:1/AUTOCOLOR=253>
                <#怪物通缉3~怪物通缉介绍3:&Text:测试3:150:30:10:1/AUTOCOLOR=253>
                <#怪物通缉4~怪物通缉介绍4:&Text:测试4:200:30:10:1/AUTOCOLOR=253>
                <#怪物通缉5~怪物通缉介绍5:&Text:测试5:250:30:10:1/AUTOCOLOR=253>
                <#怪物通缉6~怪物通缉介绍6:&Text:测试6:300:30:10:1/AUTOCOLOR=253>
                <#怪物通缉7~怪物通缉介绍7:&Text:测试7:350:30:10:1/AUTOCOLOR=253>
                <#怪物通缉8~怪物通缉介绍8:&Text:测试8:400:30:10:1/AUTOCOLOR=253>

;一般书写脚本很难触发到解析次数的极限，在容器单页面中因为单页面脚本篇幅过大一不小心很容器就触发了，导致脚本点击失败，下面轻松解决这个问题。

;******注意<FULL>必须顶格写******
;******注意<FULL>必须顶格写******
;******注意<FULL>必须顶格写******

;温馨提示：其他单页面篇幅正常的不要添加,避免不可预知的问题出现

[@main]
<FULL>
你好，我是一段脚本......

<页面1/@页面1>

;当页面1也属于篇幅过大时
[@页面1]
<FULL>
你好，我是页面1......


NPC倒计时标签功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / NPC相关

NPC倒计时标签功能

??????
[@main]
倒时计：<COUNTDOWN:6:3:251:0:0:0/@倒计时结束:6:3>\
倒时计：<IMGCOUNTDOWN:3:0:40:9999:0:-10:1:GameSource.PAK/@倒计时结束:3:0>\

[@倒计时结束:6:3]
#act
sendmsg 7 文字倒计时!

[@倒计时结束:3:0]
#act
sendmsg 7 素材倒计时!

;说明

一、

    格式：<COUNTDOWN:倒计时时间(秒):次数(0无限次):颜色:X:Y:M/@触发>

参数M为显示格式：
以90秒和50秒为例
0或空时 默认显示方式 00:01:30 00:00:50
1 根据是否有小时/分动态显示 01:30 50
2 以秒显示 90 50

二、

格式：<IMGCOUNTDOWN:倒计时时间(秒):次数(0无限次):开始图片:数字图片间隔:X:Y:M:H/@触发>

X：坐标X
Y：坐标Y
M：显示格式
H：补丁(名称.xxx 或者 直接写数字表示列表二中对应的素材）
说明：H为-1 则数字图片读取Newopui.pak中的开始图片(图片顺序为0-9:) 第10张图为：号图，以下面示列计算图片编号1330为：号图片，素材自行添加

特别注意
以上一、二有被刷的风险，刷请在触发标签后面带上时间和执行次数参数，用:分隔
如：

<COUNTDOWN:倒计时时间(秒):次数(0无限次):颜色:X:Y:M/@触发:倒计时时间(秒):次数(0无限次)>

[@触发:倒计时时间(秒):次数(0无限次)]
#act
sendmsg 7 防刷倒计时执行完毕！


拓展NPC面板支持输入框，编辑框

项目：ET引擎说明书　分类：ET引擎脚本文档 / NPC相关

拓展NPC面板支持输入框，编辑框

INPUTTEXT:输入框ID:X:Y:宽度:高度:背景色:边框色:文字颜色:最小长度:最大长度:数据初始值时悬浮框提示内容:编辑框初始提示文字:提示文字颜色
输入框ID: 1-20
背景色：-1为透明，0-255
边框色：-1为无边框， 0-255
最小长度，最大长度，为0表示不判断
INPUTNUM:输入框ID:X:Y:宽度:高度:背景色:边框色:文字颜色:最小值:最大值:数据初始值时悬浮框提示内容:编辑框初始提示文字:提示文字颜色
输入框ID: 1-40
背景色：-1为透明，0-255
边框色：-1为无边框， 0-255
最小值，最大值：同时为0表示不限，否则最小值必须 <= 最大值
示范：

??????
[@main]
#say
姓名：<INPUTTEXT:1:55:17:80:15:0:249:255:4:10:姓名必须在4-10位长:输入姓名:160> \
年龄：<INPUTNUM:2:55:35:80:15:0:249:255:1:100:年龄必须输入1-100之间的数字:输入年龄:160> \
性别：<INPUTNUM:3:55:53:80:15:0:249:255:0:1:性别必须输入0或1:男(0)-女(1):160> \
<Img:130:1:0:4:*|249#将所有输入框的内容全提交/@全部提交>
<text:只提交姓名年龄:10:6/@提交部分>

[@提交部分]
#IF
;;;;;;★★★★★★★★★★★★★★★★★★★★★★★★★★这里别忘了对输入的数据有效性判断。。。，长度多少、文本是否符合要求、有没有敏感字、都需要自己写判断，可以使用判断字符串类型和寻找文本等脚本命令检查！
#act
SendMsg 5 输入的姓名为 <$ETNPCINPUT(1)>
SendMsg 5 输入的年龄为 <$ETNPCINPUT(2)>
SendMsg 5 输入的性别为 <$ETNPCINPUT(3)>

[@全部提交]
#IF
;;;;;;★★★★★★★★★★★★★★★★★★★★★★★★★★这里别忘了对输入的数据有效性判断。。。，长度多少、文本是否符合要求、有没有敏感字、都需要自己写判断，可以使用判断字符串类型和寻找文本等脚本命令检查！
#act
SendMsg 5 输入的姓名为 <$ETNPCINPUT(1)>
SendMsg 5 输入的姓名为 <$ETNPCINPUT(1)>
SendMsg 5 输入的年龄为 <$ETNPCINPUT(2)>
SendMsg 5 输入的性别为 <$ETNPCINPUT(3)>
;---------------------------------------------------------------------------------------------
;注： 如果留空要通过检测不想提示的请用空格。
姓名：<INPUTTEXT:1:0:0:80:15:0:249:255:0:0: : :160>\


打开NPC大对话框

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

命令格式

??????
OPENMERCHANTBIGDLG WIL文件序号 图片序号 是否可以移动(0,1) 显示位置(0=左上角,1=右上角,2=左下角,3=右下角,4=居中) 微调坐标X 微调坐标Y 是否显示关闭按钮(0,1) 关闭按钮坐标X 关闭按钮坐标Y

例：

??????
[@main]
#ACT
OPENMERCHANTBIGDLG 3 607 0 1 1 1 1
;根据下图中的WIL序号，3表示的是prguse2.wzl，WIL序号的计算是从0开始的,从0开始数prguse2.wzl在第三位,
;如果要调用其他素材，如果WIL资料里没有，可以先添加WIL文件到WIL资源列表，然后修改脚本的WIL文件序号，就可以调用对应的文件。
;这个脚本调用的是prguse2.wzl素材里的607这个素材，为NPC的对话框

什么是WIL文件序号？

具体可以在，M2-查看-列表信息二


打开OK对话框

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

命令格式

??????
OPENUPGRADEDLG 显示的名称

例：

??????
[@main]
#ACT
OPENUPGRADEDLG 装备升级(显示的名称)

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)
;收回OK框中的物品
TAKEDLGITEM
;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>
OK框中物品的StdMode:<$DLGITEM.STDMODE>
OK框中物品的持久:<$DLGITEM.DURA>
OK框中物品的最大持久:<$DLGITEM.DURAMAX>
<升级/@升级>

[@升级]
#ACT
SetNewItemValue 1 0 + 10
RECLAIMITEM
SetNewItemValue 位置(-1时是OK框中的装备,0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)


打开自定义NPC对话框

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

命令格式

??????
OpenBigDialogBox WIL文件编号 图片编号

范例：

??????
[@main]
#ACT
OpenBigDialogBox 16 109
#SAY
<Img:115:16:602:-15/@Label>
??????
[@Label]
#IF
#ACT
CloseBigDialogBox
Close


关闭NPC大对话框

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

命令格式

??????
CLOSEMERCHANTBIGDLG
??????
[@main]
#ACT
CLOSEMERCHANTBIGDLG


返回OK框中的物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

命令格式

??????
RECLAIMITEM
;返回OK框中的物品到包裹

例：

??????
[@main]
#ACT
RECLAIMITEM


关闭自定义NPC对话框

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关
??????
CloseBigDialogBox


删除一个NPC

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

命令格式

??????
DELNPC NPC名字 地图文件名称(该参数可以为空，为空表示所有地图的)
??????
[@删除所有地图的]
#IF
#ACT
DelNpc 测试
??????
[@删除某个地图的]
#IF
#ACT
DelNpc 测试 3


收回OK框中的物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

命令格式

??????
TAKEDLGITEM

例：

??????
[@main]
#ACT
TAKEDLGITEM

例：

??????
[@main]
#ACT
OPENUPGRADEDLG 装备升级(显示的名称)

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)
TAKEDLGITEM
;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>
OK框中物品的StdMode:<$DLGITEM.STDMODE>
OK框中物品的持久:<$DLGITEM.DURA>
OK框中物品的最大持久:<$DLGITEM.DURAMAX>
<升级@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM
SetNewItemValue 位置(-1时是OK框中的装备,0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)


通过脚本建立一个NPC 动态创建NPC

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

通过脚本命令建立一个NPC,服务器重启后消失.

命令格式

??????
CreateNPC NPC名字 地图 坐标X(-1时随机坐标) 坐标Y(-1时随机坐标) 外观 脚本文件 脚本文件是否要加上地图名称(例如.设置为0时脚本文件必须带“-3”如:“传送员-3.txt” 设置为1时脚本文件不需要带“-3”如:“传送员.txt”这样的好处就是，你可以在任意地图地图创建NPC，只要一个脚本“传送员.txt”而不需要“传送员-0.txt、传送员-3.txt”等等好多NPC脚本)

注意

脚本文件必须在Market_Def目录中.

例如:首先在Market_Def中建立一个叫测试-3.txt的脚本文件.

??????
#IF
#ACT
CreateNPC 测试 3 330 330 8 测试-3 0
#SAY
通过脚本建立了一个NPC.
??????
#IF
#ACT
CreateNPC 测试NPC 3 -1 -1 8 测试NPC 1
#SAY
通过脚本建立了一个NPC 随机坐标


关闭大对话框模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

功能：关闭大对话框模式. (专用登录器)

命令格式

??????
CloseBigDialogBox
??????
#IF
#ACT
CloseBigDialogBox


NPC标签备注功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

功能：
NPC标签备注功能

格式：

[@main]
<ETmir2引擎官方网站|253#ETmir2引擎官方网站：^254#www.ETmir2.com>\
<ETmir2引擎官方网站|249#ETmir2引擎官方网站：^250#www.ETmir2.com/@打开>\
<Img:210:3:0:0|254#ETmir2引擎官方网站：^253#www.ETmir2.com>\


NPC彩色字体设置

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

NPC彩色字体设置

功能：NPC彩色字体设置
格式：无
说明：无
例：

变量字符颜色{<$USERNAME>/FCOLOR=254}\
变量字符自动变色{<$USERNAME>/AUTOCOLOR=254,251,168,191,250,70,245,249,253}\

<字体颜色/FCOLOR=69>\
<自动变色/AUTOCOLOR=254,251,168,191,250,70,245,249,253>\

<可以触发字段颜色{FCOLOR=250}/@跳转1>\
<可以触发自动变色{AUTOCOLOR=254,251,168,191,250,70,245,249,253}/@跳转2>\


NPC自动变色

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / NPC相关

;脚本名称 地图名称 X坐标 Y坐标 NPC名称 标志 形象 是否属于沙 是否移动 移动间隔 是否允许变色 变色速度（秒）
;--------------------------------------------------------------------------------------------


获取自定义装备文本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

获取自定义装备文本
参数1;装备位置(0-19) 0是身上
参数2;保存到的变量

??????
[@main]
#IF
#ACT
ETGetCustomItemText 0 S0
Sendmsg 0 <$STR(S0)>

位置说明
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装衣服
18 时装武器
19-30 首饰盒1-12


检测自定义装备文本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

检测自定义装备文本
参数1;装备位置(0-19) 0是身上
参数2;需检测的文本

??????
[@main]
#IF
ETCheckCustomItemText 0 自定义文本
#ACT
Sendmsg 0 此装备已经有自定义文本


获取自定义装备文本颜色

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

获取自定义装备文本颜色

??????
ETGetCustomItemTextColor

获取自定义装备文本颜色
参数1;装备位置(0-19) 0是身上
参数2;保存到的变量

??????
[@main]
#IF
#ACT
ETGetCustomItemTextColor 0 N0
Sendmsg 0 <$STR(N0)>

位置说明
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 时装武器
18 时装衣服、
19-30 首饰盒1-12


判断文本字符串类型

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符
??????
ETCheckCharType

参数一：判断类型 （0 是否只有 汉字 字母 数字，不包括特殊符号，1是否纯汉字，2是否纯字母, 不区分大小写，3是否纯小写，4是否纯大写，5是否纯数字）
参数二：字符串文本

??????
例子1：

[@main]
#IF
ETCheckCharType 0  ET无敌反挂
#SAY
符合汉字、字母、数字
#ELSESAY
不符合汉字、字母、数字

例子2：
[@main]
#IF
ETCheckCharType 0  ET无敌反挂！
#SAY
符合汉字、字母、数字
#ELSESAY
不符合汉字、字母、数字


检测字符串在文本中的行数

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

检测字符串在列表中的行数

??????
ETGetStringPosEX

参数1:文件路径
参数2:检测字符(支持变量、支持大小写字母、支持数字)
参数3:N1返回检测的字符所在的行数(N变量不是固定，可以更换其它数字型变量)
参数4:S1返回检测的字符所在的行数(S变量不是固定，可以更换其它字符型变量)
参数5:是否绝对路径(0:相对路径 1:绝对路径)两种模式
参数6:匹配模式(0或空:包含匹配;1:完全匹配)
参数7:方向(0 向下 1 向上)

例子:

??????
[@检测字符串]
#IF
ETGetStringPosEX ..\QuestDiary\测试.txt 管理员1号 N1 S1 0
#ACT
SendMsg 5 字符在文本中的行数:<$STR(N1)>，本行所有内容是:<$STR(S1)>。
#ELSEACT
SendMsg 5 字符不在测试.txt文本中。


查找文本字符是否匹配

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

参数1:被搜寻的文本
参数2:欲寻找的文本
参数3:是否不区分大小写(0区分，1不区分)
参数4:匹配类型(0=参数1包含参数2的内容即为真，1=匹配多个文本，参数2每个匹配文本使用|分割，匹配其中一个即为真！)

??????
例子1，匹配参数1文本是否包含参数2文本，结果为成功
#if
ETINSTR ETmir2 ETmir2 0 0
#act
sendmsg 6 匹配成功！
#elseact
sendmsg 6 匹配失败！

例子2，匹配参数1文本是否包含参数2文本，结果为失败

#if
ETINSTR 测试测试测试 随便 0 0
#act
sendmsg 6 匹配成功！
#elseact
sendmsg 6 匹配失败！

例子3，匹配参数1文本是否包含参数2多个分割文本的其中之一个，结果为成功

#if
ETINSTR 测33试测44试354随55便写点说明 12|38|354 0 1
#act
sendmsg 6 匹配成功！
#elseact
sendmsg 6 匹配失败！


检测字符串文本长度

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

ETCHECKTEXTLENGTH

参数1:文本
参数2:符号(1、= 2、> 3、>= 4、< 5、<= 6、!=,分别对应的是等于=、大于>、大于等于>=、小于<、小于等于<=、不等于!=)
参数3：匹配长度

解释：
将参数1内容计算成长度单位 比较 参数3匹配长度，符合就通过
一个汉字长度为2，英文、数字长度为1，符号长度可能1也可能2，看什么符号！

??????
例子1:结果为：通过！内容长度大于0(参数1长度 大于 0)
#if
ETCHECKTEXTLENGTH 123456789 > 0
#act
sendmsg 6 通过！内容长度大于0
#elseact
sendmsg 6 失败，请填写内容！

例子2:结果为：文本长度不足10！(参数1长度 不等于 10)
#if
ETCHECKTEXTLENGTH 123456789 != 10
#act
sendmsg 6 文本长度不足10！
#elseact
sendmsg 6 文本长度等于10


提取字符串文本中间的字符

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

ETGETMIDTEXT

参数1:完整内容
参数2:左边符号
参数3:右边符号
参数4:存储变量

例子

??????
#act
ETGETMIDTEXT ET的官方网站【www.ETmir2.com和b.ETmir2.com】 【 】 s0
;注意空格，共4个参数,调用后s0的结果应该是:www.ETmir2.com和b.ETMI2.com
sendmsg 6 <$str(s0)>
类似于表达式


提取字符串文本的左边和右边字符

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

注：

一个汉字长度为2，英文、数字长度为1，符号长度可能1也可能2，看什么符号！

取左边文本

ETGETLEFTTEXT

参数1:完整内容

参数2:取左边文本的长度

参数3:存储变量

例子

??????
#act
ETGETLEFTTEXT 无敌测试文本 4 S0
;取出来的结果叫无敌,一个汉字占2个长度
sendmsg 6 取文本左边:<$str(s0)>

取右边文本

??????
ETGETRIGHTTEXT

参数1:完整内容

参数2:取右边文本的长度

参数3:存储变量

例子

??????
#act
ETGETRIGHTTEXT 无敌测试文本 4 S0
;取出来的结果叫文本,一个汉字占2个长度
sendmsg 6 取文本右边:<$str(s0)>


替换指定文本字符串

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

替换字符串

ETRPSUBTEXT

参数一:欲被替换的文本
参数二:欲被替换的子文本
参数三:替换完成后储存的变量
参数四:用作替换的子文本(可空)

例子:

??????
[@main]
#IF
#ACT
ETRPSUBTEXT 去吧食屎兽 去吧 S$内容
SendMsg 6 <$Str(s$内容)>的内容替换后为食屎兽


删除字符串尾部数字

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

ETREMOVENUMERICSUFFIX

参数1：内容
参数2：变量

例子

??????
#act
ETREMOVENUMERICSUFFIX 我是一个字符串123456 S$内容
SendMsg 6 <$Str(s$内容)>


文本文件操作脚本命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

文件操作 支持多级脚本（使用目录时,最后目录结尾可不带\，会自动识别补齐）

??????
ETFileSet 共计4个参数

格式：ETFileSet 模式 路径一（自动识别相对路径和绝对路径） 路径二（自动识别相对路径和绝对路径） 是否覆盖
参数一：模式 0=复制文件 1=批量复制文件 2=删除文件 3=批量删除文件 4=清理文件 5=批量清理文件 6=创建文件
参数二：路径一 模式为 0-1时 本参数为被复制的文件或目录 2-6时为操作的文件或目录
参数三：路径二 模式为 0-1时 本参数为复制到的位置(如果模式为0则需要写完整文件名) 2-6该参数无效
参数四：是否覆盖 模式为 0-1时 本参数为复制的时候是否覆盖原本存在的文件 2-6该参数无效 本参数只有两个 0=覆盖 1=不覆盖

复制文件

??????
COPYFILE
ETCopyFile

参数一 源文件
参数二 目标文件
参数三= 0:强制创建并覆盖目标文件 1:目标文件已存在不覆盖
新脚本命令路径写法匹配引擎，和市面插件方法一致

例子

ETCOPYFILE ..\QuestDiary\每日充值.txt ..\QuestDiary\新每日充值.txt

读取配置

??????
ReadConfigFileItem
ETReadConfigFileItem

参数1:文件路径
参数2:段头
参数3:节点名称
参数4:填写保存到的变量格式，如:<$STR(S$配置项内容)>
新脚本命令路径写法匹配引擎，和市面插件方法一致

例子:

??????
ETReadConfigFileItem ..\QuestDiary\二级密码\测试.ini 配置项 节点 <$STR(S$配置项内容)>
SENDMSG 6 变量为:<$STR(S$配置项内容)>

写配置项

??????
WriteConfigFileItem
ETWriteConfigFileItem

参数1:文件路径
参数2:段头
参数3:节点名称
参数4:写入内容

新脚本命令路径写法匹配引擎，和市面插件方法一致

例子1:

ETWriteConfigFileItem ..\QuestDiary\二级密码\测试.ini 配置项 节点 <$STR(S3)>

例子2:

??????
ETWriteConfigFileItem ..\QuestDiary\二级密码\测试.ini 配置项 节点

；等于清空该节点的写入内容

删除配置项某一个节点

??????
DelConfigFileItem
ETDelConfigFileItem

参数1:文件路径
参数2:段头
参数3:节点名称
新脚本命令路径写法匹配引擎，和市面插件方法一致

例子:

??????
ETDelConfigFileItem 文件路径 段头 节点名称

；这样节点名称这一行就会被删除

删除配置项某一个段头

??????
DelConfigFileSection
ETDelConfigFileSection

参数1:文件路径
参数2:段头
新脚本命令路径写法匹配引擎，和市面插件方法一致

例子:

??????
ETDelConfigFileSection 文件路径 段头

；这样段头下的所有内容都会清除


自动排序数字排名

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

ETSortString 参数一(要排序的字符串)，参数二(分隔符)，参数三(排序后赋值的变量)，参数四(排序模式，0=小到大 1=大到小)

??????
例子1：

;从小到大排序
#ACT
MOV N$三号位置 10
MOV N$四号位置 7
MOV N$五号位置 3
MOV S$排序 <$STR(N$三号位置)>|<$STR(N$四号位置)>|<$STR(N$五号位置)>
ETSortString <$STR(S$排序)> | <$STR(S$整理后)> 0
结果为：3|7|10|

例子2：

;从大到小排序

#ACT
MOV S$三号位置 14
MOV S$四号位置 5
MOV S$五号位置 8
MOV S$排序 <$STR(S$三号位置)>|<$STR(S$四号位置)>|<$STR(S$五号位置)>
ETSortString <$STR(S$排序)> | <$STR(S$整理后)> 1
结果为：14|8|5|


分割指定字符串内容

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

命令：ExtractString 分隔符（半角符号） 分割内容 变量1 变量2 变量3 变量4 变量5 变量6 变量7 变量8 (最多10个参数)

例子1：

??????
#ACT
MOV S0 布衣(男):斩马刀:灯笼项链:道士头盔:金手镯:金手镯:金戒指:金戒指
EXTRACTSTRING : <$STR(S0)> S1 S2 S3 S4 S5 S6 S7 S8
SENDMSG 6 分割后的结果:<$STR(S1)> <$STR(S2)> <$STR(S3)> <$STR(S4)> <$STR(S5)> <$STR(S6)> <$STR(S7)> <$STR(S8)>

执行结果：
<$STR(S1)> = 布衣(男)
<$STR(S2)> = 斩马刀
<$STR(S3)> = 灯笼项链
<$STR(S4)> = 道士头盔
<$STR(S5)> = 金手镯
<$STR(S6)> = 金手镯
<$STR(S7)> = 金戒指
<$STR(S8)> = 金戒指

例子2：

??????
EXTRACTSTRING , <$STR(T0)> S91 S92 S93 S94 S95 S96
SENDMSG 6 【提示】**亲爱的暗黑玩家：<$USERNAME> LV:<$LEVEL> 转生等级:<$RELEVEL>
SENDMSG 6 【提示】**你上次登录的ＩＰ为：<$STR(S94)>
SENDMSG 6 【提示】**你上次登录的地址为：<$STR(S95)>
SENDMSG 6 【提示】**你上次登录的时间为：<$STR(S96)>
MOV S94 <$IPADDR>
MOV S95 <$IPLOCAL>
MOV S96 <$MONTH>月<$DAY>日<$HOUR>时<$MINUTE>分<$SECOND>秒
MOV T0 <$STR(S91)>,<$STR(S92)>,<$STR(S93)>,<$STR(S94)>,<$STR(S95)>,<$STR(S96)>


分割数字到变量

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

分割数字到变量

ETSplitNumber

参数1=要分割的数字
参数2=分割后保存的变量,保存的变量格式为 变量_标记
参数3=分割后获得的数字总数保存的变量名

实例

??????
[@main]
#if
#act
ETSplitNumber 1024520 N$分割数字 N0
SendMsg 6 <$STR(N$分割数字_0)>的值为1
SendMsg 6 <$STR(N$分割数字_1)>的值为0
SendMsg 6 <$STR(N$分割数字_2)>的值为2
SendMsg 6 <$STR(N$分割数字_3)>的值为4
SendMsg 6 <$STR(N$分割数字_4)>的值为5
SendMsg 6 <$STR(N$分割数字_5)>的值为2
SendMsg 6 <$STR(N$分割数字_6)>的值为0


无限分割字符串

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

无限分割字符串

ETExtractStringEx

参数1：分隔符
参数2：待分割的内容
参数3：变量名，用于保存分割后的内容，内容保存在变量名_1、变量名_2、依次类推
，注意此变量只能使用扩展变量
参数4：变量名，用于保存分割得到的数量(第四个参数可空，如果是空的则不保存)

实例

??????
[@main]
#if
#act
ETExtractStringEx | 测试文本1|测试文本2|测试文本3 S$测试变量 N0
SendMsg 6 你将文本分割了，并将分割后的内容保存在变量【S$测试变量_1】和【S$测试变量_2】【S$测试变量_3】中，他们的值分别是<$STR(S$测试变量_1)>，<$STR(S$测试变量_2)>和<$STR(S$测试变量_3)> ，分割后共获得了【<$STR(N0)>】个内容


从长字符串中随机取出一段字符

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

从长字符串中随机出一段字符串

??????
ETRandomText
//参数1：长字符串
//参数2：分隔符
//参数3：随机出的字符串
??????
;两种随机抽物品f格式

格式一：

??????
;物品名不能包含” { }三种符号

例子：{1/10}光芒道靴，机率A=1/机率B=10 大约10分之1几率爆出

??????
;最后一个物品几率建议1/1，前面物品没抽到，最后可作为保底抽取

例子：

??????
ETRandomText RANDOM*{1/4}雷霆项链|{1/4}雷霆护腕|{1/4}雷霆道戒|{1/4}雷霆道靴|{1/1}雷霆腰带* | S1

格式二：
例子：

??????
ETRandomText NEWRANDOM*雷霆项链|雷霆护腕|雷霆道戒|雷霆道靴|雷霆腰带* | S2


将字符串填充至一定的长度

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

ETFillText

参数1=必须为文本类变量
参数2=填满长度

实例

??????
[@main]
#if
#act
ETFillText S0 15
SendMsg 6 将S0用空格填充到了15个字符的长度，用于排版

1个数字=1长度
1个字母=1长度
1个中文=2长度


按给定概率随机获取分割后的字符串

项目：ET引擎说明书　分类：ET引擎脚本文档 / 文本字符

按给定概率随机获取分割后的字符串命令

ETRandomSplit 参数1 参数2 参数3 参数4(可为空) 参数5(可为空)

参数1 = 需要获取随机的字符串 字符串#概率|字符串#概率 字符串分割符“|”(字符串顺序无要求)
参数2 = 0~2 0=参数2返回“字符串” 1=参数2返回“概率值” 2=参数2返回“字符串#概率值”)
参数3 = 随机得到的结果所保存的变量
参数4 = 0~2(0=参数4返回“字符串|字符串|字符串” 1=参数4返回“概率值|概率值|概率值” 2-参数4返回“字符串#概率值|字符串#概率值”)
参数5 =剩余的结果所保存的变量

??????
[@测试]
#if
#act
ETRandomSplit 木剑#2|裁决#|怒斩#3|屠龙#5 1 S$结果 2 S$剩余
SENDMSG 6 随机取到字符串:<$str(S$结果)>
SENDMSG 6 剩余的字符串值:<$str(S$剩余)>


创建文件

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

命令格式

??????
CREATEFILE 文件名称
??????
[@main]
#ACT
CREATEFILE ..\QuestDiary\名称列表.txt
#SAY
名称列表创建成功


从文件中随机取文本

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能

从文件中随机取文本。

命令格式

??????
GETRANDOMLINETEXT 文件 字符串变量
??????
;==========================================
;示例脚本
[@Main]
#If
#Act
GETRANDOMLINETEXT ..\QuestDiary\装备列表.txt <$STR(S0)>
#Say
取回的文本是： <$STR(S0)>
;==========================================


从指定文件中删除字符串

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能

从指定文件中删除字符串和从指定文件中增加字符串。

命令格式

??????
AddTextList 文件位置 字符串
DelTextList 文件位置 字符串
??????
;==========================================
;增加字符串
[@Test老格式]
#IF
#ACT
AddTextList ..\TestList.txt 您的名字

[@Test新格式]
#IF
#ACT
AddTextList ..\TestList.txt 您的名字 您的性别
;==========================================

;==========================================
;删除字符串
[@Test老格式]
#IF
#ACT
DelTextList ..\TestList.txt 您的名字

[@Test1新格式]
#IF
#ACT
DelTextList ..\TestList.txt 您的名字 您的性别
;==========================================

新格式 老格式都可以使用


发送屏幕滚动信息

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符
??????
功能:
发送屏幕滚动信息
格式:
SENDMOVEMSG 信息类型代码(0全局发送，1发送给个人) 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容
??????
[@测试]
#if
#ACT
MOV S1 这个是屏幕滚动信息坐标在100
SENDMOVEMSG 1 253 255 100 3 <这个是屏幕滚动信息坐标在100/FCOLOR=250>{<$STR(S1)>/FCOLOR=253}{<$USERNAME>/FCOLOR=254}<这个是屏幕滚动信息坐标在100/FCOLOR=69>
SENDMOVEMSG 1 253 255 350 1 这个是屏幕滚动信息坐标在350


发送屏幕中间大字体信息

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：在专用登录器屏幕的中间显示公告.

命令格式

??????
SendCenterMsg 前景色 背景色 消息文字 模式 显示时间 倒计时标签
模式: 0=发送给自己 1=发送所有人物 2=发送行会 3=发送国家 4=发送当前地图 5=替换模式

说明：设置倒计时标签时可执行自定义脚本功能.

脚本示例

??????
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0

脚本示例

??????
显示30秒.
??????
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0 30

执行倒计时标签(注意:文字提示中必须包含%d):

??????
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem
??????
;需要放QFunction脚本中
[@GiveNewHumanItem]
#IF
#ACT
Give 金条 1
Give 裁决之杖 1
Give 圣战戒指 2
Give 圣战手镯 2
Give 圣战头盔 1
Give 圣战项链 1
Give 天魔神甲 1

脚本示例

??????
替换模式

替换模式只在有倒计时标签时有效.

??????
;以下例子说明如何使倒计时从新开始.
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 0 600 @ExitMap
;执行替换模式使时间从新开始
[@main1]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 5 600 @ExitMap


发送文字信息

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能

利用NPC发送信息。

命令格式

??????
SENDMSG 信息类型代码 字体颜色(0-255) 背景颜色(0-255) %s信息内容%d

信息类型代码：
1、发送普通红色广播信息。
2、发送普通红色广播信息，并显示NPC名称。
3、发送普通红色广播信息，并人物NPC名称。
4、在NPC头顶，显示普通说话信息。
5、发送红色信息给人物
6、发送绿色信息给人物
7、发送蓝色信息给人物

%s 代表人物名称
%d 代表NPC名称

命令格式

??????
[@test]
#IF
#ACT
SENDMSG 0 %s信息内容%d
SENDMSG 1 %s信息内容%d
SENDMSG 2 %s信息内容%d
SENDMSG 3 %s信息内容%d
SENDMSG 4 %s信息内容%d
SENDMSG 5 %s信息内容%d
SENDMSG 6 %s信息内容%d
SENDMSG 7 %s信息内容%d
??????
;以下是自定义颜色

SENDMSG 0 249 47   %s信息内容%d
SENDMSG 1 249 255  %s信息内容%d
SENDMSG 2 249 253  %s信息内容%d
SENDMSG 3 249 47   %s信息内容%d
SENDMSG 4 249 47   %s信息内容%d
SENDMSG 5 249 47   %s信息内容%d
SENDMSG 6 249 47   %s信息内容%d
SENDMSG 7 249 47   %s信息内容%d
==================================================


关闭或显示脚本命令提示没有戴指定物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符
??????
SETSHOWITEMMSG (0关闭，1显示)
用来关闭或显示，有的脚本命令会提示“你身上没有戴指定物品！！！


获取文本字符

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符
??????
GetRandomText 文件路径 变量


扩展MessageBox

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符
??????
MessageBox 信息 @确定 @取消
[@main]
#if
#act
MessageBox 是否确认要删除 @确定 @取消
[@确定]
点击的确定
[@取消]
点击的取消


清除SendCenterMsg DelayGoto

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符
??????
[@main]
#act
CLEARDELAYGOTO
sendmsg 6 DELAYGOTO延迟时清除
??????
[@main]
#act
CLEARDELAYGOTO 1
sendmsg 6 SendCenterMsg倒计时清除


人物聊天文字变色

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：改变人物公聊时的文字信息颜色.

命令格式

??????
ChangeHearMsgColor 时间(分钟) 颜色(0-255)
??????
;人物说话信息蓝色显示
[@main]
#IF
#ACT
ChangeHearMsgColor 10 180


显示倒计时信息提示

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符
??????
功能:
显示倒计时信息提示
格式:
SENDDELAYMSG信息内容 时间(秒) 字体颜色 换地图是否删除 跳转字段
??????
[@测试]
#if
#act
SENDDELAYMSG 你的礼物在%s后到达 300 255 0 @给礼物

[@给礼物]
#ACT
GIVE 布衣(男)
------------------------------------------
300秒倒计时结束后会执会当前脚本文件里的[@给礼物]段


显示验证码窗口

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

命令格式

??????
SHOWGAMEVALIDATEDLG 模式(0自己 1当前地图 2全服人物) 自定义验证码(该参数可以为空，如果为空时，会自动生成验证码)
??????
[@显示随机验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0

[@显示自定义验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0 123456
SENGMSG 6 验证码窗口会显示123456，不超过6个字符


字符串替换

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能

字符串替换

命令格式

??????
ANSIREPLACETEXT 字符串变量 旧字符串 新字符串
??????
;==========================================
;==========================================
;把www.ETmir2.com替换成www.qq.com
[@main]
#IF
#ACT
mov S1 www.ETmir2.com
ANSIREPLACETEXT <$STR(S1)> ETmir2 qq
SENDMSG 6 <$STR(S1)>


创建目录

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：创建新目录.

命令格式

??????
ForceDirectories 目录
??????
#IF
#ACT
ForceDirectories \QuestDiary\新目录\


读取文本内容到变量

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：读取文本文件中的内容到变量中.

命令格式

??????
GetListString 文件路径 行号(行号从0开始) 变量1 变量2

说明：变量2可以不需要,当读取变量2时文本单行的内容必须是以下格式:

人物1:10
人物2:20

脚本示例

??????
[@main]
#IF
#ACT
GetListString ..\QuestDiary\测试.txt 5 A10 N10


给字符串增加空格

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：给字符串在前面或者后面增加指定个数的空格.

命令格式

??????
SetStringBlank 变量(S,A) 长度(1-100) 格式(0, 1)?

说明：可支持人物S变量或者全局A变量,格式0=前面,1=后面

注意：第二个参数长度是指增加空格后整个字符串的长度,例如字符ETmir2引擎长度是13,

如果第二个参数设置1 那么实际增加7个空格.

注意：英文字母和数字占用1个字节(长度),汉字占用2个字节(长度).

脚本示例

??????
[@Test]
#IF
#ACT
MOV S10 ETmir2引擎
SetStringBlank <$STR(S10)> 20 0
SendMsg 5 <$STR(S10)>
??????
MOV S10 ETmir2引擎
SetStringBlank <$STR(S10)> 20 1
SendMsg 5 <$STR(S10)>


建立一个文本文件

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

在指定位置建立一个文本文件.

注意：文件保存在 \Envir目录中.

??????
#IF
#ACT
CreateFile ..\QuestDiary\NewFile.txt
#SAY
在Envir\QuestDiary目录中建立了一个文件.


取得随机字符串

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：从文件中随机获取一行字符串

命令格式

??????
GetRandomText 文件路径 变量(S0--S99) 指定行(0-10000)

说明

没有指定行时随机取某一行的字符串.
例如:随机取一行字符串到S10中.

??????
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10
SendMsg 5 取出的字符串是:<$STR(S10)>
例如:取特定行的字符串.
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10 5
SendMsg 5 取出的字符串是:<$STR(S10)>


取字符串在列表中的位置

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：取字符串在列表中的下标.

命令格式

??????
GetStringPos 路径 字符串

说明：返回值放在人物的N0变量中,如果值=9999999说明没有找到.

其他：返回值可以通过EQUAL做条件检测

??????
[@main]
#IF
#ACT
GetStringPos ..\QuestDiary\测试.txt 管理员
SendMsg 5 字符串在列表中的位置:<$STR(N0)>


随机验证码

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

随机输入验证码

??????
[@Main]
#If
CheckLevelEx > 0
#Act
SetRandomNo
#Say
<输入验证码/@@CheckNo>:<$RANDOMNO>
??????
[@@CheckNo]
#If
CheckRandomNo
#SAY
输入正确.
#ELSESAY
输入不正确.


写入指定文本文件

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能：把字符串写入到指定的文本文件中,可以指定写入行.

命令格式

??????
AddTextListEx 路径 字符串 行(0-65535)
??????
#IF
#ACT
AddTextListEx ..\TestList.txt <$USERNAME> 0


自定义颜色文字发送

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

功能说明: 发送自定义颜色的文字信息.

命令格式

??????
GuildNoticeMsg 255 233 发送自定义颜色的文字信息. Self
参数一是前景颜色,参数二是背景颜色,参数三是要发送的文字信息,参数四等于'Self'时只发送给自己, 等于'Group'时发送给组队, 等于'National'时发送给自己国家的人(使用于国战), 等于'Map'时发送到当前地图中的人物.如果省略参数四表示全服发送.
支持的参数: %s(玩家名字) %d(NPC名字) %m(地图名字) %x%y(坐标)
??????
<$KILLER>杀死人物的名字 <$MONKILLER>杀死怪物的名字


聊天框彩色字体设置

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

聊天框彩色字体设置[!]

{信息|F:B:M}
F=字体颜色 B=背景颜色 M=模式(0绘制背景色,1字体描边)

例:
[@main]
#ACT
SENDMSG 5 {<$USERNAME>|254:253}ETmir2引擎官方网站：http://www.ETmir2.com
SENDMSG 5 {<$USERNAME>|250:0:1}ETmir2引擎官方网站：http://www.ETmir2.com
SENDTOPCHATBOARDMSG 0 149 235 30 {<$USERNAME>|250:0}ETmir2引擎官方网站：http://www.ETmir2.com

-----------------------------------------------------------------------------------------------
爆物品彩色字体设置
String.ini文件里

DropItemHint=物品[{%Item|52:253:0}]从[{%name|180:253:0}]身上掉落在地图{%Map(%x,%y)|5:253:0}处。


装备套装备注

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

装备套装备注

功能：装备套装备注
格式：装备名称=颜色(0~255)/备注描述1\备注描述2\

物品备注：M2-查看-列表信息二-物品备注里进行编辑

套装备注：M2-查看-列表信息二-套装系统-套装备注里进行编辑

物品备注：

宝藏钥匙=250/可用来开启卧龙山庄中的“神秘宝藏”\253/直接获得其中的宝物

套装备注：

颜色(0~255)/套装名字|装备数量|颜色(0~255)/装备名称:颜色(0~255)/属性描述

例1. 223/套装名称|2|116/木剑|116/青铜头盔:253/攻魔道提升
例2. 223/套装名称=0|2|116/木剑|116/龙天魔甲:253/攻魔道提升
例3. 223/套装名称=1|2|116/木剑|116/凤天魔衣:253/攻魔道提升
例4. 223/套装名称|2|116/木剑|116/(龙天魔甲,凤天魔衣):253/攻魔道提升

例1 不检测性别
例2 男性套装
例3 女性套装
例4 根据鼠标选择的装备自动显示男女

“\”表示换行 “/”颜色分隔符 “|”套装的分隔符 “:”套装装备名称和属性之间的分隔符 “-”表示分割线

--------------------------物品备注和套装备注支持显示图片----------------------------
物品图片显示:
格式：<LOOKS:L:T:X:Y:Z>
L表示物品DB的Looks值
T0表示包裹物品图片 1表示地面物品图片
XY 表示微调坐标
Z0表示不显示背景 1表示显示背景

任意图片显示:
格式：<Img:N:F:X:Y>
N表示播放开始图片
F表示WIL文件序号
X,Y表示微调坐标

动态图片播放:
格式: <PlayImg:F:N:C:T:X:Y:M>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制 2普通绘制带偏移

物品备注例子：

布衣(男)=251/备注描述3\250/备注描述4\
金戒指=-\251/备注描述/250/备注描述/252/备注描述\<PlayImg:32:2070:10:300:0:0:0>
圣战戒指=-\251/备注描述/250/备注描述/252/备注描述\251/备注描述<PlayImg:38:970:10:100:0:0:1>
怒斩=251/备注描述3\250/备注描述4\<Img:991:38>\<PlayImg:38:970:10:100:0:0:1>
斗笠=251/备注描述3\250/备注描述4\<PlayImg:38:970:10:100:0:0:1><looks:344:0:0:0:1>

套装备注例子：

255/布衣套装|2|116/木剑|116/青铜头盔:<looks:344:0:0:0:1><looks:344:0:0:0:1>253/攻魔道提升\<PlayImg:38:970:10:100:0:0:1>


自定义输入

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 文本字符

自定义输入

@@InPutString 用法 @InPutInteger 类似

22要和后面的变量一样<$STR(S22)>

举例说明：

[@main]
<请输入充值卡卡号/@@InPutString22>\

[@InPutString22]
#IF
CHECKTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是检测你输入的卡号和50000.txt这里面的某行卡号是否相同
#ACT
DELTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是将你输入的那行卡号在50000.txt这个文档里删除掉
GAMEGOLD + 50000
SENDMSG 7 充值成功：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>
SENDMOVEMSG 0 251 249 350 1 [『<$USERNAME>』使用在线充值卡--充值成功：增加[50000元宝]，感谢您的支持希望您玩的开心:-)]
GOTO @充值元宝
#ELSEACT
SENDMSG 7 您输入的卡号不正确或已被他人使用，请重新输入！
GOTO @充值元宝

[@main]

支持自定义对话框标题，弹出来的对话框上面显示的信息，括号里的信息就是对话框上显示的信息
<请输入充值卡卡号/@@InPutString22(请输入充值卡卡号：)>\

[@InPutString22]
#IF
CHECKTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是检测你输入的卡号和50000.txt这里面的某行卡号是否相同
#ACT
DELTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是将你输入的那行卡号在50000.txt这个文档里删除掉
GAMEGOLD + 50000
SENDMSG 7 充值成功：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>
SENDMOVEMSG 0 251 249 350 1 [『<$USERNAME>』使用在线充值卡--充值成功：增加[50000元宝]，感谢您的支持希望您玩的开心:-)]
GOTO @充值元宝
#ELSEACT
SENDMSG 7 您输入的卡号不正确或已被他人使用，请重新输入！
GOTO @充值元宝


开启宝宝Ctrl+Q键锁定怪物

项目：ET引擎说明书　分类：ET引擎脚本文档 / 宝宝相关


ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 宝宝相关

拓展宝宝继承人物爆率

项目：ET引擎说明书　分类：ET引擎脚本文档 / 宝宝相关


宝宝切割命令

项目：ET引擎说明书　分类：ET引擎脚本文档 / 宝宝相关

宝宝百分比切割

BDelMonHp

请在[@宝宝物理攻击]、[@宝宝魔法攻击]里使用,其他地方使用有可能会导致引擎出错，详情【触发脚本类】-【开启宝宝攻击触发】

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2::以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0都切割 1:本次切割只切割角色 2:本次切割只切割英雄 3:本次切割只切割怪物

参数5=分母基数(<=100等于100)

参数6=是否播放切割动画(空或0不播放,1播放)

??????
例子1：
#ACT
；本次切割只切割怪物10点HP
BDELMONHP 10 1 0 3

例子2：

#ACT
；本次切割只切割人物当前血量百分之8
BDELMONHP 8 0 0 1

例子3：

#ACT
；本次切割只切割人物当前血量千分之8
BDELMONHP 8 0 0 1 1000

宝宝范围百分比切割

BDelMonHpEx

请在[@宝宝物理攻击]、[@宝宝魔法攻击]里使用,其他地方使用有可能会导致引擎出错，详情【触发脚本类】-【开启宝宝攻击触发】

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2:以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0以自身范围 1以攻击目标范围

参数5=X坐标

参数6=Y坐标

参数7=范围

参数8=0都切割 1:本次切割只切割角色，2:本体切割只切割英雄，3:本次切割只切割怪物。

参数9=分母基数(<=100等于100)

参数10=是否播放切割动画(空或0不播放,1播放)

参数11=判断怪物等级(运算符 < > =. =0不判断，其他数值的话。怪物等级接按照运算符参数进行切割)

??????
例子1：
#ACT

;切割自身1格坐标范围的怪物10/100 HP
BDELMONHPEX 10 2 0 0 <$BATTACKMONSTER_X>  <$BATTACKMONSTER_Y>  1 3

例子2：
#ACT

;切割自身1格坐标范围的怪物10/1000 HP
BDELMONHPEX 10 2 0 0 <$BATTACKMONSTER_X>  <$BATTACKMONSTER_Y>  1 3 1000 0 >50


宝宝范围百分比切割

项目：ET引擎说明书　分类：ET引擎脚本文档 / 宝宝相关

宝宝范围百分比切割

BDelMonHpEx

请在[@宝宝物理攻击]、[@宝宝魔法攻击]里使用,其他地方使用有可能会导致引擎出错，详情【触发脚本类】-【开启宝宝攻击触发】

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2:以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0以自身范围 1以攻击目标范围

参数5=X坐标

参数6=Y坐标

参数7=范围

参数8=0都切割 1:本次切割只切割角色，2:本体切割只切割英雄，3:本次切割只切割怪物。

参数9=分母基数(<=100等于100)

参数10=是否播放切割动画(空或0不播放,1播放)

参数11=判断怪物等级(运算符 < > =. =0不判断，其他数值的话。怪物等级接按照运算符参数进行切割)

??????
例子1：
#ACT

;切割自身1格坐标范围的怪物10/100 HP
BDELMONHPEX 10 2 0 0 <$BATTACKMONSTER_X>  <$BATTACKMONSTER_Y>  1 3

例子2：
#ACT

;切割自身1格坐标范围的怪物10/1000 HP
BDELMONHPEX 10 2 0 0 <$BATTACKMONSTER_X>  <$BATTACKMONSTER_Y>  1 3 1000 0 >50


宝宝改变目标状态

项目：ET引擎说明书　分类：ET引擎脚本文档 / 宝宝相关

请在[@宝宝物理攻击]、[@宝宝魔法攻击]里使用，详情【触发脚本类】-【开启宝宝攻击触发】

格式: BMAKEPOSION 类型(0-5,0和1是绿毒和红毒 5是麻痹 12冰冻 13蛛网 其他无效) 时间(秒) 威力

??????
[@宝宝物理攻击]
#act
BMAKEPOSION 5 5 888
sendmsg 6 怪物名称:<$BATTACKMONSTER_NAME> ，当前宝宝攻击目标血值:	<$BATTACKMONSTER_HP> 当前宝宝攻击目标最大血值:<$BATTACKMONSTER_MAX_HP>


脚本命令调整宝宝属性

项目：ET引擎说明书　分类：ET引擎脚本文档 / 宝宝相关

ETChangeSlaveAbility

修改宝宝属性

??????
ETChangeSlaveAbility
//参数1:属性类型 0=HP,1=MaxHP,2=MP,3=MaxMP,4=AC1,5=AC2,6=MAC1,7=MAC2,8=DC1,9=DC2,10=MC1,11=MC2,12=SC1,13=SC2,14=移速,15=攻速,16=外观,17=准确,18=敏捷,19=等级,20=体力恢复,21=行动步伐,22=宝宝等级
//参数2:数值
//参数3:宝宝名 ALL代表所有宝宝 -1代表上一个召唤宝宝
//参数4:修改前是否还原所有修改（0不还原，可以设置叠加，1为还原所有修改，属性类型0~21通通还原）
//参数5:可为空 为1时 百分比模式

1、修改叠加HP的例子

??????
ETChangeSlaveAbility 0 10000 ALL 0
ETChangeSlaveAbility 1 10000 ALL 0
ETChangeSlaveAbility 0 10000 ALL 0
ETChangeSlaveAbility 1 10000 ALL 0
;这样执行，宝宝当前HP和最大HP增加了20000

2、修改宝宝指定HP，不进行叠加

??????
ETChangeSlaveAbility 0 10000 ALL 1
ETChangeSlaveAbility 1 10000 ALL 0
ETChangeSlaveAbility 0 10000 ALL 1
ETChangeSlaveAbility 1 10000 ALL 0
;这样执行，宝宝当前HP和最大HP只增加了10000，注意参数4的运用，如果每次都是1，上面执行的修改可能就被还原！

注意：参数15宝宝攻速最小数值为50


宝宝升级触发及宝宝死亡触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 宝宝相关

宝宝升级触发

开启方法:引擎功能扩展 - 功能扩展三 - 开启对应选项并保存生效

??????
[@OnSlaveLevel]
#Act
sendmsg 7 宝宝<$CURRRTARGETNAME>升级了！

宝宝死亡触发

开启方法:引擎功能扩展 - 功能扩展三 - 开启对应选项并保存生效

??????
[@OnSlaveDie]
#Act
sendmsg 7 宝宝<$CURRRTARGETNAME>死亡了！


调整宝宝等级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 宝宝相关

功能：直接调整人物宝宝的等级

命令格式

??????
ChangeSlaveLevel 名字 操作符(+ = -) 等级(1-7)

脚本示例

把虎卫的等级调整到7级.

??????
#IF
#ACT
ChangeSlaveLevel 虎卫 = 7


杀死宝宝

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 宝宝相关

功能

将自己的宝宝全部杀死。

命令格式

??????
;==========================================
[@killslave]
#IF
#ACT
KILLSLAVE
#say
你的宝宝清理干净了。
;==========================================


召唤指定怪物为宝宝

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 宝宝相关

功能

脚本召唤宝宝。

命令格式

??????
RECALLMOB 怪物名称 宝宝等级(最高为 7) 叛变时间(分钟) 是否自动变色（0、1）固定颜色（1-7）
攻击力受自动变色颜色不同而不同
固定颜色攻击力受指定颜色不同而不同

注：如设固定颜色，自动变色参数必须设置为0

??????
;==========================================
;召唤最多5个七宝宝，30分钟后叛变,七彩变色
[@recallmob]
#IF
CHECKSLAVECOUNT < 5
#ACT
RECALLMOB 神兽 7 30 1
#SAY
好好看着自己的宝宝，不要乱咬人。
#ELSESAY
你已经有5个或以上的宝宝，现在不可以再召宝宝。
;==========================================


宝宝立即叛变

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 宝宝相关

功能

指定宝宝立即叛变的脚本命令

命令格式

??????
GetCallMob 宝宝名字
??????
#act
GETCALLMOB 神兽
#say
你的神兽已经叛变


改变宝宝名字颜色

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 宝宝相关

功能：改变人物宝宝名字颜色.

命令格式

??????
ChangeSlaveNameColor 宝宝名字 颜色(0-255)


杀死人物的宝宝

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 宝宝相关

说明：把自己的宝宝杀死.

命令格式

??????
KillCallMob 名字 数量 方式(0杀死会触发脚本 1直接消失不会触发脚本)
??????
#IF
#ACT
KILLCALLMOB 神兽
#SAY
你的神兽已经死亡.
#IF
#ACT
KILLCALLMOB 白野猪 2


召唤自己的分身

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 宝宝相关

脚本示例

??????
召唤自己的分身帮助自己作战3个小时.
??????
#IF
#ACT
RecallSelf 3


拓展客户端支持显示网络延迟

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展


拓展GM命令制造物品带物品来源

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展

功能：

GM命令制造出物品，指定物品来源，制造物品命令在插件中可修改

命令(在游戏聊天框中输入，注意每个参数中间只能有1个空格)：

@ETMakeEx 参数1 参数2 参数3 参数4 参数5 参数6

参数详解：

参数1:装备名称
参数2:来源类型 2=自定义来源 4=杀怪掉落
参数3:地图名
参数4:怪物名/来源名
参数5:角色名称(省略或使用%s时获取当前人物名)
参数6:来源时间(省略或使用%s时获取当前时间)

例：

??????
制造怪物来源的物品(指定所有参数):
@ETMakeEx 裁决之杖 4 死亡棺材 暗之触龙神 龙在天下 2010-01-01 00:00:01

制造怪物来源的物品(部分参数自动获取):
@ETMakeEx 裁决之杖 4 死亡棺材 暗之触龙神 %s %s

制造自定义来源的物品(指定所有参数):
@ETMakeEx 裁决之杖 2 盟重省 土城酷跑活动 龙在天下 2010-01-01 00:00:01

制造自定义来源的物品(部分参数自动获取):
@ETMakeEx 裁决之杖 2 盟重省 土城酷跑活动 %s %s


拓展攻击不卡。移动不卡，魔法不卡功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展


拓展行会人员管理功能

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展

用法和多开数量控制基本一致


拓展脚本命令SetNewItemValue支持到255%,并突破限制

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展

需按照图片中的设置开启后，才能拓展突破！


拓展脚本命令ChangeHumAbility命令(1~10),支持到21亿属性

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展

需按照图片中的设置开启后，才能拓展突破！


ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 功能拓展

拓展商城上架物品限制

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展


拓展锁定光环或箭头指示

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展


ET引擎说明书首页
首页 > ET引擎说明书 > ET引擎脚本文档 > 功能拓展

拓展禁止走位捡物

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展


装备属性对比

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展

装备属性对比

常见问题，勾选后有的不显示装备对比箭头。

解决方法：

1：删除微端客户端补丁目录里的GameSoure.pak文件
2：pak.txt里面补丁密码也删除，只集成到登录器即可。


新摆摊触发

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展

【引擎功能扩展 - 脚本触发和功能扩展(三) - 开启新摆摊触发】

功能说明：个人商店物品上架触发、下架触发、停止个人商店物品上架、停止个人商店物品下架

QF触发：
个人商店上架物品到出售：@ETBeginShopItemUp
个人商店从出售下架物品：@ETBeginShopItemDown

变量：个人商店名称：<$ETUserShopName>

NPC命令：停止个人商店物品上架/下架 ETStopShopItem

;例子

??????
[@ETBeginShopItemUp]
#act
ETStopShopItem
SENDMSG 7 禁止上架物品到商铺<$ETUserShopName>，物品数据库名：<$ETCURITEMNAME>；物品名：<$ETG_CURITEMNAME>；
ID：<$ETCurItemMakeIndex>；售价：<$ETCurItemPrices><$ETCurItemMoneyType>(货币类型值：<$ETCurItemMoneyTypeValue>)

[@ETBeginShopItemDown]
#act
ETStopShopItem
SENDMSG 7 禁止商铺下架物品：<$ETUserShopName>，物品数据库名：<$ETCURITEMNAME>；物品名：<$ETG_CURITEMNAME>；
ID：<$ETCurItemMakeIndex>；售价：<$ETCurItemPrices><$ETCurItemMoneyType>(货币类型值：<$ETCurItemMoneyTypeValue>)

;————————————————————————仿HERO摆摊物品上架前触发————-变量与个人商店的一致，只是触发标签不同———————————————-

??????
[@ETBeginHeroM2ItemUp]
#act
ETStopShopItem
SENDMSG 7 禁止上架物品到摊位，物品数据库名：<$ETCURITEMNAME>；物品名：<$ETG_CURITEMNAME>；
ID：<$ETCurItemMakeIndex>；售价：<$ETCurItemPrices><$ETCurItemMoneyType>；(货币类型值：<$ETCurItemMoneyTypeValue>)


新施毒系统配套脚本

项目：ET引擎说明书　分类：ET引擎脚本文档 / 功能拓展

【引擎功能扩展 - 脚本触发和功能扩展(三) - 开启新释毒系统】

命令 ETCHANGEPOSION

参数位置 | 参数说明
参数1 | 0绿毒 1红毒 2全毒
参数2 | 0毒伤威力 1防御毒伤
参数3 | 数值1
参数4 | 数值2 (数值2留空则为固定伤害，固定伤害值=数值1)

例1：ETCHANGEPOSION 0 0 100 绿毒伤害增加100如原毒伤害=10，最终则为10+100=110
例2：ETCHANGEPOSION 0 0 80 100 绿毒伤害增加80%如原毒伤害=10，最终则为10+10*80%=18 80是分子，100是分母，如果要设置2倍，应该填200 100

注意：叠加和固定伤害可以同时存在，清除命令请使用??ETCHANGEPOSION -1

??????
[@main]
<设置绿毒威力+100/@1>  <设置绿毒威力+100%/@11>\
<设置红毒威力+100/@2>  <设置红毒威力+100%/@22>\

<设置绿毒防御+100/@_1>  <设置绿毒防御+100%/@_11>\
<设置红毒防御+100/@_2>  <设置红毒防御+100%/@_22>\

[@1]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 0 0 100
sendmsg 7 绿毒伤害+100.

[@11]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 0 0 100 100
sendmsg 7 绿毒伤害+100%

[@2]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 1 0 100
sendmsg 7 红毒伤害+100.

[@22]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 1 0 100 100
sendmsg 7 红毒伤害+100%

[@_1]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 0 1 100
sendmsg 7 绿毒防御+100.

[@_11]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 0 1 100 100
sendmsg 7 绿毒防御+100%

[@_2]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 1 1 100
sendmsg 7 红毒防御+100.

[@_22]
#act
ETCHANGEPOSION -1
;清除所有新毒参数

ETCHANGEPOSION 1 1 100 100
sendmsg 7 红毒防御+100%


播放网络MP3

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

说明：播放网络上的MP3文件,或者本地MP3文件.

命令格式

??????
PlayMP3 http://http://www.etmir2.com/123.mp3

注意：如果是本地文件会自动搜索客户端Music目录中同名文件.

??????
[@main]
#IF
#ACT
PlayMusic 100.MP3

相关命令页面

  • http://www.etmir2.com/


播放音乐

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

命令格式

??????
playsound 文件位置 循环次数 播放模式(0播放给自己,1播放给全服,2播放给同一地图,,4播放给同屏人物)
??????
[@main]
#ACT
PLAYSOUND Wav\1.wav 1 0


穿人模式

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：改变当前人物的穿人,穿怪模式.

命令格式

??????
THROUGHHUM 模式 时间(秒)
模式: [-1=恢复/0=穿人穿怪/1=穿怪/2=穿人]
??????
#IF
#ACT
ThroughHum 1 60
SendMsg 5 60秒之内可随意穿怪.


打开个人商店脚本命令

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展
??????
OpenShopDlg 类型(0所有商店列表 1我的商店列表)
??????
[@main]
#ACT
OpenShopDlg 0


打开商铺脚本命令

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展
??????
OpenSndaShopDlg
??????
[@main]
#ACT
OpenSndaShopDlg


个人定时器

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

个人定时器。

命令格式

??????
SETONTIMER 定时器索引(0-255) 定时间隔（单位为秒）
SETOFFTIMER 定时器索引(0-255) //停止定时器
??????
;==========================================
设置定时器
[@Test]
#IF
#ACT
SetOnTimer 0 20
??????
QManage.txt:
[@OnTimer0]
#ACT
SendMsg 5 你目前位于%m的(%x：%y)
;==========================================
??????
;==========================================
停止定时器
[@Test]
#IF
#ACT
SetOffTimer 0
;==========================================


假人自动练功

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：假人自动练功

命令格式

??????
AutoUseMagic 技能ID 间隔秒。(必须是学过的技能，在非挂机状态，没有攻击目标的情况下才能正常练功)
??????
[@main]
#ACT
AutoUseMagic 0 10


假人自动锁定目标

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展
??????
[@假人自动锁定目标]
#ACT
DUMMYAUTOTARGET 1
;假人使用这个命令后，搜索到攻击目标后，会自动锁定该目标
;DUMMYAUTOTARGET 参数(0关闭自动锁定,1开启自动锁定)


屏幕震动

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

屏幕震动 M2-选项-客户端设置-内挂控制-勾选屏幕震动才能生效。内挂里也要勾选屏幕震动才能生效

屏幕震动命令格式:

??????
SCENEVIBRATION 模式(0~4，0仅自己，1在线所有人，2屏幕范围内人物，3.当前地图上所有人 4.指定地图上所有人) 震级(1~3) 次数 地图ID(模式等于4时，需要该参数)
??????
[@main]
#IF
#ACT
SCENEVIBRATION 0 1 1
SENDMSG 6 你的屏幕开始震动
??????
[@main]
#IF
#ACT
SCENEVIBRATION 1 1 1
SENDMSG 6 在线所有人的屏幕开始震动
??????
[@main]
#IF
#ACT
SCENEVIBRATION 2 1 1
SENDMSG 6 当前屏幕范围内的所有人的屏幕开始震动
??????
[@main]
#IF
#ACT
SCENEVIBRATION 3 1 1
SENDMSG 6 当前地图所有人的屏幕开始震动
??????
[@main]
#IF
#ACT
SCENEVIBRATION 4 1 1 3
SENDMSG 6 土城所有人的屏幕开始震动


人物小退

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展
??????
[@小退]
#ACT
LOGOUT


特修装备

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

特修装备,在物品规则列表中限制物品的不会被修理

命令格式

??????
RepairAll
该命令是检测命令，会自动扣除金币。
如果无法修理：
1.金币不够
2.需要修理的物品设置不允许修理的物品规则
3.该NPC文件头没有加上允许修理的代码.例如修理衣服需要加上 +10 +11
??????
ActRepairAll

该命令是操作命令，不会扣金币

??????
[@Test]
#IF
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.
#IF
#ACT
ACTREPAIRALL
#SAY
你的装备修好了.


新的装备改名

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：新的装备改名

命令格式

??????
ChangeItemName 物品位置(0-16) 名字
物品位置:
??????
;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================
??????
#IF
#ACT
ChangeItemName 1 新名字


一键回收包裹物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

一键回收包裹物品的脚本命令

命令格式

??????
TakeBagItem 物品名称(支持多个物品) 收取数量 每个物品增加元宝值 每个物品增加金币值 每个物品增加泡点值 每个物品增加泡点经验值 变量(保存实际回收的物品数量) 聚灵珠经验(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验)
??????
[@main]
#ACT
TakeBagItem 木剑|布衣(男)|布衣(女) 46 0 0 0 10000 N1 0
SENDMSG 6 成功回收<$STR(N1)>个木剑，布衣(男)，布衣(女)，价格为10000经验


在登陆器里浏览网页

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

浏览网页

命令格式

??????
WebBrowser 地址
??????
;==========================================
[@WebBrowsertest]
#IF
#ACT
WebBrowser http://www.ETmir2.com
;==========================================

相关命令页面

  • http://www.ETmir2.com


在线命令弹出菜单功能

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

玩家在线输入指定命令弹出菜单脚本功能

命令格式

??????
命令为command.ini内（命令名称随便定义）：MemberFunc=我是会员
输入@我是会员 命令后将运行登录脚本(Qmanage.txt)内[@Member]段内容脚本
具体脚本内容自己写。


在线泡经验

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

在线泡经验（直接得到经验）

命令格式

??????
例：（等级30级以上，地图3安全区内每1秒种得到10个经验点）
??????
==================================================
#IF
CheckLevelex > 30
#ACT
setautogetexp 1 10 1 3
命令 时间 经验 是否安全区（0为任何地方） 地图号（任何地图使用*号） 聚灵珠是否能获取经验(0=不可以 1=可以)
==================================================


装备名称自定义系统

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

装备名称自定义系统

命令格式

??????
例脚本：
(@@useitemname)
[@main]
请选择要改名的装备：(将要改名的装备戴身上)\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
◇◇◇『<盔 甲/@@useitemname0>』◇◇◇『<武 器/@@useitemname1>』◇◇◇\
◇◇◇『<项 链/@@useitemname3>』◇◇◇『<头 盔/@@useitemname4>』◇◇◇\
◇◇◇『<左手镯/@@useitemname5>』◇◇◇『<右手镯/@@useitemname6>』◇◇◇\
◇◇◇『<左戒指/@@useitemname8>』◇◇◇『<右戒指/@@useitemname7>』◇◇◇\
◇◇◇『<勋 章/@@useitemname2>』\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
〖<返回/@main>〗 〖<关闭/@exit>〗
[@@useitemname0]
#ACT
goto @ChangeName
[@@useitemname1]
#ACT
goto @ChangeName
[@@useitemname2]
#ACT
goto @ChangeName
[@@useitemname3]
#ACT
goto @ChangeName
[@@useitemname4]
#ACT
goto @ChangeName
[@@useitemname5]
#ACT
goto @ChangeName
[@@useitemname6]
#ACT
goto @ChangeName
[@@useitemname7]
#ACT
goto @ChangeName
[@@useitemname8]
#ACT
goto @ChangeName
[@@useitemname9]
#ACT
goto @ChangeName
[@@useitemname10]
#ACT
goto @ChangeName
[@@useitemname11]
#ACT
goto @ChangeName
[@@useitemname12]
#ACT
goto @ChangeName
[@ChangeName]
#if
checkgamegold > 0
#act
gamegold - 1
SETSCRIPTFLAG 1 1
sendmsg 7 改名成功！！！
Close
#elseact
sendmsg 7 没钱跑来做什么？


装备属性升级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

装备升级

装备升级功能可以指定升级物品及属性，按指定机率得到结果。
需要升级的装备物品必须放在身上。
命令格式

??????
UPGRADEITEMEX 物品位置(0-12) 属性位置(0-14) 成功机率(0-100) 点数机率(0-255) 是否破碎(0,1)

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

属性位置:
不同类型的物品属性位置不一样，以后补充这些资料，自行可以进行测试得到。

成功机率:
升级成功机率，数字越大机率越小。

点数机率:
升级成功后得到的点数，数值在 0 -255之间。

是否破碎:
升级失败后装备是否破碎，数值为0或1，1为失败后破碎。

属性位置详解

重要注意事项，请在使用本功能前务必详细阅读，否则将有可能带来严重后果
当所需要升级的项链、手镯、戒指、在DB数据库中因 StdMode值的不同，而升级
出来得到的结果也不同，所以使用者请按照以下属性变化列表进行详细设置！
其中涉及的体力恢复、魔法恢复、毒物躲避、中毒恢复、如升级成功“1”点属性，则表示为 10%

项链属性：
当StdMode值为19时：属性位置“0”升级出来表现为“魔法躲避”、属性位置“1”升级出来属性表现为“幸运”
当StdMode值为20时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为21时：属性位置“0”升级出来表现为“体力恢复”、属性位置“1”升级出来属性表现为“魔法恢复”

手镯属性：
当StdMode值为24时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为26时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”

戒指属性：
当StdMode值为22时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”
当StdMode值为23时：属性位置“0”升级出来表现为“毒物躲避”、属性位置“1”升级出来属性表现为“中毒恢复”

盔甲

值/位置 | 说明
0 | 防御
1 | 魔御
2 | 攻击
3 | 魔法
4 | 道术
5-13 | 无效果
14 | 持久

武器

值/位置 | 说明
0 | DC2
1 | MC2
2 | SC2
3 | 幸运
4 | 诅咒
5 | 准确
6 | 攻击速度
7 | 强度
8-9 | 暂不知道
10 | 需开封
11-13 | 暂不知道
14 | 持久

头盔

值/位置 | 说明
0 | 防御
1 | 魔御
2 | 攻击
3 | 魔法
4 | 道术
5 | 佩带需求
6 | 佩带级别
7-13 | 无效果
14 | 持久

项链

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8 | reserved
9-13 | 暂不知道
14 | 持久

手镯

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8-13 | 无效果
14 | 持久

戒指

值/位置 | 说明
0 | AC2
1 | MAC2
2 | DC2
3 | MC2
4 | SC2
6 | 佩带需求
7 | 佩带级别
8-13 | 无效果
14 | 持久


自定义采集

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

采集功能格式:

??????
SHOWPROGRESSBARDLG 时间(秒) 触发字段 提示信息 有动作是否中断(0不中断,1中断) 中断触发字段

使用示例：

??????
[@Main]
#ACT
SHOWPROGRESSBARDLG 5 @采集完成 正在采集,进度%d%... 1 @采集中断
Break

QF触发

[@采集完成]
#ACT
Give 回城卷 1
SendMsg 5 你采集一个回城卷
Break
[@采集中断]
#ACT
SendMsg 5 采集被中断
Break


自动穿取装备

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

自动穿取装备。

命令格式

??????
穿装备 TakeOnItem 装备名称 位置(0-16)
脱装备 TakeOffItem 位置(0-16)
??????
;==========================================
物品位置:
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================
;==========================================
;穿装备
[@TakeOnItem]
#IF
#ACT
TakeOnItem 天魔神甲 0
#SAY
已经帮你穿上衣服了。
;==========================================
;==========================================
;脱装备
[@TakeOffItem]
#IF
#ACT
TakeOffItem 0
#SAY
已经帮你把衣服脱下来了。
;==========================================


自动穿装备和取装备

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

自动穿装备和取装备.新人出生就无需手动穿装备了.

脚本示例

??????
;自动穿装备
AutoTakeOnItem 装备名称 位置(0-16)
??????
;自动脱装备
AutoTakeOffItem 位置(0-16)

物品位置:

??????
;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================


自动行走

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能

自动行走 AUTOGOTOXY 地图名称 X坐标 Y坐标

脚本示例

??????
[@Test]
#IF
#ACT
AUTOGOTOXY 3 330 330


自动寻路

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：自动移动到指定坐标,专用登录器.

命令格式

??????
GotoNow X Y

脚本示例

??????
在盟重时自动移动到330 330
??????
#IF
IsOnMap 3
#ACT
GotoNow 330 330


不允许宝石升级

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：当前宝石升级装备失败

命令格式

??????
SetUpgradeFail

说明

此命令只能在QFunction中的@ItemUpgrade下执行.

??????
[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break


拆解物品

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：可简单实现物品拆解,升级,回收等功能.

命令格式

??????
OpenItemBoxEx 标号(1-1000) 是否回收(0,1) 提示信息

说明：标号代表要执行的脚本编号,提示信息是登录器显示的简单提示.

放入的物品名字保存在人物的S0变量中.
放入的物品的持久放在人物的N0变量中.

注意：脚本文件头必须加入@ReclaimItem

N0中保存的持久1000=游戏中1点持久,20000=20点持久.

相关检测脚本命令:EQUAL?CheckTextList
例如:实现装备拆解功能.

(@ReclaimItem )

??????
[@main]
是否要把圣战戒指拆解为3个力量戒指.\
是否要把天尊戒指拆解为3个泰坦戒指.\
是否要把法神戒指拆解为3个紫碧螺戒指.\
<开始拆解/@拆解_戒指>
??????
[@拆解_戒指]
#IF
#ACT
OpenItemBoxEx 1 1 拆解戒指类物品

Q-Function.txt中脚本:

??????
[@GetBoxItem1]
#IF
EQUAL S0 圣战戒指
#ACT
Give 力量戒指 3
Break
??????
#IF
EQUAL S0 天尊戒指
#ACT
Give 泰坦戒指 3
Break
??????
#IF
EQUAL S0 法神戒指
#ACT
Give 紫碧螺 3
#ELSEACT
ReclaimItem
#ELSESAY
请放入<圣战戒指> <天尊戒指> <法神戒指>


打开网站地址

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：游戏中打开网站.

命令格式

??????
OpenWebSite 网站
??????
#IF
#ACT
OpenWebSite http://www.etmir2.com/


清除宝石升级属性

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：清除使用宝石升级的装备属性.

命令格式

??????
ClearStoneUpgrade 位置(0-14)

注意：此命令不区分极品和普通装备,清除时所有属性都将消失.

脚本示例

??????
[@main]
#IF
#ACT
ClearStoneUpgrade 0


特修身上装备

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

在物品规则列表中限制物品的不会被修理

??????
#IF
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.


延时执行脚本

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

延时执行指定的脚本.

??????
DelayCall S Label (S单位毫秒, Label是需要跳转的脚本段)
??????
#IF
#ACT
DelayCall 5000 @Kick
??????
[@Kick]
#IF
#ACT
Kick


自动穿戴装备

来源：ET引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

功能：自动穿背包中的装备

装备位置:
衣服 = 0;
武器 = 1;
蜡烛 = 2;
项链 = 3;
头盔 = 4;
左手镯 = 5;
右手镯 = 6;
左戒指 = 7;
右戒指 = 8;
护符 = 9;
腰带 = 10;
鞋子 = 11;
宝石 = 12;

??????
#IF
CheckLevelEx > 1
#ACT
Give 怒斩 1
AutoTakeOnItem 怒斩 1


称号系统

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

称号系统

增加称号：

第一步：首先选择称号的图库。在M2里设置(选项-功能设置-其他控制-称号素材读取设置)，素材的排列规则可以参考盛大的ui1.wzl里面的，从690~739都是称号的图片，每个称号需要5个图片，第一个图片是外观显示的，第二三是界面显示的，第四五是称号激活显示用的

第二步：在物品数据库里增加称号

称号功能，增加减少称号物品DB时，请注意Shape的连续性

StdMode 无要求可以随意
Name 称号的名称，该名称外观是否显示，由Reserved字段控制
Shape 称号编号，触发用的
Color 颜色 0~255
Reserved 显示DB中的名字（有部分图自带了名字，不显示DB的名字可以写上1)
Anicount 大于0时，无需设置为当前称号，属性就可以叠加到人物。等于0时，需要设置为当前称号，该称号的属性才会叠加到人物
Looks 称号图片的开始位置
DuraMax 可使用时间，单位小时
其他就等同于装备属性

玩家改变使用称号或刚上线有使用到称号，触发：QFunction的
人物：[@TitleChanged_XX]
XX代表物品DB中的Shape
玩家取消使用称号时，触发：QFunction的
人物：[@Untitled_XX]
XX代表物品DB中的Shape
比如
[@TitleChanged_1]
#IF
#ACT
伟大的【沙巴克城主】上线了

第三步：使用脚本命令增加人物称号

称号对应NPC命令:

检测人物是否有某个称号
CHECKTITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

增加人物称号
CONFERTITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

删除人物称号
DEPRIVETITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

[@增加称号]
#IF
CHECKFENGHAOCOUNT > 29
#ACT
SENDMSG 6 已经有了所有称号
BREAK
#IF
NOT CHECKTITLE 巅峰战神 //检测没有有这个称号
#ACT
CONFERTITLE 巅峰战神 //授予称号
#ELSEACT
SENDMSG 6 已经有了该称号
[@删除称号]
#IF
CHECKTITLE 巅峰战神
#ACT
DEPRIVETITLE 巅峰战神 //删除称号
;DEPRIVETITLE ALL //删除所有称号

功能：检查玩家所有称号的数量
格式：CHECKFENGHAOCOUNT 操作符(<,>,=) 数量(0-30)

称号改变属性及时刷新
称号物品DuraMax=0时，称号可以无限时间使用
赋予新称号，将标注为未使用状态，激活称号后才开始计时

称号最多支持30个

以下数据是按照盛大ui1.wzl里面的称号做的数据

573;称号一;70;0;20;0;0;0;690;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;251;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
574;称号二;70;0;20;0;0;0;695;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;252;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
575;称号三;70;0;20;0;0;0;700;48;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;253;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
576;称号四;70;0;20;0;0;0;705;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;251;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
577;称号五;70;0;20;0;0;0;710;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
578;称号六;70;0;20;0;0;0;715;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;249;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
579;称号七;70;;0;20;0;0;720;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;250;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
580;称号八;70;;0;20;0;0;725;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;252;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
581;称号九;70;;0;20;0;0;730;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
582;称号十;70;;0;20;0;0;735;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
583;称号十一;70;;0;20;0;0;1240;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
584;称号十二;70;;0;20;0;0;1245;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
585;称号十三;70;;0;20;0;0;1250;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
586;称号十四;70;;0;20;0;0;1255;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
587;称号十五;70;;0;20;0;0;1260;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
588;称号十六;70;;0;20;0;1;1265;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
589;称号十七;70;;0;20;0;0;1270;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
590;称号十八;70;;0;20;0;1;1275;1;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0


叠加功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

叠加功能

功能：多个物品放到一格
格式：无
说明：物品重叠功能不能使用在拥有持久、属性、品质、纯度等物品上。StdMode等于 0, 2, 3, 40, 41, 42
例：

物品重叠功能，StdItem.DB 中OverLap=1或2 表示可以重叠 0不叠加。DuraMax字段表示可以叠加的数量 必须大于1.例如：DuraMax=100表示可以叠加100个
OverLap=1 重量=重叠数量*单物品重量/10
OverLap=2 重量=重叠数量*单物品重量

收回物品 take 1 数字自己看着办喽

检测多少个 查看持久即可


顶戴花翎功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

顶戴花翎功能

功能：顶戴花翎功能
格式：SetIcon 位置(0-9) WIL文件序号 图片序号(0-65535) X(为空时默认X=0) Y(为空时默认Y=0) 播放张数(为空时默认张数=1) 播放效果(0普通 1特效) 播放速度(毫秒，为空时速度为300毫秒) 是否只有自己看见（0=所有人都可以看见 1=仅仅自己可以看见）新算法(默认为空或0，为1时采用新算法)
说明：无
例：

NPC顶戴花翎:
MerChant.txt中的NPC
盟重土城/流浪汉 3 346 334 流浪汉 0 3 0

流浪汉的顶戴花翎会读取 Envir\NpcIcons\盟重土城\流浪汉-3.txt

Envir\NpcIcons\盟重土城\流浪汉-3.txt 格式如下:
;WIL文件序号 图片序号(0-65535) 播放张数 X Y 播放效果(0普通 1特效) 播放速度(毫秒，为空时速度为300毫秒)
;最多不超过十行
3 1 5 0 -30

怪物顶戴花翎:
白野猪的顶戴花翎会读取 Envir\MonIcons\白野猪.txt

Envir\MonIcons\白野猪.txt 格式如下和NPC的顶戴花翎格式是一样的:
;WIL文件序号 图片序号(0-65535) 播放张数 X Y 播放效果(0普通 1特效) 播放速度(毫秒，为空时速度为300毫秒)
;最多不超过十行
3 1 5 0 -30

--------------------------------------------------------------------------
人物顶戴花翎:
[@main]
#ACT
SETICON 0 3 1 30 -30
SETICON 1 3 2 -30 -30
SETICON 2 3 3 -60 -30 3
SETICON 3 3 7
;如果要清除，WIL文件序号设置为-1即可
[@main]
SETICON 0 -1
SETICON 1 -1
SETICON 2 -1


斗笠功能设置

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

斗笠相关数据

功能：斗笠相关数据

StdMode = 16
Anicount 0戴上后显示头盔的内观 1戴上后不显示头盔的内观
Shape 0~7 Hair2
Shape 8~9 Hair3 目前Hair3只有2个斗笠，如果增加，Shape值依次增加就可以支持
Source 0时显示神秘人,Source=1时不显示神秘人 带斗笠后的"神秘人"效果对管理员无效.

神秘人显示可以在M2中设置-功能设置-其他设置

563;斗笠一;16;0;1;0;0;0;1188;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
564;斗笠二;16;1;1;0;0;0;1587;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
565;斗笠三;16;2;1;0;0;0;2080;6000;0;0;0;0;0;1;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
566;斗笠四;16;3;1;0;0;0;2081;6000;0;0;0;0;0;0;0;1;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
567;斗笠五;16;4;1;0;0;0;2422;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
568;斗笠六;16;5;1;0;0;0;2522;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
569;斗笠七;16;6;1;0;0;0;2768;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
570;斗笠八;16;7;1;0;0;0;3356;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
571;斗笠九;16;8;1;0;0;0;3890;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
572;斗笠十;16;9;1;0;0;0;4266;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;

物品位置:

0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌


多级脚本使用

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

多级脚本使用

功能：多级脚本使用
格式：无
说明：本功能的实现突破执行脚本的唯一性，使脚本的使用更加灵活多变，使用方法为 任意人物名称.任意脚本命令。以下所使用的ET网络名称等全部支持变量操作

H. 表示是英雄

O. 表示是主人

M. 表示是怪物

P. 表示是对面的角色

例：

例如：
#if
ET网络.Check [100] 1
check [100] 1
#act
ET网络的变量值100为1
你自己的变量值100也为1

下面列举几种常用的使用方法，以下方法同样可以用在#ACT命令中

例如
#if
ET网络.CheckLevel 51
CheckLevel 51
#act
ET网络.GameGold + 10
GameGold + 10
#say
ET网络的等级在50级以上，给予10元宝奖励
你的等级也在50级以上，给予10元宝奖励
上面脚本，如果ET网络不在线，M2会提示出错，但脚本会继续执行并跳过该句做为无效检测处理
当做为无效检测处理后，只要D3dm2等级和自己的等级在50级以上，既执行#say和#act段，
并且，ET网络.GameGold + 10 该句也无法执行，被跳过，继续执行下面的
所以在使用多级的时候请注意脚本的使用
#if
H.CheckLevelEx > 1
#say
你的英雄大于1级

#if
P.CheckLevelEx > 1
#say
你的对面的角色大于1级

;怪物操作，一般用在攻击触发里
#if
#act
M.HumanHP + 100


火龙神殿

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

NPC相关命令：
功能：关闭客户端'!'图标显示
格式：CLOSEMSGWINDOWS

格式：MESSAGEBOX 消息内容 QF触发段 QF触发段
例子： MESSAGEBOX 使用10元宝，便可在当前地图内原位置复活？ @确认 @取消
说明：在客户端显示一个提示框，点确定时，触发QFunction-0.txt的 @确认 代码
点取消时，触发QFunction-0.txt的 @取消 代码

物品ID
774;火龙凭证;41;0;1;0;0;0;269;0;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;;0;

MonGen.txt
;地图名：火龙殿
D2083 82 44 火龙教主 0 1 30
D2083 65 48 恶魔蝙蝠 10 10 30
D2083 81 62 恶魔蝙蝠 10 10 30
D2083 66 62 恶魔蝙蝠 10 10 30
D2083 51 75 恶魔蝙蝠 10 10 30

火龙守护兽设置说明

;名称 地图 x y dir(0-1) 攻击坐标x 攻击坐标Y(可以为多个以|分隔)
;----------------------------------
火龙守护兽 D2083 51,67 1 77,50|74,50|83,50|80,53|86,53|74,41|71,41|71,44|71,47
火龙守护兽 D2083 48,70 1 81,44|81,47|78,44|75,44|84,47|78,41|75,41|81,50|84,50
火龙守护兽 D2083 45,73 1 81,44|84,47|78,41|85,50|75,41|76,51|79,54|73,48
火龙守护兽 D2083 61,78 0 79,48|79,51|76,48|78,53|75,50|76,45|82,51|81,44|84,47|78,41
火龙守护兽 D2083 58,81 0 79,48|82,51|85,54|76,45|71,40|82,48|79,45|76,42|85,51|73,42
火龙守护兽 D2083 55,84 0 80,48|77,48|80,45|77,51|74,51|74,54|71,54|71,57

(怪物血量以及一些其他配置请自行修改)

灵魂收割者;81;19;240;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
蓝影刀客;81;19;241;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
恶魔蝙蝠;127;19;80;999;0;1000;2000;400;0;1000;1000;40;45;0;0;17;15;900;1;0;2000;
火龙魔兽;128;93;800;999;1;1000;30000;18000;0;30;30;60;150;0;0;17;15;900;1;0;3000;
火龙守护兽;129;94;802;999;1;1000;0;18000;0;30;30;40;45;0;0;17;15;900;1;0;2000;


脚本中使用图标功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

脚本中使用图标功能[!]

功能：脚本中使用图标功能[!]
格式：无
说明：无
例：

格式: <Img:N:F:X:Y/@Label>
N表示显示文件中的第几个图片,F表示WIL文件序号,X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

2015-09-01新增加 格式: <ImgEx:F:U:H:D:X:Y/@Label>
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
U=默认显示的图片序号
H=鼠标放上去时显示的图片序号
D=鼠标点下去时显示的图片序号
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

NPC对话框里，播放动态图片
格式: <PlayImg:F:N:C:T:X:Y:M:L/@Label>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制 2普通绘制带偏移
L表示播放次数，如果为空或为0时，表示无限次数。设置大于0时，表示播放的次数，次数到了就会自动消失

@Label是点击图片时需要触发的脚本标签.
例：

;显示图标
[@main]
显示图标<Img:10>
;设置坐标显示更加精确
[@main]
显示图标<Img:1185:1:1:-10>
;可执行脚本的图片
[@main]
显示图标<Img:1185:1:1:-10/@Hint>
[@Hint]
测试通过
;通过空格控制图片显示的位置.
;注意前面的空格,以及和X Y坐标的区别.
[@main]
<Img:1185:1:1:-10>显示图标
[@main]
播放图片<PlayImg:1:610:19:100/@播放图片>\
播放图片<PlayImg:1:130:7:300:-100:-100>\


人物英雄等级属性调整

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

D:\MirServer\Mir200\!Setup.txt

[Setup]
LevelValueOfTaosHP=6
LevelValueOfTaosHPRate=2.5
LevelValueOfTaosMP=8
LevelValueOfWizardHP=15
LevelValueOfWizardHPRate=1.8
LevelValueOfWarrHP=4
LevelValueOfWarrHPRate=4.5

;以下是英雄的
HeroLevelValueOfTaosHP=6
HeroLevelValueOfTaosHPRate=2.5
HeroLevelValueOfTaosMP=8
HeroLevelValueOfWizardHP=15
HeroLevelValueOfWizardHPRate=1.8
HeroLevelValueOfWarrHP=4
HeroLevelValueOfWarrHPRate=4.5


伤害吸收装备设置

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

伤害吸收装备设置

功能：伤害吸收装备设置
格式：无
说明：无
例：

Shape=188

Source 吸伤百分率(1即吸伤1%,超过100%,程序按100%计算)

*武器、衣服 不可以设置


物品衣服武器的扩展算法

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

物品衣服武器的扩展算法

功能：物品和武器的扩展算法
格式：无
说明：增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始
例：

Weapon.wzl Shape 1~99
Weapon2.wzl Shape 100~149
Weapon3.wzl Shape 150~199
Weapon4.wzl Shape 200~249
Weapon5.wzl Shape 250~299
Weapon6.wzl Shape 300~349
Weapon7.wzl Shape 350~399
Weapon8.wzl Shape 400~449
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。

Hum.wzl Shape 1~99
Hum2.wzl Shape 100~149
Hum3.wzl Shape 150~199
Hum4.wzl Shape 200~249
Hum5.wzl Shape 250~299
Hum6.wzl Shape 300~349
Hum7.wzl Shape 350~399
Hum8.wzl Shape 400~449
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。


新爆率格式

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

爆率设置方式一：(传统设置)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：几率 物品名称 (数量)数量针对金币
使用示例
1/1 万年雪霜
1/1 金币 10000
--------------------------------------------------------------------------------

爆率设置方式二：(新格式)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：#CHILD 几率 RANDOM //里面的爆率设置要使用()包围起来
使用说明
#CHILD 固定命令不能更改
几率 当符合几率条件时才会执行()里的爆率设置
RANDOM 固定值，当加入该条件后，()里的爆率设置几率将无效，系统而是从()里随机抽取一件物品爆出
使用示例
#CHILD 1/1 RANDOM
(
1/1 圣殿之刃
1/1 圣殿宝甲
)
新爆率设置的主要应用特色说明
在传统的爆率设置中，由于爆率随机性的缺点，对于爆出的物品无法精确控制。
例如：
1/4 天尊头盔
1/4 天尊项链
1/4 天尊手镯
1/4 天尊戒指
以上设置，在怪物爆出物品时无法控制每次只爆出一件，系统有可能爆出两件或四件，也有可能一件都不爆。

新方式：
#CHILD 1/1 RANDOM
(
1/1 天尊头盔
1/1 天尊项链
1/1 天尊手镯
1/1 天尊戒指
)
使用这种方式后，可以确保每次只随机爆出其中的一件物品。


游戏开宝箱功能

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

游戏开宝箱功能

功能：双击物品可以打开宝箱功
格式：无
说明：无
例：

宝箱相关数据:

宝箱的设置方法(M2-查看\列表信息二中编辑):

宝箱设置:StdMode=31 Shape=15--18(15=檀木宝箱,16=紫铜宝箱,17=白银宝箱,18=赤金宝箱,19-24=扩展的6个宝箱)
钥匙设置:StdMode=40 Shape=15--24

宝箱增加获得物品时触发Q-Function中的@GetBoxsItemX脚本段,其中X表示当前宝箱的Shape值,
当前获得的物品名称放在人物的S0变量中,例如我们在物品数据中添加一个叫做经验500000的物品,
打开檀木宝箱获得此物品时自动增加50W经验值,那么编写如下脚本:

[@GetBoxsItem15]
#IF
EQUAL S0 经验500000
#ACT
Take 经验500000
ChangeExp + 500000
Break

OpenDragonBox
功能: 使用脚本命令开宝箱
格式: OpenDragonBox 编号(15--24)
说明: 除了默认4个宝箱外,还可支持扩展的6个宝箱,具体设置M2\查看\列表信息\其他设置\宝箱系统

例子: 开宝箱.
#IF
CheckGold 10000
#ACT
OpenDragonBox 15
Take 金币 10000
#ELSESAY
没钱还想开宝箱?


自定义命令输入参数

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

获取用户自定义命令输入参数<$PARAM(0)> <$PARAM(1)> <$PARAM(2)> <$PARAM(3)> <$PARAM(4)> <$PARAM(5)> <$PARAM(6)>

借用群里的范例 无测试 自己斟酌后在用

[@usercmd1]
#IF
checkGold 9999
#ACT
MOV N9 0
MOV S9
GOTO @字符过滤
#ELSEACT
SENDMSG SENDMSG 7 提示：您的金币不足1W。
BREAK
[@字符过滤]
#IF
checkcontainstext <$PARAM(1)> <$Str(S9)>
#ACT
SENDMSG 7 提示：该信息包含敏感字符
BREAK
#IF
LARGE N9 50
#ACT
TAKE 金币 10000
SendCenterMsg 180 251 <$USERNAME>:<$STR(S9)> 0 30
BREAK
#ELSEACT
getrandomtext ..\QuestDiary\WordFilter.txt S9 <$Str(N9)>
INC N9 1
SENDMSG 6 现在N$9=<$Str(N9)>, S9=<$Str(S9)>
GOTO @字符过滤


自定义物品特效

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 功能拓展

自定义物品特效

M2-查看-列表信息(二)-特效列表


自定义技能系统

来源：ETmir2引擎帮助文档　分类：ET引擎脚本文档 / 技能相关

自定义技能系统

M2-查看-列表信息(二)-自定义技能


写入键值(包含物品首爆例子)

项目：ET引擎说明书　分类：ET引擎脚本文档 / 哈希拓展

ETHashTableCreate

功能:写入键值到内存

命令:

ETHashTableCreate 参数1 参数2

参数详解:

参数1:标识字符串(不区分大小写)

参数2:存储内容

例子:

我们做个物品首爆提示功能

首先开启ET功能,功能窗口二-个性化功能-开启物品爆出掉落反馈勾选后保存

下面进行脚本编写

QManage.txt

??????
[@Startup]

#ACT

;写在这里，是因为我们要把之前的记录，载入到哈希链表里，用于查询记录

ETHashTableLoad ..\QuestDiary\功能文件\爆出提示.txt 1

;载入文件记录,如果想每次启动M2重新计算的，这里就可以去掉，因为哈希值链表，进程每次重新启动就会初始化，他虽然是全局，但不会保存记录到下次启动M2，也不会因为玩家下线而清除之前添加的键值这一点需要理解。

QFunction-0.txt

[@物品爆出反馈]

#IF

ETHashTableContainsKey <$STR(S$当前爆出物品名称)>

;这条是查询指令，判断有没有这条记录，因为是用内存算法查找，所以会比用Checktextlist这个命令快上百倍、上千倍，以替代消耗较大的命令，这也是开发哈希链表主要原因，

#ACT

;跳到这里，说明找到此记录，那就不是首爆了，那就空着，不写代码

#elseact

;跳到这块，说明没找到此记录

ETHashTableCreate <$STR(S$当前爆出物品名称)> 1

;加入哈希链表记录，参数2可以随便定义一个，在这里、用1就可以

AddTextListEx ..\QuestDiary\功能文件\爆出提示.txt  <$STR(S$当前爆出物品名称)>

;同时输出文件，下次重新启动M2也可以载入此记录，如果想每次启动M2都是初始化，这句输出文件和载入命令也可以免了

SendCenterMsg 180 251 恭喜角色:<$USERNAME>,爆出全区第一个<$STR(S$当前爆出物品名称)> 0 3


查找键值(逻辑判读命令)

项目：ET引擎说明书　分类：ET引擎脚本文档 / 哈希拓展

ETHashTableContainsKey

功能:查找键

命令:

??????
ETHashTableContainsKey 参数1

参数详解:

参数1:标识字符串(不区分大小写)

例子:

??????
#IF
ETHashTableContainsKey 标识字符串
#ACT
sendmsg 6 找到此记录！


读取键值

项目：ET引擎说明书　分类：ET引擎脚本文档 / 哈希拓展

ETHashTableGet

功能:查找键

命令:

??????
ETHashTableGet 参数1 参数2

参数详解:

参数1:标识字符串(不区分大小写)

参数2:存储的变量

例子:

??????
#ACT
ETHashTableGet 标识字符串 <$STR(U45)>
;有没有内容，取决于这个标识字符串有没有写入数据
sendmsg 6 内容为:<$STR(U45)>


删除键值

项目：ET引擎说明书　分类：ET引擎脚本文档 / 哈希拓展

ETHashTableRemove

功能:删除键

命令:

??????
ETHashTableRemove 参数1

参数详解:

参数1:标识字符串(不区分大小写)

例子:

??????
#ACT
ETHashTableRemove 标识字符串
;删除后，再查找或读取这个标识字符串，就不会有这个记录


清除所有键值

项目：ET引擎说明书　分类：ET引擎脚本文档 / 哈希拓展

ETHashTableClear

功能:删除所有键

命令:

ETHashTableClear

例子:

??????
#ACT
ETHashTableClear
;全部删除后，此前添加的记录也会全部没有


载入文件到键值

项目：ET引擎说明书　分类：ET引擎脚本文档 / 哈希拓展

ETHashTableLoad

功能:载入文件

命令:

??????
ETHashTableLoad 参数1 参数2 参数3

参数详解:

参数1:载入的文件路径

参数2:存储内容(载入的键,全部赋予此存储内存)

参数3:分割符号(留空代表换行符)

例子:

QManage.txt

??????
[@Startup]
#ACT
ETHashTableLoad ..\QuestDiary\功能文件\爆出提示.txt 1
;我们这个txt以行作为分隔符，所以参数3留空。但参数2如果为空，会导致载入无效！


载入文件到键值-新拓展

项目：ET引擎说明书　分类：ET引擎脚本文档 / 哈希拓展

ETHashTableLoadEx

功能:载入文件

命令:

??????
ETHashTableLoadEx 参数1 参数2 参数3 参数4

参数详解:

参数1:载入的文件路径

参数2:标识字符串附加值(这个内容加上文件读取分割的内容,用于区分用途)

参数3:存储内容(载入的键,全部赋予此存储内存)

参数4:分割符号(留空代表换行符)

例子:

QManage.txt

??????
[@Startup]

#ACT

ETHashTableLoadEx ..\QuestDiary\功能文件\爆出提示.txt ABC 1

;我们这个txt以行作为分隔符，所以参数4留空。但参数3如果为空，会导致载入无效！

;-----------------------------------------------------------------------------------

;比ETHashTableLoad多了标识字符串附加值是怎么用的？

;假设文件 ..\QuestDiary\功能文件\爆出提示.txt 里面是图片里的内容

;我们用这个扩展命令载入的话,我们读取这个键值就要这样写

#ACT

ETHashTableGet ABC我是装备A <$STR(U45)>

sendmsg 6 内容为:<$STR(U45)>

;那读取到的内容就是1，ABC是自己定义的，用于区分不同用途